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Customer Service Plan
You may notice there is no registration card included with the software. Reg-
istration is accomplished during installation. To check if you are registered, 
go to HELP menu and select Register. If fields are empty, please fill them in 
and push “Submit”. If the HELP menu item “Activate your copy now” 
appears in a grey color, your copy is already registered, validated and ready to 
use. You will be able to receive technical support only if you are a registered 
owner. Registering your product is important for you in many ways:

• You will be eligible for free periodic updates from our website and 
special upgrade prices for future product releases.

• You will be given priority access to Musitek Technical Support and 
Customer Service using your Customer ID.

All Musitek products are covered by a limited 90-day warranty. To replace a 
defective CD that is still under warranty, contact Musitek Customer Service. 
Out of warranty CDs and manuals can be ordered online or by phone. A nom-
inal charge will be applied.
Musitek’s website contains up-to-date information on all our products. You 
may register online and download posted updates. Also, you may e-mail 
Musitek Customer Service for upgrade information, to notify us of a change 
in your address or request other product-related information.

• http://www.musitek.com
• sales@musitek.com
• Office: (805) 646-8051 / FAX: (805) 646-8099
• 410 Bryant Circle., Suite K, Ojai, CA 93023-4200

Most solutions to technical issues can be found in the manual or by accessing 
FAQs from our website. To contact a specialist, send e-mail either from the 
website or from your own e-mailer. To contact a specialist by phone, call dur-
ing the hours listed below. If you are located outside the U.S. or Canada, con-
tact your local Musitek dealer. You may also FAX us your questions. 

• tech@musitek.com
• Phone: (805) 646-5841 / FAX: (805) 646-8099  

10 AM to 3 PM Pacific Time - Monday thru Friday
• http://www.musitek.com/support.html
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Notices
Musitek® and its licensors retain all ownership rights to the SmartScore® computer 
program and/or other computer programs offered by Musitek including all associated 
documentation and materials. Use of SmartScore is governed by the license agree-
ment printed on the media envelope or within the installer encoded in the program. 
SmartScore source code is a confidential trade secret of Musitek. You may not 
attempt to decipher, reverse-engineer, decompile or develop any derivative code 
found within SmartScore or knowingly allow others to do so. SmartScore and its doc-
umentation may not be sublicensed and may not be transferred to any other entities 
without the prior written consent of Musitek.
SmartScore is licensed and not sold to you. You may install and use it on up to five 
(5) different machines solely for your own use before having to request more installa-
tion permissions from Musitek. You may not make copies of the installer or execut-
able program onto any media even if at the same location. You are authorized to store 
copies of generated files for your own use or for archival purposes only. Only you or 
agents authorized by you who have agreed to the above restrictions may use Smart-
Score. 
Your right to copy this manual is restricted by international copyright laws. Making 
copies, adaptations or compilations of this publication without prior written consent 
of Musitek is prohibited by law and constitutes a punishable legal violation. 
MUSITEK PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY 
OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIM-
ITED TO THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR 
ANY PARTICULAR PURPOSE. Musitek may revise this publication from time to 
time without notice.

Introduction to SmartScore X and Using SmartScore X ; Written by Chris Newell. 
Edited by Brad Ranola 
SmartScore was designed and developed by Chris Newell, Ojai, CA 
Programming by ICT, S.A., Warsaw, Poland. Wladyslaw Homenda, E.O.
SmartScore and Musitek are registered trademarks of Musitek Corporation. Ojai, CA.
Microsoft and Windows are registered trademarks of Microsoft Corporation.
Apple, Macintosh and OS X ares registered trademarks of Apple Computer, Inc.
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Important Information about Copyright 
Copyrighted material is protected from infringement by U.S. and international 
law. Title 17 of the US Code governs the making and reproduction of works pro-
tected by copyright. Under this code, reproduction, distribution and display of 
works protected under copyright is illegal if done without the permission of the 
copyright owner unless the proposed use falls under the definition of “Fair Use”. 
If you have reservations that your proposed use of SmartScore may be in viola-
tion of copyright law, consult with your attorney before using this product.
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Using to SmartScore X

Chapter 2 Introduction to SmartScore

2.1 How to use the SmartScore manual
This booklet is intended to get you started. It is not as complete as the PDF 
manual accessible from the HELP menu in SmartScore. The big advantage 
of using the PDF manual is its extensive use of dynamic cross-references. 
The easiest method of obtaining information on any topic is to look it up in 
the Index. 

2.1.1 What Edition symbols mean
Using SmartScore X is written for all editions of SmartScore. Features 
described that do not apply to all editions will have a symbol in the left mar-
gin.
• SmartScore Pro Edition
The Pro edition has no restrictions. All features and descriptions in this man-
ual apply to SmartScore Pro Edition.

• Not found in MIDI Edition

Indicates the feature or description does not apply to MIDI Edition.

• Not found in MIDI or Guitar Editions

Indicates the feature or description does not apply to either MIDI or 
Guitar Edition.

• Not found in MIDI or Piano Editions

Indicates the feature or description does not apply to either MIDI or 
Piano Edition.

• Not found in Piano or Guitar Editions

Indicates the feature or description does not apply to either Piano or 
Guitar Edition.



Chapter 3 Installation and Quick Tour

3.1 Installation
SmartScore requires verification. Copying either the download or the CD installer 
to other media will cause installation to fail. You are allowed up to 5 separate 
SmartScore installations before it becomes necessary to contact Musitek Technical 
Support for additional installs. 

a. You will need to be connected to the Internet during the installation. If you 
do not have Internet access you will be given a confirmation number 
which will require entering a response from Musitek (verification ID). For 
all verification / confirmation issues, contact technical support at 
tech@musitek.com (805-646-5841).

NOTE: Turn firewall & virus protection OFF during installation.
CD

b. Insert the SmartScore CD into your computer’s CD drive.
c. (Windows) Inserting CD should launch Auto-run. If not, Push Start > 

Run and Browse to find your CD drive in the “Look In” pull-down. Dou-
ble-click SSX_INSTALL.EXE. 

d. (Macintosh) Double-click SmartScore CD icon on your desktop. Double-
click SSX_INSTALL.

Download and CD
e. Follow all installation steps including entering Serial Number, Customer 

ID and registering your copy of the software.
f. Installation requires online registration and verification. File saving and 

printing will be disabled after 30 days if registration is not completed. If 
you are unable to register online, please contact support at 805-646-5841
or write to: 
tech@musitek.com.

3.2 Recognition of Sample Files
SmartScore includes several pre-scanned TIFF files. For the purpose of this tuto-
rial. we will start with sample file, Fandango.tif. 
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a. If the SmartScore Task Window is open (Ctrl + “W” will open it at any 
time), push the “Recognize Scans” button. The Navigator and the Toolbar 
also have a Recognition button. 

NOTE: The Task Window opens automatically only at program start. It can 
be launched at any time with Ctrl + “W” or by selecting Recogni-
tion from Windows menus (on Windows) or from the File menu (on 
Macintosh).

The Begin Recognition window opens. This is the window you will use to select pre-
viously-scanned music for recognition. 

b. Press Add Files to List. In the Open dialog box, double-click on the sample 
file, Fandango.tif, inside the SmartScore folder. This will add the pre-
scanned file to the list. 

c. Press Begin Recognition. (Guitar Editiion Users: Go to page 21)

3.2.1 System Report
This window will list the total number of systems found as well as the largest and 
smallest number of parts found in any system. This information may reveal problems 
with broken systems / missing parts often due to incorrectly scanned pages. If the 
information in the report does not agree with the original score, check your originals 
or quickly scroll through the ENF file to locate problem systems. Otherwise, click 
“Open ENF”.

3.2.2 Unfiy Key and Time
In the Unify window, click OK to accept the default (Unify key signatures based on 
the topmost staff line in each system). 
The name Fandango.enf will appear in the Save As filename window. SmartScore’s 
filetype is listed as ENF (Extended Notation Format). The ENF extension will auto-
matically be added to all filenames after recognition. Click on Save. 

3.3 Notes on Basic ENF Editing
3.3.1 Macintosh / Windows shortcut conventions

Most SmartScore keyboard shortcuts are identical on both Windows and Macintosh 
computers. Since most Macs do not have a right mouse button, the Windows right-
click function is performed on the Mac version of SmartScore by holding down the 
“alt” (Option) key and clicking the mouse.
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3.3.2 ENF Display
The original scanned image is displayed in the upper window and the newly recog-
nized ENF file appears below it. Use the scroller bars, mouse wheel, or arrow keys on 
your keyboard to scroll up and down the page.  
Mac Users: Try the “overlay” mode controlled by the variable opacity slider in the 
Toolbar. In the main menu, select View > Split screen > Overlay.
Only one staff line is active at a time. The active staff displays black while inactive 
staff lines display in grey. Move your cursor within the boundary of a staff until it 
highlights black. Caps Lock will “lock in” an active staff until it is hit again. If you 
want all staves to display in black, go to the View menu and uncheck Show Active 
Staff. If you do this, remember to move your cursor within a staff line first before 
doing any editing within a staff line.

NOTE: In this manual, Quick Keys (keyboard shortcuts) are indicated in bold 
parentheses: e.g. (C).

As accurate as SmartScore is, you should always check for errors in recognition. 
Sometimes only a few simple edits are all that is required.
TIP: To see all staff lines in black, check “Show Active Staff” in the View menu. 

Since editing is done a staff-to-staff basis, turn this back on if you are unsure 
which staff line you are editing. 

3.4 Editing Sample Files
3.4.1 Editing Fandango

You will notice in the right-hand staff that Measure 3 is highlighted with a reddish 
color. This indicates a rhythmic error in one or more voices was found. The triplet 
was recognized with 16th beamed notes instead of 8th beamed notes.

Changing note values using Quick-select method
a. Hold down the Ctrl button and move your cursor to the next measure (Mea-

sure 4). Hold the cursor over the first beamed 8th note until highlights yel-
low. Click once on the note and notice the cursor immediately becomes a 
beamed 8th note.

This action is called Quick-select. With Ctrl down, clicking on any object will inherit 
its attributes. You may find Quick-select to be the fastest and easiest method for 
selecting most musical objects.
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b. Move the cursor over the first 16th note in the 3rd measure until it highlights 
yellow. Click on the note to change it to an 8th note. 

NOTE: If the target note turns light blue, a new note will be inserted. Only 
objects that highlight yellow will become changed. If a mistake is 
made, push the Undo button or Ctrl + “Z” (Cmd + “Z” for Macs).

c. Repeat the same Quick-Select action on the last beamed note in Measure 4 
and click on the far right beam note in Measure 3. 

d. Quick-Select the middle beamed note in Measure 4 then click the last incor-
rect middle note in Measure 3. Notice the red “error” color outlining the 
measure disappears after the final correction is made.

e. Push the Space bar to begin playing the piece. To pause, hit Space.

Correcting ties
Ties in Measure 19 to 21 were mis-read and became slurs.

a. Push the Select tool in the Toolbar (or the “O” key).
b. Click or drag over the slur found towards the end the top staff in Measure 

19. Hit Delete on your keyboard. 
c. Hit the “V” key on your keyboard. This activates the ties tool. Click on the 

head of the last note in the top staff of Measure 19. Notice the tie connects 
with the first note in the next system.

d. Repeat on the misread slur between Measures 21 and 22.

Inserting accidentals
a. Quick-Select on the sharp found in the top staff of Measure 23. 
b. Click on the head of the recognized grace note in Measure 24.

Transposing the key
a. Push the “Transpose” button in the Toolbar (or select Edit > Transpose).
b. In the Transpose window, click the scroller upwards to change the target 

key signature from 1 flat (Dm) to 1 sharp (Em). 
c. Push OK to effect the key transposition.

Insert beamed grace notes
A beamed grace note was missed in the top staff of Measure 1.
Using to SmartScore X



a. Move your cursor to the “Notes” tool palette (left of your screen). Hold the 
mouse button down until the toolbar expands. Select a 16th note (with 2 
flags) from the expanded palette. (The number “5” key on your computer 
keyboard will also select a 16th note). 

b. Hold the ‘beam direction” button down and select the “right beam” icon. 
(Toggling the “A” key will cause the cursor to alternate beam directions i.e. 
right / middle / left. 

c. Click the “Grace note” button in the “Notes” palette. 
d. Move your cursor into Measure 1 and position the note head of the grace 

note on D. Notice the cursor stem is in the down position. Press the “S” key 
to flip the stem up. Click to insert the first grace note. Notice the cursor’s 
beam direction has gone from right to left. Position the cursor note head on 
F and click to insert the second grace note.

Unifying irregular staff sizes
This piece comes from an older edition with somewhat irregular sized staff lines. In 
the last system on the page, notice the bass staff is slightly larger than the treble staff. 
Since SmartScore measures exact distances between staff lines and systems, the ENF 
display will reflect this also.

a. Locate the blue “staff height” tab left of any staff you wish to resize. Drag 
the blue tab downward to increase staff height. Drag upward to reduce staff 
height.

b. Once you are satisfied with staff and line spacing, hit the “Caps Lock” key 
to “lock in” the active system.

c. Push the “Unify” button in the Navigator. Select “Unify System, Staff and 
Line Spacing” (Based on active system). Push OK.

d. Hit the “Caps Lock” key again to release the active system.

Prepare for printing (Page setup / centering / adjust margins)
a. Push the “Setup” button in the Navigator or select File > Page Setup. 

Notice default Document Layout is From Recognition.
b. Change Document Layout to Center on Page. The print preview pane in the 

background will change to reflect actual page size. Push Apply. Notice that 
unifying staff sizes will have caused the last system to roll to the next page.

c. Move the top & bottom tabs (inside the left margin ruler). Increase the verti-
cal margins until the system moves back.
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d. Push the Print icon at the top of the Page Setup window. 

Visualizing contrapuntal voices
Turning on voice color will display contrapuntal voices in different colors. This 
allows you to view secondary voices (both notes and rests) in red and tertiary voices 
in green. Notes in 4th voice will appear in blue.

a. In Page Setup view, push “Main View” button at top of screen.
b. In the Toolbar, push the “Voice Visibility” button.

Notice in each staff how notes and rests appear as either black or red. They 
represent two of the four possible contrapuntal voices. Voices can be 
assigned different MIDI instruments if desired.

c. Push the Console button to open the Playback Console or use the keyboard 
shortcut, Ctrl + 9 / Cmnd + 9. 

FIGURE 3 - 1: Playback Console with Voice Visibility on

Changing Instrument sounds in Playback Console
The left and right-hand piano parts have been automatically recognized as piano and 
assigned the General MIDI patch of Grand Piano.

a. In the Instrument column of Track 2 / Voice 2, click on Grand Piano and 
scroll down to select Harpsichord. Press the spacebar or Play button. The 
secondary voice of the left hand will have a different sound than the other 
voices. 

b. Move volume slider left or right to increase or decrease volume on one or 
more parts. Close Playback Console. 

3.4.2 Editing Gluck 

Piano users: skip to “Editing Chorale” on page 19.  
Guitar users: skip to “Editing Guitar” on page 21.
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a. Push the Recog button in the Navigator. In the Begin Recognition window 
press Add Files to List. Double-click the file Gluck.tif inside the Smart-
Score folder. 

b. Press Begin Recognition button to start the recognition process. Press Open 
ENF in System Report then Save the ENF file.

c. To listen to Gluck, simply press the spacebar. 

Shift note pitches:
• An eighth beamed note in the flute part of Measure 3 ought to be one pitch higher. 

While holding the Shift button down, drag the note head of the first beamed note 
up from A to B.

Quickly delete objects:
• Activate the Select tool (“O” key). Click and drag to highlight slurs above 

Measures 9 and 10. Hit the Delete to remove them.

Using Quick-select to copy and insert objects:
a. Hold down the Ctrl button and Quick-select the dotted half note in Measure 

9. 
b. Hit the “S” key to toggle the stem direction of the note. Move the cursor to 

the beginning of Measure 10 and click to insert the dotted half note.
c. Hit the “V” to activate ties. Click on the dotted half notes in Measure 9 and 

again in Measure 10 to insert ties across measures.
d. There is a spurious dot in the eighth note beam group of the right hand piano 

part in Measure 10. Toggle the “D” key until the cursor appears as a greyed-
out dot and arrow. Click on the note head to remove dot.

e. Hit the “D” key again and click on the half note chord in Meas. 8.
f. In Measure 18, Quick-select on the natural sign in the right-hand piano part. 

Move the cursor into the flute part and click on the half-note to insert the 
natural. 

Using Properties tool to change playback characteristics
In Measure 20, the word “rit.” (ritard or ritenudo) was recognized and applied to 
gradually slow playback down for that measure. The word “poco” (a little bit) was 
also recognized, but not applied, so playback probably slows more than it should. 
Default playback characteristics can be changed by using the Properties tool.
Using to SmartScore X



a. With Properties tool active (Esc key), click on the word “rit.”. 

FIGURE 3 - 2: Ritenudo Properties window

b. Change the tempo value of the Ending of the measure by moving the slider 
to something like 70 or 80% of the current value. 

c. Push OK. The measure will slow a bit as indicated by “poco rit.”.
NOTE: With Properties tool active, try clicking on the “tr” and “f” signs in 

Measure 19 to get a sense of how this tool can work.

Selecting a few measures for playback
You may want to hear back only Measures 19 through 20 to test the playback settings 
which you changed using the Properties tool.

To playback a small range of measures,
a. Push the Select tool in the Toolbar.
b. Hold down the right mouse button (alt + click for Mac) and drag inside a 

selected range of measures. Measures will highlight blue and become staged 
for playback using Spacebar or the Play button. 

c. Press the Spacebar again to replay the selected range from the beginning. 
d. Click anywhere outside of the range of measures to deselect range.
e. Use the menu item, Playback > Set Play Range to select a wider range of 

measure or to continuously loop playback.

Extracting a part in System Manager

MIDI users: Skip to “Editing Guitar” on page 21.
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f. Hit (Ctrl + M) or select System Manager from Edit menu. Part and 
voice visibility is controlled in this window.

FIGURE 3 - 3: Extracting a part in System Manager

g. Remove “Visibility checkmarks” for PianoR and PianoL parts in the far-
left column. Check “Visibility” in the Apply region. Push Apply to New to 
create a new document which will include only the part(s) selected by visi-
bility checkmarks. 

h. Play the flute part, then close this newly created document.

• Changing Parts and MIDI instruments in System Manager
You can use the System Manager to select parts and assign MIDI sounds. MIDI 
instrument sounds are automatically changed in the System Manager (and Playback 
Console) by choosing one of a number of preset Part Names. MIDI instruments can 
be changed in any of the available voice columns.
NOTE: Instrument part properties are created by and edited in Instrument Templates 
(see page 72, "Instrument Templates").

a. Return to the original Gluck score. Press Ctrl + M. Go to the Part Name
column and click on the first Part Name, Flute. Scroll down the list and 
select Oboe. Notice Voice 1 becomes Oboe. 
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NOTE: Default instrument names and linked sounds are obtained from 
Instrument Templates. 

FIGURE 3 - 4: Changing MIDI instruments by selecting new Part Name

b. Even more interesting is to assign different instrument sounds to contrapun-
tal voices within a single part (staff line). Refer to the next figure, Changing 
MIDI Instrument of a voice in System Manager. 

c. Select Harpsichord instrument for Voice 2 of the PianoR part. Each voice 
(V1, V2, V3 or V4) can each be assigned a unique MIDI sound simply by 
clicking on its current instrument name and selecting one of 128 MIDI 
instruments. Click outside menu.

FIGURE 3 - 5: Changing MIDI instrument of a voice in System Manager

d. Press OK to apply the change and close System Manager. 
e. Now hit the spacebar to play back. Whenever the secondary voice in the 

right hand is played, you will hear a harpsichord sound. This technique is 
ideal for distinguishing “inner voices” of parts that are written contrapun-
tally.

NOTE: Changing MIDI instrument assignments of parts and voices can also 
be accomplished in the Playback Console (Ctrl + 9 / Playback 
Menu > Console).
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3.4.3 Editing Chorale

Many scores are written with multiple voices within a single staff line. Solo 
piano, guitar and choral music typically include different voices moving 
independently in and out of measures. “Voiceline threading technology” 
allows you to isolate and manipulate voices easily. 

The sample file, Chorale.tif, is a famous Lutheran hymn with four voices: Soprano, 
Alto, Tenor and Bass written in two staff lines.

NOTE: SA/TB scores usually have voices separated either by opposing 
stems or by multiple noteheads joined to a single stem. 

a. Push the Recog button on the Navigator. Press the Add Files to List button 
in the Begin Recognition window. Select Chorale.tif from the SmartScore 
folder

b. In the Options tab window, leave Triplets, Endings and Text Recognition
unchecked. 

c. Press the Begin Recognition button. Once Recognition is complete, press 
“Open ENF’ and save the ENF file, Chorale.enf.

d. Hit the spacebar to hear the playback.

Correct playback of pickup and closeout measures
Pickup and closeout measures are commonly found in hymns and other vocal scores. 
While notes are correctly recognized, playback hesitates in those measures because 
timing is “locked” to the time signature. You may force individual measures or all 
measures to “play as written”. 

Individual Measures: Push the Properties tool (Esc key). Click on the bar-
line at the beginning of the first measure. In the Barline Properties window, 
change the Playback pull-down menu from Current time signature to As 
written. Repeat for Measure 5.

All Measures: Select Playback tab in Edit > Document Preferences. Choose Play 
all measures as written in the Time Signature pull-down menu. Playback will lock 
to default time signature without hesitation.

Apply different MIDI sounds to each part
In the upper staff, the Soprano voice is black (Voice 1) and the Alto voice is red 
(Voice 2). In the lower staff, the Baritone voice is black and Bass is red. Up to four 
voices are possible within each staff.
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e. Hold down the Ctrl key and hit the “9” key (Cmnd + 9 for Mac). This 
opens the Playback Console. Or push the “Console” button in the Toolbar.

f. Change MIDI Instrument assignments of the two voices in the top part, 
PianoR (Track 1). Change Voice 1 (black) to Choir Aahs and Voice 2 (red) 
to Voice Oohs.

g. To hear differentiated voices, push the Play button, manipulate the volume 
sliders and the solo or mute buttons. Press Close to close the Playback Con-
sole.

3.4.4 Editing Songbook

a. Select Recognition. 
b. Press the Add Files to List button in the Begin Recognition window. Select 

Songbook.tif and press Open. In the Options area, check the box to the left 
of Text. 

c. Press the Begin Recognition button. Once Recognition is complete, accept 
“Open ENF” and save the ENF file, Songbook.enf. 

Insert missing time signature
The original score is missing a time signature. Actual meter is 3/4.

a. In the Clefs and Signatures tool palette, locate the time signature button (4/
4). Press and hold until all available signatures expand to the right. Select 
the 3/4 signature.

b. Move you cursor to the any part and click anywhere in the first measure. A 
3/4 sign will insert into all the parts.

Change system margins
Because the first system of this piece is not indented, part names overlap the first sys-
tem. System margins can be modified using ruler tabs. Here’s how...
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• In the horizontal ruler, drag the upper tab (margin control) to the right. If neces-
sary, drag the bottom tab (part name control) too.

FIGURE 3 - 6: Controlling System Margins

Working with lyrics
The lyrics in the first system are a printed a but too high. Let’s nudge down.

a. With Shift button down (Nudge mode), locate the small yellow box along 
the left-hand bracket to the left of the lyrics.

b. Click and drag the box up or down to move lyrics vertically.

In the verse there are two small mistakes. Here’s how to edit lyrics:
c. Push the Lyric button in the Toolbar. 
d. Click the quarter note that begins Measure 3. Hit the down arrow to jump to 

second verse. Hit the right arrow and then the Backspace to delete the capi-
tal “D”. Enter a small “d”. Click the half note at the end of the line then right 
arrow to the end of “tain”. Enter an “s” and a question mark.

e. Push the Lyric button again to exit Lyric mode.

3.4.5 Editing Guitar
SmartScore includes some very useful and powerful features for solo guitar music 
including recognition and editing of tablatures.

Editing three or more voices
Solo classical guitar and solo violin scores are unique in the world of published 
music. In most music, usually no more than two voicelines are present; each being 
distinguished by notes having opposite stem directions. 

a. Push the Recognition button. In the Begin Recognition window, push Add 
FIles to List. Double click on the file, GUITAR.TIF in the SmartScore 
folder to add the file to the list of recognized pages. Press Begin Recogni-
tion.

b. Save the file with the default name given.
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c. Notice measures have notes in three colors, including green. The green notes 
represent the third or tertiary voice. Push spacebar to Play. Hit spacebar 
again to Stop.

Adjust default tempo
The original tempo is marked “Poco allegro”. SmartScore recognized the word, 
“Allegro” which has a default tempo of 150 bpm. It’s too fast.

a. Select the Properties tool and click on the mark, Allegro in Measure. Move 
the slider to change the speed to something slower.

NOTE: With “Apply this tempo to all similar marks” checked, all existing
marks of Allegro will become updated to the new tempo after you 
push OK. 

Controlling part names
The part name (Nylon Guitar) overlaps the first measure. To turn off part names, go 
to Show Part Name under the View menu. Check “Don’t Show”.

Assigning different instruments to voices
b. Open the Playback Console (Ctrl + 9 / Cmnd + 9). Click into Instrument 

selection for Voice 2. In the Instrument pull-down menu, change Nylon 
String Guitar to Tango Accordion.

c. Change Voice 3 to Acoustic Bass or some other instrument.
d. Push the spacebar and listen to how contrapuntal voices become more dis-

tinct when they are assigned to different instrument sounds. 

Converting notation to guitar TAB
a. Select Properties tool from the Toolbar.
b. Click on the yellow triangle to the left of any staff line.
c. In the Staff Properties window, click in the “Apply Staff Type” checkbox. 

Select “6-string guitar TAB” from the pull down menu.
SmartScore has some very powerful tablature functions. For more details, refer to 
"Recognizing, converting and editing tablature", Section 4.1.1, on page 75.
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Chapter 4 Scanning and Recognition

4.1 Scanning Music
SmartScore uses “3rd-party drivers” for scanner control. These drivers are installed 
from the CD packaged along with your scanner. The drivers are usually WIA or 
TWAIN. Some users may have to select “Custom” install mode for installation. If 
you encounter problems when attempting to scan, we ask that you locate your scan-
ner manufacturers’ website, download and install the most recent scanner driver 
before calling Musitek Technical Support. 

4.1.1 Choosing a scanner
All scanners are not created equal. Most will work well with SmartScore; some bet-
ter than others. For an updated list of recommended scanners, visit: 
http://www.musitek.com/bundle.html
For common scanning problems and solutions, go online to: 
http://www.musitek.com/scanningnotes.html 
or visit: http://www.musitek.com/faqs.html

4.1.2 Selecting your scanner and interface in SmartScore
a. Go to File > Scan Music > Choose Interface = SmartScore’s. Smart-

Score’s scanning environment is activated.
b. Go to File > Scan Music > Select Scanner. Click on the driver name that 

corresponds to your scanner.

FIGURE 4 - 1: File > Scan M usic > Select Scanner

Windows Users: Sometimes more than one scanner driver will appear. If you are 
using an “All-in-One” scanner / printer / copier, it is strongly recommended that 
you select the “WIA xxx” driver from File > Scan Music > Select Scanner win-
dow if it is shown. Otherwise, select the driver name that corresponds best to your 
scanner. 
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c. Push the Scan button found in the Navigator and in the Toolbar or choose
File > Scan Music > Acquire.

4.1.3 Using the SmartScore Scanning Interface
When you start scanning, a low-resolution pre-scan will appear in the Preview win-
dow. 
If your scanner does not respond properly inside SmartScore’s scanning interface, 
select File > Scan Music > Choose Interface = Your scanner’s and try again. If 
your scanner still fails to respond correctly, turn to “Scanning Outside of Smart-
Score” on page 30.

4.1.4 Enhanced scanning functions
• Auto Cropping
If your music extends to the edge of the preview window, uncheck “Cropping” and 
push “Prescan” to scan again. This will allow for maximum scanning coverage. If 
cropping is checked, a bounding box will limit the scanning region. If you scan with 
cropping on, make sure about a 1/4” of clear white space is left on all sides of the 
music inside the preview image.
• Auto Deskew
If the preview appears slightly crooked, push the “Deskew” button to correct. If the 
preview is very crooked or if some music is cut off, reposition the music in the scan-
ner and scan again.
• Auto Resolution
This feature takes the guesswork out of choosing the correct resolution (dpi) setting 
for each scan. When selected, the image is analyzed and sized in order to obtain an 
optimum image resolution, thus achieving the highest possible recognition accuracy. 
Use this whenever possible.
If the preview image appears with white notes on black background, you will be able 
to invert image in the Image Editor (see page 38).
NOTE: Selecting Next Page immediately activates your scanner. Before selecting it, 

position your next page onto the scanner and wait until the scanner bar 
resets. If you push too soon, you may get an error message that “Scanner is 
not ready.”

d. Push Next Page and continue to preview, deskew and scan until you have 
finished scanning your entire song, project, section or movement. Select 
Finish when done.
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NOTE: If the piece you are processing exceeds 10-15 pages, divide it into smaller, 
discrete sections, e.g. Intro, Part1, Part2, etc.

The following section lists image-enhancement and scanner settings which you can 
control within the SmartScore scanning interface. If you understand and/or accept the 
default settings in the Scan window, turn to “Recognition Sequence” on page 26 to 
complete scanning and to begin the recognition process.

4.1.5 Scanner settings
• Brightness
The default brightness setting is -25%. For typical printed music, this setting should 
be fine. If beams smear together and whole and half notes appear closed or 
“blobbed”, then brighten the scan. If the original music is faded, if it is a weak copy 
you may want to scan even darker than the default setting. SmartScore wants to see 
solid, well-defined lines that are neither razor-thin nor smeared together. 
NOTE: If recognition accuracy is poorer than expected, examine the file in the 

Image Editor (see Open Pages in Image Editor in “Recognition Sequence” 
on page 26.). Zoom in close on a detailed area and examine the following:

• If note stems and staff lines are broken, thin or appear to be only one pixel wide: 
Rescan with -30% to -40% decreased brightness.

• If stems and staff lines are thick and continuous but objects appear small and lack 
detail: Rescan at a higher resolution.

• Resolution 
It is recommended that you use Auto-Resolution when possible. 
NOTE: When scanning music with staves having different widths (e.g. containing 

both standard notation and TAB staves or smaller “cue” staff above a piano 
accompaniment), always turn Auto-resolution OFF.

If you choose to set resolution manually, check Auto-Resolution off. For most printed 
music, the recommended resolution is around 350 dpi. If the original music is printed 
in smaller type, you can increase resolution to 400 or 500 dpi. For miniature scores, 
try 600 dpi. Scanning at too high or too low a resolution may actually reduce recogni-
tion accuracy. It is not recommended to scan music below 250 dpi or higher than 600 
dpi.
Using to SmartScore X



4.1.6 Choosing an alternative scanning interface
If your scanner fails to respond properly to the Scan command in the SmartScore 
interface or your scanned image is unacceptable (partially scanned, distorted, etc.) 
your alternative is to scan using the software provided with your scanner. See “Scan-
ning Outside of SmartScore” on page 30 for details.

4.1.7 Scanning in Macintosh®

Some Mac scanners are not fully TWAIN-compatible. In order for SmartScore to 
control a scanning device, it must be TWAIN-compatible. Otherwise scanning will 
have to be done outside of SmartScore using the software provided with your scan-
ner. See “Scanning Outside of SmartScore” on page 30 and “Selecting Prescanned & 
PDF files for Processing” on page 31 for details.

4.1.8 Scanning Orchestral Scores
There are several methods that may be used to scan in oversized orchestral scores. 
Refer to http://www.musitek.com/faqs.html 
“My orchestra score is bigger than my scanner”.

4.2 Recognition Sequence
When scanning pages is done, choose Save As and Begin Recognition to initiate 
recognition. Or you can choose Open Pages in Image Editor to view scanned pages 
and make alterations to the scanned image (e.g. cropping, deskewing, line drawing, 
cutting and pasting). Pushing Cancel before recognition is complete will exit the pro-
cess and return you to the main window.
NOTE: Turn to “Image Editor” on page 38 to learn about editing scanned images 

(Open Pages in Image Editor). 
To save your scanned image file and begin recognition sequence, 

a. Push the Save As and Begin Recognition button.
b. Browse to a location for saving your SmartScore ENF files. You may wish 

to add a unique directory at this time.
c. Give the image file a name. If you are using Windows, the extension “.TIF” 

will be added automatically.
d. Push OK to begin the recognition process.
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The image file you have just saved contains all pages you scanned. The default file-
type is “Compressed TIFF” (CCITT Type 4), a multi-page, single-file TIFF compres-
sion format. This type of TIFF file is approximately 10 times smaller than an 
uncompressed TIFF image file. 
NOTE: If you are going to open the scanned image in Adobe Photoshop®, you may 

want to save in the larger, uncompressed TIFF format; Photoshop does not 
currently support CCITT Type 4 files.

TIP: When you Save a file to a specific location, SmartScore will continue to 
save to that directory until you change it. The same is true when you Open a 
file. Remember that SmartScore may look in one directory when opening a 
file and then go to a different one when saving a file. Once changed, the new 
path becomes the default.

4.2.1 Recognition Options

FIGURE 4 - 2: Recognition - Options

The following section describes options you can choose for recognition. When satis-
fied with your choices, push Begin Recognition. 
NOTE: If Recognition fails, refer to “Troubleshooting Scanning and Recognition” 

on page 35.
• Text 
Check this box if you wish to recognize lyrics and text in the music. 
TIP: If you are scanning in single-line parts for the purpose of joining them into a 

conductor’s score, it is recommended not to recognize text. Otherwise, text 
from every score-part will be overlaid on the pages of the conductor’s score.
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• Lyrics Outside of Systems

Check this box if you are recognizing a choral or orchestral score which has 
one or more lines of lyrics written under the last staff line of each system. 
Otherwise, leave unchecked. 

• Triplets
Check this box if the score contains triplets that are indicated with the number “3” 
above or below an arc or bracket.

• Limit to Triplets

When unchecked, SmartScore will attempt to recognize any kind of tuplet 
(duples, quintuplets, sextuplets, etc.). If your score contains only triplets, 
keep this box checked to avoid “false positives”.

• Pedals
If pedal markings are written into the music, check this box.
• Bowings
If up/down bowing marks are written into the music, check this box.
• Heavy beams
Some printed music is written with especially thick note beams. If single beams are 
recognized as double or triple, re-recognize the music again with this option selected.
• Hymnal Fonts
If you are scanning in music from a hymnal (with stubby flags and short stems), 
check this box. NOTE: “Shaped notes” do not apply.
• Ossias
Select if your score has one or more ossias (line above a staff suggesting an alterna-
tive passage) that you wish to have recognized.
• Recognize Tablature and Percussion staff lines
Select to recognize TAB (guitar) notation or percussion staves having other than 5 
lines per staff.
• Join Offset Voices
Two notes belonging to different voices might appear horizontally offset even though 
they sound at the same time. SmartScore decides which notes to join to the same 
“event” based on the distance between their noteheads. Normally, offset notes 
belonging to different voices (when sharing the same “event”) have no more than 1/4 
of a notehead’s space between them. 
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• If your music has offset voices in the same event which regularly exceed this off-
set distance, choose a greater distance. The amount of white space between note 
heads determines this distance.

• If your music has dense polyphonic texture, like that found in solo guitar music or 
tightly-spaced orchestral passages, it may be necessary to “tighten up” the allow-
able distance between offset voices. In these cases, choose a distance of less than 
1/4 of a notehead.

For editing details on joining / un-joining offset voices, see “Correcting Vertical 
Alignment” on page 62). 
• Part Linking
When a score is “optimized”, parts (i.e. stafflines) will appear only when they are 
meant to be played. Otherwise, the parts remain invisible. Optimized systems can be 
referred to as either “collapsed” or “expanded”. Usually, parts are added to the top of 
a system, e.g. after a piano introduction, the vocal line will appear above the piano 
part. This “top-down” arrangement is the default. However, some scores may have 
parts are added to systems in a “bottom-up” fashion, e.g. existing staves are bumped 
upwards. If your score is structured in this way, change default to “Add Parts to Bot-
tom”. Orchestral scores, being grouped by instruments, may have no pattern. 
• Fretboard Strings
The default fretboard for recognition is the six-string guitar. If your music has ukulele 
fretboards (4 strings) or some other configuration, change the selection to the correct 
number of strings.

4.2.2 Post-Recognition

FIGURE 4 - 3: Post-recognition System Report
Using to SmartScore X



The scanned file will be saved prior to recognition. Following the recognition pro-
cess, a System Report will be displayed indicating the number of systems found and 
on how many pages. The System Report reports the largest and smallest systems 
including the number of parts found in each. If any of these do not agree with the 
original music, investigate the cause before spending a lot of time editing the score... 
it could be difficult to restructure parts and systems later on.
• If you select Open ENF File, you will be asked to save the ENF file which is 

given the same name as the image file. If you wish, change the name and/or the 
destination directory then press Save to save the new ENF file.

• If you selected Open Super System, you will be able to scroll from system to sys-
tem and locate any systems containing an incorrect number of parts. See Detailed 
ENF Editing chapter in the PDF manual. for details.

• If you selected Open Image Editor, the scanned image will open in the Image 
Editor where you can correct certain flaws in the scanned image. See “Image Edi-
tor” on page 38 for more details.

A checkbox allows you to skip viewing the System Report in the future. To reset this 
option, go to Edit > Program Preferences > User Interface > Recognition. 
When recognition is complete, the screen will split between an image pane and the 
ENF pane which displays a representation of what was recognized. As you scroll 
down and page, the image and ENF panes remain synchronized. An alternative to the 
“split screen” view is the “Zoom Window” view. 

4.3 Scanning Outside of SmartScore
An alternative to operating your scanner when TWAIN or WIA drivers don’t work 
properly with SmartScore is to scan in another application. You can use your scan-
ner’s software or a third-party imaging program like Photoshop® to scan and save 
images. Then, inside SmartScore, you will be able to Recognize the saved images.

a. Check that your scanner is on and that the proper driver is installed (File > 
Scan Music > Select Scanner). If a compatible driver is not present, you 
will have to reinstall your scanner’s software either from the original CD or 
by downloading the most recent scanner driver from your scanner manufac-
turer’s web site. If the above is true and pushing the Scan button in the Nav-
igator still causes problems, your driver is probably incompatible with 
SmartScore’s scanning interface. 

b. Switch to the scanning software that was installed with your scanner. To do 
this, go to File > Scan Music > Choose Interface > Your Scanner’s. When 
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you push the Scan button, you will then be handed off to the software that 
came with your scanner.

If you are using your scanner’s interface, follow the following guides:
• Place your music in the scanner as squarely as possible.
• Look for Scan type or Output option. Set scanning to Grey (Greyscale). 
• Set Resolution to 300-400 dpi for average printed music.
• Set Brightness to -15 to -25% for average printed music.
• Crop around but not on the music to be scanned in preview pane.
• Scan between 300-400 dpi (for average-sized printed music). Scan at higher reso-

lutions for music printed in smaller-than-average print size. Do not exceed 600 
dpi.

• Save as TIFF (Uncompressed) or BMP file. Each page will be about 1 MB per 
page. Use a unique filename for each page... e.g. Page1.tif, Page2.tif, etc.

TIP: Optimum resolution is achieved when the distance between staff lines is 
about 20 pixels. Zoom into the image. Referring to the mouse position read-
out in the status bar, measure the distance between two lines in a stave (mea-
sure white space only).

4.4 Selecting Prescanned & PDF files for Processing
SmartScore will recognize nearly all PDF music files. Before being processed, they 
are converted to TIF file format and saved in the default directory. Pre-scanned files 
must be properly imaged. For scanning requirements and procedures, see “Scanning 
Outside of SmartScore” on page 30.

To recognize pre-scanned and PDF images of printed music,
a. Push one of the Recognition buttons (in the Toolbar or Navigator) or select 

Recognize under the File menu.
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b. A file-selection window Begin Recognition will open. This is where you list 
your pre-scanned files for recognition by selecting them, rearranging them, 
removing or reordering them.

FIGURE 4 - 4: Recognition - Selected Files / Options / Preview

c. In the Begin Recognition window, push Add Files to List.
d. Browse to where your images are stored. Click on an image file to select. If 

more than one page was scanned in the SmartScore scanning interface, the 
file will appear as a multi-page list.

NOTE: You may click on and drag image icon(s) to the selected files list of the 
Begin Recognition window. Some older Windows operating systems may 
not support drag-and-drop.

e. Preview pages prior to recognition to check that pages were scanned com-
pletely and that no page is severely skewed. Any of these issues will affect 
recognition results. Select the Preview tab and click on each page to view 
your pre-scanned pages. 

f. Refer to “Recognition Options” on page 27 for details on how recognition 
options operate.

4.4.1 Reordering the File List
Notice that one file may contain many pages. If you happened to have scanned a page 
out of sequence or if you notice pages out of order (e.g. “Page10” is listed before 
“Page2”). To reorder the list of pages to be recognized, click on any page and hit 
Move Up or Move Down. It will be repositioned. Hitting Remove Files from List
will cause that page to be taken off the list and will not be recognized.
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4.4.2 Removing, replacing and re-saving scanned pages
If one page of a scanned group is incorrectly scanned or is missing altogether from a 
multi-page image file (Page group), you may reselect individual pages to form a new 
page group.

a. Select (or drag) the original multi-page file inside the selected files list of the 
Begin Recognition window.

b. Highlight a page to remove and push Remove Files from List. 
c. To add a replacement or additional page to the original page group, select or 

drag the page(s) to the selected files list. 
d. Reorder pages as necessary. 

NOTE: If pages were reordered, added to or deleted from the original image file, 
you will be able to re-save the newly listed pages.

To Save a modified list of grouped pages as a new image file,
• Select all pages so they are highlighted and push Save As.
• Select the existing name to over-write or type in a new name.

4.5 Scanning Part Scores (Score-Parts)
SmartScore allows you to process and combine scanned pages of solo parts, 
duets, trios or quartets and play them back simultaneously. They may also be 
recombined into a conductor’s score.

TIP: If you are scanning in Score-parts for the purpose of joining solo parts into a 
conductor’s score, it is recommended not to recognize text. 

To scan and combine Score-parts into one ENF file,
a. Scan in all pages for each part. For easiest identification, give a unique name 

or number for pages belonging to one part, e.g. Flute_Pg1, Flute_Pg2 and 
Guitar_Pg1, Guitar_Pg2, etc.
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b. In the Begin Recognition window, arrange files in order of parts then pages: 
e.g. Part1/Page1, Part1/Page2, etc.

FIGURE 4 - 5: Grouping pages to Score-Parts

c. Highlight the first set of pages that make up the first Score-Part.
d. Push Group to Score-Part. In the Part Name window, give the selected 

pages belonging to a score-part a unique name.
e. When all pages are properly grouped to score-parts, push the Begin Recog-

nition button.
SmartScore will internally organize score-parts following recognition. The ENF win-
dow will display pages for the first part followed by pages of the next part. Parts will 
play back simultaneously. 

4.6 Recognition Accuracy
If recognition accuracy is not as good as what you expected, examine the image up 
close by zooming into the image pane of your ENF view. You may also view Image 
Editor (FIle > Open > Image filetype).
Determine the following by zooming close up:
• If objects lack detail, re-scan with the Auto-Resolution setting checked (On) or 

increase scanning resolution manually. Optimum distance between horizontal 
stafflines is 20 pixels. You may use the cursor and readout in the Status Bar (pixel 
coordinates) to measure exact width of a typical staff line.

• If objects such as note stems and staff lines are broken or lack thickness, re-scan 
with decreased brightness to fill in gaps.

• If the source document is poorly printed or is faded and weak, try locating a better 
print copy of the music.
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TIP: Following recognition, guitar chord fret symbols may overlay chord names 
recognized as text: “Dumb” text chord names will not transpose. To remove 
“dumb” text fields, use Nudge mode (Shift) and drag the control handles of 
each text field upwards. Use the Select tool and “group delete” all selected 
text fields.

Recognition accuracy is directly related to the quality of the source document as well 
as the quality of the scanned image. Cheaper scanners, including Fax-Scan-Copy 
combos, are known to create poor images. Remember the old saw: “Garbage in / Gar-
bage out”. If after examining the image and consulting the Troubleshooting chart, 
you are still unable to achieve good recognition results, we invite you to send us your 
TIFF file(s) for detailed analysis by our technicians. 
You can attach your image (TIFF) files to e-mail along with a short description of the 
problem you experienced to the following address: tech@musitek.com. We will 
reply as soon as possible. Most likely, we will be able to locate the problem and offer 
a solution or recommendation.
NOTE: Many PDF files and music printed from laser printers have extremely nar-

row note stems and staff lines. If note stems appear “razor thin” and recogni-
tion was poorer than expected, open the .tif file in the Image Editor and 
apply darker thresholding to the image. See 4.8.2 on page 39.

4.7 Troubleshooting Scanning and Recognition

Table 1: Scanning and Recognition Troubleshooting

Problem Probable Cause Fix
Scanner does not operate. Scanner drivers not 

installed properly.
Install WIA or TWAIN 
software.

Scanner not selected in 
SmartScore.

Ensure proper scanner 
driver is selected (File 
> Scan Music > 
Choose Scanner).

Scanner not connected 
or not turned on.

Check cabling and 
power. Use scan test 
program if available.
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“This page should be 
scanned at xxx dpi. Res-
can or Accept.

Staff widths not con-
sistent. Music contains 
cue, TAB or percussion 
staves.

Re-scan in Smart-
Score’s scanning inter-
face with Auto 
Resolution = off. 

Scanner model used 
does not support infi-
nitely variable DPI 
(only scans in large 
increments).

Re-scan with Auto 
Resolution = off. Man-
ually set resolution 
acceptable to scanner 
(300 to 600 dpi).

“Scanner not responding 
to SmartScore scanning 
interface when running 
under Mac OS 10.5 
(Leopard)”

Apple made significant 
modifications to image 
acquisition module in 
10.5 (Leopard).

See: 
www.musitek.com/
updates or faq page for 
fixes and workarounds.

Printed area containing 
music is too wide or too 
long to scan on a standard 
sized scanner.

Actual image size of 
the music is what 
counts, not the size of 
the paper or page.

Refer to “Scanning 
Issues” section of http:/
/www.musitek.com/
faqs.html for work-
around.
Reduce original size 
using photocopier.

“Recognition failed for 
this page.”

Scanner set to screen 
resolution of 50-100 
dpi.

Scan again accepting 
Auto-resolution set-
tings for best results.

Scanner set to screen 
resolution of 50-100 
dpi. (cont’d)

Manually set resolu-
tion to 300-600 dpi. 
Scan again.

Page was scanned with 
too light a setting. 

Re-scan with -30% to  
-35% brightness.

Scanner was forced to 
create a black & white 
image with “dither-
ing”.

Re-scan in Your Scan-
ner’s interface: Grey-
scale / 350 dpi.

Table 1: Scanning and Recognition Troubleshooting

Problem Probable Cause Fix
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Music not fully 
scanned or is severely 
skewed.

Re-scan making sure 
all the music is 
selected. Scan music 
straight or use 
“Deskew” function.

Image too large for 
selected resolution.

Re-scan ensuring Auto 
Resolution = On.
Accept setting. If rec-
ognition is poor, rescan 
with Auto-Resolution 
off. Reset to 350 dpi.

Scanner hangs or crashes. Driver conflict. Ensure latest scanner 
drivers are installed.
Scan outside of Smart-
Score using software 
that came with your 
scanner.

Poor recognition results. Missing barlines due to 
light obscuring right 
margin or to right mar-
gin having been cut off 
during scanning.

Open image file in 
Image Editor. Use 
Select Tool to delete 
obscured regions and 
the Line Draw tool to 
restore barlines on 
right side of systems.

Poor recognition results. 
(cont’d)

Image too small for 
selected resolution.

Scan again accepting 
Auto-resolution set-
tings for best results.

Note stems “razor 
thin” due to laser print 
output.

Open .tif image in 
Image Editor and apply 
darker thresholding.

Handwritten or non-
standard notation. Poor 
print.

Scan well-printed, 
standard-sized sheet 
music.

Table 1: Scanning and Recognition Troubleshooting

Problem Probable Cause Fix
Using to SmartScore X



4.8 Image Editor
4.8.1 Opening files in the Image Editor

Following the final scan of music pages, you can choose to “Open Image Editor”. 
This choice will stop the recognition process and open the scanned pages in the 
Image Editor. At any time, you can open and edit an existing image file with the 
“Open” command.
The Image Editor allows you to manually draw in missing system brackets and/or 
barlines prior to recognition. You can erase or add details as well as being able to 
delete large areas of unwanted material from the image.

After touching up scanned pages, recognition can be launched directly from 
the Image Editor by pushing the “Recognition” button in the Toolbar. 
Launching recognition will ask you to first save the image with a new name.

• Loading a prescanned image file

To open an image file you have previously scanned, 
a. Press the Open button on the Navigator or choose Open (Ctrl + O) (Cmnd 

+ O for Mac) from the File menu.
b. Change Files of Type pull-down menu to Image Files.
c. Browse and highlight an image file from the listed saved files. Press Open.

“Recognition failed for 
this page.” (cont’d)

Poorly printed music. Decrease brightness 
level. Find better origi-
nal.

Image not straight 
(skewed).

Open file in Image 
Editor (File > Open > 
Image). Use Deskew 
tool to straighten each 
page.

Stafflines and note 
stems of canned file 
are broken or too thin.

Re-scan page(s) with 
decreased brightness 
setting.

Table 1: Scanning and Recognition Troubleshooting

Problem Probable Cause Fix
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4.8.2 Image Editing Tools

• Image Information
Select View > Image Information to display characteristics about the current 
scanned image including resolution, file type and page size.

• Zoom

To Zoom in and out click the Zoom Tool in the Toolbar (Ctrl + Q). Click 
inside the image will increase the scale of your view (Zoom In), while right-
click (alt / option + click for Mac) will decrease the scale of your view 
(Zoom Out).

• Page

To view pages of an image file, use the paging buttons in the Toolbar or 
select Next Page/ Previous Page from the View menu.

• Image Toolbar

FIGURE 4 - 6: Image Editor Toolbar

4.8.3 Page Tools
• Select
Used for selecting a region for cropping, deleting, cutting or copying.
• Crop

To crop an image file (trimming unwanted portions of your image from outside a 
marked frame), 

a. Press the Select button in the Image Toolbar. 
b. With your mouse, drag a box around the area you wish to keep. If you want 

to extend the cropping region outside of the display, keep dragging; the page 
will scroll as you drag up or down.

c. To adjust the marked bounded area, move your cursor over a boundary line, 
click and drag the boundary to a new position.

Crop 

Invert RotateL 

RotateR 

Freehand

Line Select 

Deskew 

Color

Thickness 

Delete

Threshold 
Page
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d. Select Crop from the Edit menu OR press the Crop button in the Image 
Toolbar. The resulting image will be reduced to the area inside the bounded 
frame. Remember to Save when done.

• Correcting Skew
Page through each scanned image and check for relative straightness of each image 
page. If a page appears tilted or skewed, recognition accuracy will be compromised. 
The Deskew tool rotates the image slightly to correct skewed pages and will optimize 
recognition accuracy.

a. Press the Deskew button in the Image Toolbar or select Deskew from the 
Edit menu. 

b. Position the cursor over a staff line. Starting from the left side, click and 
drag the mouse along the length of the staff line. A red “skew angle” line 
will display as you drag the mouse. When you are certain the red “skew 
angle” line parallels the staff line, let go. The page will automatically 
straighten. Repeat for each page. Remember to Save when done.

NOTE: If the page becomes incorrectly rotated, undo with Ctrl + z / Cmnd + z for
Mac (or select Edit > Undo).

• Invert
If the image you open in SmartScore is white-on-black (instead of the normal black-
on-white), then you should reverse the image output in your scanning software. 
SmartScore defaults to 0=white polarity. 
If your scanned image appears white on black, choose Edit > Invert or choose the 
Invert button from the Toolbar.
• Delete Page
If there is more than one scanned page in the image file, the Delete Page function is 
active. Use it to remove poorly scanned or duplicated pages. To re-scan and restore 
deleted pages, see “Removing, replacing and re-saving scanned pages” on page 33.
• Freehand Draw (Brush)
To draw free hand lines in your image file, select Brush from the Edit menu OR 
press the Brush button in the Image Toolbar. Choose a line width then click and drag 
to paint.
• Line Draw
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Some printed scores have weak or missing stafflines and/or brackets that can create 
problems during recognition and may result in missing or incorrectly bracketed sys-
tems. Sometimes, by accident, brackets and/or barlines are cut off during scanning. If 
this is the case, you can manually draw in staff line and brackets or enhance their 
thicknesses. 
To restore cut-off or missing system brackets,

a. Select Edit > Line or choose Line Draw in the Image Toolbar. 
b. Push the Pen Color push button in the Image Toolbar, if necessary, to 

choose Black Color. 
c. In the Width pull-down selector, choose a fairly wide thickness (10-20 pix-

els).
d. Click and drag the mouse to draw a line along the missing or broken bracket 

along the left margin of the music.

FIGURE 4 - 7: Using Line Draw tool to restore missing bracket

e. When finished modifying the image. Select File > Save As and give it a 
name. You may then Recognize the file with corrections.

• Line / Brush Thickness

To change the width of brush or line tool, select a new size from the Width menu in 
the Image Toolbar. Select from 1 to 50 pixels.
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• Black / White Color toggle (Eraser)
Push the “Eraser” button to activate white color. Push again to deactivate it for black 
color. Or choose Pen Color > Black or White from the Edit menu. 
• Rotate Left / Rotate Right
 To rotate an image file (for landscape formatted scores or upside down scans), go to 
the Edit menu and highlight Rotate OR press one of the Rotate buttons in the Image 
Toolbar.
• Rotate the image Left (90 degree rotation).
• Rotate the image Right (90 degree rotation).
• Select Edit > Rotate > Any to rotate at angles other than 90 degrees.
• Thresholding
If note stems and/or staff lines are “razor thin”, recognition will be improved by dark-
ening the image. Use this feature to manually convert grey images to black & white 
using a variable threshold (75% lighter to 75% darker). Many PDF music files and 
sheets output from laser printers have thin lines (1 pixel wide.) Move the threshold 
slider far to the right in cases of “razor thin” lines.
• Begin Recognition

After modifying the image, you can save and begin recognition of it by 
pushing the “Begin recognition” button in the Toolbar.

4.8.4 Cut / Copy and Paste functions
• Cut (Edit > Cut)
To cut an area from the scanned image, hit Delete button. Or use the Select tool and 
drag a box. Cut with Ctrl + “X”. 
• Copy
To copy an area without removing it from the image, use the Select tool and drag a 
box with the mouse. Select Edit > Copy (Ctrl + C (Win) / Cmnd + C (Mac)). 
• Paste
To Paste the cut or copied region into an image file, select Edit > Paste (Ctrl + V / 
Cmnd + V (Mac)). The cut or copied section will drop into the image. With the 
mouse, drag the fragment anywhere within the image and release the left mouse but-
ton. To fix the fragment in place, click outside the pasted fragment.
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Chapter 5 Playback

5.1 Quick Play
To play back an open ENF file quickly, use the spacebar, 

a. Press the spacebar to start playback. Press again to pause. Press again to 
resume play. 

b. Press the comma key (“,”) to rewind to start point.

5.1.1 Mini-Console

The Mini-Console transport controls Play, Rewind and Stop. The Record 
button will launch a new MIDI recording session to record additional 
tracks (see "MIDI Recording", Section 11.8). The “spring-loaded” slider 
will accelerate or decelerate playback depending on how far the slider is 
dragged. The slider will snap back to the default tempo once it is released.

FIGURE 5 - 1: Mini-Console

5.2 MIDI Setup
It is necessary to identify the MIDI device attached to your system in order for 
SmartScore to play through it. Selecting the MIDI device is similar on both Win-
dows® and Macintosh®. Fortunately, computer operating systems now provide 
built-in MIDI synthesizers. This allows you to select and play General MIDI (GM) 
sounds without installing an outboard synthesizer or soundcard. 

IDI
ding
Introduction to SmartScore X



To set the MIDI input and output devices,
a. Select MIDI Devices from the Playback menu. The MIDI Devices window 

will open.

FIGURE 5 - 2: Playback > MIDI Devices

b. Click on the MIDI Output device you wish to use for MIDI playback. The 
MIDI device window will display all installed MIDI device drivers. 

c. If you intend to record in SmartScore, select the desired MIDI recording 
device/interface in Input window.

NOTE: If the desired device is not listed in the MIDI Devices window make sure 
your MIDI device driver has been properly installed.

d. Press OK to set the selected MIDI devices as your MIDI sources.
NOTE: You may need to close any open MIDI programs. Some MIDI programs pre-

vent playback by blocking the MIDI Out port.

5.2.1 Audio MIDI Setup (Macintosh)
To access Audio MIDI Setup in Mac OS X, locate “Utilities” folder inside the 
“Applications” folder. Double-click on Audio MIDI Setup.

FIGURE 5 - 3: Applications > Utilities > Audio MIDI Setup (Mac)
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If you have external MIDI devices installed such as an external synthesizer module 
and MIDI interface, they should appear as icons in the window. Using your mouse, 
drag the “Out” arrow of the source device to the “In” arrow of the receiving device 
and vice-versa. Internal connections should then be established. Close Audio MIDI 
Setup.f

FIGURE 5 - 4: Connecting MIDI Devices in Audio MIDI Setup

With SmartScore ENF file open on your Mac, go to Playback menu, click and select 
Playback at the bottom of the list. Choose CoreMIDI Playback to activate devices 
connected in Audio MIDI Setup. To activate built-in soft-synthesizer (Macintosh 
QuickTime Musical Instruments), choose QT Internal Playback.

5.3 Playback Console
In the Playback Console, you can make changes to MIDI instrument assignments, 
tempo, transposition, muting, soloing, volume and pan settings. 
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To open the Playback Console, 

Press the Playback Console button in the Toolbar or hold down Ctrl + 9 
(Win) / Cmnd + 9 (Mac). The console is also menu-accessible from: Play-
back > Console.

FIGURE 5 - 5: Playback Console

5.3.1 Playback Console controls
The playback transport controls works exactly as the Mini-Console. The General 
Volume slider controls overall volume. Tempo controls default tempo (if no metro-
nome value was assigned in ENF). Measure/Beat slider resets playback position to 
desired measure and beat. 
Each horizontal MIDI track is linked to a contrapuntal voiceline found in a staff. 
Tracks are grouped with light or dark grey shading representing one part / staff line. 
Each track has its controls arrayed in columns: 
• Column 1 (Track): Indicates the MIDI track assigned to the staff. MIDI Tracks 

are assigned automatically and cannot be changed.
• Column 2 (Voice): Lists the contrapuntal voice number (1 thru 4) given to each 

voiceline. 
• Column 3 (Part Name): Each track (part) is linked to a Part Name. Part names 

are created in the System Manager.
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• Column 4 (Channel): A unique MIDI channel is assigned to each voice in the 
score. MIDI channel numbers appear inside colored boxes representing one of 4 
possible voices (black, red, green and blue).

• Column 5 (Port) displays the current port to which MIDI playback data is being 
sent. If more than one MIDI device is available, the port assignment can be 
changed. 

• Column 6 (Lock): You may choose to lock the MIDI Channel of one or more 
parts to keep them from being changed dynamically.

• Column 7 (MIDI Instrument): Every track is assigned a MIDI Instrument. The 
default instrument is “Grand Piano”. Some recognized scores, depending on their 
structure, may have other instruments assigned. 

• Column 8/9 (Mute / Solo): buttons control whether a track should be muted while 
all other tracks play or soloed, muting all other tracks.

• Column 10 (Volume): This slider controls the default volume of each track.
• Column 11 (Pan): This slider controls the Left/Right balance for each track.
• Column 12 (Transpose): Each track can have its playback transposed up or down. 

Note that transposed instruments will already reflect a transposed playback value 
to compensate for correct pitch.

5.3.2 Set Instrument
This button will open the Instrument Settings window which is designed to reallo-
cated MIDI Channels and to save and load custom MIDI instrument settings.

FIGURE 5 - 6: Set Playback Range
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5.3.3 Playing back a selected section

The quickest way to play back a snippet of the score is to use the “Select” 
tool and drag the mouse over a region of the page while holding down the 
right mouse button (Alt + click for Mac). Measures selected for playback 
will highlight light blue. Hit Space bar to play.

FIGURE 5 - 7: Selecting measures for limited playback

For playing larger sections and for looping, go to Playback menu and select Set Play 
Range.

FIGURE 5 - 8: Set Playback Range

e. In the From field, choose a starting measure. Then select an end point in the 
To pull-down box. 

f. To repeat playback over the range, check the Loop box.

5.4 Dynamics and Articulations
5.4.1 Dynamics

You can use any of the tools in the “Dynamics” palette to alter playback velocities. 
Using to SmartScore X



Inserting dynamic markings, crescendo & decrescendo markings or hairpins will 
alter the velocity of selected notes in the active staffline. See "Signatures (Key and 
Time) palette", Section 9.4.4 for details on inserting dynamics. For more details, see 
"Dynamics Palette", Section 9.3.5.
To apply dynamics and/or dynamic markings to more than one staff, enter the 
dynamic in each active staff that you wish to apply the effect. If you do not wish to 
have so many dynamics visible in every staffline, you may enter symbols in the Hid-
den Symbols mode. For more details, see "Hidden Symbols", Section 9.11.

5.4.2 Articulations
Numerous note articulations including slurs, trills, turns, mordents, staccatos, tenutos, 
accents, arpeggios, glissandos and tremolos can be applied from the “Articulations” 
palette. For information on modifying articulation playback characteristics, see 
"Articulations", Section 5.4.2. More information on articulations can be found in 
"Articulations palette", Section 9.4.1.

5.5 Tempo
Default tempo for all time signatures is 120 beats per minute (120 bpm) except for 
“cut-time” and 2/2 time, which play at 60 beats per minute. Tempos can be modified 
by inserting one or more metronome marks, by inserting a tempo marking or with the 
ENF Tempo Controller.

5.5.1 Metronome mark

.The Metronome tool in the “Tempo” palette (also activated in Edit > Default 
Tempo) sets the tempo at the point the mark is inserted. 

FIGURE 5 - 9: Setting Default Tempo 
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5.5.2 Tempo Markings
Tempo Markings are found in the “Tempo” palette. Clicking anywhere inside a 
staffline will insert the selected Tempo Marking above the staff. Tempo will be 
altered at that point. 

FIGURE 5 - 10: Selecting Tempo Markings from Tempo palette

Note that Expressions, found in the “Articulations” palette are ‘fuzzy” descriptors 
and will not alter playback. 

5.5.3 Change of tempo (metronome mark)
Creating a change-of-tempo is accomplished by inserting a metronome mark at the 
point where you want the tempo to change. For details, see "Metronome Mark", Sec-
tion 9.4.2a

5.5.4 Ritards, Accelerandos, Descelerandos
Select the appropriate symbol and enter it by dragging the mouse over the range of 
notes you wish to apply the effect to. Use the Properties tool to modify the tempo 
change over the range of notes to which it applies.
NOTE: To view the selected range of accelerando/descelerando, push the Hidden 

Objects button. Range is shown with dotted line.

5.5.5 Tempo controller
Another method to change tempos is to use the Tempo Controller.

To activate the interactive Tempo Controller,
• Push the Tempo Controller button in the Toolbar Clicking the orange line changes 

the default tempo value. For more details, see "ENF Graphical controllers", Sec-
tion 5.8
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5.5.6 Tuplets and Slurs (Legatos)
While in the Insert mode, select a triplet (“T” key) from the “Notes” palette or select 
Legato from the “Articulations” palette. 

FIGURE 5 - 11: Creating a Tuplet or Slur (legato)

a. Click and drag down to insert the tuplet or legato above the notes to be 
selected.

b. Click and drag up to insert the tuplet or legato below the notes to be 
selected.

To delete a tuplet or articulation
c. Ctrl+click on it, press the “X” key then click again on the object. Or use the 

Select tool (“O” key) to highlight one or more tuplets and/or legatos.
d. Once selected, push the Delete key.

NOTE: To resize or move a tuplet bracket, use Nudge mode and drag the control 
point located on either end of the tuplet.

• User-defined Tuplet

The D:B tool button allows for custom tuplets.  
Divisions = The number of equal beats to be applied to the group.  
Value = The number of note values (if they were not modified) that would 
be applied to give the same duration.

See "Tuplet Properties", Section 5.6.9, for more tuplet options.
For example: The quintuplet (-5-) has a default D:B ratio of 5:4. When applied to a 
group of 5 eighth notes, its total duration value would equal 4 “normal” eighth notes. 
• Nested tuplets (tuplet within a tuplet)

Creating a 
slur

Creating a 
triplet
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Choose the value required from the “Rhythmic Groups” palette. Click and drag the 
cursor to select a tuplet group within another tuplet. A bracket will drop identifying 
the nested tuplet.

5.6 Playback Properties
Playback values of dynamic and articulation markings can be altered by use of the 
“Properties” tool. Changes can be applied individually to the marking itself or glob-
ally to all similar markings in the score. Finally, default values can be reset for that 
particular mark for all future SmartScore files. Certain changes to barline properties 
will also affect playback. See Section 5.6.11 and Section 5.10.1 for barline properties 
details.

To activate the Properties window of an object:
• Hit the “Esc” key or select the Properties icon from the Toolbar and click on one 

of the objects below to open and modify its playback and display properties:

5.6.1 Note Properties
Clicking on any note head will open the Note Properties window. 

FIGURE 5 - 12: Note Properties

• Note duration: Change basic note value.
• Dots: Add or change dots of prolongation.
• Staccato: Change default duration when staccato is applied.
• Tenuto: Change default duration when tenuto is applied.
• Accents: Change default velocity when accent is applied.
• Fermata: Change default tempo when fermata is applied.
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• Notehead types: Noteheads can be altered to several alternative shapes configura-
tions including triangle, empty triangle, diamond, empty diamond and “x”.

5.6.2 Property Options (All Properties windows)
• Apply (changed property) to All: 

Selecting this option will update playback properties of the same mark throughout 
the score. 

• Apply Setting(s) to All Future Files: 
Selecting this option will permanently reset the default value for the selected 
property to its new values for all future ENF files.

• Back to Default: 
This will reset values to application launch defaults.

• Reset Defaults; 
This will return values to new installation defaults.

5.6.3 Slur (Legato) Properties

FIGURE 5 - 13: Dynamic Marking Properties

• Extend duration: Duration of notes associated with the slur.
• None: No increase of note duration.
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5.6.4 Tempo Marking Properties
Tempo values can be changed by clicking any tempo marking with the Properties 
tool. Changes can be applied to all tempo marks in the document or to all future 
instances of the selected tempo mark.

FIGURE 5 - 14: Tempo Marking Properties

• Tempo slider: Reset tempo value.
• Uncommon Name: Enter an alternative name for the tempo marking (e.g. “really 

fast”).

5.6.5 Accelerando, Descelerando and Ritard Properties

• Starting and ending tempos (as a percent of default tempo)

• Use an uncommon name (e.g. “gradually slower”)
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5.6.6 Hairpin, Cresc. and Decresc. Properties

FIGURE 5 - 15: Hairpin Properties

• Velocity sliders: Start value and Ending velocity values.

5.6.7 Trill Properties

FIGURE 5 - 16: Trill Properties

• Permutations: The number of half-step movements.
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5.6.8 Dynamic Marking Properties

FIGURE 5 - 17: Dynamic Marking Properties

• Volume slider: Resets the volume for the current part.
• Range: 10 to 127 (General Volume)

5.6.9 Tuplet Properties
• Divisions = The number of beats to be applied to the tuplet. Value = The number 

of (equal) notes that would be in the group if no tuplet were applied. See Section 
5.5.6 for more details.

• Hide = Do not show (uncheck to show) Value number or Symbol bracket.
• Apply to: Only this symbol or All symbols in current file.

FIGURE 5 - 18: Tuplet Properties
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NOTE: Default settings for how tuplets appear can be changed in Text Symbols and 
Score symbols tabs found in Program Preferences or Document Prefer-
ences.

5.6.10 Multi-Measure Rest Properties
• Measures = Number of measures the multi-measure rest applies.

FIGURE 5 - 19: Multi-measure Rest Properties

5.6.11 Barline Properties (Pickup measures and Codas)
Pickup, measures normally begin a piece or section with a truncated measure having 
less beats than the time signature calls for. It is often associated with a “closeout” 
measure at the end of the section. Split-measures are divided between the final mea-
sure of one system and continue through the first measure of the following system. 

FIGURE 5 - 20: Pickup and split measures

Incomplete, pickup, closeout and split measures will normally cause playback to hes-
itate. By default, SmartScore applies the exact number of beats to each measure 
(Lock to Time Signature). 

To play individual measures exactly as written, 
a. Select Properties Tool and click on the barline that precedes the measure in 

question. 

Pickup Measure (Typical) Split Measure (Typical)
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b. In the Playback combo box, choose “As written”. 

FIGURE 5 - 21: Barline Properties

Sometimes a score will contain so many split or incomplete measures that you will 
simply want to play it entirely without hesitation. In this case, you will want to apply 
“Play as written” to the Playback tab in Document Preferences.

To play all measures in the document exactly as written, 
• Go to Edit > Document Preferences. In the Time Signature (Lock to Time Sig-

nature) pull-down menu, select “Play as written”. All measures are now 
unlocked.

FIGURE 5 - 22: Document Preferences > Playback > Play as Written

In Barline Properties, you can also create system breaks (Codas) and page breaks. 
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To create a Coda (Split system)
• Select Properties Tool and click on the barline that begins a measure of interest. 

Choose Actions > “Split System”.

FIGURE 5 - 23: Creating Codas (Split Systems)

5.7 Other Playback Options
5.7.1 Karaoke View 

Feel like singing out loud? Hey, you only live once...

To view moving lyrics with familiar bouncing ball,
a. Press the Karaoke button in the Navigator palette.
b. The Options menu allow for changes in the Karaoke display. These options 

are also available in Edit > Program Preferences.
c. Open the Playback Console (Ctrl + 9 / Cmnd + 9 for Mac) to adjust tempo 

and change instrument assignments for parts and voices. 

5.7.2 Add drum tracks 
Adding an automatic drum track will add more pizazz to the mix. 
Push the Drum Pattern button in the Toolbar to select an appropriate pattern for your 
piece. For more information on adding or creating drum tracks, go to "Automatic 
Drum Patterns", Section 10.4.
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5.7.3 Swing
This feature applies standard swing rhythm to straight 8th and 16th notes notated in 
beamed groups. SmartScore will modify playback and the underlying MIDI represen-
tation as follows:

To apply swing to playback,
• In the Playback menu, click on Swing.

5.8 ENF Graphical controllers 
With the Velocity graphical controller you can vary note velocities of each note clus-
ter quickly and smoothly. With the Tempo controller, you can “draw in” tempo varia-
tions smoothly over time. Controllers can be accessed either in the ENF Toolbar or 
below the Piano Roll window in MIDI view. 

FIGURE 5 - 24: Text and Controllers

5.8.1 Velocity Controller 
In ENF score view, push the “Velocity controller” button to activate. Click and drag 
your mouse along the vertical bars which represent each note’s velocity. The higher 
the bar, the more the velocity.

FIGURE 5 - 25: ENF Velocity Controller
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5.8.2 Tempo Controller
Push the “Tempo controller” button to active. The horizontal line in the topmost staff 
represents default tempo. To vary tempo, click and drag your mouse up or down. The 
last tempo point will be fixed until changed.

FIGURE 5 - 26: ENF Tempo Controller

NOTE: For ritards, accelerandos and descelerandos, use the Properties tool 
instead of the Tempo Controller. You will have much more predicable 
results. See Section 5.6.5 for information on these properties.
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5.8.3 Normalize controllers
After making changes to Tempo or Velocity controllers, you may find you have cre-
ated greater-than-desired changes to playback. If so, you may globally reduce the 
effects of either controller by applying normalizing.

FIGURE 5 - 27: Normalizing Tempo

To reduce effects of either Tempo or Velocity graphical controllers
a. Choose Playback > Graphical Controller
b. Select either Normalize Tempo or Normalize Velocity.
c. Choose amount of reduction desired: 20% / 40% / 60% or 80%. Controller 

display and playback will change accordingly. 
d. Choosing Reset removes all controller changes and resets the default set-

tings. Tempo markings inserted into ENF will still take effect. The end result 
is an averaging of all tempo values.

5.9 Voices and Playback
Control of contrapuntal voices is key to proper playback of your score.

Normalize Tempo Controller (Before)

Tempo Controller after normalizing by 80%
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5.9.1 Voice Visibility
To view contrapuntal voices as colors, push the Voice Visibility button in the Tool-
bar. Each ENF Part (each staffline of the score) can contain a maximum of 4 voices 
(represented by 4 colors, black, red, green and blue). For scores to play back cor-
rectly, it is important that voices appear correct and be properly manipulated. See 
"Working with Contrapuntal Voices", Section 9.9 for additional details about editing 
voices.

5.9.2 Voice Splitting (Select + “H”)
Many hymnals and choral scores have voices grouped into chord clusters as opposed 
to notes with stems in opposite directions. Chord clusters are treated as one voice in 
SmartScore (usually black). Music ministers and choir directors will find this tool 
extremely handy in order to split two-note clusters into 2 contrapuntal voices. Then, 
assign each voice a unique instrument or extract each voice to a separate file. See 
"Extracting Voices", Section 9.10.4 for more details.

To separate a two-note cluster to two separate voices,
a. Hit the “O” key or Select button to activate the Select tool.
b. Drag a box around any number of two-note clusters in the staff.
c. Press the “H” key to separate two-note clusters into 2 voices.

FIGURE 5 - 28: Splitting two-note chords into 2 voices

TIP: If you wish to split clusters containing three or more notes, select and delete 
the least desirable notes until you are left with two notes in each cluster. 
Only two note clusters will split.

5.9.3 Assigning instruments to voices
Assigning unique MIDI instruments adds richness and allows the user to distinguish 
contrapuntal voices during playback. There are two areas where you can change 
MIDI instrument assignments for voices: inside the Playback Console and inside the 
System Manager.
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To change an instrument assignment of a voice in the Playback Console,
a. Push the Playback Console button in the Toolbar to open it. The console 

may be opened with quick-keys (Ctrl+9 / Cmnd+9) or from the menu by 
selecting Playback > Console.

FIGURE 5 - 29: Changing MIDI instrument of a voice in Playback Console

b. In any of the Voice column, click to select a new MIDI instrument.

To change an instrument assignment of a voice in the System Manager,
a. Open the System Manager (Ctrl+M) or select System Manager from Edit 

menu. All staves are displayed in horizontal rows as “Parts”. Voices are 
arranged in columns above each part (1 thru 4). 

FIGURE 5 - 30: Changing MIDI instrument of a voice in System Manager

b. Find the voice number within the part you want to change. Click the MIDI 
instrument name assigned to that voice in the pull down menu. Select an 
alternative instrument. During playback, you will hear voices stand out from 
other voices provided you chose instruments with different timbres.
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5.9.4 Correcting Vertical Alignment 
In printed music, noteheads belonging to different voices may appear side-by-side 
even though they are meant to sound simultaneously. During recognition, horizontal 
distances between offset noteheads are measured and a decision is made whether or 
not to join (or glue) notes to the same vertical event. It is possible that offset notes 
will not become glued due to excessive distance between the noteheads. It is also pos-
sible that notes will become incorrectly glued if they are too close. The default dis-
tance for joining noteheads to the same vertical event is 1/8th of a note head. This 
distances can be adjusted prior to recognition. See Section 4.2.1, "Recognition 
Options" for details on resetting the distance for joining notes. 
Following recognition, check that Voice Visibility is on (See Section 5.9.1, "Voice 
Visibility"). If two notes with opposing stems both appear black and are meant to play 
simultaneously, they can be aligned as follows:

To vertically align offset voices, 
a. Use the Select tool (“O” key) and highlight notes or rests that are horizon-

tally offset (likely, they will both be black).
b. Press the “Y” key to group the selected, offset notes into a single vertical 

event. Selected voices may move a bit and one should turn red.

FIGURE 5 - 31: Correcting offset voices not “glued” after recognition.

Similarly, if you see notes that belong in a single voice each displaying a different 
color (most likely black and red) and nearly touching, they are joined to the same ver-
tical event and can easily be “unglued”...

O ffset voices not “glued” 
following Recognition 

Using Select tool to 
highlight offset voices

“Y” key “glues” offset
voices to a single tim e
event. Select and “Y”
again “unglues” voices.

(half note appears in black)
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To “Unglue” offset notes which are not intended to play simultaneously,
a. With the Select tool (“O” key), carefully select the incorrectly glued notes 

(NOTE: they will each have different colors). Be sure to select only the 
notes which are incorrectly joined.

b. Hit the “Y” key. Joined notes separate and change color. Select again and hit 
the “Y” key once more to rejoin.

See “Join Offset Voices” in "Recognition Options", Section 4.2.1 to reset default dis-
tances prior to recognition. See also "Working with Contrapuntal Voices", Section 9.9
for more information on editing voices and their affect on score playback.

5.10 Repeats
To insert a repeat barline, repeat measure or any other repeat symbol,
• Toggle the “C” key to enter Insert mode. Select any repeat symbol from “Bar-

lines & Repeats” palette and click to place it. 

To change any current barline to a repeat barline,
• Select a repeat barline from the “Barlines” palette. Click on any existing barline 

to change it to the selected barline.

To delete any barline,
• Quick-select (Ctl+click) on a barline (or select any barline from the “Barlines” 

palette). Hit the “X” key and click on the barline to delete it. 
NOTE: Deleting a barline at the end of a system will cause the proceeding measure 

to roll to the next system. A notice warning of this effect will open whenever 
the last bar of a system is deleted.

To insert a “Repeat Previous Measure” mark,
a. Select the Repeat Previous Measure mark from palette.
b. In Insert mode, click into an empty measure. 

All notation present in the previous measure will automatically repeat itself during 
playback.

5.10.1 Repeated verses
Many scores have multiple verses that repeat several times even though they may not 
contain repeat barlines (e.g. hymnals). Other scores have sections marked only by 
single repeat barlines but are intended to repeat several times (e.g. the ending of a 
song with “repeat and fade”).
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To set how many times a score or section of a score should be repeated,
a. Make sure the score or the section is bounded by a left and right repeat sign. 

If not, select a Left Repeat sign from the Repeats tool palette and click on 
the single barline that begins the repeated section. The single bar will 
become the repeat bar.

NOTE: Do not delete a barline to change it; measures will reformat. Select a new 
barline and click on an existing barline to change. If the barline begins a sys-
tem, a repeat barline will insert to the right and symbols will nudge to make 
room. This is normal. The two barlines will still behave as one.

a. With the Properties tool selected, click on the Left Repeat barline that 
begins the section. The Barline Properties window will open.

FIGURE 5 - 32: Selecting the number of verses to be repeated

b. Select the number of desired repeats in the Repeat Section pull-down menu. 
Choices are from 1 to 8 repeats.

5.10.2 Change of key/time and the double barline
Usually, changes of time and key signatures at the end of a system are preceded by a 
double barline. If for any reason playback hesitates after a change of key or time sig-
nature, make sure the barline preceding the signature is actually a double barline. 
Two single barlines will cause playback to hesitate.

5.11 Numbered Endings
Endings can be simple or complex. SmartScore can cope well with logical endings, 
repeats and jumps. However, some printed music is ambiguous or outright faulty (e.g. 
“bowl of spaghetti”). In these cases, playback may have unexpected results.
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5.11.1 Simple Endings

To create a simple ending,
a. Select Start Ending tool from the “Barlines and Repeats” palette and click 

on the appropriate barline to insert the first ending. 
b. The Repeats window will open. Choose “1” as the sequence number of the 

first ending.
c. The Close Ending tool will appear on the cursor. Click on the last barline 

that terminates the first ending. The cursor then switches again to the Start 
Ending tool. 

d. Click on barline that starts the second ending (it may be the same barline 
that closes the first ending). Choose “2” as the sequence number of the sec-
ond ending. 

FIGURE 5 - 33: Multiple Endings

e. Finally, click the barline that “closes out” the last ending.

To change a numbered ending barline to a “normal” barline,
a. Ctrl + click on a nearby barline (or pick it off the Barlines palette). Click to 

insert selected barline directly to the left of the numbered ending.
b. Delete the numbered ending (hit the “X” key and click to delete).

NOTE: If the numbered ending appears at the end of a system, be sure to insert the 
replacement barline to the left of the numbered ending. Then delete the end-
ing barline.

5.11.2 Repeated Endings
Some numbered endings are repeated multiple times before continuing. And some 
endings may play out of strict linear sequence (e.g. 1,3 for the first ending and 2,4 for 
the next).
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To create repeat endings, 
a. Select the Start Ending button. Click on the measure that begins the first 

ending. In the Repeats window, select the number of repeats and/or the 
sequence order numbers. Sequences do not have to be in strict order. 

FIGURE 5 - 34: Ending Sequence

b. Click the last barline to close out the second ending.
c. Repeat above steps as necessary for subsequent endings.

Playback will attempt to play repeated sequences in the order selected.
NOTE: Numbered endings are sometimes repeated in different places in the same 

piece (e.g. “1st & 2nd ending” in the middle and then “1st & 2nd” again 
somewhere else. SmartScore can handle these twice-repeated endings pro-
vided each set of endings is placed inside repeat barlines (See Section 5.10, 
"Repeats").

5.11.3 Deleting numbered endings
Numbered endings cannot be changed to “normal” barlines. Once it acquires the 
property of a numbered ending, a numbered ending has to be deleted first and then 
replaced by a normal barline. 

To delete a numbered ending and replace it with a normal barline,
a. Insert the desired barline type to the left of the numbered ending that you 

wish to remove.
b. Delete the ending (hit “X” key and click). The measure will shift slightly to 

the left.

5.12 Jumps
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Jump symbols may include segno, da capo, coda, to coda, fine and other markings 
indicating where playback should stop and jump back, jump forward or be repeated 
and finally stop. To avoid discontinuity or endless looping (what we call the “bowl of 
spaghetti” problem), it’s important that jumps be used logically.

5.12.1 Working with the Coda
A Coda sign generally marks the concluding passage of a piece. A To Coda sign is 
used to mark where a jump to the Coda begins; usually from inside a repeated pas-
sage. 

To insert a “jump to Coda” sign and mark the beginning of a Coda,
a. Select the To Coda sign from the palette. Find the measure where playback 

begins its “jump” (usually at the end of a repeated section or numbered end-
ing). Click on the barline to insert the To Coda sign. It will appear above the 
bar.

b. Select the Coda sign from the “Barlines and Repeats” palette. In Insert 
mode, click on the barline where the coda is to begin, (usually near the end 
of the piece).

NOTE: The Coda will not be played back until it is activated by the To Coda or d.s. 
al Coda sign. 

5.12.2 Working with the Segno
Segno means “sign”. It marks the beginning of a final repeat or ending. Segnos are 
usually positioned early on in the piece.

To mark a final repeat with a segno, 
a. Select Segno from the “Barlines and Repeats” palette. 
b. Insert the Segno by clicking the barline that begins the last repeated ending 

or section. 
c. To stop a final repeat or ending, return to the Segno and continue on to the 

Coda, select d.s. al Coda (meaning “from the sign to the Coda”).

To have a final repeat or ending return to the beginning of the piece and terminate at 
the Segno sign, 
• Select d.c. al Segno (meaning “from the beginning up to the sign”) and insert it by 

clicking on the barline in the last ending or repeat where playback is to return. 
The repeated section will return to the beginning of the score and play through to 
the Segno.
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NOTE: To Coda, Segno, d.s. al Coda, D.S., D.C. and d.s. al Fine signs are all 
ignored until an ending or repeat is played once.

5.12.3 Working with the da Capo (D.C.), dal Segno (D.S.), and Fine signs
D.C. (da capo) means “from the beginning” or “return to the beginning”. 

To have playback return to the beginning of the piece and play through to the end,
• Select the D.C. button from the “Barlines and Repeats” palette.
D.S. (dal Segno) means “from the sign” or “return to the sign”. 

To have a final repeat or ending return to the Segno and play through to the end,
a. Select the D.S. button from the “Barlines and Repeats” palette.
b. Click on the desired barline to insert the D.S. sign.

Fine means ending. It is usually placed in the middle of a repeated ending and termi-
nates the song.

To have the last repeat stop, return to the Segno and continue on to the end of the 
piece,

a. Insert a Fine sign by clicking on the barline that marks the final end point. 
b. Select d.s. al Fine (meaning “from the sign to the end”) from the “Barlines 

and Repeats” palette.
c. Insert either the d.s. al Coda or d.s. al Fine mark by clicking the barline 

where the last repeat is to begin. 

To have the final repeat or ending return to the beginning and play through to the 
Fine,
• Place the Fine sign at the appropriate barline. Select and insert d.c. al Fine in a 

measure following the Fine sign.
Repeat signs, ending markings (including Codas and Segnos) are found in the “Bar-
lines and Repeats” palette. Using repeat signs properly will alter playback accord-
ingly. 

5.13 Instrument Templates
Instrument Templates is the “source” from which instruments are created and linked 
to parts in the System Manager (Section 9.10.).
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a. To open Instrument Templates, select Edit > Instrument Templates or hit 
Ctrl + F Win (Cmnd + F Mac) or push “Open Instrument Templates” from 
inside System Manager. 

FIGURE 5 - 35: Instrument Templates

To change or add a new instrument template,
a. Hit (Ctrl+F/Cmnd+F) or Edit > Instrument Templates.Click in the Name

field of any template and type to change the given name of an instrument.
b. To change an abbreviation, click then type inside the Abbr field.
c. Click and select a different MIDI instrument from the Instrument list to 

change default MIDI instrument assignment.
d. Transpose displays the default playback transposition for selected instru-

ments. The MIDI representation will reflect the transposed shift in pitch.
e. Various sets of MIDI instruments can be selected in Instrument Settings 

pull-down menu. Instrument sets acquire their names by clicking on the 
Instrument Settings button and selecting a set.

f. To save settings for future ENF files, check “Save for Future”.

5.13.1 Transposed instruments
Transposed instruments do not actually play the pitches notated in the score. To play 
them back in tune with the other non-transposed instruments, they must have their 
playback adjusted up or down by certain intervals. This “playback transposition” is 
already preset in Instrument Templates for most transposed instruments. The number 
in this column represents the amount of pitch change (+/-) in half-step increments.
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5.13.2 Adding instruments
You can add new instruments with unique names and playback parameters as well as 
change existing names and parameters for any existing template. All templates are 
accessible in the Part Name column of the System Manager. For more information on 
the System Manager, turn to "System Manager", Section 9.10.

5.14 Broken Parts (Loss of Continuity)
Parts (staves of the system) may loose playback continuity for several reasons, e.g. 
system braces/brackets were cut off during scanning.

5.14.1 Merging Systems

For parts to be joined to single system (and to play simultaneously), an adjoining 
bracket along the left-hand margin must be visible. If during scanning, brackets are 
cut off by mistake, one or more parts become separated and will appear in ENF as 
single-line systems themselves. In this case, it is possible to rejoin them; forming 
larger, corrected system. 
NOTE: It is important to properly re-assign part links before merging systems. (See 

"Re-linking parts" below).

To merge two systems into one larger system,
a. Position your cursor over the first broken system / staff line. Hit Ctrl+L / 

Cmnd+L (Mac) to open the Re-link Parts window.

FIGURE 5 - 36: Merging Systems

b. The active system highlights in grey. Using the checkboxes, reassign each 
highlighted staff to its correct part name and position in what will become 
the final, reformed system. Apply to = System.
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c. Press the Next System button and reassign each highlighted staff line to its 
correct part name as you did above. Return to the first staff of the final, 
reformed system by selecting Previous System. 

d. Now, check the Merge with checkbox. When the Next System button is 
pushed, the two systems will join into a single system. Continue using Next 
System again until all separated parts are correctly joined. Review Part 
Name checkboxes for correctness. 

5.15 Re-linking parts 
Occasionally, scores will contain collapsed or expanded systems (sometimes referred 
to as “optimized systems”). Unless you re-link parts, these systems will not playback 
with the correct instrumentation.
The Re-link Parts function allows you to reassign each visible staff with its correct 
part (as defined by Part Name in System Manager). By re-linking parts of optimized 
scores, parts will play back correctly as they disappear and reappear throughout the 
score. 
NOTE: Parts listed in Re-link Parts window are derived from the Part Name col-

umn of the System Manager (see "System Manager", Section 9.10 for more 
information). Checked boxes identify which parts are assigned to the active 
system. Before re-linking, make sure all possible parts have been created.

To re-link parts in a system, 
a. Hit Ctrl+L (Win) / Cmnd+L (Mac). Or with Properties Tool selected, right-

click (alt / option for Mac) over any staffline in a system that requires re-
linking and select “Part Linking”. This will open the Re-link Parts win-
dow.

FIGURE 5 - 37: Re-link Parts window
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b. Check the part names that are associated with each staff in the active system. 
Be sure to remove checks from parts that are not associated with the active 
system. Larger systems may require scrolling down the list. The program 
will not allow you to select more or less parts than actually appear in the 
active system. 

c. To view adjacent systems, press Next or Prev System. 
d. In the Apply To box, press Apply to apply to active system. System+ will 

apply to the active system plus all subsequent systems.
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Page #1 of Orchestral Score

Page #2 of Orchestral Score

In this example, the first page consists 
of one system having 15 parts (15 
staves per system). With the cursor 
positioned over the system and Re-link 
Parts opened, 15 parts will be checked.

The second page contains 3 systems 
each with 6 staves. Many parts that 
appeared on the first page have dropped 
out. With the cursor positioned over 
one of the systems, 15 Part Names will 
be listed but only 6 will be checked in 
the Re-link Parts window. In this case, 
it was necessary to remove all check 
marks and then check the top six parts 
to reestablish proper part linking. 
See FIGURE 5 - 37:. Notice that the re-
linked parts were applied to all subse-
quent systems (System+) from the top-
most active system.

FIGURE 5 - 38: 
Re-linking an orchestral score
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5.15.1 Adding a staff when missed by recognition
Occasionally, a staff inside a system may not be localized during recognition due to 
flaws in the original score (or if the scanned page is severely skewed. If there is a 
missing staff line in the ENF display, it can be reconstructed quite easily as follows:

a. First, you want to re-link parts in the shorted system. Position the cursor 
inside the system and hit Ctrl + L to open Re-link Parts.

b. Put a check next to the appropriate visible parts. Leave the missing part 
unchecked. Make sure the parts you check correspond to the visible staffline 
and the missing part is unchecked. Hit OK.

c. Select the Properties tool. Yellow arrows along the left system bracket will 
indicate all known parts, visible or invisible. 

d. In the affected system, click on the yellow arrow of any staff and put a check 
mark next to “Visibility”. Make sure “Show Staff” is also selected.

e. In the “Apply To:” pull-down menu, select “Current Staffline or System”.
f. Hit the “U” key and select Unify Key Signatures (based on First System). 

Hit OK and the key signatures of the score will become unified. Now you 
need only to fill in the missing notes. Remember you can always use Copy
and Paste to clone measures of notes at a time whenever possible.

5.16 Working with audio sound libraries (Plug-ins)
SmartScore hosts third-party sound libraries compiled for VST (for Windows) and 
Audio Units (for Macintosh). Some sound libraries may not be supported. Libraries 
and players that have been tested and are known to work with SmartScore X are Kon-
takt® and Kontakt2® players (e.g. Garritan® libraries) and MOTU® MachFive®

library and player.
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5.16.1 VST (Windows) and AU (Mac) audio setup 
a. Go to the Playback menu again and select VST or AU Setup. Push Add

and browse to the plug in folder created when your sound library was 
installed. If the plug-in folder cannot be located, reinstall the library and be 
sure to install the audio plug-in.

FIGURE 5 - 39: VST (Win) and AU (Mac) Setup

b. Go to Playback menu and select MIDI Devices. Click on “VST Plugins” 
(Win) or “Audio Units” (Mac) from inside the Output window. Click OK.

FIGURE 5 - 40: Playback > MIDI Devices 

c. To return to your computer’s wavetable sound set, open Playback > MIDI 
Devices and reselect the desired driver.

d. Once the desired plug-in is selected, push OK. In the main ENF view, push 
the VST button in the Toolbar to open the plug-in player.

5.16.2 Working with the Garritan libraries and Kontakt2
For the best results when using Garritan plug-ins, follow these steps:
• Make sure to check the box titled “Use MOD wheel controller for Velocity” 

when selecting plug-ins from the MIDI Devices window. 
• After loading an instruments, look for the MIDI Channel control and make sure 

each one is set to “Omni”.
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• Be sure to uncheck “MOD wheel controller” in MIDI Devices window when 
returning to your computer’s sound set or you will hear strange noises during 
ENF playback.

5.17 Working with Finale®

SmartScore full version works seamlessly with MakeMusic’s® Finale® pro-
gram. If you already own a version of Finale or Print Music with Smart-
Score Lite, SmartScore can be made to launch automatically when “Music 
Scanning” is launched in Finale...

To replace SmartScore Lite with SmartScore full in Finale:

• In SmartScore, open Edit > Program Preferences. In the User Interface
tab, place a check in the “Integrate with Finale” option. Push OK to apply.

FIGURE 5 - 41: Program Preferences > User Interface

Always edit your music in SmartScore before bringing it into Finale. You will loose a 
lot less in the translation. You may find it more convenient to work entirely in Smart-
Score (e.g. transposition, playback and printing) or you may decide at some point to 
bring the SmartScore file into Finale. 

To launch Finale and import the current SmartScore file,
Push the “Save as XML and open in Finale” button in the lower Toolbar. 
The current ENF file will be saved as an XML file. Finale is then launched 
(provided it is installed) and the SmartScore file will import as a MusicXML 
file.
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5.17.1 Converting SmartScore files to other file types

To save SmartScore files in one of several different file formats...
In the File > Save As (Filetype/Format) pull-down menu, choose one of the follow-
ing formats to save the ENF score to:

• MusicXML (.XML) MusicXML has quickly become the most widely used 
file format for the exchange of music notation files between scorewriters. 
Most well-known notation scorewriting programs now support importing 
and exporting MusicXML files including Sibelius®, Finale®, Notion®, Per-
sonal Composer® and others.

• MIDI files (.MID) will import playback data into most other music software pro-
grams with no page formatting. All graphical information about note position, 
stem direction, voices, etc. are lost. MIDI is to music what ASCII is to text.

5.17.2 Copying an ENF region to paste into non-music programs

To copy an on-screen region for pasting into another application (Microsoft™ 
Word®, Adobe™ Photoshop®, e-mail programs, etc.), 

a. Press the “O” key to activate the Select tool.
b. Right click (option + click for Mac) and drag to select a region in an ENF 

page that you wish to copy to the clipboard. The stafflines will highlight 
blue.

c. Select Edit > Copy (Ctrl +C / Cmnd+C) to copy selected (highlighted) 
region to the clipboard as a bitmap image. 

d. Open application that supports bitmap graphics and select Paste.
• Use this feature to take “snapshots” of musical snippets and Paste into word pro-

cessors or other non-music programs.
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Chapter 6 Basic Score Editing

This section describes basic SmartScore editing features. For information on 
advanced editing techniques such as part extraction, optimizing scores, managing 
systems, applying or changing instrument templates, reformatting, respacing, page 
reformatting, print setup and part linking, turn to Chapter 9, "Detailed ENF Edit-
ing". Many editing and playback default settings are accessible in either Document 
Preferences or Program Preferences under the Edit menu. See "Preferences", 
Section 12.1 for details.

6.1 Navigating Inside an ENF Document
6.1.1 Active staffline

Only one staff can be edited at a time. Positioning your mouse over a staff will 
cause it to highlight black. Objects associated with the highlighted staff (including 
text and lyrics) can then be edited. You can choose to display just the active staff or 
to all staves in black. 

To display all staff lines in solid black, 
• Go to the View menu and uncheck Show Active Staff. 

To lock the active staff and allow the mouse to move anywhere,
• Hit the Caps Lock key. To unlock the active staff, press again.

6.1.2 Page View Display
Several ENF page view layouts are available after scanning. 

To select a different page view layout,
• Click on any one of four page view buttons in lower Status Bar.

FIGURE 6 - 1: Page View Buttons

• View ENF pages horizontally
• View pages vertically
• View pages in book format (facing pages)
• View score in horizontal scroll format (long view)
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NOTE: Whenever the ENF and TIFF view panes loose synchronization, e.g. in 
Long View mode or after score reformatting, the Image display pane will 
close and the “Scan View” window will appear instead. Closing the Scan 
View window will re-initialize normal Image / ENF view panes.

6.1.3 Scan View Window
The TIF/ENF split screen format can be changed to display only the ENF view with a 
floating “scan view window” corresponding to the same region in the scanned image 
where your cursor is placed.

To view full-screen ENF pane with a floating scan window:
• Go to the Window menu and select Scan View window.
By dragging the Split Pane control up or down, you can quickly view more of the 
TIF pane or more of the ENF pane.

FIGURE 6 - 2: Window pane shade control bar (View > Split Screen > Vertical)

The slider to the right of the Toolbar controls both the TIFF / ENF window shade bar. 

6.1.3a TIFF / ENF Overlay view (Mac Only)
An opaque ENF-over-TIFF view is available on Macs. The ENF-TIF slider adjusts 
the opacity of the ENF overlay from 0 to 100%.
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To edit using ENF variable-opacity overlay,
Go to View > Split Screen > Overlay. 

FIGURE 6 - 3: ENF / TIFF overlay view (Mac only)

To change zoom level in any view window,
• Select one of 3 zoom levels in View > Scan View window.

6.1.4 Zoom 

To Zoom in and out,
• Click the Zoom icon in the Toolbar or press Ctrl + Q. 
• Left click will increase the scale of your view (Zoom In), while right-click 

(Option + click for Mac) will decrease the scale of your view (Zoom Out). Ctrl + 
scroll wheel works for zooming in and out as well.

For additional information on navigating inside an ENF document, see "More ENF 
navigating", Section 9.1.

6.1.5 Paging

To page forward or backward in an ENF document, 
• The Next / Previous page control buttons are located to the far right of the 

ENF Toolbar.

To add a new page with empty systems,
• Push the Add New Page button in the Status Bar.

6.1.6 Status Bar options
The status bar at the bottom of the SmartScore window contains information about 
the current page being viewed. Clicking inside any of these fields will open a control 
window: Page Number (Go To), Page Size (Page Setup) or Zoom Level (Zoom). 
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6.2 Editing the Music
For editing, we recommend a “left-hand-on-keyboard” technique as shown below. 
The left index finger is over the “C” key, the left middle finger is over the “X” key, 
the left ring finder is over the “Z” key and the small finger is over the “CTRL” key.
NOTE: You will find editing fast and easy once you begin working with this “Quick 

Keys” method:

FIGURE 6 - 4: Left-Hand Position for ENF Editing

6.2.1 Pitch shift (Nudge mode)

To change the pitch of any note, 
Position the mouse over a staff line. Hold the Shift key down with your 
small left finger then click and hold on the control point in the center of 
the notehead. Drag the note head up or down to shift its vertical position 
in the staff.
To change the pitch of several notes at once,

a. Press “O” key to activate the Select tool in Toolbar.
b. Click and drag a box around any series of notes.
c. Hold down the “Shift” key and drag the notes up or down.

6.2.2 Rhythmic errors
Measures highlighted in a reddish color indicate that one or more rhythmic errors 
were found inside a voiceline. 

FIGURE 6 - 5: Measure with rhythmic error (1 beat is missing)
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For neatness sake, many scores intentionally truncate second and third voicelines. 
Normally, truncated voices will not cause playback problems provided notes on the 
same beat are vertically aligned.

FIGURE 6 - 6: Voice #2 (stem down) is truncated causing measure to highlight

Pickup measures and measures split between systems play back without pauses by 
selecting Properties Tool (Esc key), clicking the beginning barline of the pickup, 
closeout or split measure and choosing “Play as written”. 
NOTE: The red color used to highlight flag error measures can be turned off by 

unchecking “Show Error Measures” under the View menu. 

6.2.3 Inserting Notation Symbols

Musical symbols can be selected from one of several floating tool palettes 
positioned on the left side of the screen. Symbols with multiple values are 
grouped inside a single “master’ button identified with a small arrow. By 
holding down any button containing an arrow, the entire set of selectable 
symbols will expand to the right.

FIGURE 6 - 7: Expandable Palette Buttons (Notes and Rests)

6.2.4 Quick-select (Ctrl + Click):
You can select any symbol on a page without having to find it in a palette. Hold the 
Ctrl key down and click on any object The cursor will inherit that object’s properties. 
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6.2.5 Insert/Change mode

The “C” key on your computer keyboard activates Insert/ Change mode 
(Insert button on the Toolbar.) Insert/Change mode is automatically acti-
vated when a symbol is selected from the Tool Palette or when an object is 
selected with Cntl + click. In Insert mode, the selected symbol will insert 
or will change an existing symbol when its clicked on. 

To change the value an existing note, rest or other symbol:
NOTE: Quick-select (Ctrl+click) is the easiest way to select and /or change objects. 

Hold down the Ctrl key and click on any nearby object. The cursor will 
become that object and inherit its attributes. Clicking on an existing symbol 
will change its value to the one selected.

a. Select a note or rest within the same symbol class but with a different value.
b. Position your cursor over the symbol to be changed until it highlights yel-

low. Then click to change the new symbol.
NOTE: When a note highlights light blue, clicking will insert a new note in another 

voice at the same vertical event. See "Working with Contrapuntal Voices", 
Section 9.9 for more about vertical events.

6.2.6 Stem direction
In Insert mode, the default stem direction of a note switches when the cursor crosses 
the middle line of a staff.
To insert a note with the opposite stem direction as shown by your cursor, with a 
right-click (option + click for Mac). 

To reverse the stem direction of one or more selected notes,
• Select one or more notes with the Select Tool (“O” key). Hit the “S” key to 

change stem direction of the selected notes. 

To change the stem direction of an existing note,
a. In Insert mode, right-click (option + click for Mac) on any note once it 

highlights yellow. 

6.2.7 Deleting objects
There 4 methods for deleting objects. They are:

• “Click Delete”: Hit the “X” key (or push the “Delete” button in the Tool-
bar). Click on any symbol to delete it.
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• “Group Delete”: Use the Select tool (“O” key) and drag the selector box 
over one or more objects highlighting them in yellow. Selected objects will 
appear grey-green. Hit the “Delete” key to delete all selected objects.

• “Control Delete”: Quick-select (Ctrl+click) any symbol. Hit the “X” key. 
Click on any object of the same class to delete it. NOTE: In this mode, note 
clusters will be deleted.

• “Clustered Note Delete”: Hit the “X” key (or push the “Delete” button in 
the Toolbar). Now hit the “Z” (cluster) key. In this mode, single noteheads 
of clusters will delete.

6.2.8 Undo / Redo

To undo any single action,
• Click the Undo or Redo button to reverse the last editing action. Or hold the Ctrl 

down and hit the “Z” key (Cmnd + Z for Mac). 

To Undo or Redo one or more previous actions
• To select one or more actions to be reversed, click the small arrow to the right of 

the Undo or Redo buttons. Drag to select multiple actions. Push “Undo Actions” 
or “Redo Actions”.

FIGURE 6 - 8: Undo multiple actions

TIP: The Reset Workspace button (or F1 key) will reset all windows and pal-
ettes to their default “startup” positions. It’s useful if your workspace gets 
messy. 
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6.2.9 Editing note clusters

To insert additional note heads to existing note stem: 
In Insert mode, additional noteheads can be added to an existing note stem simply by 
clicking above or below an existing note provided the selected note value (displayed 
by the cursor) is the same as the existing note stem. Position the cursor on the correct 
line or space and when the note highlights yellow, click to insert.
• To add a notehead to any existing note stem (regardless of what is shown on your 

cursor), hit the “Z” key (“Cluster tool”). When the existing note highlights yel-
low, click to insert new notehead. 

To delete a notehead from existing cluster: 
• Select Cluster tool from the Notes palette (“Z” key). Then hit the “X” key Click-

ing on any notehead in a cluster will remove a single notehead. The Delete cluster 
tool also works to delete single-headed notes.

NOTE: Always use the Cluster tool to remove single note heads. The single greyed 
note and arrow will delete entire note cluster.

6.2.10 Inserting, changing and deleting beamed notes

To edit beamed notes:

Hit the “C” key (or click on the Insert button for Insert mode) and select a 
flagged note from the “Notes” palette. Then choose a beam direction from 
the “Beams” palette or the “A” key on your computer keyboard. If a similar 
beam note is nearby, Ctrl + click on it to select it.

FIGURE 6 - 9: Editing Beamed Notes

• To form a beamed group, insert the selected beamed note by clicking into a staff 
(not adjacent to another beam group). Repeated clicks will form successive 2-note 
beam groups when “left” or “right” beam direction is selected. One continuous 
beam group will be created when the “middle-beam” is selected. Auto-Beam can 
be used, but it may also cause re-coupling of other beams in the measure. See 
"Staff Line Options (Right-click inside staff line)", Section 9.7.1 for more details.

Notes palette (expanded) Beams palette (expanded)
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• Inserting a “right” or “middle” beam to the left of an existing beam group will 
cause that note to attach itself to the beam on its right. Likewise “left” and “mid-
dle” beams will attach to the right of an existing beam. Clicking inside an existing 
beam group with the “middle” beam selected will insert a beam note inside the 
beamed group.

• Clicking on an yellow-highlighted beamed note will change its note value and/or 
beam direction as indicated by the cursor. 

• To delete a beamed note, Quick-Select it, hit the “X” key and clicking again to 
remove it. Deleting an end beam will cause the beam to join to any adjacent 
beamed groups. 

6.2.11 Forming beam groups (Select + “B”)

To create a single beam group from adjacent flagged or beamed notes: 
• Use the Select tool (“O” key) and highlight any number of adjacent flagged notes. 

Hit the “B” key to join the notes into a single beamed group. The “B” key will 
also join two or more adjacent beam groups that are selected.

6.2.12 Barlines
a. While in the Insert mode, hit the “I” key (or select any barline from the 

“Barlines & Repeats” palette). 
b. Click anywhere in the active staffline to Insert a barline.

6.2.12a Deleting / changing barlines at the end of systems.
Deleting a barline at the end or beginning of a system will cause that measure to roll 
up or down to an adjacent system. Follow this step to delete or change a barline type 
that ends or begins a system...

To change a barline at the end of a system to another barline type,
a. Insert the desired barline type to the left of the barline that you wish to 

remove.
Delete the barline (“X” key then click). The measure will shift slightly to the left but 
not roll to an adjacent system.

6.3 ENF Symbol Properties
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The Properties tool is found in the Toolbar. Certain playback and display 
properties of most symbols can be edited by clicking with the Properties 
tool. Changes can be applied to all similar symbols in the score and even to 
all identical symbols created in future files.

Other symbol properties directly affect playback. To find out about editing those 
symbols, see "Playback Properties", Section 5.6.

6.3.1 Staff Properties

With Properties Tool arrow, click into any yellow marker to the left of a staff 
line. Staff properties for that part are shown in the window.

FIGURE 6 - 10: Staff Properties window

Editable properties include:
• Staff Visibility: View or hide active staff line.  

NOTE: Turning off visibility permanently removes symbols).
• Apply Staff Type: Change the characteristics of the staff (e.g. change “melody” 

staff to “6-string guitar” TAB staff.
• Apply Current Line Spacing: Select to apply current staffline spacing to other 

staves in the system or score.
• Set number of Systems: Select number of measures per line to apply to current 

or other systems.
• Apply to: Select which staff lines will have selected property changes applied: 

Current, subsequent (System+) or all (Score).
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6.3.2 Barline Properties
With the Properties tool selected, click on the barline preceding the measure of inter-
est. For details on controls, see "Barline Properties (Pickup measures and Codas)", 
Section 5.6.11.

FIGURE 6 - 11: Barline Properties

6.3.3 Note Properties
With Properties tool selected, click on any note head. Here you can change note val-
ues, dots and even the appearance of the notehead.

FIGURE 6 - 12: Note Properties
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Refer to "Playback Properties", Section 5.6 for details on Note Properties and other 
playback properties including:
• Articulations & Dynamics (trill, arpeggio, dynamic marks, etc.)
• Slur (to shorten or extend legatos)
• Tempo marking (to change default tempo speeds)

6.4 Transposition by Key and Clef 
Transposing all or part of a score can be accomplished in one of several 
ways. The most common is “transpose globally by key”, e.g. change an 
entire song from the key of E-Flat to the key of C.

Other transposition methods such as transpose-by-clef, transpose within a selected 
range and transpose-notes-only are all possible. To transpose the key of a score, first 
check that the “source” key signature is correct before applying any transposition 
function...

a. Push the Transpose button or hit Ctrl +T Win (Cmnd+T Mac).
b. The “source” key signature will appear in the main window with its signa-

ture name listed in both major and relative minor keys.

FIGURE 6 - 13: Key Transposition

c. Choose to transpose either by Key or by Clef or by Pitch.
d. Use the scroller to select a new key signature if by Key or a new clef sign if 

by Clef.
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e. With Closest selected, SmartScore will transpose to the target key, up or 
down, with the least number of intervals. Choose Up or Down if you wish to 
make your own choice. Push OK.

For information on additional transposition methods turn to "Transposition", Section 
9.8.

6.5 Printing and your final score / Save as PDF
If your score was scanned, ENF pages will probably not be centered. Page 
Setup provides various tools for controlling print layout. The simplest way 
to center music on each page is to select the Fit to Page layout option.

To center ENF frames prior to printing...
• Open Page Setup. In the Document Page Setup pull-down menu, choose Center 

on Page. Click Apply.
NOTE: Other document layouts can be applied in Page Setup. For example, you 

may want to have alternating left/right margins for bound scores. To explore 
other printing layout option, see "Changing default margins", Section 8.5.2.

To print your score,
• Select File > Print or push the Print button in the Toolbar.

To save your ENF score as a PDF file,
• Select File > Save As PDF.

Windows Users: CutePDF is the default PDF creator application, but several other 
alternatives may be installed and used.

To select an alternative PDF creator application for Windows,
a. Open Edit > Program Preferences and click on ENF-PDF.
b. Install an alternative PDF creation program and select it in the pull-down 

menu in the upper part of the window.

6.5.1 Optimizing oversized and undersized scanned scores
Modern “intelligent” scanners can (and will) do some unexpected things... in order to 
attain required resolutions (dpi), some scanners will actually re-scale the size of the 
image. An 8.5” x 11” page may end up becoming 9” x 13”. Since SmartScore 
matches the size of music scanned exactly, the resulting ENF file may print off the 
page. If this is the case, you can “optimize” the size of the SmartScore frame to fit 
precisely inside the margins of your default page size and orientation.
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To re-scale (optimize) your ENF pages,
a. Center the score on the page. (See Section 8.5.1)
b. Go to File>Format Score. Check Scale score. Push Find Optimal. OK.

FIGURE 6 - 14: Format Score window

6.6 Saving and Exporting ENF Files
You can save the current ENF file at any time by pushing the Save button in 
the Toolbar or by hitting Ctrl + S (Cmnd + S for Mac). 

6.6.1 Converting SmartScore files to other file types

To save SmartScore files in one of several different file formats.
a. In the File > Save As (Filetype/Format) pull-down menu, choose one of 

the following formats to save the ENF score to:
• MusicXML (.XML) MusicXML has quickly become the most widely used 

file format for the exchange of music notation files between scorewriters. 
Most well-known notation scorewriting programs now support importing 
and exporting MusicXML files including Sibelius®, Finale®, Notion®, Per-
sonal Composer® and others.

• MIDI files (.MID) will import playback data into most other music software pro-
grams with no page formatting. All graphical information about note position, 
stem direction, voices, etc. are lost. MIDI is to music what ASCII is to text. See 
Section 11.13.
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• NIFF (.NIF) Notation Interchange File format is somewhat dated, but is still 
used by few applications such as Lime.

b. Press Save. The proper extension will automatically be added.

6.6.2 Copying an ENF region to paste into non-music programs

To copy an on-screen region for pasting into another application 
(Microsoft™ Word®, Adobe™ Photoshop®, e-mail programs, etc.), 

a. Press the “O” key to activate the Select tool.
b. Right click (option + click for Mac) and drag to select a region in an ENF 

page that you wish to copy to the clipboard. 
c. Select Edit > Copy (Ctrl +C / Cmnd+C) to copy selected (highlighted) 

region to the clipboard as a bitmap image. 
d. Open application that supports bitmap graphics and select Paste.

TIP: Use this feature to take “snapshots” of musical snippets and Paste into word 
processors or other non-music programs.

6.7 Working with Finale®

SmartScore full version works seamlessly with MakeMusic’s® Finale® pro-
gram. If you already own a version of Finale or Print Music with Smart-
Score Lite, SmartScore can be made to lauch automatically when “Music 
Scanning” is launched in Finale...

To replace SmartScore Lite with SmartScore full in Finale:

• In SmartScore, open Edit > Program Preferences. In the User Interface
tab, place a check in the “Integrate with Finale” option. Push OK to apply.
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FIGURE 6 - 15: Program Preferences > User Interface

Always edit your music in SmartScore before bringing it into Fianle. You will loose a 
lot less in the translation. You may find it more convenient to work entirely in Smart-
Score (e.g. transposition, playback and printing) or you may decide at some point to 
bring the SmartScore file into Finale. 

To launch Finale and import the current SmartScore file,

• Push the “Save as XML and open in Finale” button in the lower Toolbar. 
The current ENF file will be saved as an XML file. Finale is then launched 
(provided it is installed) and the SmartScore file will import as a MusicXML 
file.

TIP: Before exporting any SmartScore file to another program, make sure it is 
edited first. Small mistakes become compounded if the file is not cleaned 
up. This is especially true for key and time signatures and measures with 
rhythmic problems.

6.8 Creating a New ENF Score from Scratch
SmartScore isn’t only about scanning. It is also a full-featured scorewriter as well. 
When creating a new score from scratch, certain defaults will turn on such as auto-
beaming and auto-spacing.
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6.8.1 New score

To create an empty ENF score using one of several basic templates,
a. Push the Score button on the Navigator or select New > New ENF under the 

File menu (Ctrl + N (Win) / Cmnd + N (Mac)). 

FIGURE 6 - 16: New score window

b. Type in a Title for the new score.
c. Add the Composer’s name for the first page score header.
d. Press the Page Setup button to change the basic page layout of your score. 

See "Custom document layouts", Section 8.5.5 for details.
• Page Setup opens document size and layout window.
• Tempo will insert a metronome mark for playback.
• Uncheck Insert Clef Signs automatically to create an ENF document without 

clefs.

6.8.2 Using Built-in Templates
SmartScore has 15 preset 2-page templates including solo instrument, piano, duet, 
common vocal and orchestral scores and a custom setup.

a. Select a desired template from System Type in Score window.
b. Once the score is open, you can edit normally.

To add a new page, 
a. Push the “Add New Page” button on the right of the status bar. 
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b. Or, push the Properties Tool, right-click into any staff line and select “Add 
Empty Page” from the Staff Line Options menu.

To delete an empty page,
• To delete a page, all systems on the page must first be removed. Right-click (alt

for Mac) into each system of the page you wish to delete. Select “System > 
Remove” in the Staff Line Options menu. Repeat as necessary.

6.8.3 Real Time Recording

An alternative to entering notes in by hand is to record MIDI-based perfor-
mances using a MIDI keyboard or some other MIDI instrument. For more 
about this, see "MIDI Recording", Section 11.8.

6.8.4 Step Time Recording

An alternative to Real Time Recording is Step Time Recording. Step Time 
Recording is done in MIDI and can be a very fast method of entering in 
notes (when you can’t scan it in of course!). For more, turn to "Step Time 
Recording", Section 11.9.
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Chapter 7 Editing Text, Lyrics & Symbols

This section covers editing text, lyrics and chord symbols. SmartScore 
attempts to distinguish between “dumb” and “smart” text when music is 
recognized. Dynamic and tempo markings written as text are “smart” as 
are chord symbols. Annotations, rehearsal markings and fingerings are 
“dumb”. 

7.1 Lyrics
A lyric “block” is a string of characters equivalent to a spoken syllable. Out of rec-
ognition, a lyric block becomes associated with a single note or rest in the staffline 
immediately above it. Locating the note or rest associated with a lyric block is as 
simple as searching directly above the center-justified lyric block. All lyric blocks 
within stafflines are horizontally linked and are separated from each other by 
dashes, underlines and/or periods. 

NOTE: Text and lyrics have different colors. Text is black, lyrics are blue. 
Text and lyric colors are changeable.

NOTE: Lyrics sometimes appear below a system (e.g. some choral scores) 
and a special option should be selected before Recognition. See 
Lyrics Under Last Staff of Systems in "Recognition Options", 
Section 4.2.1.

TIP: Move notes in Nudge mode (Shift) to verify lyric-to-note associations.

To edit lyrics,
a. Push the “L” button in the Toolbar to enter Lyric mode. 
b. Click into a lyric block or on an associated note or rest. Once highlighted, 

text within the block can be edited like normal text.
c. Click and drag inside a lyric block to highlight characters for editing. Use 

the left arrow, right arrow or spacebar on your keyboard to navigate 
within a lyric block. Once positioned, type normally. 

d. Characters can also be cut, copied or pasted to other lyric blocks using 
standard Ctrl + “X”, “C” and “V” keyboard shortcuts (Cmnd + “X”, “C” 
and “V” for Mac).
Using to SmartScore X



e. To edit a lyric block below the current line of lyrics, click into the topmost 
line of lyrics and use the down arrow key. Cursor will enter the next block in 
lyric line immediately below. 

f. To create a new lyric line, hit Return anywhere in a lyric line. A new lyric 
line will be created at the first note of the system. 

g. Push “L” again (Toolbar) to exit Lyric Edit.

To move lyrics up or down between staves,
a. Hold the Shift key down (Nudge mode), locate the yellow control handle 

along the left-most barline of the system.
b. Drag the control handle up or down to move entire lyric block.

FIGURE 7 - i: Nudge mode - repositioning Lyrics

TIP: You may also change lyric font size. See "Adding and changing styles of 
Text and Lyrics", Section 7.2.2.

7.1.1 Dashes, spaces and underscores
Dashes, spaces and underscores are special characters used to separate lyric blocks. 
Typing any of these characters will move the cursor to the next block. The Backspace
key deletes dashes, spaces and underscores.
In the following example, the block “der-” was missed in recognition. The cursor was 
positioned at the end of the previous block. A dash was entered to create a new “syl-
labic” block and the correct text was then entered. 

FIGURE 7 - 2: Editing Lyrics
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• Dash = Moves the cursor to next lyric block and inserts a dash. Normally used to 
connect multiple syllables within a single word.

• Space = Moves the cursor to the next lyric block. Normally used to separate 
words. Does not insert a dash or an underline.

• Underline = Normally used as a “miasma”, an underline indicates that one vocal 
sound should be extended over two or more beats. Inserting creates an underline 
up to the next block. Entering multiple underlines will string them together over 
several lyric blocks. 

• Backspace = Deletes characters inside a lyric block. Also deletes hyphens when 
backspacing from one lyric block to the next.

• Enter = Creates a new lyric line and positions cursor in the first lyric block below 
beginning note or rest of the staffline.

7.1.2 Verifying vertically aligned voices
Nudging note heads horizontally is a good way to verify that a particular lyric block 
is indeed associated with a note stem. In a similar way, Nudge mode is useful in veri-
fying that vertical events are properly aligned. Refer to "Checking vertical alignment 
of voices", Section 9.9.3 for more information.

To verify vertical alignment of two or more voices in Nudge mode,
Horizontally nudge the upper note (Voice #1) of a vertically aligned set of notes and/
or rests. All vertically aligned (joined) notes or rests will move together.

7.2 Text mode
7.2.1 Entering and editing text

To enter Text mode for editing or creating “dumb” text,
a. Push the “T” button in the Text and Controller Toolbar. 

Text fields are associated with the nearest staffline. To ensure text is associ-
ated with a particular staff, move the cursor over the staff first.

b. Click anywhere and begin typing.
NOTE: It will not be possible to do other sorts of editing other than text or 

lyrics in either of these modes. It will be necessary to push “T” or 
“L” again to exit the mode first.

To edit a text field,
a. While in Text mode, click anywhere inside a text field.
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b. Drag left or right to highlight one or more characters within the field. Typing 
will replace the characters. Hit the Delete key to remove highlighted charac-
ters. Text can also be cut, copied or pasted elsewhere using standard Ctrl 
+“X”, “C” and “V” shortcuts (Cmnd + “X”, “C” and “V” for Mac).

To delete text fields,
a. To delete more than one text field, use the Select tool (“O” key) to select and 

highlight text in yellow. Hit the Delete (Del) key removes all highlighted 
text fields. 

b. Quick-select (Ctrl+click) any text field, hit the “X” key (cursor goes grey) 
and click again on any text field to remove it.

7.2.2 Adding and changing styles of Text and Lyrics
Out of recognition, text and lyrics are matched to the closest font type and size avail-
able. You can modify the font type, size and color of all text or lyric styles. Changing 
the style of the lyric block will change ALL lyrics because lyric have only one style 
and text fields can be assigned many different styles.

FIGURE 7 - 3: Changing Text and Lyric styles

.To modify font styles of text fields and lyric blocks,
a. Push the “T” button to enter Text mode. Click into any text field. While the 

cursor is blinking, right-click (alt/option + click for Mac) to open the Style 
window.

b. For lyrics, push the “L” button and click on either the associated note or rest 
or directly into a lyric field. Right-click to open the Style window (alt / 
option + click for Mac). 

The current text style will be highlighted in the Text Style window. 
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c. Click on the style you wish to change. Select “Modify Style” and enter new 
font characteristics and push “OK”.

You may also add a new style to the list for continued use later.

To add a new style, 
• Select “Add style” and enter new font characteristics. Push “OK” and then give it 

a name (e.g. “Fingering”).
NOTE: The styles window is also accessible by pushing the “Text Styles” 

button in File > Document Preferences.

7.2.3 Nudging text
To nudge text,

a. Hold the Shift button down to enter Nudge mode.
b. Each text field has a small yellow box to its left. 
c. Click and drag the box to reposition the text field to where you want it. 

To move multiple text fields,
a. Use the Select Tool and drag the cursor to highlight a multiple text fields. 

Release the mouse button. Selected text fields will turn from yellow to 
green-grey. 

b. Hold the Shift button down to activate Nudge mode.
NOTE: Dragging one control box of a highlighted text field will move all 

selected text fields together

7.3 Music Symbols
7.3.1 Guitar Fret and Chord Symbols

Guitar fret diagrams are recognized automatically. Chord symbols written as 
text can be recognized and automatically converted to fret symbols when 
Recognize Text Symbols as Chords option is selected prior to scanning. See 
"Recognition Options", Section 4.2.1. When transposing key signatures, fret 
symbols transpose and root names will automatically be updated. 

7.3.2 Choosing a fret / chord symbol from the library,
If no chord or fret symbol was recognized, one can be selected and inserted using the 
Guitar Chord Library (GCL).
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a. Push the fretboard button in the Toolbar or Ctrl + click on any chord symbol 
nearby.

b. Click above the topmost staff where you want the symbol to be inserted.
c. The Guitar Chord Library and editor will open. 

FIGURE 7 - 4: Guitar frets and chord symbols library

d. Select a Root chord. Add a Sharp, Flat, Tonality, Extension and Augmen-
tation as necessary. 

e. If the selected chord name matches one stored in the library, a corresponding 
fret configuration will appear in the right window. 

NOTE: If there are multiple fret configurations for the same chord name, the 
box next to Primary will be checked. Use the Index scroller to 
search for alternatives.

f. Push OK. The fret / chord symbol will appear where you previously clicked.

7.3.3 Changing Chord and Fret symbols
If a fret / chord is incorrectly recognized, you can quickly fix it; often by acquiring 
the value of a nearby chord which is correct.

To copy the value of one fret / chord symbol and apply it to another,
a. Ctrl + click on a chord symbol that is identical or similar to the correct 

chord name. That chord’s configuration will be inherited and stored by the 
cursor.
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b. Right-click (Option + click for Mac) on the chord symbol that you wish to 
change. The stored (correct) chord will then appear in the Guitar Chord 
Library. If you are satisfied with the naming and fingering of the displayed 
chord, push OK. The correct configuration will be applied to the old chord.

To change an existing chord by selecting one from the library,
a. Ctrl + click on a chord symbol to be changed. Click on the chord again to 

open the Guitar Chord Library.
b. Change the root chord, tonality or other extension. Fingerings associated 

with the selected configuration will appear in the diagram to the right.
c. Click OK once you have found an acceptable chord name / fingering config-

uration. The chord will become updated. 

If you are unhappy with the fingering diagram or fret positioning of any particular 
chord, you can permanently change it.

To change the fingering configuration of an existing fret symbol,
a. Push the Change button in the main GCL window to open the Change Gui-

tar Chord editor.
b. Select the Frets tab to open the fingering and frets editor. Edit options are as 

follows:.

FIGURE 7 - 5: Guitar Chord Library - Fingering Editor

• Right-click (Option + click for Mac) on any finger marker inside the fretboard to 
remove it.

• Clear All (grid) removes all current finger markers in fretboard.
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• String Marker (dot) places a finger marker on any string between frets on the 
fretboard. Clicking above the fretboard nut (thick line) places an open string sym-
bol (open dot) at any string position.

• Barre Marker (arc) places a barre marker above the fretboard by dragging above 
the nut. When dragged across strings inside the fretboard, the barre marker is 
positioned between frets.

• Mute-string marker (x) places an X above any string position to indicate a 
muted string. When clicked above the nut, any finger marker of that string is 
deleted.

• For banjo, ukulele, bass or other non-six string fretted instrument or for chords 
that require more range than 4 frets, choose the configuration you wish from 
Strings x Frets combo box.

• To show fingerings in other than 1st position, choose from Position Selector. The 
solid line represents the fret position.
c. Once changes have been made, push Done. The original configuration will 

be permanently replaced when you press OK. If you made a mistake, push 
Cancel and try again.

7.3.4 Creating a new chord symbol / fret configuration
If the particular chord symbol or fingering configuration you want does not exist, you 
can add it to the chord library.

a. Push the Guitar Chord button in the Toolbar. The cursor will become a grid. 
Click where you want to insert a new chord above a staff line. (Be sure the 
correct staff is “active”)

b. In the main GCL window, select a Root chord name. Add Sharp, Flat, 
Tonality, Extension and Augmentation. If the selected configuration does 
not exist, no diagram will show.

c. Push the Add button to open the Add Guitar Chord editor.
d. Make chord configuration selections in the Label tab and desired fret and 

fingering settings in the Frets tab.
e. Once changes have been made, push Done. In the main GCL window, push 

OK is drop the new chord in place.
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7.3.5 Adding additional fret configurations to the library
You may wish to add alternative fingering configurations to other chord symbols 
which share the same chord name. Also, following recognition, you may see some 
fret symbols without chord names. These can also be configured and added to the 
library.

To add alternative fret configurations to the Guitar Chord Library,
a. Ctrl + click on any existing chord symbol or push the fretboard button in 

the Toolbar so the cursor becomes a grid. 
b. Click on top of any fret symbol or click anywhere above a staffline to open 

the chord library.
c. Push the Add button in the main GCL window to open the Add New 

Chord editor.
d. Make chord configuration selections in the Label tab and desired fret and 

fingering settings in the Frets tab.
e. Push Done. A notice may appear telling you that another fret configuration 

with the same chord name exists. When asked if you want to add the new 
chord to the library, select “Yes”.

7.3.6 Guitar Library file management

To export, import, reset or clear a GCL library file, 
• Press File in the Chord Library window. The Library Management window will 

open.
• Export Library will save the current set of chord and fret configurations to 

your hard drive as a .GCL file.
• Import Library will load a saved guitar chord library from a directory and/

or drive. Locate the .GCL file and push OK to load.
• Reset to Default will reload original guitar chord library as initially loaded 

during installation.
• Clear All Chords deletes all current guitar chord library data.
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7.3.7 Chord Symbol Preferences

To modify how all chord symbols appear in the ENF view,
a. Open the Chord Symbols tab in Edit > Document Preferences window.

Change the default appearance of chords as follows:

FIGURE 7 - 6: Guitar Chord Preferences

• Chord Symbol Appearance: Show Fret & Chord names / Frets only / Chords 
only / None

• Long Tonality: Check this off to display Major tonality as “M” and Minor as 
“m”.

• Guitar Chords Scale: Use the scroller to increase or decrease the size of all fret / 
chord symbols. Scale by percentage.

• Chord Name Font Style: Change the default font, style and size for chord sym-
bol names.
b. Press Apply or OK to apply and close.

7.3.8 Editing chord and fret symbols in ENF

To Copy and Paste any fret or chord symbol,
• Ctrl + click on the chord symbol you wish to copy. With your mouse, click any-

where to paste the symbol you just clicked on. The Guitar Chord Library will 
open to confirm your choice. Press OK to insert.

To delete existing chord symbol(s),
• Hit the “X” key and click on the symbol you wish to delete. To remove several 

fret symbols at once, use the Select tool (“O” key) to highlight as many fret sym-
bols as you wish and hit the Delete key.
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To move one or more chord symbols,
• Use the Select tool (“O” key) and highlight one or more fret symbols. Hold the 

Shift key down (Nudge mode) (Shift) then drag the control point of any fret sym-
bol. This will move to all selected chord symbols.

7.4 Non-musical Symbols
7.4.1 Using Text and symbols to mark up scores

Solo guitar, violin and other scores often contain many annotations and fingerings. 
Most can be entered using score symbols and even rehearsal markings.

To annotate fingerings and string numbers,
• Use Text mode to enter fingering numbers. If the default text size is too large, add 

and use a new text style with a smaller font (see "Adding and changing styles of 
Text and Lyrics", Section 7.2.2)

• Use Rehearsal marks to enter string numbers with in circles. 
• Use Nudge mode (Shift) to position inserted symbols exactly.

7.4.2 Document Preferences
Non-lyric and non-text symbols (e.g. dynamic and tempo markings) which appear as 
text are also editable. Default font, size and behavior of symbols can be changed in 
Document Preferences.
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To edit Text Symbols,
Open Edit > Document Preferences. The Text Symbols tab appears as follows:

FIGURE 7 - 7: Document Preferences > Text Symbols tab

To edit Score Symbols font characteristics,
Open Edit > Document Preferences > Score Symbols tab.

7.4.3 Bracketing
Instrument families are grouped with the use of brackets. Grand staff and braces are 
recognized whenever possible. Use Bracketing to assign braces, grand staff brackets 
and to join selected parts into barline groups in an ENF document. This feature can be 
also be used to change the behavior of brackets and barlines. For example, barlines 
can be separated by stafflines and/or by instrument grouping.

To break barlines between stafflines
a. Select Bracketing from Edit menu (Ctrl + B (Cmnd + B Mac).
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b. Select “Break barlines by staff”. Click “OK”.

FIGURE 7 - 8: Bracketing window

To create braces, grand staff brackets and create barline groups,
a. Highlight two or more parts in list to select for grouping.
b. Choose Brace, Grand Staff or Barline Group set and press Set Sel.
c. Continue to select parts for any other type of group. Any selected group can 

overlap parts of another selected group.
d. Click “Break Barline by Brackets” checkbox to have barlines break 

according to instrument families which are already designated by braces, 
groups and grand staffs.

e. Choose Clear Sel or Clear Selected Parts in selected group or Clear All to 
remove groupings.
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7.4.4 Score Header
Score headers are not considered “text”. They are unique tags.

To enter a Score Header at the top of the first page of the ENF file,
a. Select Edit > Score Header.

FIGURE 8 - 1: Score Header

a. Enter a name for the ENF document in the Title field.
b. Enter a Composer name if desired. 
c. Type a part name if it is a Score-Part. For definition, see Score-Part on 

"Score Formats", Section 13.1.

To move a Score Header vertically,
• With Selector tool active, drag the positioning tab associated with the score 

header found in the left-hand ruler up or down.
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Chapter 8 Reformatting, Part Extraction & 
Page Setup

8.1 Reformatting scores in ENF view
Measures, staff lines, systems and even pages can be resized, compressed or 
expanded while maintaining proper note spacing. Parts can be extracted from the 
score and/or recombined to form conductor’s scores. Page layout and margins can 
then be selected, modified and previewed prior to printing. 

NOTE: It’s best to correct mistakes before reformatting the score because 
ENF synchronization with the original scanned pages may be lost. 
Even if synchronization is lost, a floating Scan View reference 
window will be available. For more details, see Section 9.1.1, 
"Split-screen and scan view reference views".

8.2 Edit > Format Score
This window provides tools that can reformat the ENF score including line and 
staff spacing, measures per system and even a tool that rescales (optimizes) the 
ENF frame should your scanner force rescaling the image instead of resetting dpi..

FIGURE 8 - 1: Format Score window

• Measures per system 
Select a fixed number of measures for every system in the score.
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• Apply punctuation 
Apply auto-spacing to reformatted measures.

• Setup indents 
Set indent for 1st system.

• Setup spacing. 
Set staff and system spacing.

• Scale entire score (optimize score size)
Following recognition and before printing, scores can be resized up or down to fit the 
default page size. This is particularly useful when scores were incorrectly scaled by 
some scanners (e.g. all-in-one scanners); correcting overly large-scale or small-scale 
ENF files.

To rescale the ENF score (optimize page size for printing)
a. Push Find Optimal button in Format Score window. The optimal ENF 

page resize amount is calculated and will appear in percentage window.
b. Push OK to apply change in page size.
c. Open Page Setup (File > Page Setup) and change Document Layout to 

“Center on Page”. Push Apply to view changes in Preview mode. Push OK 
to close Page Setup.

8.3 Horizontal Reformatting
System widths can be changed one-by-one or globally. 

To globally change system widths, 
• See "Changing default margins", Section 8.5.2.
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Single system widths can be changed in the ENF main view by dragging either end 
point tab in the upper ruler margin.

FIGURE 8 - 2: Using tabs to change staff distances and system widths

The lower tab towards the left margin adjusts the position of instrument Part Names 
(See 

8.3.1 Nudge Mode (Barlines)
Several interesting and useful reformatting possibilities can be applied when barlines 
are repositioned in Nudge mode:
• Resizing adjacent measures by dragging barline horizontally. See "Nudge mode 

(Shift button)", Section 9.2.
• Shuttling measures in/out of systems by dragging last barline. See "Repositioning 

measures using barlines", Section 9.2.6.

8.3.2 Adjusting measures
Measures can be compressed or expanded in Nudge mode. This may cause measures 
to scroll from system to system. Also, the number of measures per line may be set to 
a fixed number. These actions will cause the score to reformat.
For more details, see "Repositioning measures using barlines", Section 9.2.6. For set-
ting fixed number of measures per system, see “Set Number of Measures” in Section 
6.3.1, "Staff Properties".
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8.4 Vertical Reformatting (Line, staff and system spacing) 
Staff and system spacing can be changed by simply dragging sizing tabs up or down. 
Staff height and distance settings can also be made numerically and applied globally 
using the dialog box described in "Staff Line Options > Line/staff spacing", Section 
8.4.3. 

8.4.1 Changing staff and system distances (Red tabs)

To visually increase/decrease staff and system distances...
• Position the cursor over a staff to make it active. The bottom-most red tab con-

trols the distance between the active system and the system below it. Each staff 
will have a red tab aligned with its topmost line. These tabs change distances 
between staff lines. The “T” tab on top changes the margin between the active 
staff and the staff above it.

FIGURE 8 - 3: Using tabs to change staff distances and system widths

8.4.2 Changing staff line spacing (Blue tabs)
Moving the blue (staff height) tabs not only increases the height of a single staffline, 
it also increases the size of all musical symbols inside that staff. To apply a staff 
height change to all remaining staves, use the “Copy to” command. See "Staff Line 
Options > Line/staff spacing", Section 8.4.3

Changing staff distances
(Red tab)

Changing system distances
(“T” tab)

Active
Staff
Using to SmartScore X



To increase/decrease the height of individual staves...
• Drag the blue tab aligned with the bottom line of any staff up or down. The staff 

will resize vertically.

FIGURE 8 - 4: Using tabs to change staff distances and system widths

8.4.3 Staff Line Options > Line/staff spacing

With the Properties Tool selected, right-click (alt + click for Mac) in any 
staff line for spacing options. The Spacing window provides a method to 
make and uniformly apply changes in staff and system distances to the 
remainder of the score. Measurements shown are numerical representations 
of distances for all staves of the active system. Changes made by colored 
spacing tabs in the main ENF view can also be applied using this window. 
See earlier section (colored tabs for line and staff spacing).

Here are some practical examples:
• Improve page layout by optimizing number systems in pages. 
• Create piano accompaniments with smaller (reduced) solo parts.
• Create large-notehead (“E-Z Read” format) scores.
• Resize staves converted from TAB to melody and vice-versa.

Resizing staff height
(Before dragging blue tab)

Resizing staff height
(After dragging blue tab)
Using to SmartScore X



To numerically change staffline and system spacing,
a. Right-click (alt + click for Mac) inside a staff line. Choose “Line/staff 

spacing” among the options.

FIGURE 8 - 5: Line/staff spacing window

b. Make changes to staff line distances and to top / bottom staff spacing in the 
active system. Push OK to view changes.

To apply distance changes to other systems in the score,
a. Once changes in distances are confirmed in the ENF display, right-click on 

the source system and select Staff Line Spacing again to continue.
b. In the Copy Settings To area, select either “Next Systems” or “All Sys-

tems”. Next Systems will change subsequent systems and All Systems will 
change all systems in the score.

c. Push Copy to apply the changes. 
Push OK to close the window.
Use the Next System or Previous System buttons to compare settings. To visually 
check changes in the ENF display, push OK and examine changes made. 
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8.5 Document Page Setup
Your finished score will probably be printed out so you’ll want to control how it will 
look beforehand. You may want to resize staves and systems or reformat the entire 
score. You may also want to extract and recombine parts and voices or create a con-
ductor’s score from separate parts. This chapter includes changing score structure, 
reformatting margins, page layout control and print preview.

To preview and change a document’s page layout, 
• Push Page Setup button in the Navigator (File > Page Setup)
If your score was created out of recognition, the Document Layout pull-down menu 
will show “From Recognition”. Each page frame represents the exact area cropped 
when each page was scanned. Choices include selecting a default page size and orien-
tation as well as centering music on the page or else choosing one of several preset 
layouts as described below. 

8.5.1 Page Centering

To apply selected page size / orientation and center music on pages, 
a. Make sure your Page Type is correctly set to your paper size.
b. In the Document Page Setup pull-down menu, select  

Center on Page. 

FIGURE 8 - 6: Document Page Setup (Center on Page)

c. Push Apply. Score pages in the background update with changes.
NOTE: Each page can be fine-tuned by dragging either of the frame tabs in 

the left margin up or down. Use the bottom scroller to view and repo-
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sition each page up or down if necessary. Once you are satisfied with 
the layout of your document, push OK.

8.5.2 Changing default margins
Default page margins can be changed after selecting a layout choice and page type/
orientation.

FIGURE 8 - 7: Document Page Setup (Center on Page)

• In Page Setup, change margins of each page by moving tabs inside the vertical 
and/or horizontal rulers.
NOTE: Changing margins is done on a page-by-page basis. Tabs inside verti-

cal and horizontal rulers will affect only the active (highlighted) 
page. Move cursor over a page to make it active. To change width of 
a single system, see "Vertical Reformatting (Line, staff and system 
spacing)", Section 8.4.

8.5.3 Changing page orientation of an ENF score

To change page orientation of an entire ENF score (e.g. from Portrait to Landscape). 
a. If you are changing layout from Portrait to Landscape, you should increase 

the number of measures per system (e.g. from 4 to 7). If Landscape to Por-
trait, decrease the number of measures per system (e.g. 8 to 4). See "Staff 
Properties", Section 6.3.1.
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b. In Page Setup, choose the layout (e.g. Centered) then choose a page type 
and orientation (Landscape or Portrait). 

c. Move the left and right margin tabs to achieve the desired system width / 
margin spacing for each page.

In the page preview, you may see systems too close to the top or bottom of the page. 
Or you may see large gaps at the bottom or top of pages. You will need to change sys-
tem distances in these cases. 

d. Push Main View button at the top of the page and zoom out to full-page 
view as necessary. Adjust staff and system distance spacing using the tabs 
along the left margin. For more information on vertical spacing tabs, see 
"Vertical Reformatting (Line, staff and system spacing)", Section 8.4

8.5.4 Default Page Size and Type

In the English version of SmartScore, the default page size and type is Letter / Por-
trait. In European versions, A4 / Portrait is the default page type. The default for 
Page Type can be reset in Edit > Program Preferences.

To permanently change your default Page Type and orientation,
a. Go to Edit > Program Preferences > Page Type
b. Select “Letter”, “Legal” or “A4” for your default page type / size.

8.5.5 Custom document layouts
Custom document layouts (other than Center to Page) are intended for publishing 
printed scores that will be spiral bound or stitched together. Page margins and system 
widths will be altered depending the page size and orientation of the layout scheme 
you select. Since pages will probably become reformatted, you may see systems 
move from page to page. We recommend that you correct (edit) the full score first 
while the TIF-ENF panes are still synchronized. 

NOTE: In the English version, Page Type size is “Letter”. In European ver-
sions, “A4” is the default page type. The default for Page Type can 
be reset in Edit > Program Preferences.

a. To select an alternative (custom) document layout, 

Select the layout you want to apply from the Document Layout pull-down 
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menu as described below:

8.5.6 Document Layout Defaults
Page Layout: Loose Leaf  
Single-sided pages with music centered in the middle of the page
Page Alignment: Centered 
Page Margins: 0.5” Top, Bottom, Left, Right
Page Layout: Loose Leaf with Header Page  
Single-sided, centered pages with first page having a 2” header:
Front Page: Centered 
Page Alignment: Centered 
Page Margins: 3” Top (1st page). 0.5” inch Top, Bottom, Left, Right (remaining 
pages).
Page Layout: Facing 
Left / Right pages with increased inside margins for binding
Left Page: 1.5” right margin 
Right Page: 1.5” left margin 
Page Margins: 0.5” Top, Bottom, Side (default)
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Page Layout: Facing with Header Page 
Left / Right pages with first page having a 2” header
Front Page: Centered 
Left Page: 1.5” right margin 
Right Page: 1.5” left margin 
Page Margins: 3” Top (1st page). 0.5” inch Top, Bottom, Left, Right (remaining 
pages).
You may wish to create your own personalized layout and add it to the existing layout 
schemes.

To create a new document layout:
a. In Document Layout pull-down menu, select a Custom Layout (other than 

Center to Page). Push the Add button.
b. Give a name to the new layout.
c. Reset the numerical scrollers on Left, Right, Top and Bottom or simply click 

and drag the margin guides inside the preview window. You may also 
change page orientation and page type from the pull-down menus on the 
right. 

d. Push OK to create the new layout.

FIGURE 8 - 8: Default Page Margin Control

8.6 Extracting and joining parts and voices
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8.6.1 Extracting parts using Visibility
Below is an example of a vocal / piano arrangement. Here is how to extract the vocal 
line and open it in a fresh document.

FIGURE 8 - 1: Three-part score (e.g. Gluck.ENF)

To extract a selected Part from within the System Manager,
a. Position your cursor over an ENF system that contains the part you wish to 

extract. Hit Ctrl+M (Cmnd+M for Mac). The System Manager will open.

FIGURE 8 - 1: System Manager (displaying active system)

b. Check the box “Visibility” in lower left-hand corner of the window. This 
informs the System Manager of the kind of action we are taking. 

c. Now we will choose which parts to extract. To the left of the parts you do 
not wish to extract, remove the visibility checkmarks. This leaves only the 
part(s) you wish to extract with checkmarks.

d. Press Apply to New to create a new score, leaving the current file unaf-
fected. Or press OK to remove parts from the open document.
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This is the result of extracting the part shown in FIGURE 8 - 1:

FIGURE 8 - 2: Extracted vocal Part

8.6.2 Extracting voices using Visibility
Let’s go back to the original ENF document in FIGURE 8 - 1: (Gluck.enf / tif or any 
three part score). Let’s say we want to extract a contrapuntal voice from the right 
hand part.

To extract a voice from an existing part,
a. Select Edit > System Manager (Ctrl+M (Cmnd+M Mac)).
b. Remove checkmarks of all parts and voices except for the part and voice you 

wish to target.

FIGURE 8 - 3: Selecting Voices to be extracted

c. Make sure “Visibility” in lower left-hand corner is checked.
d. Press Apply to New to create a new score, leaving the current file unaf-

fected. Or press OK to isolate the part in the open document.
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Here is the result of extracting Voice #1 from the right hand piano part:

FIGURE 8 - 4: Extracted Voice

8.7 Using Score Structure to Extract & Join Parts
8.7.1 Structure and hierarchy

Score Structure (Edit > Score Structure) is a powerful tool that allows you to create 
entirely new scores by removing, creating and re-linking parts. By simply dragging 
links around, you have the ability to remove parts, extract parts and join individual 
part scores into multi-part “conductor” scores. See "Scanning Part Scores (Score-
Parts)", Section 4.5 for more info.

NOTE: Using Score Structure is a graphical method for extracting / recom-
bining parts. Another method is to use “visibility” control in the 
Master System. For more details, see "Extracting Parts", Section 
9.10.3

8.7.2 Extracting parts in Score Structure
a. With multi-staff score open in ENF vies, select Edit > Score Structure.

FIGURE 8 - 5: Score Structure (Typical Piano/Vocal Arrangement)
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b. Click on parts you wish to remove (leaving the part/s to be extracted).
c. Push Apply to New. The remaining parts will open in a new ENF document 

without affecting the original.

8.7.3 Creating a conductor’s score from individual parts
a. An ENF file was recognized from 3 part scores (each having one Part per 

Score-Part). A “Score-Part” consists of all the pages of a single instrument 
in a part score. Some Score-Parts may contain more than one Part (a piano 
Score-Part has 2 Parts and an organ Score-Part has 3 Parts). Let’s view the 
structure of a part score and then combine all parts into one document. 

FIGURE 8 - 6: Score Structure (Typical 3 Score-Part structure)

To view score hierarchy & create a conductor’s score from score parts, 
b. Click on any Score-Part to highlight it and push the Insert button at the bot-

tom of the window. You will see a blank Score-Part appear.

FIGURE 8 - 7: Inserting new Score-Part

NOTE: Inserting a new ENF Document will work just as well. In either 
case, applying the change (Apply to New) will create a brand new 
ENF document, leaving the original file untouched.
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To the left, a new, empty 
Score-Part was Inserted 
(you could also re-link 
parts to an existing 
Score-Part). Here, the 
new Score-Part is given a 
name (Win: Right-click /
Mac: Option + click to 
open its Properties). To 
relink any structural 
object, click on the 
object and drag it to 
another object in an adja-
cent column. Here, the 
three existing parts are 
relinked to the newly 
created Score-Part 
(named Conductor’s). 
FIGURE 8 - 8: Creating a 

Conductor’s Score

Highlight the unlinked 
Score-Parts and push 
Remove. Push Apply to 
New. The modified 
structure is transformed 
to a new ENF document.

NOTE: Newly-created documents will have the same name of the source file 
plus “1”, “2” etc.

8.7.4 Creating Part Scores from Ensemble Scores
Extracting instrumental parts out of a conductor’s score in Score Structure is similar 
to creating a conductor’s score from score-parts, just reversed. NOTE: All Smart-
Score files (ENF documents) must contain at least one Score-Part linked to at least 
one Part.

a. Open an ENF file with 2 or more staves per system. 
b. Select Edit > Score Structure.

Naming new Score-Part in Properties

Re-linking Parts to new Score-Part

New Conductor’s Score (Apply to New)
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Here is a typical “ensemble” 
score containing several 
parts linked to it. Since all 
parts are joined, there is 
only one Score-Part. 
Click on the empty Score-
Part and push Insert to cre-
ate three new Score-Parts. 
Drag each Part (child) to 
new Score Parts (parent) to 
deconstruct the ENF docu-
ment. Right-click (option + 
click for Mac) in Proper-
ties and give a name to 
each. 
FIGURE 8 - 9: Creating Score 

Parts from Ensemble scores

Push Apply to New. This 
will create a new document 
with 4 Score-Parts arranged 
in order (all pages of Part 1 
first, then all pages of Part 
2, etc). Playback remains 
synchronized. Again, the 

original ENF document will remain open and unchanged.

Inserting New Score-Parts

Naming and re-inking 
Parts to New Score-Parts

Ensemble score having 4 parts
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Chapter 9 Detailed ENF Editing

9.1 More ENF navigating
9.1.1 Split-screen and scan view reference views

Both the ENF view (white) and the image reference view (yellow) appear in “split 
screen” format immediately following recognition. Alternative reference views 
include a floating “Scan view window” and “Overlay with fader” feature (Mac 
only). 
NOTE: After reformatting a system, page or score, the floating scan view window 

will automatically open. 

FIGURE  9 - 1: Scan Reference Views

To choose an alternative reference view,
a. Go to View > Split Screen and select an alternative reference view option.

Default Split Screen Floating Scan View window

TIFF / ENF Transparency Overlay (Mac only)
Using to SmartScore X



Mac Only: Try the TIFF / ENF transparency overlay with fader.

To view a variable ENF transparency over the TIFF pane,
a. Go to View menu and select “Split Screen > Overlay”.
b. Use the variable transparency fader to the right of the Toolbar to adjust the 

opaqueness of the top ENF pane.

To activate the floating Scan View window,
a. Go to View menu, select “Scan View Window”. 
b. To increase or decrease zoom view of the window, choose either Zoom 25% 

or Zoom 50% from the View > Scan View window. 

9.1.2 Scrolling
Use the scroll bar and up/down arrows to the right of the ENF window. You may also 
use the arrow keys located on your computer keyboard to scroll up, down, left, and 
right in an ENF document.

9.1.3 Paging

To page forward or backward in an ENF document, 
• Use the “Next page” / “Previous page” buttons located in the Toolbar or 

push the double paging arrows at the lower right-hand corner of the Smart-
Score window.

9.1.4 Go To…(Ctrl +G or Cmnd+G for Mac)
While editing, you can jump to any page or measure in ENF file. 

To open the GoTo… window 
a. Choose the View menu and select Go To... (Ctrl+G or Cmnd+G for Mac).

FIGURE 9 - 2: Go To window

b. Select whether it is a Part, Page or Measure you wish to jump to.
c. Enter the Part, Page or Measure number.
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d. Checking the Open Target in New View box will open a new ENF at the 
targeted Part, Page or Measure. Push OK to jump.

9.2 Nudge mode (Shift button)
By holding the Shift button down, the display switches to a special edit mode. Active 
control points are shown as orange boxes. 

9.2.1 Changing note pitches 
• Click and drag the control point (center of notehead) up or down.

9.2.2 Moving notes and rests horizontally
• Each note contains two horizontal “pull points”; one above the staff and one 

below. Click and drag either control point to nudge a note or rest horizontally.
• To move multiple symbols horizontally, use the “O” key to select the objects. 

Drag the “pull point” of any object left or right.
• To compress or expand symbols within a measure or within an entire staff line, 

refer to "Repositioning measures using barlines", Section 9.2.6.

9.2.3 Resizing beam angles and note stems
• Dragging the endpoint of a beam or note stem will increase or decrease its 

length.

9.2.4 Repositioning text fields linked to an active staffline.
• All text fields are linked to an active staff line. To reveal the control point for 

each text field, position your cursor over its associated staffline and then 
locate the control point of the text field.

9.2.5 Reshaping arcs and slurs
Slurs (legatos) can be reshaped in two ways:
• By moving end points of the arc or
• By controlling the shape of the curve with either Bezier control handles.

FIGURE 9 - 3: Reshaping slurs

End points con-
trol the place-
ment of the slur.

Bezier handles 
control the shape 
of the slur.
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9.2.6 Repositioning measures using barlines

To horizontally reposition all symbols in adjacent measures:
• In Nudge mode, moving barlines to the left or right will reposition symbols in 

measures adjacent to the barline. Symbols will become more spaced out or more 
contracted depending on the direction. This is helpful when a particular measure 
becomes crowded. Try it! Notice that relative note spacing (punctuation) is 
retained when measures are expanded or contracted. 

To horizontally reposition all symbols in a staff line:
• Moving the barline at the end of a system will compress symbols in the entire 

system and all relative note spacing will still be kept intact. If a barline at the end 
of a system is moved far enough to the left, the first measure of the following sys-
tem will reposition itself to become the last measure of the active system. 

NOTE: For more details, see "Vertical Reformatting (Line, staff and system spac-
ing)", Section 8.4.

9.2.7 Special fixes possible with Nudge mode

9.2.7a Fixing beam angles
Beam angles are a function of the length of note stems within the beam. By dragging 
note stems up or down, the angle of the beam will change. Control points at the end 
of beams can also be dragged up or down to adjust overall beam angle.
If a beam collides with note stems or appears at odd angles after moving or deleting 
notes, click & drag the control point on either beam end. Drag beam end until it is 
properly positioned. Stems of notes alternate as the beam angle is changed. 
Use the stem-lengthening method to control cross-staff beaming:

FIGURE 9 - 4: Controlling cross-staff beams 

Beam colliding with 
note stem

Drag beam control 
point to flip stem direc-
tion

Drag beam control 
point to change beam 
angle
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FIGURE 9 - 5: Improving flagged note positioning by lengthening its note stem

9.2.7b Fixing offset notes & rests belonging to two voices
Notes and/or rests belonging to different voices (within the same vertical event) will 
automatically offset when positioned next each other. This is meant to avoid colli-
sions between the two. Depending on the situation, readjusting position offset objects 
is possible:

FIGURE 9 - 6: Offset due to rests too closely positioned

9.3 Tool Palettes
Tool palette buttons are expandable. Any button with a small arrow in the 
lower right corner will expand to reveal all possible symbols when held 
down with the left mouse button for several seconds.

FIGURE 9 - 7: Expandable tool palettes

Flagged note in secondary voice After dragging note stem control
causes offset in primary voice. point downward, offset is corrected.

Offset corrected after dragging.vertical proximity. 
Offset rests due to close
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9.3.1 Notes and Rests palette

9.3.1a Inserting Notes and Rests (Numeric keys)

NOTE: Press any numeric key from 1 through 0 to select a particular 
note value. “Shift + 1-0” will select rests. 

a. Select any note or rest from either of the expanding Notes or Rests but-
tons located “Notes” palette. 

b. Press the “C” key to activate Insert mode. 
c. The cursor will display the selected symbol along with a grey dot which 

indicates the line or space on the staff. Click to insert.

9.3.1b Cluster tool 

See Section 6.2.9.

9.3.1c Rests 

See Section 6.2.2.

9.3.1d Multi-measure rests 
a. Select the “n-measures” object from the “Rests” palette. 
b. Select the number of empty measures.
c. Click in an empty measure of the active staffline. 

9.3.1e Tuplets (T)
The “T” key opens the tuplet (Rhythmic Groups) Palette. Triplet is selected as the 
default. Drag the mouse to box in the notes/rests to become the selected tuplet. Drag 
downwards to insert the tuplet above the selected notes/rests. Drag upwards to insert 
the tuplet below selected notes/rests. For details, see Tuplets (Section 5.5.6)

9.3.1f Beam tool
See Section 6.2.10.

9.3.1g Grace Notes

While in Insert mode, select a rhythmic value and press the grace note but-
ton in the “Notes” palette. Click before any note in the active staff to insert a 
grace note. ENF playback will insert the grace note and truncate the duration 
of either the following or the previous note.
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To control how grace notes play back
• Select Edit > Document Preferences > Playback

Change default playback characteristics for grace notes:
• On the beat (accaciatura)
• Before the beat 

• If “Before the beat” is selected and the grace note begins a measure, the 
grace note will have to be placed at the very end of the previous measure. 
For more information, see Grace notes (Section 9.3.1g)

9.3.1h Dots of Prolongation
• Select the “D” key, dot or double dot from the “Notes” or “Rests” palette.

Click on any notehead to attach a dot of prolongation.

To delete a dot of prolongation, 
• Press the “D” key again and click on the notehead.

9.3.1i Ties

Ties connect contiguous notes of the same pitch causing the first note to 
sound for the duration of both notes. Ties are not the same as slurs.

a. While in the Insert mode, hit the “V” key or press a Tie button in the 
“Notes” palette. 

b. Click on the notehead of the first note of a tied pair to insert the tie with a 
downward arc.

c. Right-click (option + click for Mac) to insert a tie with upward arc. 
d. To delete a tie, hit the “X” key with a tie showing on the cursor and click the 

first note of the pair to delete. 

9.3.1j Accidentals 

FIGURE 5 - 10: Accidentals (in Notes palette)

To insert an accidental, 
a. Select any accidental from the expanding accidental button located in the 

“Notes” palette. 
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b. Toggle the “C” key to activate Insert mode.
c. Click on the notehead that is to receive the marking.

To change an accidental,
• Select an accidental from the “Notes” palette. Click on a note with an accidental. 

It will change to the selected accidental.

To delete an accidental, 
• Quick-select (Ctrl + click) any accidental, press the “X” key and click on a note-

head to remove its associated accidental.

9.3.1k Courtesy accidental tool 
A courtesy accidental is bounded by parentheses and acts as a reminder that a note 
has an accidental.

To insert a courtesy accidental, 
Press the parentheses button when any accidental is selected before clicking a note-
head.

9.3.2 Articulations palette

See "Articulations palette", Section 9.4.1 for editing details.

9.3.2a Slur (Legato)

Note durations associated with slurs are increased about 10% giving an 
overlapping or “connected” effect when played back.

• Expressions (In Section 9.4.1)

9.3.2b Turn

Click on note head or note stem apply a turn. Turns play as follows:

FIGURE 8 - 1: Turn

9.3.2c Fermata (bird’s eye)
Click on note head or note stem to apply a fermata. Tempo is slowed by 50% for the 
duration of the note to which the fermata is attached.
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9.3.2d Staccato
Click on note head to apply a staccato. Duration of the associated note is shortened by 
25%.

9.3.2e Tenuto
Click on note head to apply a tenuto. Duration of the associated note is extended by 
125%.

9.3.2f Accent
Click on note head to apply an accent. Accent increases the velocity of its associated 
note by 150%.

9.3.2g Soft Accent
Click on note head to apply a soft accent. Soft accent increases the velocity of its 
associated note by 125%.

9.3.2h Trill
With tr (trill) selected, click on a note to insert a single trill marking. To create an 
“extended” trill, hold the Shift button down (Nudge mode) and drag the yellow con-
trol handle on the trill marking to the right. See also "Articulations palette", Section 
9.4.1.

FIGURE 11 - 2: Trill and Extended Trill

9.3.2i Sharp, Flat and Natural
With one of these modifiers selected, clicking on a trill marking will insert the acci-
dental above the trill and cause playback of the trill to “flatten”, “sharpen” or “neu-
tralize” target pitches while considering the active key signature. 

9.3.2j Mordent
Click on notehead to apply a mordent. Mordents play back as follows:

Trill Extended Trill 
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FIGURE 11 - 3: Mordent

9.3.2k Inverted Mordent
Inverted mordent play back as follows:

FIGURE 11 - 4: Inverted Mordent

9.3.2l Tremolo (single, double, triple, quadruple)
Tremolos repeat the note affected by dividing the associated note by four times the 
selected tremolo value. See change existing half notes to beamed tremolos in "Articu-
lations palette", Section 9.4.1.

FIGURE 11 - 5: Tremolo (Double)

9.3.2m Arpeggio
Arpeggiated chords will offset the start time of all members of a cluster and will keep 
them sustained throughout the duration of the chord.

FIGURE 11 - 6: Arpeggio

9.3.2n Glissando
Glissandos divide connecting notes into equal notes of 1/4 base value.

FIGURE 11 - 7: Glissando)

Written Played

Written Played
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9.3.3 Clefs and Signatures palette
In Insert mode, Quick-select (Ctrl+click) the any nearby clef of the desired type. Or 
select any clef from the “Clefs” palette. 
• Click anywhere in the active staff to insert the selected clef. 
Click on any existing clef (yellow highlighted) to change it to the selected clef. Notes 
will not reposition themselves when a clef is changed either by a change-of-clef sign 
or by Unifying Clefs.

To delete a clef, 
• Quick-select (Ctrl+click) any clef, press the “X” key and click on a clef to remove 

it.
NOTE: Note positions do not move when a clef sign is changed. To change a clef 

while keeping original note pitches of a part or selected region, note posi-
tions must be shifted. Refer "Transposition by Key and Clef", Section 6.4.

9.3.3a Alto / Tenor / Mezzo-soprano (“C”) clefs
The midpoint of the “C” clef indicates where C below middle C (MIDI C3) is to be 
located.

9.3.3b Treble Octava / Bass Octava clefs
Playback in these clefs will be an octave higher than with a standard clef.

9.3.3c Treble Octavo / Bass Octavo clefs
Playback in these clefs will be an octave lower than with a standard clef.

9.3.3d Percussion clef
When the Percussion clef is inserted into a staff line, MIDI channel assignment of the 
staff switches to 10; the default drum channel. Notes are entered normally, but play-
back as MIDI drums. Note pitch-to-MIDI drum assignments are mapped in Drumset
option under the Playback menu.

9.3.3e Octava / Octavo tools
These are not clefs per se. Rather than insert with a mouse click, they are applied to 
selected notes by dragging to select the notes to be modified. Playback of selected 
notes will be an octave higher when selecting with Octava tool and an octave lower 
when selecting with Octavo tool.
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To assign Octava or Octavo to a range of selected notes
a. Select either Octava or Octavo tool. 
b. Drag the cursor to select notes in the active staff.

FIGURE 11 - 8: Octava

Notice that the Octava or Octavo mark will appear at the beginning of the range of 
selected notes an the applied range will be indicated by a dashed line above the 
selected notes.

• Signatures (Key and Time)
See "Articulation markings, such as trills, staccatos, tenutos, arpeggios, glissandos 
and mordents are note-specific.", Section 

9.3.4 Barlines palette (I)

To change or delete a barline, 

a. Select a desired barline from the “Barlines” palette or Ctrl+click on a bar-
line nearby. 

b. Click on a yellow-highlighted barline to change it to the selected barline.
c. To delete a barline, Quick-select it, press the “X” key and click on the bar-

line. 

9.3.4a Deleting / changing barlines at the end of systems.
Deleting a barline at the end or beginning of a system will cause that measure to roll 
up or down to an adjacent system. Follow this step to delete or change a barline type 
that ends or begins a system...

To change a barline at the end of a system to another barline type,
a. Insert the desired barline type to the left of the barline that you wish to 

remove.
Delete the barline (“X” key then click). The measure will shift slightly to the left but 
not roll to an adjacent system.
For details on repeats and jumps, see "Repeats", Section 5.10.
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9.3.5 Dynamics Palette
Dynamic markings affect the volume of a range of notes in the active staff (MIDI 
track) to which they are entered. 

9.3.5a Crescendos and Decrescendos (Hairpin Tool)

To insert a hairpin, 
a. Toggle the “C” key to the Insert mode.
b. Select a dynamic hairpin from the “Dynamics” palette or hit Shift + “,” for 

crescendo hairpin and Shift + “.” for decrescendo. 
c. Click and drag to select notes for which a hairpin is to be applied.
d. Dragging downward will insert the hairpin above the active staff. Dragging 

upwards will insert the hairpin below the active staff.

FIGURE 9 - 1: Hairpin crescendo (drag upwards)

To use keyboard shortcuts for entering hairpins (P, < and >)
• Press the “P” key to select p (piano) dynamic marking and open the “Dynamics” 

palette.
• Hold down “Shift” + “,” to select the crescendo hairpin.
• Hold down “Shift” + “.” to select the decrescendo hairpin.

To insert a crescendo or decrescendo mark,
a. Select Cresc. or Decresc. from the “Dynamics” tool palette.
b. In Insert mode, click and drag the mouse to highlight the range of notes over 

which you wish to apply the dynamic change.

FIGURE 9 - 2: Inserting a crescendo marking
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c. Dragging downward while selecting the range of notes will insert the mark-
ing above the staffline. Dragging upward will insert the marking below the 
staffline. 

d. To change the range of cresc. / decres. markings, hold the Shift button down 
(Nudge mode) and drag the yellow control handle horizontally. Notes to be 
affected by the mark will highlight in a light grey color.

NOTE: Playback properties of articulations and dynamics may be changed using the 
Properties tool. See "Playback Properties", Section 5.6.

9.3.5b Dynamic Markings
To Insert a Dynamic marking,

a. While in the Insert mode, select a dynamic marking from the “Dynamics” 
palette. 

b. Click anywhere above the active staff. A change in playback volume (MIDI 
Volume) for that particular active staff (MIDI track) then will apply. 

c. Changes in note volumes range as follows: 
pppp = 30 / ppp = 40 / pp = 50 / p = 60 / mp = 70 / mf = 80 / f = 90 / ff = 100/
fff = 110 / ffff = 120.

NOTE: Dynamics apply only to the active staffline. To apply dynamics and/or 
dynamic markings to more than one staff, enter the dynamic in each part in 
which you want the effect to apply. If you do not wish to have multiple 
dynamics visible, you may enter dynamics in the Hidden Symbols mode. 
For more details see "Hidden Symbols", Section 9.11.

To delete a dynamic or tempo marking, 

• Quick-select, press the “X” key and click on the marking. An alternative is 
to use the Select tool (“O” key), highlight the mark and hit Delete.

9.3.6 Tools palette

9.3.6a Text
Selecting the Text button sets the cursor to the Text Edit mode. See Section 7.2, "Text 
mode".

9.3.6b Lyrics
Selecting the Lyric button sets the cursor to the Lyric Edit mode. See Section 7.1, 
"Lyrics".
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9.3.6c Guitar Fretboard
Selecting the Guitar chord fretboard button resets the cursor to “Insert Guitar Chord” 
mode. See "Guitar Fret and Chord Symbols", Section 7.3.1.

• Rehearsal
Ten Rehearsal Markings can be placed anywhere in the ENF view.

• Pedals
Four Pedal Markings can be placed anywhere in the ENF view.

• Bowings
Two Bowing Markings can be placed anywhere in the ENF view.

• Breaths
A Breath Marking can be placed anywhere in the ENF view.

9.4 Tool Palettes 
All notation symbols used in SmartScore can be selected from the Tool palettes. By 
default, up to 3 palettes remain open at one time. Palettes “recycle” by default, but 
you may have all open at once. 
NOTE: Tool palette buttons are expandable. Any button with a small arrow in the 

lower right corner will expand to reveal all possible symbols when held 
down with the left mouse button for several seconds.

To replace an open Tool Palette with another palette type,
a. Right-click on any open Tool Palette. (Mac: Ctrl + click). 

FIGURE 9 - 3: Tool Palette Selection
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b. Click to select an alternative palette.
NOTE: The F1 key (Reset Workspace icon in Toolbar) always resets windows and 

palettes to their default positions.

To change palette display behavior,
a. Right-click (Ctrl + click for Mac) onto any open tool palette.
b. At the bottom of the Palette window, choose one of 4 alternative modalities 

for palette behavior including:

• Recycle (Default):  
This changes the secondary open palette when a Quick Key is activated. The 
Notes palette remains open and does not cycle.Show All opens all 9 Smart-
Score Tool Palettes.

• Hide All: 
This removes all Tool Palettes from view.

9.4.1 Articulations palette
Articulations affect the playback of selected notes. These include slurs, turns, ferma-
tas, mordents, trills, accents and tremolos.

To insert a legato (slur),
a. Push the Legato button in the “Articulations” palette.
b. Drag to select range of notes to be associated with the legato. Dragging 

downward places the legato above notes. Dragging upward positions legato 
under the notes. 

To insert expression marks,

Many common expression marks can be inserted as text with the use of 
Expression tool. Available phrases can be found in English, Italian, French, 
German with English translation.

FIGURE 9 - 4: Expression Tool
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a. Select the Expression button.
b. Choose a language and an expression from the pull down menu or type your 

own expression in the text field. Press OK.
c. Position the cursor anywhere in the active staff.

NOTE: Expressions are simple text and have no affect on playback.

To insert turns, fermatas, accents and mordents,
Turns, fermatas, accents and mordents can be inserted above or below notes by click-
ing near the top of a notehead or near the tip of note stem.

a. Select the articulation.
b. Click on a note head to insert the articulation above the note head.
c. Click on a note stem to insert the articulation at the tip of the stem.

To delete a turn, fermata, accent or mordent,
• Quick-select the articulation. Or use “O” key to select. Press the “X” key and 

click on the notehead or stem of the associated note. 

To insert a staccato, tenuto or accent,
a. Select the articulation.
b. Click on a note head to insert the articulation above the note head. Click the 

stem tip to insert the articulation near the stem.
NOTE: Playback properties of Staccatos, Tenutos, Accents and Fermatas can be 

changed individually or globally by selecting the Properties tool and click-
ing on the associated note head.

To insert a trill,
• With tr (trill) selected, click on a note to insert a single trill. 

To create an “extended” trill, 
• Trills have a control handle to the right of the “r”. In Nudge mode, dragging the 

control handle to the right will extend the trill’s effect to all notes in the same staff 
below the extension.
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FIGURE 9 - 5: Extended Trill

NOTE: Playback properties of trills can be changed individually or globally. Select 
the Properties tool and click on a trill.

To insert a tremolo,
a. Select a tremolo from the Tremolo button of the “Articulations” palette. 

Available tremolos are single, double, triple or quadruple (Both single or 
beamed tremolos.

FIGURE 9 - 6: Tremolos (Articulations Palette)

b. Click on the head of the note to apply the tremolo value.
c. Adjacent half notes will join to become beam tremolos when the first half 

note is clicked with beam tremolo selected.
NOTE: Beam tremolos will playback only if the applied “half-beam” notes are posi-

tioned in measures as if they were quarter notes.

To change existing half notes to beamed tremolos,
• With a beam tremolo value selected, click on the first of two adjacent half notes. 

The notes will beam with tremolo mark inside.

To insert an arpeggio,
a. Select the Arpeggio button (squiggly line) from the palette.
b. Click and drag the mouse to select a chord cluster (can include more than 

one voice).
c. Dragging the mouse in an upward direction will cause the notes to arpeg-

giate in an upward scale.
d. Dragging the mouse in the downward direction will cause the notes to 

arpeggiate in a downward scale. A down arrow is added.

To insert a glissando,
a. Select the Glissando button (two notes connected with a line) from the pal-

ette.
b. Clicking on any single (non-chord cluster) note will insert a glissando to the 

following note belonging to the same voice. During play back, the glissando
will be heard.
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To delete any articulation associated with a note,
• Quick-select the articulation. Press the “X” key, and click on the note associated 

with the articulation.
NOTE: To delete any articulation that is not note-specific, use the Select tool (“O” 

key) to highlight it and hit the Delete key.

9.4.1a Inserting or Deleting Multiple Articulations 
Any articulation can be applied to multiple notes at one time.

To assign an articulation to many notes at once,
a. Use the Select tool (“O” key) then drag to select a range of notes.
b. Select the articulation to be applied to all highlighted notes and insert it to 

any note.

To delete all articulation marks and slurs in a selected area,
a. Use the Select tool (“O” key) to drag a box around the area from which you 

wish to remove articulations.
Once the area is selected, hit the “G” key to delete all articulations in the selected 
region.

9.4.2 Tempo Palette
Use the Tempo palette to set default tempo at the beginning of the score and to insert 
change-of-tempo markings (metronome marks). Tempo markings can also be inserted 
and modified.

9.4.2a Metronome Mark 
NOTE: The default tempo of all ENF scores is 120 beats per minute (BPM). Any 

tempo marking (whether recognized or inserted) will over-ride the default 
tempo. Default tempo can be reset by clicking the Default Tempo button in 
the Playback Console or from Default Tempo under the Edit menu. See 
"Tempo", Section 5.5 for more details.

To insert a metronome mark or change-of-tempo marking, 
a. Push the metronome marking in the “Tempo” palette or select a custom 

tempo by pushing the Metronome Mark button at the bottom of the palette.
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b. If using a metronome mark, select a new tempo and baseline note value. Pre-
set tempo markings ranges from 30 bpm (Lento) to 240 bpm (Prestissimo).

FIGURE 9 - 7: Tempo Change (Metronome Mark) window

c. In Insert mode, click anywhere above the topmost staff of a system to insert 
mark. Tempo will adjust accordingly at that point.

To edit a metronome or change-of-tempo mark in the score,
a. Select the Properties tool from the Toolbar.
b. Click on a mark in the score to edit its properties. 

FIGURE 9 - 8: Tempo Marking Properties window

c. Using the horizontal slider, select a new tempo for the mark. Choose 
whether to apply the change to just the single mark, all similar marks or per-
manently apply the change for that mark.

9.4.2b Tempo Markings
See "Tempo Markings", Section 5.5.2.
Tempo changes are global and cannot be applied to one staffline. 
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9.4.3 Articulations Palette
Articulation markings, such as trills, staccatos, tenutos, arpeggios, glissandos and 
mordents are note-specific. 

9.4.4 Signatures (Key and Time) palette

To change an existing key or time signature to another signature, 
Entering or changing any time signature automatically updates time signatures in all 
parts of all systems; up to the first change-of-time signature if one exists. Entering or 
changing key signatures must be done one staff at a time. 
NOTE: Once Key or Time signatures are fixed in one system, subsequent systems 

can be “cloned” by using the Unify command. For details see "Unify Score 
(“U”)", Section 9.6.4.

a. Quick-select (Ctrl+click) a desired key or time signature nearby or select a 
new signature from the tool palette.

b. Click on a highlighted signature to be changed. 
NOTE: The key of C major (A minor) does not have a visible sign to indicate its 

presence. If no key signature is visible in the first measure of the ENF dis-
play, the key signature will be C major (A minor) by default. 

To create a custom time signature to Insert or Change,
a. Select the Custom Time button from the “Signatures” palette
b. Using numeric scrollers, select a new numerator (beats per measure) and a 

new denominator (note value receiving the beat).
c. Click to insert signature immediately following any barline.

To insert a new key or time signature in the body of a score, 
• With a time or key signature selected from the “Signatures” palette, Insert mode, 

click to the right of any barline.
NOTE: The score will be parsed from the insertion point. Error measures likely dis-

appear after correcting the new time signature.
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To insert a new key or time signature at the end of a system:
According to the conventions of music notation, a change-of-key or a change-of-time 
signature that begins on a new line should also be indicated to the right of a barline at 
the end of the previous system. 

FIGURE 9 - 9: Time Signature at the end of a system

• Simply insert a new key or time signature at the beginning of the following sys-
tem. The last measure of the prior system will automatically become updated with 
new key or time signature. 

To delete a signature
• Quick-Select a key or time signature. Hit the “X” key and click on the signature 

to delete it.
NOTE: To prevent the last measure from rolling to the next line, avoid deleting the 

final barline of any system.

9.5 Quick Keys
TIP: Refer to the Quick Keys map (FIGURE 9 - 13:) for a graphic depiction of all 

SmartScore keyboard shortcut keys.

9.5.1 Quick-select (Ctrl + Click)
The fastest way to choose any object for inserting, deleting or changing is to Quick-
select it first. Ctrl + Click on any object inside the active staff and the cursor inherits 
all of that object’s attributes.The cursor becomes any object that is Quick-Selected.

9.5.2 Inserting and changing symbols (C)
To insert a symbol anywhere in the active staffline, 

a. Toggle the “C” key to activate the Insert mode.
b. Quick-select any symbol or select it from a tool palette.
c. Click inside the active staff to insert the object. 

To change the rhythmic value of an existing note or rest,
Using to SmartScore X



a. Quick-select (Ctrl+click) a nearby note or rest having the desired value. Or 
select a new value from the “Notes” or “Rests” palette.

b. Position the cursor over the symbol to be changed until it highlights yellow. 
Click to change it to the selected value.

NOTE: When you Quick-select on any object inside the active staff, the palette 
associated with the object will open.

9.5.3 Deleting notes and symbols (X)
To delete an object in the active staff,

a. Quick-select (Ctrl + Click) a note or non-lyric symbol.
b. Press the “X” key and click on any note or non-lyric symbol to delete it.

To delete one or more object using the Select tool,
a. Press the Select tool icon in the Toolbar.
b. Click on an object or drag a region to select one or more objects.
c. Hit the Delete key to delete selected object(s).

9.5.4 Select tool (“O”)
Use the Select tool to highlight one or more objects for single or mass editing func-
tions such as copying, deleting, splitting voices, flipping stem directions and joining 
notes of different voices to a vertical event. The “O” key activates this tool. Its button 
is found in the Toolbar.
TIP: Use the Select tool + Delete key to remove any object other than lyrics and 

barlines. It is especially useful for removing a large number of spurious or 
unwanted text or multiple objects that do not delete easily with the “X” key. 

To delete one or more objects including notes, rests and symbols,
a. Push the Select tool icon in the Toolbar (“O key) and click on an object or 

drag to select multiple objects to delete. 
b. Hit the Delete key. 

NOTE: Occasionally, you might find an area full of incorrectly recognized ties and/
or slurs or hairpins. Use this tool to “mass-delete” these objects.

9.5.4a Cut, Copy, Paste, Insert and Merge selected symbols
Refer to Section 12.4.3 through Section 12.4.6a for details on how to use the Select 
Tool to clone measures or entire score segments and place them elsewhere in the 
music.
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9.5.5 Using the Select Tool (O) to edit selected objects
A group of selected notes on the same staff can be transformed into one beamed 
group if they are flagged or they can be pitch-shifted at once.

To convert a sequence of flagged notes into one beamed group,
a. Use the Select tool (O) to select a group of adjacent flagged notes to be 

beamed together.
b. Hit the “B” key to form the flagged notes into a beamed group.

To move a selected group of notes upwards or downwards in pitch,

To delete spurious articulations on a page,
c. Use the Select tool (O) to select an entire region for cleanup. Edit > Select 

All (Ctrl + A) will select everything on the current page.
d. Hit the “G” key. Only articulations will be deleted. All other notation 

objects remain unaffected.

9.5.6 Dots (D)
Hit the “D” key. This toggles between Insert a dot and Delete a dot modes. Notice 
how the cursor alternates between a solid insert dot and grayed-out delete dot.
Any note or rest may be selected with dots of prolongation assigned to it. Select a 
note or rest from the appropriate palette, then click on the single or double-dot button 
inside the palette. In Insert mode, the new note/rest will have a dot. 

9.5.7 Ties (V)
Hit the “V” key. This toggles you between the solid Insert tie and grayed-out Delete
tie modes. To tie two contiguous notes of the same pitch, click on the first note. The 
“V” tie tool will also insert multiple ties from one chord cluster to the next as long as 
note pitches match. 
NOTE: To over-ride default arc direction, insert ties with a right-click (option +

click for Mac). Inserted ties will have reversed arc directions.
To insert only one tie at a time, select the single tie button from the “Notes” palette.

9.5.8 Beam direction (A)
With any single flagged note chosen, hit the “A” key. This toggles between Left 
beam, Middle beam and Right beam directions.
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9.5.9 Stem direction (S)
The “S” key changes the default note stem direction. When inserting a note, toggling 
the “S” key reverses the stem direction of an inserted note. 
Default stem direction of an inserted note is determined by its vertical position on the 
staff. Stem direction of inserted notes automatically changes when the cursor crosses 
the middle line of any staff. 

To place a note with a stem in the opposite direction of the cursor, 
• Hit the “S” key to flip the stem on the cursor. Or right-click while inserting a note 

(option + click for Mac).

To change the stem direction of an existing note,
• In Insert mode, right-click on any given notehead (option + click for Mac). The 

stem direction of the note will become flipped.
NOTE: In general, Voice #1 should have stems up and Voice #2 should have stems 

down.

To change the stem direction of several notes at once,
a. Hit the “O” key to activate the Select tool.
b. Click and drag a box around any series of notes.
c. Press the “S” key to reverse the stem direction of the highlighted notes.

9.6 Navigator
9.6.1 Open (Ctrl+O / (Cmnd+M Mac)

Push to open / import a file compatible with SmartScore. Select SmartScore (ENF), 
Image (TIFF, BMP, PCX), XML or MIDI file from “Files of Type” pull-down menu. 
Same as File > Open.

9.6.2 Scan
Push to initiate scanning. Same as File > Scan Music > Acquire.

9.6.3 Recognition
Push to initiate recognition on any pre-scanned image. Same as File > Recognize.
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9.6.4 Unify Score (“U”)
Unify updates key and time signatures, clef signs and staff spacing throughout the 
score based on choices made in the dialog window.

FIGURE 9 - 10: Unify Key, Time and Clefs

TIP: Check part linking (Ctrl + L) before applying Unify when editing optimized 
scores.

If your ENF score contains collapsing and expanding systems, it is recommended to 
perform Part Linking before Unifying. Unifying signatures and clefs will maintain 
part linkages as set in Logical Part Linking. Refer to "Re-linking parts", Section 5.15
for more details.

9.6.4a Unify Key Signatures
• Based on topmost staffline. (Default)
All key signatures for every part are updated based on signatures found in the first 
staffline of each system. Any change-of-key signs found in the topmost staffline will 
update subsequent stafflines within each system. Use when systems have the same 
key signature in each part.
• Based on 1st system.
All key signatures in every system are updated based on signatures found in the first 
system on the first page. Any subsequent changes in key signatures will be removed. 
Use to unify scores that have transposed instruments with a fixed number of parts per 
system. 
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NOTE: Manually edit key signatures when scores contain: 
a) Transposed instruments AND change-of-key signatures 
b) Transposed instruments AND have optimized systems.

9.6.4b Unify Time Signatures
All time signatures are updated based on signatures found in the first system on the 
first page. Change-of-time signatures are removed in any subsequent systems. Use 
when no change-of-time signatures occur.

9.6.4c Unify Clefs
All clef signs are updated based on clefs found in the first measure of the each sys-
tem. Any change-of-clef found inside systems are removed. Use if many false 
change-of-clefs were recognized or if very few change-of-clef signs are found in the 
original.

• Parse every measure (Default)
Clefs are updated on a line-by-line basis. Change-of-clefs encountered updates each 
staffline until another change-of-clef is encountered. Use when many change of clefs 
are written into the original score.

9.6.4d Unify System, Staff and Line Spacing
Distances between systems, staves and line will be universally applied throughout the 
score based on:
• the active system (default)
• the first system of the score

9.6.4e Do not launch Unify after recognition
Select the option if you choose not to have Unify open automatically after recognition 
is completed.

9.6.5 Setup
Opens Page Setup environment for page printing alignment & margins. For more 
details on Page Setup, see Section 8.5.5, "Custom document layouts".

9.6.6 Print Preview
Use to check for proper page layouts. Also seen in Page Setup view.
Using to SmartScore X



9.6.7 Score
Push to create ENF score from scratch. Choose ENF score template from “System 
Type in Score” pull-down menu. Same as File > New > New ENF. See "Copying an 
ENF region to paste into non-music programs", Section 6.6.2 for details.

9.6.8 Record 
Push Record button to initiate MIDI Recording. All open ENF documents are closed 
when MIDI recording is launched. A MIDI Piano Roll view opens with Track 1 
staged for MIDI recording through an external MIDI device. Identical to Real-time > 
Record in MIDI View.

9.6.9 Karaoke View
Push to enter Karaoke playback environment. 

9.6.10 MIDI View (Ctrl + I / Cmnd + I for Mac)
Push MIDI button to view score in MIDI environment. Use also to change from one 
MIDI view to another; e.g. to change from Overview to Piano Roll view. Choose 
Overview or Piano Roll or Event List for a selected Part. Same as View > New MIDI 
View. ENF view remains open until or unless recording is initiated. To revert back to 
ENF view, close the open MIDI view. 

9.6.11 Tiling 
Viewing several displays of your score can be extremely useful. It is possible to view 
several MIDI and ENF views simultaneously.
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• Push Tile button to display all open TIF/ENF views along with any open MIDI 
Overview, Piano Roll or Event List views. This is identical to selecting the Win-
dow > Tile menu.

FIGURE 9 - 11: Tiled view (typical)

9.6.12 CD Burn

Push this button to create a .WAV file of the ENF playback and/or burn to 
CD.

NOTE: CD-Audio write devices must be located on the system. Some external 
devices may not be discoverable. In these cases, create the .WAV file and 
then use CD-R or CD Audio burn software.

9.7 Score Reformatting
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SmartScore allows for flexible reformatting of the finished ENF score. Changes to 
both horizontal and vertical formats can be easily made. For detailed information, 
turn to "Reformatting scores in ENF view", Section 8.1.

9.7.1 Staff Line Options (Right-click inside staff line)
Staff spacing, bracketing and part linking (for re-linking parts in expanded or col-
lapsed systems) controls can be accessed from a single window: the Staff Line 
Options. 
• With Properties Tool selected, right-click (alt / option + click for Mac) inside 

any system.

FIGURE 5 - 10: Staff Line Options (Right-click)

For detailed description of these commands, refer to:
• Line/staff spacing: Use to uniformly apply line, staff and system spacing. 

See Section 8.3.2.
• Bracketing: See Section 7.4.3.
• System Manager: See Section 9.10.
• Part Linking: Use to check and restore continuity of instrumental parts in 

optimized scores. See Section 5.15.
• Add Empty Pages: Inserts empty page(s) with similar structure and brack-

eting of the active system. 
• System: Use to insert a new system above or below the active system.See 

Section 12.4.15. May be used to delete the active system (Parts remain 
intact; system becomes “invisible”).

• Staff: Use to insert a new staffline above or below the active staff. See Sec-
tion 12.4.16. May be used to delete the active staff (without deleting the 
entire part).
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9.7.1a Ossia
Use this tool to delete or insert an ossia above or below the active staff. Inserted 
ossias are editable just as any normal staffline except that ossias are not played back. 

FIGURE 9 - 1: Ossia

To resize an ossia,
a. Hold the Shift key down (Nudge mode) and drag either of the control points 

at either end of the ossia. Barline, key and time signature information is 
inherited from its associated staffline. 

• Re-space ossias using tabs in the left margin just as any staffline.

9.7.2 Go to.
• Use this tool to jump to a new measure, page or score part.

9.7.3 Select entire part
• This is a special feature for selecting the contents of an entire part (staff) for 

cloning or pasting. Refer to Section 12.4.3 through Section 12.4.6a for 
details on how to clone measures or entire segments and place them else-
where in the score.

9.7.4 Auto-Beaming
With Auto-Beam selected, beamed notes will automatically form into common 
groups based on the active time signature and standard notation beaming rules. Auto-
Beam defaults to “off” after recognition. 

To automatically insert and edit beams into preformed groups. 
• Push Auto-Beam button in the Toolbar
• Select a note value from the Notes palette.
• With any beam tool selected, clicking from left-to-right, will create beamed 

groups into pre-determined sets. 

9.7.5 Auto-Spacing
With the Auto-Space button selected, notes and rests will insert proportional to their 
relative value within a measure. After recognition, Auto-Space defaults to “off.” 
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9.8 Transposition 
SmartScore offers several types of transposition options depending on your needs. 
You can transpose by key, the most common type of transposition. Transposing by 
clef is useful for transforming one instrument to another written in another clef sign. 
You can also choose to transpose by altering note pitches only, either considering the 
active key signature or by ignoring the active key signature. Using the Limit option, 
you can choose a specified range, part or voice to transpose.

To Transpose your entire ENF document to a new key, 
a. Position your cursor inside the first staffline of the score. Press Ctrl + T / 

Cmnd + T for Mac or select the Transpose button in the Toolbar or select 
Transpose from the Edit menu. The window in Transposition always dis-
plays the key signature or clef sign of the active staff. This is your source 
key. 

FIGURE 9 - 2: Transposition window

b. Select a new target key or target clef for the score by selecting either the 
Key or Clef tab. Scroll up or down to select a target key signature or target 
clef.

c. Closest allows SmartScore to automatically choose up or down based on the 
least number of intervals. To choose the direction manually, select either Up 
or Down.

NOTE: It is recommended that you fully edit your score before transposing. If your 
score contains incorrect change-of-key signatures and/or guitar fret and 
chord symbols, it may be hard to Undo properly. Also, the scanned score 
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won’t transpose and visual checking of pitches will be difficult after transpo-
sition.

9.8.1 Transposition Strategy
You can choose two “strategies” for transposing your scores: Link Accidentals to 
Key and Keep Line-space. 

• Link Accidentals to Key
This choice will consider the target key signature during transposition. If the target 
key belongs to the opposite class than that of the source key (e.g. transposing from a 
key with sharps to a target key with flats), then accidentals may be swapped to their 
harmonic equivalents. 

• Keep Line-Space
This choice will retain exact relationships between intervals after transposition is 
completed. Accidentals will generally remain fixed. No attempt will be made to swap 
harmonic equivalents of accidentals. For example, c and d# may transpose up to c# 
and d double-#.

• Transpose Symbols
To transpose guitar fret and chord symbols to match the new target key, check this 
box. This selection will also move articulations, such as slurs, up or down along with 
notes and rests. If necessary, guitar fret and chord symbols may move up to avoid col-
lisions with upwardly-transposed notes.

• Ask For New Chord Symbol
This option allows you to accept or change each transposed guitar fret and chord 
symbol during transposition. Use this option when you know you won’t accept 
default fretboard patterns or when you know you will need to add new fret and chord 
symbols to the library.

• Adjust Stems
Stem directions will be maintained unless this box is checked. It is important to 
remember, however, that adjusting the direction of stems may create voicing prob-
lems. Automatic voiceline recognition relies heavily on stem directions. Flipping 
stems as they cross the mid-staff point can create unexpected results. Best Bet: Adjust 
Stems = Off. Use Undo (Ctrl + Z / Cmnd + Z for Mac) if necessary.

• Move Notes
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Uncheck this box to leave the notes in their original positions. This will transpose 
only key signatures, leaving notes unchanged... good for mental games, but not much 
more.

• Change Pitch
This transposes notes without changing the key signature. Select the number of half-
steps to move selected notes (harmonic pitch shift). Pitches are moved by a uniform 
interval while considering the key signature. Change Pitch can be used in conjunction 
with Limits tab.
TIP: To shift the pitch of a small range of notes, it is easier to use the Select tool 

(O). Hold the Shift key down, drag the selected notes up or down.

9.8.2 Limit Transposition
You may limit transposition to a part or voice or to a selected range within the ENF 
score.

To limit transposition by part, voice or range,
a. Click on the Limit tab at the top of the Transposition window.

FIGURE 9 - 3: Limit Transposition

b. Choose All Parts, or select individual parts by name to transpose. If you 
select a single part, you may also limit the scope of transposition to a single 
voiceline. In the Part Voice box, select the voice to transpose.

c. To limit transposition by range, choose Selected Area (range must already 
be highlighted by the Select tool) or by Measure number.

d. Click OK to transpose with selected limits applied.

9.9 Working with Contrapuntal Voices
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Each staff line has the potential of containing up to four contrapuntal voices. Contra-
puntal voices are “measure-based”. This means that notes and rests are organized into 
“threads” (voicelines). See "Voices and Playback", Section 5.9 for more about how 
voices affect playback.

To view contrapuntal voices as separate colors, 
• Push the Voice Visibility button in the Toolbar. 

9.9.1 Voice color
Contrapuntal voices display as one of four possible colors (Voice 1= black, Voice 2 = 
red, Voice 3 = green and Voice 4 = blue). Normally, you will see black (Voice 1) and 
red (Voice 2). 

9.9.2 Overriding voice color assignments
Voice color/number assignments can be changed manually.

To override default voice color of a note or rest (change voice number),
a. Select desired voice number (and color) from Voice Tool combo button in 

the Toolbar.
b. Locate the note or rest for which you want to change voice color. 
c. Click on a note or rest to change it to the selected color and voice. 

Voice color is automatically determined based on several factors (number of voices, 
stem direction, number of beats, vertical alignment, etc.) You can override voice col-
ors manually. Changing voice color may change voice colors of other notes in a given 
measure.
NOTE: Do not override voice colors until a measure is entirely edited. Unusual 

color combinations usually correct themselves automatically after a measure 
is corrected.

To vertically align offset voices, 
a. Use the Select tool (“O”) to highlight offset notes and/or rests.
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b. Press the “Y” key to group the selected, offset notes into a single vertical 
event. Selected voices will move slightly.

FIGURE 9 - 4: Correcting offset voices not “glued” after recognition.

Similarly, if you see notes bunched together each displaying different colors (usually 
black and red and sometimes green), but which actually belong to only one voice, 
they are probably “glued” to the same vertical event. Joined notes can be “unglued” 
as follows:

To “Unglue” offset notes not intended to play simultaneously,
a. With the Select tool (“O” key), carefully select the incorrectly glued notes 

(NOTE: they will each have different colors). Be sure to select only the 
notes which are incorrectly joined.

b. Hit the “Y” key. Joined notes will separate and change color.

9.9.3 Checking vertical alignment of voices
Measures with notes and rests that are incorrectly aligned will become highlighted 
reddish (“error”). In addition, all notes and rests that are glued will move together 
when dragged left or right in Nudge mode. 
• Hold the Shift button. Click and drag note control point to verify.

Offset voices not “glued” 
following Recognition 

“Y” key “glues” offset
voices to a single event.Using Select tool to 

highlight offset voices
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FIGURE 9 - 5: Using Nudge mode (SHIFT) to check vertical alignments

9.9.4 Swap position of note heads (Select + “L”)
Occasionally, you will want to swap the horizontal positions of a pair of joined offset 
notes. This can easily be done by selecting a vertically aligned pair with the Select 
Tool (“O”) and hitting the “L” key. The relative positions of these joined notes will be 
swapped without altering voice color or playback.

FIGURE 9 - 6: Note head swapping

9.9.5 Cross-staff voicing
Occasionally, notes of one voice may “visit” an adjacent staff. Technically, visiting 
notes belong to their “home” staff, but they obtain their pitch information from the 
visiting staff line.

To create cross-staff voicing, 
• Make sure the note to be moved across staff lines has its stem in the correct orien-

tation (Select + “S” to change stem direction). Hold the Shift key down and drag
the notehead to the desired pitch of an adjacent staff. If cross-staff notes belong to 
a beamed group and the beam does not interfere with the movement of the note-
head, simply hold the Shift button down and drag the notehead into the adjacent 
staff to its desired pitch. 

FIGURE 9 - 7: Cross-staff voicing 

• Notes positioned in a “visiting” staff still belong to the “home” staff. To edit or 
move a note positioned in an adjacent “visiting” staff, press the Caps Lock key 

Note heads
before swap

Note heads
after swap
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while the “home” staff is active. Press Caps Lock again to unlock the active home 
staff.

NOTE: Cross-staff indicator lines can be either solid or dotted. These attributes can 
be changed in Edit > Program Preferences > Systems > Cross-staff voic-
ing line style.

To control cross-staff beams (beam collisions and flipped stems)
• If a beam collides with note stems or appears at odd angles after moving notes, 

hold Shift down (Nudge) then click & drag the control point on either beam end. 
Drag beam end until it is properly positioned. Stems of notes alternate as the 
beam angle is changed.

FIGURE 9 - 8: Controlling cross-staff beams 

9.9.6 Cross-measure beaming

To create a cross-measure beam,
a. Insert a flagged note on either side of a barline.
b. Use the Select tool to highlight both notes and hit the “B” key.

9.9.7 Overlapping or offset noteheads
Two notes in different voices can share the same pitch at the same time. You can 
choose whether note heads of different voices should overlap one another or become 
horizontally offset. 

To allow offset note heads, 
• Check off “Overlap Notes” in Edit > Document Preferences > Score Symbols > 

Overlap mode. Playback will not be affected whether note heads are offset or 
overlap.

9.10 System Manager

Beam colliding with
note stems.

Drag beam control point
to alter stem orientation

Drag beam control point
to change beam angle
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Use the System Manager to assign or change instrumental parts, change part names 
and extract parts and voices by controlling visibility. The System Manager displays 
information about what is found in the active system (the highlighted system). 
Changes made can be applied to the current system, current plus subsequent systems, 
to the entire score or limited to the current Score-Part. 

FIGURE 9 - 9: System Manager

To open the System Manager, 
a. Position the cursor over a given system in the ENF view. 
b. Press (Ctrl+M / Cmnd+M) or select Edit > System Manager from menu. 

All parameters of the active system will be displayed including part name, 
visibility and assigned MIDI instruments.

Parts of the system run vertically along the far left column. Checkmarks identify 
whether parts are “visible” in the active system. Voices run horizontally with check-
marks below which identify the status of their visibility. 

9.10.1 Part Names
When a Part Name is selected in the System Manager, playback parameters are 
inherited from Instrument Templates, including pitch shifting of transposed instru-
ment. See "Apply to New is useful when you want to extract parts or voices to a new 
ENF document without affecting the original.Instrument Templates", Section TIP: for 
additional information. 

To select a Part Name,
a. Click into a desired instrument name in the Part Name column. Select one 

of preset instruments Notice that MIDI instruments for each voice become 
updated. 
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b. If you wish to add a new part name with a unique MIDI instrument assign-
ment, select “Add New Part” from the top of the pull-down list. This will 
open Instrument Templates and allow you to create a new template, name it 
and assign any MIDI instrument and alter transposition pitch shifting. 

Abbreviated Part Names are shown by default in the first system of the ENF main 
view. To change or remove Part Name display, see "Document Preferences", Section 
12.1.1

9.10.2 Assigning MIDI Instruments to Voices
Voices inherit MIDI instrument assignments from Instrument Templates initially. You 
can change MIDI instrument assignment for voices (in Voice mode) or parts (Part 
mode) in the System Manager or Playback Console.
TIP: Assigning each voice a different MIDI instrument adds richer sound texture 

and helps in hearing “inner voicings” of the music. Highly recommended for 
classes in composition.

NOTE: Playback Console and System Manager are linked. Changes made to MIDI 
instruments in one environment will update the other. MIDI instrument 
assignments in Instrument Templates are not changed automatically. They 
can only be changed manually.

To change MIDI instruments for voices in System Manager, 
• In System Manager, click on any voice of any part and select a new MIDI instru-

ment in the pull-down menu. 

9.10.3 Extracting Parts
Visibility checkboxes along the far left side of the System Manager are used to 
extract parts. Parts can be extracted to new files without altering the original docu-
ment. Checkmarks identify which parts are assigned (visible) in the active system. 
Individual parts and/or voices can also be “removed” from a score by selective use of 
Visibility. 

To extract a part from the score, 
a. Check Visibility boxes next to the parts you want to extract. Unchecked 

parts will be made invisible, but data will be retained.
b. Check Visibility in the Apply field and choose a scope from the “Apply To” 

pull-down menu. See "Applying changes in System Manager to the score", 
Section 9.10.8 for details on “Apply To” options.
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c. Push Apply to remove all unchecked parts from the current (open) docu-
ment. 

d. More commonly used is to select Apply to New. This will extract all 
checked parts to a new ENF document while keeping the original document 
unchanged. Both documents will display.

9.10.4 Extracting Voices

To extract a voice from the score, 
a. Highlight a visible part by clicking on the dot next to Part Name. 
b. Check or uncheck the Visibility box below the desired voice number 

depending on which voice(s) you want to extract. 
c. Select Visibility in the Apply field and choose a scope from the Apply To

pull-down menu.
d. Apply alters the current document. Apply to New will creates a new ENF 

document.
TIP: Part and voice extraction/removal can also be controlled in an entirely dif-

ferent way by using the Score Structure feature. See "Using Score Structure 
to Extract & Join Parts", Section 8.7 for more details on how to isolate, 
recombine and/or remove parts and voices from a score.

9.10.5 Super System
All parts (or staves) in SmartScore, whether they’re visible or not, are stored, created 
and deleted in a special area called the Super System which is found in the System 
Manager window. 
NOTE: While you can add a staff with the use of the Add Staff Above/Below option 

found in the Staff Line Options tool (see Section 9.7.1) and new part is 
actually created in the Super System, that part remains invisible in all but the 
active system. As a rule, always use the Super System to create a new part in 
the score.

To add a new part to the score,
e. Open System Manager (Ctrl+M or select File > System Manager from the 

menu).
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f. In the Controlling System pull-down menu, choose Super.

FIGURE 9 - 10: Creating a new part using Super System in System Manager

g. Highlight the part where you wish to add a part (above or below) by clicking 
on the black dot to the left of it 

h. Choose Insert Above or Insert Below. 
i. Switch Controlling System back to Active. Notice the newly added part is 

added, but is not checked for visibility. This means the part exists, but it is 
not visible in any staff.

j. To make the part visible in all staves, check the box next to Visibility and 
make sure Apply to: All is selected. This will make the part visible in all 
systems. Press Apply.

Sometimes “optimized” music is scored for more instruments than may appear in any 
single system. If the total number of possible instruments exceeds even the largest 
system in the score, parts need to be added to the Super System. SmartScore assumes 
that all possible instruments are equal to the system with the largest number of parts. 
For playback will sound correct, parts in optimized systems need to be reassigned to 
their appropriate instruments. See "Broken Parts (Loss of Continuity)", Section 5.14
and "Re-linking parts", Section 5.15 for more details. 

9.10.6 Removing parts (Delete or make invisible)
There are two approaches to removing a part. One is to delete the part entirely. The 
other is to remove its visibility from one or more systems. Making the right choice 
depends on your needs.

To delete a part from a score.
a. Open System Manager (Cntl + M) then select Super System from the 

Controlling System menu.
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b. Click the dot corresponding to the part you wish to remove.
c. Select a correct scope to Apply to: and push Remove.
d. Push “Apply to New” to create a new document without changing the origi-

nal. Otherwise, push “Apply” and “OK”.
NOTE: For part extraction, there are more direct methods than the one listed above. 

(refer to Section 8.6).

9.10.7 Part Visibility
Any part of any system can be made “visible” or “invisible” without having to delete 
a part or create a new one.

To make added parts visible in one or more systems, 
a. Make sure Controlling System is Active. Check the Visibility box next to 

the Part Name and check Visibility in the Apply region below the parts 
matrix. 

b. Select the option, Apply To = All so the part will be visible in all systems. 
select System so part becomes visible only in active system. For visibility in 
subsequent systems, select System +. 

c. Push OK.
Staff (part) visibility can also be controlled in using the visibility option in Staff Prop-
erties. Refer to Section 6.3.1, "Staff Properties".

9.10.8 Applying changes in System Manager to the score
Changes you make to System Manager will apply to the area of interest you select in 
the “Apply To” pull-down menu:
• All
Applies the change to all systems of the score. Used when you want a change to be 
globally applied.
• System
Applies only to the currently active system.
• System+
Applies to the currently active system and all subsequent systems.
• Score/Part
Applies to the Score or Score-Part.
• Super System (Do not use except in extraordinary cases)
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Changes will be applied only to the Super System.
• OK 
Applies changes to the current ENF document.
• Apply 
Applies changes and allows further editing in System Manager.
• Apply to New
Creates and opens a new ENF document with changes applied to it. This action does 
not affect the original document which remains open behind the newly-created ENF 
document (Minimize window of topmost document to view other open ENF files.) 
TIP: Apply to New is useful when you want to extract parts or voices to a new 

ENF document without affecting the original.Instrument Templates 

9.10.9 System Manager and Instrument Templates
Many characteristics of parts in the System Manager are inherited from Instrument 
Templates including part name, abbreviation, MIDI instrument assignment and play-
back pitch transposition. To open, push “Open Instrument Templates” button in 
System Manager. See Section 5.13, "Instrument Templates" for more details. 

9.10.10 Transposed Instruments
Because ensemble instruments have such wide pitch ranges, it is necessary for tran-
scribers to notate certain instruments in key signatures that are remote from others in 
the ensemble. Players of transposed instruments “read” and “transpose” naturally 
without worrying that the part they are reading is actually out of tune! In order for an 
ENF score with transposed instruments to play back correctly, transposition of play-
back by specified amounts must be set. This is accomplished for preset instruments in 
the Instrument Templates but it is also possible to compensate for transposed instru-
ments in the Playback Console.

9.11 Hidden Symbols
Hidden symbols displays every possible object in the ENF display. Certain markings 
such as the range of a 8va, 8vb, ritard, accelerando or descelerando are only visi-
ble when Hidden Symbols is active. You may want certain notation objects to be 
applied to playback, but at the same time, you may not want these symbols to be visi-
ble. For example, you may need to insert rests to “fill out” a given voiceline in a mea-
sure, but you do not want these “placeholder” rests to be printed. 
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To insert a hidden notation object,
• Push the Hide/Show Symbol button in the Toolbar. Insert any notation object 

normally. Symbols entered in Hidden Symbols will appear as a lighter color than 
when entered normally. 

In the following example, the measure in question has only 1 beat written into the 
upper part and 2 beats written in the lower part. Inserting 2 hidden rests in the upper 
and one hidden rest in the lower corrects error.

To view ranges of dynamics and tempos,
a. Push the Hide/Show Symbol button. Dynamics or tempos which were 

applied to a range of notes will appear as follows:

FIGURE 9 - 11: Hidden range of an accelerando

Push again to exit Hidden Symbols mode. “Hidden” symbols do not appear in normal 
mode and will not print.

9.11.1 Overriding voice color assignments in Hidden Symbols
You may find that it is necessary to change the assigned voice color (and number) of 
a hidden symbol after it is entered. If so, simply use the Voice Color tool found in the 
Toolbar. This is done exactly as in normal ENF editing mode. Notes and rests with 
changed voice assignments will remain invisible after you exit Hidden Symbols. 

To override voice numbers in Hidden Symbols,
a. Select a voice color and number from the Voice Color tool.

Recognized measure 
(w/ cross-staff voice)

Corrected measure 
(w/ rests placed in Hidden mode)
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b. Click on any note or rest to change its voice number and color.
NOTE: In Hidden Symbols mode, voice colors display differently than in normal 

edit mode:  
Voice #1 = Grey, Voice #2 = Purple, Voice #3 = Yellow, Voice #4 = Aqua

To change the default color of Hidden Symbols, 
a. Select Edit > Program Preferences > Color >Hidden Symbols. 
b. Choose a new color and push OK.

9.12 MIDI to ENF
SmartScore accepts any Standard MIDI file and converts it to an ENF file. Since 
printing is disabled, SmartScore MIDI Edition does not include MIDI to ENF.

To create an ENF document from a MIDI file,
a. Select File > Open and change the filetype pull-down menu from Smart-

Score Files to MIDI Files. All MIDI files in the given directory will appear 
in the selection window. Double-click on a selected MIDI file to open.

b. The Playback Console window will appear with a MIDI Overview represen-
tation in the background. To hear the file playback, push the Play button in 
the console.

c. To convert the MIDI file into SmartScore notation, push the Close button in 
the Playback Console. Closing the console will begin the conversion pro-
cess. 

FIGURE 9 - 12: MIDI to ENF window
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• Staff Voicing
Choose the number of contrapuntal voices you wish to see in the converted ENF file. 
NOTE: It is unusual to have more than 2 voices in most music. For neatness sake, 1 

or 2 voices is a goo
• Density

• Measures per System determines the number of evenly spaced measures 
per system. Automatic is recommended.

• Systems per Page determines the number of evenly spaced systems per 
page. Automatic is recommended.

• Quantization
SmartScore can quantize the MIDI file that will be converted. Each note event will 
“snap to” the nearest beat boundary eliminating fluctuations in the timing of a MIDI 
performance. 
MIDI files created with “free tempo” (rubato) will probably have many irregular note 
divisions and odd-looking timing as SmartScore attempts to “compartmentalize” 
notes “off-the-beat”.
• Check None to prevent the application of quantization.
• Use Note On/ Note Off to determine the smallest rhythmic values used to when 

spelling note start times (Note On) and end times (Note Off) in the ENF docu-
ment.

• Use Note On/ Note Duration to determine the smallest rhythmic values used to 
when spelling note start times (Note On) and the minimum length of each note 
(Note Duration) in the ENF document.
• Shorten each note to the last Note Duration value.
• Lengthen each note to the next Note Duration value
• Justify each note to the nearest Note Duration value.

If the resulting ENF file has many stand-alone flagged notes, try reducing the Quanti-
zation value (e.g. to 1/8th notes).
• Divide By Beats: When ON, resulting ENF file will interpret measure lengths by 

number of beats and insert change-of-time signatures if beats of each measure do 
not correspond to the default time signature. Turn OFF to lock default time signa-
ture.

• Smooth Voices: When ON, contrapuntal voices will be interpreted as continuous 
lines whenever practical. When OFF, contrapuntal voice will be interpreted 
loosely.
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9.13 Troubleshooting ENF Problems

Table 1: Troubleshooting ENF Problems

Problem Probable Cause Fix
Notes and symbols 
appear as large letters.

Font association lost. Reinstall Chopin10 font. 
Font is located in the 
SmartScore directory.

Measures outlined in a 
red color.

Incorrect rhythm in one 
or more voices.

Edit voicelines to agree 
with time signature.

Pickup or closeout mea-
sure highlights red & 
doesn’t play smoothly.

Voiceline durations do 
not agree with the current 
time signature

With Properties tool 
selected, click on barline 
that begins the measure. 
Select “As written”.

Only one system high-
lights black at a time.

View active staffline is 
ON (default selection).

Check off View Active 
Staffline in View menu.

Measure remains high-
lighted but measure plays 
back smoothly.

Secondary voice may be 
truncated (not fully com-
pleted in the measure).

This is a common con-
vention in music notation. 
May be left as is.

Can’t delete an object 
when “X” key is pushed.

Actual object must be 
selected first.

“Ctrl + click” the object 
before deleting. Or, sim-
ply use the Select tool 
(“O” key) & drag around 
an object then hit Delete.

New note is inserted 
when trying to change an 
existing note.

Existing note was not 
highlighted yellow when 
clicked.

Yellow-highlighted notes 
will be changed to new 
value. Blue inserts new 
note at same time slice.

Measures unexpectedly 
roll from one system to 
another. 

Barlines at the end or 
beginning of measures 
may have been deleted.

Restore the number of 
measures per system by 
clicking of Staff Proper-
ties with Properties tool.

Systems unexpectedly 
roll from one page to 
another.

Line, staff or system 
spacing may have been 
changed.

Readjust spacing tabs in 
left margin until systems 
are restored to page.
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Staffline missing from 
system

Staffline cut off or during 
scanning or was not 
localized during Recog-
nition.

Restore missing staff. See 
Section 5.15.1

Wrong part suddenly 
plays.

Expanding / collapsing 
score; Part / instrument 
linking lost.

Reassign parts in system. 
See Section 5.15

Display shows notes as 
brightly colored or with 
green vertical lines or 
with a solid orange hori-
zontal line along the staff 
line.

ENF display is in Hidden 
Objects, Tempo or Veloc-
ity controller mode.

Exit Hidden mode. See 

Table 1: Troubleshooting ENF Problems

Problem Probable Cause Fix
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FIGURE 9 - 13: Quick Keys Map (Windows)
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Chapter 10 Working with TAB & Drums

SmartScore supports recognition, editing and playback of percussion and 
tablature parts. Any existing part (or staff) can be transformed to and from 
a variety of staff types including TAB, percussion and standard notation. 
Individual MIDI sounds are linked to all staff lines & spaces. Drums and 
percussion instruments can be re-linked using the Drum Map editor. Play-
back can also be enhanced by adding automatic drum styles. New rhyth-
mic styles can easily be imported, created and added to the drum styles 
library. 

10.1 Converting staff line types
You may convert staff properties simply by choosing an alternative staff type. For 
example, you may want to convert a line of standard notation (melody) to guitar 
TAB (6-string guitar). Or reverse it: change TAB to notation. This is all done in 
Staff Properties.

To change staff property types), 
a. Select the Properties Tool then click on the yellow arrow to the left of the 

staff you wish to change.

FIGURE  10 - 1: Staff Properties: Changing staff type
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b. Check the “Apply staff type” box and choose a new staff line configuration 
from the list of available staff types in the pull-down menu.

c. Select how to apply the change in the “Apply to” pull-down menu: Entire 
part, Current staffline or system, All parts in all systems, System + (current 
system forward).

d. Push OK to apply the change.
NOTE: It is recommended to correct mis-recognized symbols before chang-

ing the staff height since this could cause loss of synchronicity 
between the TIFF / ENF screens. Once synchronicity is lost, the 
floating scan window will open so you will still maintain some refer-
ence.

10.2 Working with tablature (TAB) parts
Parts written in TAB format are automatically recognized if the option “Recognize 
TABs and Percussion Staff Lines” is selected prior to recognition (see Section 4.2.1). 
TAB scores are edited in a similar fashion as standard ENF notation. Parts written in 
standard notation (melody staff) can be converted to the TAB format. Recognized 
TAB music can also be converted to standard notation. Converting one to the other is 
done in the Staff Properties window. See "Converting staff line types" above.

10.2.1 Tablature notation display in SmartScore
Tablature notes (fret numerals) are displayed as numbers on top of a string line (6 
lines for guitar). The number represents the fret that string is to be played (with “0” 
representing an open or unfretted string). SmartScore uses an unique notation con-
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vention that not only displays the rhythmic value of each TAB numeral, but also its 
voicing. Note duration values (rhythmic cues) belonging to Voice 1 appear above the 
staff. Rhythmic cues belonging to Voice 2 appear below the staff (in red).

FIGURE 10 - 2: SmartScore TAB notation

10.2.2 Change fingering configurations
Changing fingerings is easily done in Nudge mode. Moving a fret numeral to a new 
string automatically updates its fret number.

To reassign a fret numeral to another string
a. Hold down the SHIFT button (Nudge mode).
b. Drag the handle of any fret numeral to an adjacent string. 

The number will automatically become updated to reflect its new finger 
position. Its playback pitch remains the same.

10.2.3 Editing TAB symbols

To enter a fret numeral inside a TAB staff, 
First select a note value: Ctrl + click on any nearby note with the desired value or 
select that note value from the Notes palette. Position the cursor on the line you wish 
to enter a numeral and left click to enter the numeral as Voice 1. Right-click to enter 
the numeral so it is assigned to Voice 2 (red / below staff).
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NOTE: To add a TAB numeral to an existing chord cluster, position the cur-
sor inside the vertical line of numerals until they highlight blue, then 
click to insert.

To change the fingering of any TAB numeral, 
Enter Insert mode by hitting the “C” key or selecting the “Insert” button from the 
lower Toolbar. Click on any numeral until a red box (numeral editor) appears. Enter a 
new number. 

NOTE: You will have 4 seconds to enter a new number before the numeral 
editor becomes inactive. You may change the default time period by 
going to Edit > Program Preferences > Tablature > Timer.

To change the rhythmic value of a TAB numeral, 
Ctrl + click on any nearby note with the desired value or select that note value from 
the Notes palette. Click on the rhythmic value displayed directly above or below the 
numeral you wish to change. Horizontal note spacing will automatically be adjusted. 
Measures with rhythmic errors will highlight in pink, exactly as “melody” lines 
behave. To interpret pink measures, see Section 6.2.2, "Rhythmic errors"

To change to voicing of a TAB numeral, 
You must first delete the numeral by hitting the “X” key and clicking on the numeral. 
Hit the “C” key to enter Insert mode and select the correct note value, if necessary. 
Position the cursor where you want to insert the numeral and right-click to insert it as 
Voice 2 (red) or left-click to insert the numeral as Voice 1 (black).

To delete a TAB numeral, 
Simply hit the “X” key and click on any numeral. This action will delete both single 
TAB numerals and numerals in chord clusters.

10.2.4 Creating a guitar TAB staff below a melody line

You may wish to duplicate a part written in standard notation and have it dis-
play as guitar tablature. Or you may wish to take a guitar solo written in tab-
lature and have it also display as standard notation. It’s simple...

To duplicate a notation staff and transform it to a TAB staff,
a. Open any ENF score. Go to Edit > Score Structure. 
b. Click on the box that represents the part you wish to copy. Push the “Dupli-

cate” button. The new part will appear below the original box. Click on the 
newly-created part and drag left to create an “association” line to the ENF 
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Score Part box next to it. Select “Apply to New”. A new ENF document 
will be created, leaving the original unchanged.

c. In the ENF view, you will see the duplicated part beneath the original part. 
With the Properties Tool selected, click on the yellow triangle to the left of 
the new part. Select “5-line guitar TAB” from the Staff Type pull-down 
menu and unify staff and line spacing as described in Section 10.1 and Sec-
tion 10.2.1.

To reverse the process (duplicate a TAB staff and transform it to standard notation), 
follow the same steps above but instead, choose “6-line melody” from the Staff Type 
pull-down menu.
After converting a “melody” to a “TAB” staff, you may want to change the fingering. 
Refer to "Change fingering configurations", Section 10.2.2 for details.

10.2.5 Unifying TAB line distances and line spacing.
After converting “melody” to “TAB” or vice-versa, you may want to change line dis-
tances and unify those changes for a clean look.

To resize the TAB spacing and apply it to the entire part,
a. Position your cursor over a TAB staff line and manipulate the red (distance) 

and blue (line space) tabs per Section 8.4.
b. Select the Properties Tool and right-click into the staff that has been altered. 

Choose Line/Staff Spacing. In the “Copy settings to” menu, select “All 
Systems” and push “Copy”. 

c. Push “OK”. All staves belonging to that part will adjust.

An alternative method for “unifying” layout is as follows:
a. With your cursor over the modified staff line, hit the “Caps Lock” key to 

lock in focus on that staff. 
b. Push the “Unify” button in the Navigator (“U” key). Select “Unify System, 

Staff and Line Spacing” (Based on active system). Push OK.
c. Hit the “Caps Lock” key again to release the active system.

10.3 Editing and creating percussion parts
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10.3.1 Editing a percussion part
SmartScore recognition acquires and reconstructs variable-line staves when “Recog-
nize TAB and percussion staff lines” option is checked in the Begin Recognition
window (See Section 4.2.1).

To edit recognized notes on a percussion staff,
a. First, check that the number of lines of the percussion part is correct: If 

incorrect, you may change the number of lines as described in Section 10.1, 
"Converting staff line types". 

b. Then ensure that the percussion part has correct number of lines in all sys-
tems: Select the Properties Tool and right-click into the percussion staff. 
Choose Line/Staff Spacing. In the “Copy settings to” menu, select “All 
Systems” and push “Copy”. When done, push “OK”. All percussion staves 
belonging to that part will become updated.

c. Edit drum notes exactly as any normal “melody” staff including note dura-
tion value and pitch. A MIDI drum instrument is associated with every line 
and space and will sound as you Shift + drag notes up or down. If neces-
sary, you may need to reassign MIDI drum sounds using the

10.3.2 Playback > Drumset

To reassign drum instruments to percussion staff lines...
a. With Property Tool active, click in the yellow arrow associated with any 

percussion staff.
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b. Push “Drum Set” button in the Staff Properties window to access the drum 
instrument map.

FIGURE 8 - 1: Drum-to-pitch links (Drum Set) 

c. Click on a drum instrument name and drag to a new line or space. If another 
instrument is linked to the line or space, it will unlink.

d. Clicking and dragging a line or space to an instrument name will also create 
a new link and delete any existing link.

e. Press OK to finalize changes. Press Cancel to undo changes.
NOTE: Accidentals are ignored regardless of the key of the score. 

10.3.3 Creating a percussion staff from scratch
a. Position your cursor inside the staff line where you wish to insert a new per-

cussion line and right-click (Ctrl + click for Mac). 
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FIGURE 10 - 1: Staff Line Options (Right-click)

b. Select Staff > Insert (above or below).
c. See "To change staff property types)," above to change the part from nota-

tion to percussion.
d. Select eighth note from “Notes” palette and using beam direction tools, cre-

ate the following pattern. Hit Spacebar to play back.

FIGURE 10 - 2: Creating a drum pattern

NOTE: Simultaneous drum sounds must be contained in the same voice. 
Therefore, you will need to use the Cluster tool to add additional 
drum “note heads” to an existing note stem. Holding down Shift and 
dragging a notehead up or down will allow you to hear each drum 
sound associated with each space and line.

10.4 Automatic Drum Patterns
It’s more fun if it’s got a beat! Simply select a drum accompaniment or you can add 
customized patterns to the drum library yourself.

10.4.1 Play back with automatic drum pattern

To select an instant drum pattern for ENF playback,
a. With any ENF file open, click on the Drum Pattern button in the Toolbar.
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b. Sort each column by clicking on its name in the column header.

FIGURE 10 - 3: Automatic Drum Track Window

c. Click on a pattern that matches the time signature and style of your ENF file. 
d. Choose a starting measure in the “from measure no.” field and push the 

Insert button.
e. To enter another drum groove at another location, repeat steps c. and d. 

above.
f. If you wish to mute drum playback for one or more measures, select the 

starting measure and push the “Insert Silents” button.
NOTE: Insert Silents are automatically inserted if the Begin and End points 

of 2 or more patterns are not sequential.
g. Press OK to accept the selection.
h. Press the spacebar to hear your file playback with drum accompaniment.

To Remove a drum pattern from the library, 
• Locate the Styles folder inside the SmartScore application folder and delete the 

.ssd file you wish to remove.
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10.4.2 Adding custom drum patterns from ENF
The drum pattern library is expandable. You can add new patterns that you have 
either created yourself or imported from a MIDI file which contains a drum track on 
MIDI Channel 10.

To add an ENF drum pattern to the automatic drum pattern library,
a. Open an ENF file which contains a percussion part (written with a percus-

sion clef) or, 
b. Open an ENF file in which you have created your own drum pattern. Refer 

to "Creating a percussion staff from scratch", Section 10.3.3 for more infor-
mation on how to create drum patterns. 

c. Click the MIDI button in the Navigator to open the MIDI Overview. See 
Section "Selecting MIDI views", Section 11.1.1 for more details on chang-
ing MIDI views.

d. Select Edit > Create Automatic Drum Pattern.

FIGURE 10 - 4: Creating a drum pattern from a MIDI file

e. Locate the track in which the drum is played and select it in the Track field. 
Note that MIDI drums will sound only if they are assigned to MIDI Channel 
10. 

NOTE: To check the channel number of a track, right-click (alt + click for 
Mac) next to the track number in MIDI Overview then select Piano 
Roll. The channel number (and its color) will appear in the upper left 
corner of the Piano Roll View. Close the Piano Roll window to return 
to Overview window. Another option is to simply open the Playback 
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Console (Ctrl + 9). Next to each track number listing is a colored 
box containing the MIDI channel number assigned.

f. Enter the name you wish to give the pattern in the Name field.
g. Select a musical style to classify the new pattern and enter it in the Style

pull-down menu.
h. Locate the first measure where you wish the pattern to begin and enter it into 

the Beginning Measure field.
i. Decide how many measures you wish the pattern to contain and enter it in 

the Length (in Measures) field. This is a very important decision if you 
want to have proper-sounding patterns. 

j. Click Generate to add the pattern to the library. It’s name will then appear 
in the Automatic Drum Pattern window.

TIP: Add “fills” to longer patterns (8 or 12 measures). Repeated fills in patterns 
having 1 or 2 measures usually sound dumb.

• Importing MIDI drum patterns
a. Push the Open button in the Navigator (File > Open) and click to select 

MIDI from the “Files of Type” pull-down menu. Browse to a MIDI file con-
taining a drum track and double-click.

b. Push the Play button to hear the MIDI file play back. Push Close.
c. The imported MIDI file will appear in the MIDI Overview window. 
d. Repeat the process from Step d) above.

10.5 Virtual Drum Kit
This option allows you to create a drum track to accompany any ENF playback with-
out requiring a drum machine or any other external MIDI device. It maps selected 
MIDI drum sounds to the keys of your computer keyboard. MIDI quantization to six-
teenth notes is applied by default. For more information about quantization, see 
"Snap to", Section 11.8.3.

10.5.1 Recording a virtual drum track

To create a virtual MIDI drum track ,
a. Open MIDI View.
b. Right click inside any number the Track Number column. Select “New 

Track”.
Using to SmartScore X



c. A MIDI Record view will open. Test drum sounds by hitting the center keys 
on the two front rows of your computer keyboard.

d. When ready, hit the Record button. You will hear a metronome sound for 
one measure. Playback and drum recording begins.

e. Hit Stop when finished. Close the MIDI window to return to ENF.

10.5.2 Defining Virtual Drum Kit

To change a MIDI drum and link to your computer keyboard,
a. Select Options > Virtual Drum Kit Definition

FIGURE 10 - 5: Virtual Drum Kit Definition

b. Click on an instrument / key in Instrument list.
c. To reassign a MIDI drum instrument, push Change Instrument and make 

another MIDI drum selection in the pull-down menu.
d. To reassign a keyboard key for that instrument, push Change Key and press 

any keyboard key to be linked to that instrument.
e. When finished, press OK.

To add a MIDI drum and link it to your computer keyboard,
a. Push Add.
b. Press a key to become associated with the sound. 
c. Select a new drum sound from the pull-down menu.
d. When finished, press OK.
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Chapter 11 MIDI Editing and Sequencing

Underlying MIDI data of an ENF score can be viewed and manipulated in 
one of three MIDI views: Overview, Piano Roll and Event List.

11.1 MIDI Views
11.1.1 Selecting MIDI views

To open MIDI environment from ENF and select a MIDI view, 
a. Press the MIDI button in the Navigator or choose View > New MIDI 

View (Ctrl +I / Cmnd+I (Mac)). 
The New MIDI View Window will open.

FIGURE  11 - 1: New MIDI View

b. In the Type window, select the type of MIDI view desired, Overview, 
Piano Roll or Event List).

• Overview
This view displays all MIDI tracks (parts) found in the open Score-Part.

• Piano Roll
This view displays all MIDI note events found in the selected track.

• Event List
This view lists all MIDI events and every detail associated with them.
The above MIDI view buttons are accessible from the MIDI Toolbar.
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11.1.2 MIDI Toolbar
The MIDI Toolbar (View > Toolbars > MIDI Toolbar) includes buttons for opening 
Overview, Piano Roll, Event List views. Also visible are the Shuttle tool, Record, 
Record to New Track, Record Virtual Drum, Delete Track and Insert Instrument 
Change buttons.

FIGURE 11 - 2: MIDI Toolbar

11.1.3 Closing MIDI Views
Each MIDI view (Overview, Piano Roll and Event List) has its own “close” icon in 
the upper left-hand corner of the window. Click to close an active MIDI view win-
dow. Or select File > Close. Closing the last MIDI view will return display to its 
associated ENF view.

11.2 Track Overview
Overview provides a “bird’s eye view” of all existing MIDI tracks. Some editing 
functions are limited

FIGURE 11 - 3: Track Overview window
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11.2.1 Selecting tracks and MIDI events
Right-clicking (option + click Mac) into a track’s Name field in Overview will dis-
play the track properties. Double-clicking into a track’s Name field will open its 
Piano Roll view.

FIGURE 11 - 4: MIDI Track Properties

The Track Properties window allows for editing of the Track Name and its Transposi-
tion. It is also used to create new MIDI tracks. Push Piano Roll or Event List buttons 
to view selected track in one of these views. 
NOTE: The Transpose selection window will actually move all the note events of 

the selected track by half steps.
• New Track will create an empty new track.
• Selecting Duplicate Track will create an exact copy of the active track and insert 

it at the bottom of the track listing.
• Delete Track will erase the highlighted MIDI track completely.

11.3 Playback
11.3.1 Spacebar

• Press the spacebar to Play. Press again to Pause. Press again to resume Play. Press 
the comma key (“,”) to Rewind to the start.

11.3.2 Mini-Console

The Mini-Console is a dockable (tear-off) Toolbar that plays, records, 
rewinds and stops playback. IDI

rding
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FIGURE 11 - 5: Mini-Console Transport

The “spring-loaded” tempo slider will increase or decrease tempo speed 
depending on the distance it is pulled from the center. Releasing the mouse 
will return playback tempo to the default speed.

• Play button initiates/resumes playback of the active MIDI file. Once play-
back has begun, the Play button becomes Pause. Use this button to retain 
MIDI data after returning to ENF display.

• Stop button stops playback/recording of the MIDI. Play/Record is re-initial-
ized at 0 (rewinds to the beginning).

• Rewind button resets playback to the beginning of the range.
• The Record button will be active only when a MIDI Out device is selected. 

Pushing the Record button will create a new MIDI track and will launch a 
new recording session. When Record is lit, press Play button to begin 
recording a new MIDI performance to a new track. When recording to a new 
MIDI track, existing MIDI data, instruments, channels and transpositions of 
the original ENF or imported MIDI file will be maintained.

NOTE: All playback functions are also available in the Realtime menu (in MIDI) or
Playback menu (in ENF).

TIP: To select an entire track for cutting and pasting, go to Overview and click 
(option + click for Mac) in the track’s Name field.

11.3.3 MIDI Devices

To set the MIDI input and output devices,
a. Select MIDI Devices from the Options menu. The MIDI Devices window 

will open.
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FIGURE 11 - 6: Options > MIDI Devices

b. Click on the MIDI Input device / interface you will use for recording new 
MIDI data. 

c. Click on the MIDI Output device you wish to use for MIDI playback. The 
MIDI device window will display all installed MIDI device drivers. MIDI 
Mapper is the default in Windows and is most commonly used for sound 
cards although a specific soundcard driver may be selected from the Output 
list.

d. Press OK to set the selected MIDI devices as the current SmartScore MIDI 
sources. The selected device then moves to the top of the list.

NOTE: If the desired device is not listed in the MIDI Devices window make sure the 
device driver has been properly installed. Check any software that was 
installed with your MIDI device and/or download MIDI driver from manu-
facturer’s website. When installing a new MIDI driver, reboot to initialize 
the new driver.

11.3.4 Playback Range

To specify part of the score for playback, 
a. Select Set Play Range from the Realtime menu. 

FIGURE 11 - 7: Set MIDI Play Range

b. Set the first measure and last measure of the Play Range.
c. Mark Play All to play the entire score.
d. Check Loop to continually repeat the assigned playback range.

11.4 Piano Roll
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In the familiar MIDI piano roll view, it is possible to alter MIDI note events and fine 
tune other playback parameters. MIDI events are only editable when “Show Actual 
Playback” option in the View menu is checked off. When “Show Actual Playback” 
is checked, articulations (trills, tremolos, etc.) display but cannot be edited since 
articulations are controlled by Properties. The Piano Roll view is track-based. 

11.4.1 Selecting MIDI tracks
• To move from track to track, click the Track Paging buttons located in the Tool-

bar.

To select and display a track in Piano Roll view:
a. Select the MIDI button in the Navigator. In the New MIDI View window, 

select a track or Part Name. Pushing OK will open the selected track in 
piano roll format.

FIGURE 11 - 8: Overview - Selecting a track

b. Select the MIDI track you wish to display and press OK.
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c. Select the magnifying glass from the Toolbar. Left click to zoom in and right 
click (option + click for Mac) to zoom out of the Piano Roll view.

FIGURE 11 - 9: MIDI Piano Roll View

d. Another method of zooming in or out is to drag measure markers horizon-
tally. Dragging to the right zooms in and dragging to the left zooms in.

FIGURE 11 - 10: Horizontal zoom by dragging measure markers
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11.4.2 Tiling ENF and MIDI views
Using the Tile Windows feature, you can view both ENF and MIDI windows simulta-
neously. This is useful if timing problems are encountered while editing ENF nota-
tion. By switching to MIDI Piano Roll view and pushing the Tile Windows button, it 
is possible to examine underlying MIDI events while referring to the same region as 
notation in the associated ENF window.

To tile all open document windows,
• Push the Tile Windows button located both in the Toolbar and in the Navigator 

palette.

FIGURE 11 - 11: ENF / MIDI Tile View (with floating Zoom window)

11.4.3 Inserting program changes (Assign new MIDI instrument for 
playback)

You can insert any number of instrument changes into a MIDI track.

To insert a Program Change (MIDI instrument change) in a track:
a. In Piano Roll view, position cursor and click to drop the red marker where 

you wish to make a MIDI instrument change. 

Tile Windows
Menu Button
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b. Push the Program Change button in the MIDI Toolbar or select Edit > Pro-
gram Change. 

FIGURE 11 - 12: MIDI Program Change (Piano Roll)

c. Select a new MIDI Instrument from the pull-down menu.
In the Voice pull-down menu, select the voice number you wish to apply the new 
instrument sound to. For more about Voice Color Mode, turn to "Working with Con-
trapuntal Voices", Section 9.9.

d. Press OK.
NOTE: List of instruments is determined by the selected Instrument set selected in 

Options > Instrument Settings. Instrument set is also able to be selected in 
the Playback Console (see Section 5.2).

e. An inverted red triangle will indicate the point where the program change 
was inserted. Clicking on any Program Change triangle will open the Pro-
gram Change window for additional changes.

NOTE: SmartScore supports multiple MIDI channels within each MIDI track. This 
allows for contrapuntal voices within ENF staff lines to be assigned to dif-
ferent instruments within each MIDI track. In other words, multiple voices 
in ENF are equivalent to multiple channels within a MIDI track. This is a 
sort of hybrid MIDI type (MIDI Type 1/Type 0 hybrid).
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11.4.4 Velocity and Tempo Graphical Controllers
In Piano Roll view, the bottom pane of the window displays a graphical, continuous-
change MIDI controller. Click into Controller Selector pull-down menu and select a 
new MIDI controller you wish to view.

FIGURE 11 - 13: Velocity and Tempo controllers in Piano Roll view

• With the pencil mouse pointer, click and drag a curve over the range you wish to 
apply the effect.

11.4.5 Shuttle Tool
The Shuttle Tool allows you to sound MIDI events forward or backward by dragging 
the mouse over a range of events.
To operate the Shuttle Tool,
In Piano Roll view, the “S” key toggles the Shuttle Tool off and on. To manually 
select, press the Toggle Shuttle button in the MIDI Toolbar or go to the Options
menu and select Shuttle On. Click and hold anywhere in an Overview or Piano Roll 
and drag the Shuttle Tool to the right to play the MIDI file at your own tempo. Drag 
the Shuttle Tool to the left to rewind and hear the MIDI file simultaneously. 

To insert or change the voice assignment of selected note event(s):
a. Use the Voice Selection pull-down menu located above the piano keyboard 

to select a voice number.
b. Right-click and drag to create a note event.
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11.4.6 MIDI Instrument settings

To change MIDI instrument parameters,
a. Select Instrument Settings under the Options menu. In Playback Console, 

push the Set Instrument button. This will open the Instrument Settings win-
dow.

FIGURE 11 - 14: Instrument Settings

b. Select the MIDI Port of the MIDI instrument you will be adjusting with the 
MIDI Port pull-down menu.

c. Choose a specific Instrument Bank or all Banks from the selected MIDI Port 
if numerical banks are supported by your MIDI device.

d. Select the type of MIDI Instrument (GM, MT32, GS, Yamaha XG, Numeric 
or Custom) from the Instrument pull-down menu.

e. Use the radio buttons to activate or deactivate specific MIDI channels for 
selected Instrument set and Drum set. The default MIDI channel for drums 
is 10.

f. Use the Drum pull-down menu to select the type of MIDI Drum set your 
device supports (GM, No Drums, Roland GS Drums, Yamaha XG Drums, 
Numeric or Custom).

g. Push Custom to create a formatted text document for displaying custom 
instrument names for your MIDI device. Edit to change.

h. Save will save Custom patch names as a formatted text document (.TXT). 
Save this file then open it in a word processing application and enter your 
patch names. Then save as a text document.

i. Load will allow you to load the Custom text file. Your custom patch names 
will display throughout SmartScore’s MIDI patch selection windows 
(Instrument Templates and Playback Console).
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11.4.7 MIDI event selection
Under the Edit menu choosing Select opens the Select Window. 

FIGURE 11 - 15: Select Event window

Select All tracks or an individual track or voice to highlight for cut, paste, pitch shift-
ing or assigning parameters. Choose Full time to display the full length of the MIDI 
file or designate a portion of the file to display by entering the measure, beat, and tick 
into the From and To fields.
NOTE: Edit > Select All is only available from a Piano Roll or Event List view.
Selecting MIDI events using mouse click-and-drag can be done from any view. 
Mouse functions work the same in all views.

To select a note or group of notes:
• Click on the individual note or click and drag to Group Select many notes.

To add note(s) to the Group:
• Hold down the Control key and click on the unselected note(s).

To select note events within a given time frame: 
a. Click in Piano Roll to mark the beginning of the time frame.
b. Hold down the Shift key and click again to set the end of the time frame. 

The selected range will highlight in grey.
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11.4.8 Changing MIDI event characteristics

To change the start time of selected note event(s):
• Click and drag the left edge of the note(s) to the position you want. 

FIGURE 11 - 16: Editing MIDI note on/off events

To change the duration of selected note event(s):
• Click and drag the right edge of a note to change a note’s duration.

To change the velocity (loudness/note attack) of selected note event(s):
• Drag the top and bottom edges of a note adjust the note’s velocity.

FIGURE 11 - 17: Editing MIDI note velocities and pitches

To change the pitch or position of selected note event(s):
• Click and drag the center of the note to change pitch (vertical drag) or note place-

ment (horizontal drag).
NOTE: The arrow keys on your computer keyboard can also be used to adjust the 

pitch and start time of the selected note. 
NOTE: To realign MIDI events to the nearest starting point (quantization), go to 

Options > Snap to and select the base rhythmic value.

To delete selected note event(s):
• Hit the Delete key to remove any highlighted notes.

Changing note velocity Changing note pitch
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To change the velocity and/or the duration of selected note(s):
a. Select the Velocity/Duration option from the Edit menu. The Velocity and 

Duration window will open.

FIGURE 11 - 18: Velocity and Duration window

b. Use the sliders or type in numbers to increase or decrease the velocity or 
duration of the selected note(s) by a percentage. Example: You wish to dou-
ble the duration of a group of selected notes. In the Velocity/Duration win-
dow move the Duration slider to 200%. 

c. Press OK.

11.4.9 Note Event window
Double-clicking on any note event will open the Note Event window.

FIGURE 11 - 19: Note Event window

The Note Event window allows access to and adjustment of an individual note’s 
parameters.
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• Raise or lower the Pitch of the Note Event
• Start Time changes when the Note Event begins
• The Duration of the Note Event can be shortened or lengthened 
• Increase or decrease the Velocity of the Note Event
• Select a different Voice for the Note Event

11.4.10 Cut/Copy and Paste
Click and drag the mouse or use Edit > Select to select a region that you would like 
to cut, copy or paste. 
• Cut removes the highlighted notes from the score and places them in the clip-

board.
• Copy stores the selected notes to the clipboard without removing them from the 

score.
• Paste will insert the contents of the clipboard back into the score without deleting 

the existing notes. Click where you want to insert the music into the score. 
• Paste Special will open the Paste Special window.

FIGURE 11 - 20: Paste Special

The Paste Special window offers several options for pasting the contents of the clip-
board back into the music.
• Add to existing events will add the contents of the clipboard to the selected area 

without erasing the existing notes.
• Replace existing events will replace the existing music with the contents of the 

clipboard.
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• Move to make room will push the existing music backward and then insert the 
contents of the clipboard.

• Use Repetitions to determine the number of times the contents of the clipboard 
will be inserted.

• Start from time designates where the inserted music will begin by choosing the 
measure, beat, and tick.

• Select Start from track to paste to a selected track number. 
• All to track will insert the contents of the clipboard, no matter how many tracks 

were originally selected, into one track.

11.5 Event List
To view and edit detailed MIDI events, meta events, note events, controllers, program 
changes, key and time signatures, etc. in a selected track, 

a. Press the MIDI button of the Navigator or in the menu, select  
View > New MIDI View or Window > Event List. 

b. Choose Event List from the Type pull-down menu
c. Select a track to view and press OK. 

The Event List displays every MIDI event of the selected track:

FIGURE 11 - 21: Event List

• Select what event types are displayed in the Event List by checking or un-check-
ing the Event Type boxes along the top of the Event List. 

• To scroll the Event List display during playback, check the “Scroll when playing” 
box in the Event List window.

• To page from track to track, click on Track Paging buttons in the Toolbar.
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11.5.1 Changing parameters of selected notes

To change parameters of a group of selected notes:
• Click in any of the columns to change the parameters of an existing MIDI event or 

double click in the Type column of a Note Event to open the Note On window.

FIGURE 11 - 22: Note On window

The Note On window, like the Note Event window, allows for adjustment of an indi-
vidual note’s parameters: Channel, Time, Duration, Pitch, and Velocity.

11.5.2 Inserting note events

To insert new events in the Event List view, 
a. Click the Event you want the Note to follow. Select New from the upper 

left-hand corner of the Event List. The Create New Event window will 
open.

b. Scroll to Note On in the Event Type menu.
c. Press OK.
d. A Note On event will be inserted into the Event List. 
e. Enter the Voice, Time, Duration, and Pitch of the new event by clicking in 

the corresponding columns or double-click in the Type column to open the 
Note On window.
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11.5.3 Editing Key, Time and Tempo
Click in any column to make changes to any existing MIDI events. To insert a new 
tempo, key, or time signature click the event you want the new event to follow. Press 
the New button. The Create New Event window will open. 

FIGURE 11 - 23: Create New Event window

Use the scroll bar to select Meta Event. A Meta Event is a MIDI file instruction. 
Scroll through the Event Subtype window to choose Tempo, Time Signature, or Key 
Signature. Press OK. Use the Other column to select the new tempo, time signature, 
or key signature OR double-click in the Type column to open an event-specific win-
dow. You may type in a new value.

11.5.4 Inserting Non-Note Events
Any MIDI event that is not a note-on or note-off event is a non-note event. This 
includes MIDI Control Changes, Program Changes, Channel Pressure, Pitch Bend 
information, and Meta Events. 

To insert a non-note event in the Event List view:
a. Select the event you want the non-note event to follow.
b. Press the New button. 

The New Event window will open. 
c. Use the Event Type menu to select the event to be added. 
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NOTE: Some events, such as Control Change and Meta Event, have Subtype event 
listings. Choose one if applicable.

d. Press OK.

• Program Changes 
Program Change inserts a MIDI event that changes the instrument playback for a 
given channel / voice. 

To insert a Program Change of the voice/channel in Create New Event:
a. Program Change is the default New Event, so simply press OK.

The selected Program Change will be inserted into the Event List. 
b. Use the Voice pull-down menu to designate the voice to which the Program 

Change applies.
c. Use the Other pull-down menu to select a new instrument.

• Control Changes 
Control Changes send adjustable parameters to your selected MIDI device i.e., 
vibrato, hold, volume, pan, effects, etc. You can add specific changes to these con-
trols from within SmartScore’s Event List. To find out more about what each control 
change will do, refer to the user’s manual of your MIDI device.

• Meta Events 
Meta Events are MIDI file instructions written to the MIDI file. They provide infor-
mation such as file and track headers, SMPTE code, tempo, key and time signatures, 
etc. and can be added to any MIDI file using SmartScore’s Event List

11.6 Playback Console
The Playback Console is available in Overview and Piano Roll views and allows for 
detailed viewing and control of playback and provides real-time editing of the active 
MIDI file. Push MIDI in the Navigator and select Piano Roll or Overview. 
Push the Playback Console button in the Toolbar or choose Real-time > Playback 
Console (Ctrl +9 Win / Cmnd+9 Mac) to open the Playback Console.
NOTE: The console can act as a “window shade”. To shrink vertically, drag the bot-

tom edge of the console up or down.
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11.6.1 Adjusting Playback Console Settings

General;
• Adjust global playback volume using the General Volume slider.
• Adjust channel volumes using individual Volume sliders.
• Use Pan to adjust stereo balance for each channel.
• Default resets all MIDI tracks to their original settings.
• The Close button will close the Playback Console.
• Mute any voice while all others continue to play or Solo a single voice for play-

back.
• Change the MIDI Instrument or Channel of any voice.

To play back at a given point in the file; 
• Use the Measure / Beat slider and scroll to the desired measure and beat in the 

score.

To select the MIDI output device; 
• Use the Port pull-down selector.

To transpose playback globally; 
• Use the General Transposition pull-down selector. 

To transpose an individual track / voice;
• Use the Transposition pull-down selector in any track / voice.

11.7 Display Controls
11.7.1 Time

To choose whether the timing of MIDI note events is displayed by Measure: Beat: 
Tick or by Tick Number;
• Go to the Options menu and select Time Format.
• Choose by Measure: Beat: Tick or by Tick Number.

11.7.2 Velocity

To choose whether the velocity of MIDI note events is displayed with absolute num-
bers (0-127) or as percentages;
• Go to Velocity Format under the Options menu.
• Choose by Value (0-127) or Percent.
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No MID
Recordin
11.8 MIDI Recording
11.8.1 Recording Options

To activate the Record mode and adjust the recording options choose Record 
from the Realtime menu.

• Synchro Start 
Recording is synchronized to start with the first MIDI note played. To “unsynchro-
nize” the start of recording with the first played MIDI event uncheck Synchro Start
from the Realtime menu OR choose the Metronome Settings listed under the 
Options menu and uncheck Synchro On.

• Thru
Sends new MIDI events to the selected MIDI output device. The active Piano Roll 
determines the parameters of the MIDI Thru sound. If no Piano Roll is open, MIDI 
Channel 1 is used.

11.8.2 Metronome
The Metronome is on by default. The metronome is useful in keeping time while 
recording and as a “count-in” tool to mark the beginning of the recording session.
Sometimes, you may want to record “freely”... that is, you simply want to capture a 
performance in MIDI without worrying about timing or about trying to convert the 
performance into notation. For this purpose, you will want to turn the metronome off. 
To make the metronome inactive during recording, uncheck Metronome from the 
Realtime menu OR choose the Metronome Settings listed under the Options menu 
and uncheck Metronome On.

I
g

Using to SmartScore X



To make changes to SmartScore’s metronome;
• Choose Metronome Settings from the Options menu. The Metronome Settings 

window will open.

FIGURE 11 - 24: Metronome Settings

NOTE: The Metronome On check box must be selected for the metronome to 
sound during recording. To record without a metronome uncheck the Metro-
nome On box.

With Synchro On, SmartScore will synchronize the start of recording with the first 
played MIDI event.
Select which MIDI Port the metronome will play through.
Choose the metronome’s MIDI Channel. 
NOTE: The de facto drum channel, MIDI Channel 10, is the default channel. But 

you can change it if you wish.
Determine the number of Lead-in Measures that will play prior to the start of record-
ing. The metronome will click at each baseline beat (derived from the time signature) 
for as many measures as you choose.
The Primary Beat (down beat) will sound when its On check box is selected. The 
Pitch pull-down menu displays all General MIDI drum sounds. Use the Volume
scroll box to increase or decrease the volume of the Primary Beat. The default accents 
the Primary Beat. 
The Secondary Beat will sound when it On check box is selected. The Pitch pull-
down menu displays all General MIDI drum sounds. Use the Volume scroll box to 
increase or decrease the volume of the Secondary Beat.
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11.8.3 Snap to
MIDI recording is very strict. Any fluctuation in timing or speed may result in 
strange or even useless notation. To prevent this, you can apply quantization to your 
performance. Select Snap to from the Options menu prior to recording. Choose the 
smallest rhythmic value that you think you can accurately play while recording. The 
resulting MIDI events will be justified, each event beginning at the nearest selected 
rhythmic timing mark.
You can reset start times of selected events to the nearest value set in Options > Snap 
to will also reset start times of all selected MIDI events and will fix the increment at 
which selected MIDI events can be moved, when using the mouse or arrow keys to 
move events horizontally.

11.8.4 Recording New Tracks / Voices

To Record a new track to a MIDI file, 
a. Select Record from the Realtime menu OR press the Record button in the 

Playback Console. The New View window will open if any MIDI data 
already exists in an active file.

FIGURE 11 - 25: Selecting Track to Record

b. Select an existing track to record a new voice within the same track.
NOTE: The new MIDI data will be added to the existing track without overwriting 

any material. 
c. Select New Track to record a brand new MIDI track.
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NOTE: A Piano Roll will open for the selected track. A Piano Roll must be open to 
record in SmartScore. A new voice and MIDI channel will automatically be 
created when recording into any track.

d. Use the Playback Console to assign the MIDI parameters for the new track / 
voice.

e. Press the spacebar or select Play from the Realtime menu, or press the Play 
button in the Playback Console to start recording at measure 1, unless a 
Punch In point has been set (see below). 

While recording:
• Pause (spacebar) will temporarily halt recording. 
• Play button (spacebar) will resume recording the same track / voice
• Stop will end the current recording session. SmartScore will return to the standard 

MIDI editing environment.

11.8.5 External Timer
• To run SmartScore’s MIDI recording from an external timer, select External 

Timer from the Realtime menu.

11.8.6 Setting Punch In and Punch Out points
To set Punch In and Punch Out points for recording, double click any measure num-
ber in an Overview or Piano Roll. The Measure Settings window will open.
• Check Punch In to start recording at the beginning of this measure.
• Check Punch Out to set this measure as the last measure for recording.
The Punch In and Out points are marked with red triangles in the Overview and Piano 
Roll displays.

11.9 Step Time Recording
Recording a “live” MIDI performance to a metronome may be very useful to an 
accomplished keyboardist, but many of us do not have the timing skills required to 
record a performance meaningful enough for conversion to notation. Even if using 
“Snap to” quantization will result in note positions that are offset with a mix of 
strange note values and, usually, many rests. A logical alternative to live recording is 
Step Time Recording. Using this method, you will be able to quickly select exact 
note durations as well as “skips” (rests) from the number pad of your computer key-
board. With your other hand, enter notes and chords from your MIDI keyboard or 
MIDI instrument.
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To activate Step Time Recording,
a. Make sure your MIDI keyboard or MIDI instrument is properly connected 

to your computer and that it or its interface is selected under Input in the 
MIDI Devices window (See "MIDI Devices", Section 11.3.3 for more.)

b. From the Realtime menu, select Step Time Record.
c. Select a track. The default is set to “New Track”. If you wish to record onto 

an existing MIDI track, select that track in the New View window.
d. Press OK.
e. A floating window representing the computer keyboard number pad and 

associated note durations appears. Record is now staged. 

FIGURE 11 - 26: Step Time recording (Number Keypad)

f. Click on a note value or control button in the floating key pad window. Or, 
you may select the corresponding value / control function using the numeri-
cal keypad on your computer keyboard. 

g. Press the Play button of the Mini Console. Recording will begin at Measure 
1.
Using to SmartScore X



h. Press a note or chord on your MIDI instrument. Notes of the selected value 
will insert. The next note you enter will begin at the same point the last note 
ended. e.g. In 4/4 time with quarter note selected, hitting a note four times 
will fill up one measure.

i. To insert a rest, choose a note value and hit Enter or right arrow.

11.10 Virtual Drum Kit
In any MIDI view, you can record your own drum tracks onto existing tracks using 
nothing more than your computer keyboard. To activate Virtual Drums, go to the 
Realtime menu and select Virtual Drum Kit. See for more information.

11.11 Playback Considerations after MIDI Editing
If you return to the ENF view after editing in the MIDI environment, playback will 
retain changes made in MIDI views until the ENF display is updated with “MIDI 
Refresh”. If notation is subsequently edited in ENF or if MIDI Refresh is selected, 
you will be given a choice of A) Keeping current MIDI playback B) Refreshing ENF 
and clearing previous changes made in MIDI or C) Saving the current playback as a 
MIDI file.

11.12 MIDI to ENF
SmartScore accepts any Standard MIDI file and converts it to an ENF file.Turn to 
"MIDI to ENF", Section 9.12 for details.

11.13 Saving MIDI Files
When saving a MIDI file, remember that you are not saving a music notation file. The 
more “humanized” the MIDI file sounds, the less likely it will appear correctly when 
imported into a music notation application, such as SmartScore. Saving SmartScore 
files derived from scanning will normally give reasonably good results because the 
music is already “quantized” into discreet start and stop times.
To save a SmartScore MIDI file,

a. Select FILE > Save As, click the “Save as Type” pull down menu and 
select either MIDI Type 0 (Single Track/Multiple Channels) or MIDI Type 
1 (Multiple Tracks / Multiple Channels).

b. Push the Save button. A window appears saying the following:
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Articulations such as slurs, staccatos and legatos will result in a MIDI file that will 
not import properly into a notation program. Choose whether you want your MIDI 
file for importing into a notation program or for playback only.

c. Choose Remove or Keep Articulations according to your need.
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Chapter 12 Reference

12.1 Preferences
Default ENF display characteristics can be changed. Select Edit >  
Document Preferences or Edit > Program Preferences depending on whether it 
is document or program-dependant.

12.1.1 Document Preferences
• Text symbols
Reset default font size and type for text symbols such as triplets, dynamics and 
expression marks. For text and lyric defaults including part names, push the “Text 
Styles” button. Push Apply to change. See "Adding and changing styles of Text 
and Lyrics", Section 7.2.2.
• Systems
Reset display characteristics for systems including part names, measure numbers, 
lyric display, clef visibility and printing, cross-staff pointer lines and constraining 
system scrolling when the score is reformatted.

FIGURE  12 - 1: Docum ent Preferences > System s

• Select how to display part names: Choose how to abbreviate part names 
and whether to show or don’t show part names. 
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• Change options for showing measure numbers.
• Change whether or not to display clefs in every system.
• Select whether to show and/or print lyrics.
• Change the line style for cross-staff voicing.
• Editing Defaults (may be turned off):  

- Minimize symbol repositioning when reformatting music. 
- Display rhythmic errors (highlight measures in red). 
- Suggest Auto-tuplets after the same rhythmic grouping is inserted more 
than twice.

• Score symbols
Change display options for:

• Triplet bracketing (square, arc, none)
• Note overlap control (overlap voices or offset noteheads)
• Rehearsal symbol display (numbers or letters).

• Page number
• Change display options for page number display, visibility and position on 

the page.
• Chord symbols
Change display options for chord symbols and fretboard font type, size and color, 
fretboard size scaling and how chord symbols will be displayed:

• Show both chord name and guitar fretboard symbols.
• Show only guitar fretboards.
• Show only chord names.
• Show neither chord nor fretboard symbols.
• Long Minor will display “min” instead of “m” for the word “minor”.

• Playback
Change GLOBAL playback characteristics:

• Grace notes: On the beat (accaciatura) / Before the beat 
• Lock to Time Signature: Lock (Default) / Play as written
• Randomizer: Place check in checkbox to apply. Adjust sliders to increase/

decrease random changes to start time and note velocities. 

12.1.2 Program Preferences
• User Interface
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Control tool palette behavior, turn display of active staff and margins off and on and 
show Task Window at startup. Reset disabled windows including post-recognition 
pop-up notifications.

FIGURE 12 - 2: Document Preferences > User Interface

• Page type
Reset default page size and orientation.
• Units and Zoom
Reset default ruler display units and reset zoom - screen size ratios.
• Tablature

• Select whether or not to print note value symbols. 
• Change the length of time to enter fret number values.

• Color settings
Reset color properties of notes and other symbols.
• MIDI channel color
Reset the colors displayed for MIDI channels 1-16
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• Karaoke settings
Control appearance during playback including scroll and ball behavior as well as 
background and lyric colors. These options are also available in Karaoke mode under 
the Options menu.
• Autosave
Reset default Autosave rules.

• Every n minutes - even if no editing takes place.
• Every n actions - based on number of editing actions, e.g. Inserting, Chang-

ing, Deleting, etc.
• What is first - based on which is first; the number of minutes selected or the 

number of actions performed.
• Never - deactivates Auto Save of the ENF file.
Using to SmartScore X



• Notifications
Control whether or not to display certain warning and caution notices.

FIGURE 12 - 3: Document Preferences > Notifications

• MusicXML
Change default options for saving ENF to Music XML files.
• ENF - PDF (Win Only)
Select alternative PDF creation application. These 3rd-party applications may redi-
rect your browser to the publisher’s website for upgrading or other offers when 
launched.
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FIGURE 12 - 4: Document Preferences > ENF-PDF

• Systems
See "Systems" under "Document Preferences".
• Score Symbols
See "Score symbols" under "Document Preferences".
• Page Number
See "Page number" under "Document Preferences".
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12.2 Properties Tool
Playback properties of many markings, including dynamics and articulations, may be 
adjusted singly or globally by clicking with this tool.whick is located in the Toolbar. 
See "Playback Properties", Section 5.6 and for more details.

12.3 ENF FILE Menu
12.3.1 File > New ENF / New MID

Select between a new ENF or a new MIDI. Choosing New ENF will open the New 
SmartScore Document window. Select a Template or use Custom to create a unique 
score. Choosing New MIDI will open a blank MIDI Overview and Piano Roll for 
MIDI input.

12.3.2 File > Open (Ctrl +O Win / Cmnd+O)
Opens File Selection dialog box and lists saved files. A selected file will be loaded 
into memory and will display on the screen. 

12.3.3 File > Close (Cmnd+W)
Closes active ENF document. If changes have been made, a Save As dialog box will 
open.

12.3.4 File > Save (Ctrl +S / Cmnd+S for Mac)
This will save an open SmartScore document to the same drive the file was opened 
from. The original name remains unchanged. If ENF and Image are displayed, only 
the ENF file is saved. 

12.3.5 File > Save As
You can save files in several file formats other than SmartScore’s native ENF format. 
These include MIDI (.MID), NIFF and MusicXML (.XML) file. 

a. Go to File > Save As. 
b. In the Filetype/Format window, choose a format to save the file.
c. Browse to another directory and change the name if necessary.
d. Press OK. The file will be saved in the last directory used to “save”.

NOTE: Use File > Save (Ctrl +S /Cmnd+S) to update the current ENF file.
NOTE: When saving ENF to MIDI files, a dialog box will open to explain that artic-

ulations such as slurs, staccatos and tenutos will create MIDI events that are 
not quantized. You will be given a choice to save the MIDI files with articu-
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lations removed or kept. For the purpose of playback only, it is recom-
mended that articulations be kept. If t is recommended that articulations be 
removed if MIDI files are to be imported into other notation-based pro-
grams.

12.3.6 Save & Open XML in Finale (Toolbar button)
Use this function, also found in the lower Toolbar, to launch Finale and import the 
current ENF file (saved as an XML file).

12.3.7 File > Save as PDF
This opens file browser and saves current active ENF file as an Adobe® Acrobat®
PDF format file. (Windows requires PDF 995 from installer)

12.3.8 File > Scan Music

• Acquire: Initiates scanning. Same as Scan in Navigator.

• Select Scanner: Opens list of available TWAIN drivers to select.

• Choose Interface:
> SmartScore’s = selects the SmartScore scanning interface. Refer to "Selecting your 
scanner and interface in SmartScore", Section 4.1.2 for details. 
> Your Scanner’s = selects scanning software from your scanner. 

12.3.9 File > Recognize
This initiates the recognition sequence for recognition of pre-scanned images. See 
"Recognition Sequence", Section 4.2 for details.

12.3.10 File > Page Setup
This opens the document layout control panel. See "Custom document layouts", Sec-
tion 8.5.5 for details.

12.3.11 File > Print (Ctrl+P / Cmnd+P)

12.3.12 File > Print Preview
Use to check for proper page layouts. Also seen in Page Setup view.
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12.3.13 File > CD Writer
Using the CD Writer feature, you will be able to record one or more ENF (MIDI play-
back) performances as a audio file or burn to a CD playable in your car, home stereo, 
etc. In order to burn to CD, it will be necessary to have a CD-R (CD Writable) device 
installed and connected to your system. 
NOTE: Some external CD-R devices may no respond to the CD Writing “burn” 

command. In this case, you should record to .WAV file and use dedicated 
CD burning software to record to CD.

To record ENF or MIDI files and burn them to audio CD,
a. Push the CD Writer icon at the bottom of the Navigator.
b. Push “Add Files” and select one or more ENF or MIDI files to be recorded 

to CD.

FIGURE 12 - 5: CD Writer window

c. Each selected file must undergo a conversion to an audio format. (.WAV is 
the default). After converting, the selected file(s) will appear in the “Files to 
Burn” list as an audio.  
Files may be reordered using the “Move Up” or “Move Down” buttons. 
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They may be removed from the list separately or all together with 
“Remove” or “Remove All” buttons.

d. Insert an unused writable CD (CD-R) into your CD tray. Burn Method = 
Auto. Change to another method if you have trouble.

e. Push “Burn Last Track and Finalize CD” to record and finalize your ENF 
files to CD. All selected files will record on a single CD track. To record 
individual tracks, use “Burn New Track” as described below.

NOTE: “Finalizing” a CD is necessary before a can be played back. Once Finalize is 
applied, you will not be able to record anything more to the CD.

f. If you wish to continue burning new selections without finalizing the CD, 
push “Burn new track”. Each set of converted files in the “Files to Burn” 
list will record to one track. Select “Burn Last Track and Finalize CD” to 
record last track and finalize the CD.

12.3.14 Most recently opened ENF files
The last four ENF files are listed and may be opened by clicking their names. 

12.3.15 Exit
Saves and closes all open ENF files and closes SmartScore.

12.4 ENF EDIT Menu
12.4.1 Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine layers of Undo. 

12.4.2 Redo (Ctrl +Y / Cmnd+Y)
Reapplies the last action that has most recently been Undone. 

12.4.3 Edit > Cut (Ctrl+X / Cmnd+X)

To view selected objects from the score and place them on the clip-
board, 

a. Hit “O” key or choose the Select tool from the Toolbar. 
b. Click and drag a box with the cursor until objects you wish to cut (and store 

to the clipboard) are highlighted orange.
c. Press the Cut button in the Toolbar, hit Ctrl + X / Cmnd + X or select Edit 

> Cut from the menu.
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12.4.4 Edit > Copy 

To copy selected objects for pasting elsewhere in the score, 
a. Activate the Select tool then click and drag a box to select a region of inter-

est.
b. Press Ctrl +C / Cmnd+C or go to Edit > Copy.

NOTE: To copy selected region of the page to the clipboard for pasting as a bitmap 
image into another program, activate the Select tool and drag a region with 
the right mouse button (Alt + click for Mac).

12.4.5 Edit > Paste (Ctrl +V / Cmnd+V)

To paste the contents of the clipboard into an ENF file, 
• Select Paste (Ctrl +V / Cmnd+V) from the Edit menu and click anywhere in the 

score. The contents of the clipboard will be added to the score and will not replace 
any existing notes.

12.4.6 Edit > Paste Replace (Ctrl+R or Cmnd+R)

To paste the copied material into an ENF file and replace existing 
notation, 
• Select Paste Replace from the Edit menu (Ctrl+R or Cmnd+R) and click any-

where in the score.
TIP: Use Paste Replace to quickly replace a complex passage that was poorly 

recognized with an identical passage that is correct. 

12.4.6a Merging and Inserting (Paste option)
A special paste mode becomes available after selecting and copying symbols or entire 
system segments. Clicking on the beginning barline of the section to be altered will 
open the following dialog box:.

FIGURE 12 - 6: Paste Option Dialog (Barline click)
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• Merge with existing bars: Copied symbols will be added to current measures.
• Insert new bars: Copied measures will be inserted and follow-on measures will 

be rolled forward. 
• Replace existing barlines: This choice will replace existing measures (identical 

to Paste Replace).

12.4.7 Edit > Delete
In this mode, clicking on objects that are moused over (and highlight yellow) are 
deleted.

12.4.8 Edit > Select All (Ctrl+A or Cmnd+A)

To select all objects on the current page for cut, copy or paste / replace 
action, 
Choose Select All from the Edit menu (Ctrl+A or Cmnd+A).

12.4.9 Edit > Bracketing (Ctrl+B or Cmnd+B)
Refer to "To delete existing chord symbol(s),", Section .

12.4.10 Edit > System Manager (Ctrl+M or Cmnd+M)
Refer to "System Manager", Section 9.10.

12.4.11 Edit > Staff Spacing
Refer to "Adjusting measures", Section 8.3.2 for details.

12.4.12 Edit > Text Styles
Refer to ".To modify font styles of text fields and lyric blocks,", Section  for more 
details.

12.4.13 Edit > Part Linking (Ctrl+L or Cmnd+L) 
(Collapsing and expanding systems)

Many printed scores “collapse” or “optimize” systems to show only actively playing 
parts. Similarly, instruments that appear in one part may split into two or more parts 
anywhere in the score causing systems to “expand” in size. SmartScore automatically 
senses expanding systems when, for example, a piano solo introduction precedes a 
vocal/piano arrangement. Expanding and collapsing parts are easily linked or re-
linked in a simple-to-use environment called Part Linking. Part Linking is also used 
when merging staves with brackets that were cut off. Turn to "Re-linking parts", Sec-
tion 5.15 for details on this feature.
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12.4.14 Edit > Score Structure
This special environment is used to perform useful functions such as creating a con-
ductor’s score from different parts and for isolating or joining parts and voices. For 
detailed discussion on using this powerful feature, turn to "Using Score Structure to 
Extract & Join Parts", Section 8.7.

12.4.15 Edit > System > Insert Above/Insert Below/Remove
Use this feature to insert an entire empty system above or below the currently active 
system. Use to delete a system, if you need to.

a. Position the cursor over the current system to make it active. 
b. To remove a system from a score, position the cursor over the system you 

wish to delete and select Edit > System > Remove.
NOTE: When an ENF score structure is changed by adding or deleting staves and/or 

systems from the Edit menu, synchronization with the scanned images will 
be lost. We recommend that you complete all needed edits/corrections or 
save a copy of the ENF file before using the Edit menu to change structure 
of your scanned music. See "View >Associate Image Files", Section 12.5.8
for more about keeping synchronization.

12.4.16 Edit > Staff > Insert Above/Insert Below/Remove
Use this feature to expand or collapse a system. 
TIP: Keep in mind that when you add a part to a system, you are also adding a 

new part to the score. When adding a part to a system, the new part will not 
be visible in any system except the active system. For details, see "Part Visi-
bility", Section 9.10.7.

12.4.17 Edit > Score-Part
Use this feature to append a new Score-Part to the ENF document. When a new 
Score-Part is added, it will begin playback at measure #1 along with all other Score-
Parts that have been created. For definition of Score-Part, see Score-Part under Sec-
tion 13.1, "Score Formats".
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12.4.18 Edit > Add Empty Pages
Use to add new pages. Also found in Status Bar (lower right corner).

FIGURE 12 - 7: Add Empty Page window

12.4.19 Edit > Unify Signatures (U)
Refer to "Unify Score (“U”)", Section 9.6.4.

12.4.20 Edit > Reformat Score
Refer to "Edit > Format Score", Section 8.2

12.4.21 Default Voices (Ctrl + U)
Use this feature to revert a selected set of notes within a measure to their default voice 
/ color assignment. Useful if voice / color assignments become confused after 
repeated over-riding of voices. 

12.4.22 Edit > Instrument Templates (Ctrl+S or Cmnd+S)
Refer to "Apply to New is useful when you want to extract parts or voices to a new 
ENF document without affecting the original.Instrument Templates", Section TIP:.

12.4.23 Edit >Score Header
Refer to "Score Header", Section 7.4.4.

12.4.24 Edit >Default Tempo

To set the default tempo,
a. Select desired Beats per Minute from the horizontal slider.
b. Choose a base note Tempo Value (4/4 default = quarter note).
c. Check the Metronome Mark Visibility box to display the Metronome 

Mark in the ENF document in the first measure.
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Refer to "Tempo Markings", Section 5.5.2 for entering change-of-tempo (metro-
nome) markings.

12.4.25 Automatic Drum Track
Opens the “assign drum pattern” window. See "Add drum tracks", Section 5.7.2 for 
details on creating automatic drum tracks.

12.4.26 Edit > Guitar Chord Library
The Guitar Chord library contains preset guitar chords and associated chord symbols. 
Add, change, delete and store any custom chords. Guitar frets and chord symbols 
automatically transpose with key transposition. Refer to "Guitar Fret and Chord Sym-
bols", Section 7.3.1 for details.

12.4.27 Edit >Transpose (Ctrl +T / Cmnd+T) 
Transpose your score by key or by clef. Limit to a part, a voice or select a range. 
Refer to "Transposition", Section 9.8 for details.

12.4.28 Edit > Edit Mode

• Zoom 

• Select tool (Ctrl+O / Cmnd+O)

• Insert / Change - See "Insert/Change mode", Section 6.2.5.

• Delete - See "Deleting notes and symbols (X)", Section 9.5.3.

• Vertical Alignment (Y) - See "Working with Contrapuntal Voices", Section 
9.9.

• Beam Notes (B) - See Convert a sequence of flagged notes into one beamed 
group under Section 9.5.5.

• Split Voices (H) - See "Voice Splitting (Select + “H”)", Section 5.9.2.

• Flip Stems (S) - See "Stem direction (S)", Section 9.5.9.

• Delete Selected Ties/ Articulations (G) - See "Select tool (“O”)", Section 
9.5.4.

12.5 ENF VIEW Menu
12.5.1 View > Toolbars

• Navigator
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Opens and closes the SmartScore Navigator.

• Main
Opens and closes Toolbar

• SmartScore
Opens and closes Toolbar

• Image
Opens and closes Image Editing Toolbar

• Text and Controllers
Opens and closes the Toolbar containing control buttons for text and graphical con-
trollers.

• Mini Console
Opens and closes the Mini playback console in ENF view.

• MIDI Toolbar
Opens the MIDI Toolbar in the active ENF view.

• Print Preview Toolbar
Open and closes the Print Preview Toolbar when Print Preview is active.

• Status Bar
Opens and closes Status Bar at the bottom of display. Displays current page, cursor 
position, image size, zoom, page view type and add page. 

12.5.2 View > Palettes
Refer to Section 9.4, "Tool Palettes" for details.

12.5.3 View > Show Active Staff
This selection will cause the ENF display to highlight the active staff in black while 
other staves become grey. The active staff line is the staff that the cursor was last 
positioned over.
TIP: Show Active Staff is useful when notation objects do not respond to editing 

actions. Using this view option might reveal that they actually belong to an 
adjacent staff line.
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TIP: If an object does not delete even if it shows itself to be in an active staff, use 
the Select tool (“O” key) to highlight it and then hit Delete. All selected 
objects will be removed with the Delete key, whether they are in the active 
staff or not.

12.5.4 View > Reset Tools and Palettes (F1)
Resets tool palettes and toolbars to their default (program launch) positions and max-
imizes the ENF display.

12.5.5 View > Hidden Symbols
Refer to Section 9.11, "Hidden Symbols" for details.

12.5.6 View > Show Part Names

To display the part name or abbreviation on the left staff line margin, 
a. Selecting Show Part Names and Abbreviations displays Part Names in the 

first system and the Part Abbreviations in subsequent systems. 
b. Select Show Part Names Only or Part Numbers Only to display just name 

or number in the 1st system and nothing more.
NOTE: For information on selecting and modifying Part Names, see "Apply to New 

is useful when you want to extract parts or voices to a new ENF document 
without affecting the original.Instrument Templates", Section TIP:.

c. Selecting Do Not Show will nor display any Part Names or abbreviations in 
the ENF display. 

12.5.7 View > Lyric Show/Don’t Show
Checking this option off will remove the display and printing of lyrics.

12.5.8 View >Associate Image Files
Synchronization between the ENF and TIFF panes assumes exact ENF correspon-
dence to the original score structure. Synchronization may become lost after systems 
are inserted, removed or if page margins are changed. Once a system rolls from one 
page to another, ENF-TIFF synchronization will become lost for all subsequent 
pages. 
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To synchronize ENF and TIFF views, 
a. Go to View > Associate Image Files...

FIGURE 12 - 8: Associate Image File Window

b. Push Load Image to browse and locate the TIF file associated with the open 
document. Double click to select the image. If the file contains several pages 
of images, they will appear as xxxP1, xxxP2, xxxP3, etc.

c. Click to highlight a page in the image-page list. A preview of the page will 
appear in the view window if Preview is checked. Then click on the appro-
priate ENF page in the list of ENF pages.

d. Push the Associate button to associate the image page with the appropriate 
ENF page. Continue as necessary.

12.5.9 View > Image Information
Provides information on the structure and type of the currently displayed image file.

• Next Page
Displays next page of ENF document

• Previous Page
Displays previous page of ENF document

• Go to Page (Ctrl +G / Cmnd+G)
Presents a dialog box to select a page number to jump to. Refer to "Paging", Section 
6.1.5 for details. 
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• Zoom
Lists available view percentages. Changing zoom will affect both the image and the 
ENF file simultaneously. Range is from 8% to 400% view scale.

12.5.10 View > Scan View
Provides options for the floating zoom window including whether to display ENF or 
TIFF close-ups in the zoom window and selecting additional zoom views. Refer to 
"Split-screen and scan view reference views", Section 9.1.1 for details on the floating 
zoom window.

12.5.11 New MIDI View (Ctrl +I / Cmnd+I)
Opens New MIDI View dialog box. Select type of MIDI view.

• Overview - Displays all staves as MIDI tracks.

• Piano Roll - Displays selected stave as MIDI track.

• Event List - Displays MIDI events of selected staff line. 

12.6 ENF PLAYBACK Menu
12.6.1 Playback > Set Playback Range

Refer to "Playing back a selected section", Section 5.3.3.

12.6.2 Playback > Play / Stop / Rewind
Used to control playback functions from menu.

12.6.3 Playback > Thru
Sets MIDI device to play “live” without MIDI Record on.

12.6.4 Playback > Console
Opens Playback Console (Ctrl+9 / Cmnd+9).

12.6.5 Playback > Mini Console
Opens and closes Mini Console Toolbar.

12.6.6 Playback > MIDI Devices
Opens MIDI device dialog box. Select MIDI input and output sources. Refer to 
"Quick Play", Section 5.1 for details.
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12.6.7 Playback > Swing
Turns swing playback on or off. Refer to "Swing", Section 5.7.3.

12.6.8 Playback > Play as written
Refer to "Barline Properties (Pickup measures and Codas)", Section 5.6.11.

12.6.9 Playback > Graphical Controller
Refer to "ENF Graphical controllers", Section 5.8.

12.7 ENF WINDOW Menu
12.7.1 Task Window (Ctrl + W)
a. Opens the SmartScore task window:

FIGURE 12 - 9: Task Window

12.7.2 Clone Document
Duplicates and opens currently open ENF file.

12.7.3 Cascade
Display, overlap and offset all open ENF files. 

12.7.4 Tile
Display all open windows of all open ENF files with no overlap.

12.7.5 Split
Activates the ENF / Scan view split control tool.
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12.7.6 Scan View Window
Removes the split-screen Image pane and activates the floating scan view window. 
See "Split-screen and scan view reference views", Section 9.1.1 for more details.

12.7.7 Karaoke
Opens the Karaoke view window. See "Karaoke View", Section 5.7.1 for more 
details.

12.7.8 Overview / Piano Roll / Event List
Opens MIDI view window and displays the selected MIDI environment, Overview, 
Piano Roll or Event List. See "MIDI Views", Section 11.1 for more details.

12.8 ENF Help Menu
12.8.1 Help > SmartScore Manual (PDF)

In CD versions, this selection will open the file, SSManual.pdf. This file is the full 
Using SmartScore 5 manual in Adobe Acrobat format. It is located in the SmartScore 
directory and is opened by Adobe Acrobat.
In download versions, this selection will attempt to open an Internet connection and 
begin downloading of the file, SSManual.pdf from the Musitek website. If the file is 
moved to the SmartScore directory, the local file will open when the Help > Smart-
Score Manual (PDF) is selection is made again.

12.8.2 Help > Online Help
This selection will attempt to launch your Internet browser and connect to a special 
interactive help system online at musitek.com. The Online Help system is fully inter-
active and contains index links, table of contents links and text hyperlinks to related 
subjects.

12.8.3 Check for Updates
Opens Internet browser and attempts to locate the SmartScore online updates page at: 
http://www.musitek.com/updates.html

12.8.4 Registration
Opens Internet browser and attempts to locate the Musitek online registration page at: 
http://www.musitek.com/registration.html
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12.8.5 About SmartScore 5
Displays version / update number. Pushing the graphic icon reveals author / program-
ming information.

12.9 MIDI FILE Menu
12.9.1 File > New

Select between a new ENF or a new MIDI. Choosing New ENF will open the New 
SmartScore Document window. Select a Template or use Custom to create a unique 
score. Choosing New MIDI will open a blank MIDI Overview and Piano Roll for 
MIDI input.

12.9.2 File > Open (Ctrl +O / Cmnd+O)
Opens File Selection dialog box and lists saved files. A selected file will be loaded 
into memory and will display on the screen. 

12.9.3 File > Close - (Cmnd+W Mac)
Closes all MIDI views. If any changes were made to the MIDI file, option to Save 
MIDI file. Return to main SmartScore window.

12.9.4 File > Save (Ctrl +S / Cmnd+S)
Writes currently displayed file to the hard disk. 

12.9.5 File > Save As 
Opens Windows File Selection dialog box
Save processed or modified MIDI files to hard disk following MIDI Recording or 
Editing procedures.
Use to save selected files to directory other than the working directory

12.9.6 File > Show Task Window (Ctrl + W)
Opens SmartScore Task Window.

12.9.7 File > CD Writer
Opens CD Writer / Burn window. See "File > CD Writer", Section 12.3.13.

12.9.8 File > Recent (1,2,3, or 4)
Automatically loads one of the last four files accessed by SmartScore.
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12.9.9 File > Exit/ Quit- (Cmnd+Q)
Exit SmartScore. Save current file. Go to Windows main desktop.

12.10 MIDI EDIT Menu
12.10.1 Edit > Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine layers of Undo. 

12.10.2 Edit > Redo (Ctrl +Y / Cmnd+Y)
Reapplies the last action that has been Undone. 

12.10.3 Edit > Select
Opens the Select window for defined note selection.

12.10.4 Edit > Select All (Ctrl +A / Cmnd+A)
Selects all MIDI events in every track. 

12.10.5 Edit > Cut (Ctrl +X / Cmnd+X)
Removes the highlighted notes from the score and places them in the clipboard. 

12.10.6 Edit > Copy (Ctrl +C Win / Cmnd+C Mac)
Places selected notes on the clipboard without removing them from the score. 

12.10.7 Edit > Paste (Ctrl +V / Cmnd+V)
Insert the contents of the clipboard back into the score without deleting the existing 
notes. 

12.10.8 Edit > Paste Special
Opens the Paste Special window. The Paste Special window offers several options for 
pasting the contents of the clipboard back into the music.

12.10.9 Edit > Delete (Del)
Deletes the selected section from the MIDI file. 

12.10.10 Edit > Delete Track
Deletes the currently displayed MIDI track.

12.10.11 Edit > Program Change (Piano Roll only)
Opens the Change Instrument window. Insert a change to a new MIDI patch.
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12.10.12 Edit > Velocity/ Duration
Opens the Velocity and Duration window. Adjust the Velocity and/ or Duration of the 
selected MIDI events.

12.10.13 Edit > Create Automatic Drum Pattern
If you wish to convert a MIDI drum pattern and add it to the SmartScore drum pattern 
library, load the MIDI drum pattern file and select this option. For more information, 
see "Adding custom drum patterns from ENF", Section 10.4.2.

12.10.14 Edit > Convert MIDI to ENF
Converts MIDI data in the currently open file to ENF notation.

12.11 MIDI VIEW Menu
12.11.1 View > Navigator

Opens and closes the SmartScore Navigator.

12.11.2 View > Toolbar
Opens and closes Toolbar.

12.11.3 View > Toolbar
Opens and closes Toolbar.

12.11.4 View > Image Toolbar
Opens and closes Image Editing Toolbar.

12.11.5 View > Toolbar
Opens the Toolbar.

12.11.6 View > Mini Console
Opens Mini Console transport control.

12.11.7 View > MIDI Toolbar
Opens the MIDI Toolbar.

12.11.8 View > Synchronize
Synchronizes measure sizes in all MIDI views to that of current MIDI view. All hori-
zontal resizing is synchronized between all MIDI views.
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12.11.9 View > Show Actual Playback
When selected, all MIDI events (including articulations such as trills and tremolos) 
are visible in the Piano Roll view. When selected, MIDI events cannot be edited 
(behavior of articulations is controlled with Properties tool in the ENF view. Turn off 
to edit MIDI events.

12.12 MIDI OPTIONS Menu
12.12.1 Options > Snap to (Quantization)

Quantities selected MIDI “Note On” events to the nearest “tick” specified. Also 
determines default quantization value for MIDI recording and for horizontal nudging 
of selected MIDI events by mouse dragging or by use of the arrow keys. Quantization 
values range from 32nd triplet to whole note. 

12.12.2 Options > File Settings
Opens Sequence Settings window. Shows the MIDI header information including: 
tempo, time base, time signature, key, and MIDI instrument.

12.12.3 Options > Track (not in Overview)
Opens Track Properties dialog box. Select a different track view, delete, duplicate, 
rename, or transpose the selected track.

12.12.4 Options > MIDI Devices
Opens MIDI device dialog box. Select MIDI input and output sources.

12.12.5 Options > Instrument Settings
Opens Instrument Settings dialog box. Allows for selection of Port, Bank, and MIDI 
channel assignment for Instrument and Drum sources.

12.12.6 Options > Metronome Settings
Opens Metronome Settings dialog box. Allows for selection of Port, MIDI Channel, 
number of lead in measures, MIDI sound and volume for Primary and Secondary 
beats.

12.12.7 Options > Shuttle On
Activate/ deactivate SmartScore’s shuttle tool.

12.13 MIDI PLAYBACK Menu
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12.13.1 Playback > Set Playback Range
Opens Set MIDI Play Range dialog window.

12.13.2 Playback > Play/ Pause “Spacebar”
Begins/ pauses/ resumes playback of current MIDI file. In Record Mode will start 
and pause MIDI recording.

12.13.3 Playback > Stop
Stops playback or recording of current MIDI file.

12.13.4 Playback > Rewind “,” (comma)
Rewinds to beginning of Set Playback Range. 

12.13.5 Playback > Record 
Check to activate MIDI Record mode

12.13.6 Playback > External Timer 
Set recording to begin from an external signal.

12.13.7 Playback > Synchro Start 
Active only in Record Mode, check to synchronize start of MIDI recording with first 
note played on MIDI keyboard.

12.13.8 Playback > Thru
Allows MIDI input to sound without having to be in Record mode.

12.13.9 Playback > Metronome
Activates/ deactivates Metronome in recording

12.13.10 Playback > Playback Console (Ctrl + 9 / Cmnd+9)
Opens the Playback Console.

12.14 MIDI WINDOW Menu
See "ENF WINDOW Menu", Section 12.7.

12.15 IMAGE FILE Menu Items
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12.15.1 File > New
Select between a new ENF or a new MIDI. Choosing New ENF will open the New 
SmartScore Document window. Select a Template or use Custom to create a unique 
score. Choosing New MIDI will open a blank MIDI Overview and Piano Roll for 
MIDI input.

12.15.2 File > Open (Ctrl +O / Cmnd+O)
Opens File Selection dialog box and lists saved files. A selected file will be loaded 
into memory and will display on the screen. 

12.15.3 File > Save (Ctrl +S / Cmnd+T)
Writes currently displayed file to the hard disk. 

12.15.4 File > Save As
Opens Windows File Selection dialog box
Save processed or modified Image files to hard disk following Scanning and Editing. 
Use to save selected files to directory other than the working directory.

12.15.5 File > Save As PDF
Saves currently open TIFF image as a PDF file (Windows requires PDF 995 from 
installer). 

12.15.6 File > Scan Music
Selects scanner or initiates scanner to acquire image.

12.15.7 File > Recognition
Initiates Recognition to begin processing saved image file(s).

12.15.8 File > Print (Ctrl +P Win / Cmnd+P Mac)
Initiates Windows Print Monitor. Current Image file is output to default printer from 
selected printer port. 

12.15.9 File > CD Writer
Opens CD Writer / Burn window. See "File > CD Writer", Section 12.3.13.

12.15.10 File > Recent (1,2,3, or 4)
Automatically loads one of the last four files accessed by SmartScore (Win). Select 
any recent files by type (Mac)
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12.15.11 File > Exit/ Quit (Cmnd+Q Mac)
Exit SmartScore. Save current file. Go to Windows main desktop.

12.16 Image EDIT Menu
12.16.1 Edit > Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine layers of Undo. 

12.16.2 Edit > Redo (Ctrl +Y / Cmnd+Y
Reapplies the last action that has been Undone. 

12.16.3 Edit > Cut (Ctrl +X / Cmnd+X)
Removes the selected section from the image file and places it on the clipboard 

12.16.4 Edit > Copy (Ctrl +C / Cmnd+C)
Places selected section on the clipboard without removing it from the image file. 

12.16.5 Edit > Paste (Ctrl +V / Cmnd+V)
Insert the contents of the clipboard back into the image file 

12.16.6 Edit > Delete (Del)
Deletes the selected section from the image file. 

12.16.7 Select All
Selects the entire image for moving / centering.

12.16.8 Edit > Crop
Trims the image file down to the selected region

12.16.9 Edit > Invert
Switches the colors of the image file.

12.16.10 Edit > Rotate
• Left: Rotates the image file counter-clockwise
• Right: Rotates the image file clockwise
• Any: Opens the Rotate window for rotation by defines degrees.

12.16.11 Edit > Delete Page
Deletes currently displayed page. Does not delete the entire file.
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12.16.12 Edit > Selection
Activates the Area Selection tool.

12.16.13 Edit > Line
Activates the Line drawing tool.

12.16.14 Edit > Brush
Activates the Brush tool.

12.16.15 Edit > Deskew
Activates the Deskew tool for straightening “crooked” scans

12.16.16 Edit > Selection Mode
• Opaque

When a selected area is moved to the clipboard the background will be 
included

• Transparent

When a selected area is moved to the clipboard only the black portion of the 
selected area with be moved.

12.16.17 Edit > Pen Color
Select the color used by the Brush and Line drawing tools.

12.17 Image VIEW Menu
12.17.1 View > Navigator

Opens and closes the SmartScore Navigator.

12.17.2 View > Toolbar
Opens and closes Toolbar

12.17.3 View > Toolbar
Opens and closes Toolbar

12.17.4 View > Image Toolbar
Opens and closes Image Editing Toolbar
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12.17.5 View > Status Bar
Opens and closes Status Bar at the bottom of main SmartScore Window. Displays 
current page, cursor position, image size, and zoom percentage.

12.17.6 View > Palettes 
Opens and closes tool palettes for ENF document editing.

12.17.7 View > Image Information 
Provides information on the structure and type of the currently displayed image file.

12.17.8 View > Next Page
Displays next page of ENF document

12.17.9 View > Previous Page
Displays previous page of ENF document

12.17.10 View > Go to Page (Ctrl +G Win / Cmnd+G Mac)
Presents a dialog box to select a page number to jump to. Use scroller to select 
desired page and click OK. 

12.17.11 View > Zoom
Lists available view percentages. Changing zoom will affect both the image and the 
ENF file simultaneously. 

12.17.12 View > Reset Tools and Palettes (F1)
Resets windows, toolbars and palettes to their default position.

12.17.13 View > Reset Warnings
Resets warning messages to their default.

12.18 Image Realtime Menu
12.18.1 Realtime > Thru

Allows MIDI input to sound while recording.

12.18.2 Realtime > MIDI Devices
Opens MIDI Device window.
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Chapter 13 Glossary

13.1 Score Formats
Score - A musical piece compiled as a document. A score usually contains more 
than one part with all the parts to be played together. In SmartScore, it is a single 
computer file; an ENF file. A hand-written score is called a manuscript.
Part - A part is represented by a staff line either alone (solo part) or grouped into a 
system with other instruments (ensemble part). A part is usually an single instru-
ment, but in the case of two-handed instruments (piano, organ, xylophone, etc.), it 
may represent one hand’s part.
Voice - Derived from choral music but applied to instrumental music as well, con-
trapuntal voicing (sometimes referred to as polyphonic voicing) refers to a unique 
melodic thread distinct from other voices in a measure by its harmonic direction 
and possibly its timbre. Contrapuntal voices reside in the same measure of the same 
staff. Voices are often distinguished by stem direction and sometimes by offsetting 
the horizontal position of notes. For the purposes of SmartScore, a “voice” written 
in its own staff line is referred to as a “Part”.
Score-Part - Scores that are printed in sets for each individual instrument. Players 
read from their own unique set of pages. For example, a duet for guitar and flute 
would be printed in two separate sets: one for the flute player and one for the guitar. 
Staves of part scores flow like a book where each staff line appends to the one 
above it. 
Ensemble - Scores that have multiple staff lines connected by a vertical bar or 
“bracket” (usually along the left-hand edge of the music). When joined in this way, 
each staff line represents a different part or instrument. All parts are played 
“ensemble”. Piano music, (with left-hand and right-hand staves) are joined into one 
system, is regarded as “ensemble”. SmartScore assigns each stave to separate MIDI 
tracks.
Landscape - Some scores are wider than they are high. These “landscape” layouts 
need to be rotated prior to processing.
Folio - Large sized and conductor scores may need to be scaled down during scan-
ning or reduced on a copy machine before scanning. If the score must be reduced 
more than 50% in order to fit the imaging area of your scanner, you may consider 
scanning each full-sized page twice and treat each scan as one “image-page”.
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13.2 Score Components
System - A grouping of multiple staves linked together by a solid line or bracket 
along the left margin is called a “system”. All staves belonging to a system are played 
simultaneously. In ensemble scores, each system appends to the one before it. A sin-
gle page of a symphony conductor's score, containing 10 or 20 staff lines per system, 
may represent only a few seconds of music!
Staff (Stave) - The field on which notes are represented is called a staff. “Staves” is 
normally used as the plural. At the core of every staff are five horizontal lines. Each 
successive line and space are equivalent to a full step in note pitch. The higher the 
note appears on the stave, the higher its pitch. Every staff line anomaly begins with a 
clef sign and a key signature.
Voiceline - An individual melodic line formed by a voice within one measure. When 
a staff contains more than one voiceline in any given measure, note stems of each 
voiceline usually point in the opposite directions. The sum of all note and rest values 
of each voiceline in any given measure should be accounted for, but sometimes are 
not. Refer to "Working with Contrapuntal Voices", Section 9.9 for more on dealing 
with this rule in SmartScore.
Clef - The clef sign at the beginning of each stave identifies which pitch “class” that 
stave belongs to. The lowest instruments are written in the bass clef, intermediate 
instruments and voices often use one of three “C” clef classes while higher-pitched 
instruments, in addition to the right-hand part of a piano score, are scored in the treble 
clef. The clef sign always appears at the beginning of every staff line and in the first 
measure if a change of clef occurs. Change of clef signs are smaller than normal clefs.
Key Signature - The key signature, along with the clef sign, appears at the beginning 
of every line; it is also found in the measure where a change of key occurs. The key 
signature defines the “tonal center” of the piece. The number of sharps or flats in the 
key signature determines the key tone (or tonic).
Time Signature - Time signatures usually appear only once: at the beginning of the 
stave in the first measure of the piece. They will also appear when a change of time
signature occurs. Time signatures indicate both the number of beats per measure 
(numerator) as well as which note value is given the fundamental beat (denominator). 
The sum of note duration values in a given measure must equal the value of the cur-
rent time signature.
Note - A note is the fundamental unit of tone. The duration of a note is determined by 
its note value (normally between 1 and 128 divisions). The note’s vertical position on 
a given staff (with clef) determines its pitch. 
Using to SmartScore X



Rest - Rests are equivalent to notes insofar as their durations; but represent silence. 
They act as “place-holders” used to keep the rhythmic structure of the measure intact. 
Measure - Staff lines are segmented into equal time divisions called measures. Mea-
sures are the building blocks that provide structure for music. The sum of note and 
rest durations within each measure must equal the value of the current time signature
Barline - Barlines are the vertical lines that define the beginning and ending of mea-
sures
Accidental - Note pitches often range outside of the tonal center defined by the key 
signature. An accidental shifts its associated note up (sharp) or down (flat) by 1/2 
step. Accidentals may also be doubled. An accidental remains effective only for the 
remainder of the measure in which it appears. A natural “cancels” a note’s current 
accidental.
Dot of Prolongation - Notes and rests that are dotted have the value of their duration 
lengthened by 1/2. For example, a dotted quarter note is equal in duration to three 
eighth notes. Double-dotted notes increase the note’s duration by 3/4 of the original.
Tuplet - Some notes belong to a special readmit class called “tuplets”. These include 
triplets, quintuplets and sextuplets. A tuplet is a group of notes marked with a bracket 
that is subdivided into equal beats (divisions) with a total duration equal to the num-
ber of unmodified notes (value). For example, a (3:2) triplet applied to three eighth 
notes is equal in total duration to two eighth notes. 
Ties - A tie links two pairs of notes of the same pitch whose durations are combined 
so that both notes are played as if one note. Ties are often used to sustain the sound of 
a note across more than one measure. 
NOTE:Ties and slurs (legatos) often look alike, but they are different. Ties connect 
two notes of the same pitch and combine their durations into one note event and slurs 
connect two or more notes over a range of pitches forming a legato that when per-
formed, creates a slight overlapping of the notes. 
Articulations - Performance markings that provide instructions for playback of the 
marked notes. For example, a staccato, a dot placed above/ below a notehead, means 
the note should be short, sounding for only a moment. 
Dynamics - Dynamic markings are used to denote the general volume and intensity 
of music. For example, “f” or forte means loud and “p” or piano means soft.

13.3 MIDI Terms
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MIDI- Musical Instrument Digital Interface. Originally a hardware device that 
allowed a computer and a synthesizer to communicate, now a generally accepted 
term for hardware or software that operate according to General MIDI standards.
Standard MIDI File (SMF) - The file protocol or format for music files saved as 
MIDI (.MID extension). Includes Type 1 (multiple track / multiple channel) and Type 
0 (single track / multiple channel) formats.
Sound Device- A MIDI driven tone generator. Sound cards, synthesizers, and MIDI 
modules all fall under this category.
MIDI Event - Each piece of information contained within a MIDI file is an event. 
This includes Notes (attack and release), Control Changes, System Exclusive, Meta 
Events, Program Changes, etc.
Velocity - The speed at which the note was struck, measured with a number from 0-
127.
Channel -A MIDI device sends and receives MIDI information along separate and 
distinct Channels. Each channel contains note and non-note event data. Most MIDI 
devices can support up to 16 MIDI Channels at one time.
Patch - Every MIDI channel has a MIDI patch assigned to it. A Patch is the instru-
ment sound selected for a particular channel when playing back.
Program Change - Same as a patch. Indicates a change of patch within a given chan-
nel or track.
Bank - MIDI devices divide patches into groups of 128. One Bank of patches from a 
MIDI device can be accessed at a time by a MIDI computer program or another MIDI 
device.
Port - A computer can run several MIDI devices at a time with the proper hardware. 
Each device is connected to a unique Port.

13.4 SmartScore Terms
ENF - Extended Notation Format. This is SmartScore’s proprietary file format. 
Navigator - The floating window containing buttons designed to “navigate” through 
SmartScore’s main features and editing environments. 
System Manager - The System Manager is a sort of “virtual system” which allows 
for manipulating all or specific voices, parts and systems in the score. It contains the 
parts and voices that make up the active system. The Super System, within it, con-
tains ALL possible parts.
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Voice Line Threading - SmartScore will differentiate multiple voices within a single 
staff line by displaying them in different colors (Voice 1-black, Voice 2-red, Voice 3-
green, and Voice 4-blue) while, at the same time, creating an independent MIDI chan-
nel for each voice..
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