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Music is a kind of counting performed by the mind 
without knowing that it is counting.
G.W. Leibnitz (1714)

Mathematics is music for the mind.
Music is mathematics for the soul.
Anonymous (18th century)
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Registration is accomplished during installation. To double-check if you are 
registered, go to HELP menu and select Register. If fields are empty, please fill 
them in and push “Submit”. If the HELP menu item “Activate your copy now” 
appears in a grey color, your copy is already registered, validated and ready to 
use. You will be able to receive technical support only if you are a registered 
owner. Registering your product is important for you in many ways:

• You will be eligible for free periodic updates from our website and spe-
cial upgrade prices for future product releases.

• You will be given priority access to Musitek Technical Support and Cus-
tomer Service using your Customer ID.

All Musitek products are covered by a limited 90-day warranty. To replace a 
defective DVD that is still under warranty, contact Musitek Customer Service. 
Out of warranty DVDs and manuals can be ordered online or by phone. A nom-
inal charge will be applied.

Musitek’s website contains up-to-date information on all our products. You may 
register online and download posted updates. Also, you may e-mail Musitek 
Customer Service for upgrade information, to notify us of a change in your 
address or request other product-related information.

• http://www.musitek.com
• sales@musitek.com
• Office: (805) 646-8051 / FAX: (805) 646-8099
• 410 Bryant Circle., Suite K, Ojai, CA 93023-4200

Most solutions to technical issues can be found in the manual or by accessing 
FAQs and support videos from our website. To contact a specialist, send e-mail 
either from the website or from your own e-mailer. We strongly encourage com-
municating by e-mail so you can attach problem files along with descriptions of 
your issues. Phone calls are generally answered during the hours listed below. 
You may also FAX us your questions. 

• tech@musitek.com
• Phone: (805) 646-5841 / FAX: (805) 646-8099 

10 AM to 2 PM Pacific Time - Monday thru Friday
• http://www.musitek.com (also at www.smartscore.com)
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Notices

Musitek® and its licensors retain all ownership rights to the SmartScore® computer program 
and/or other computer programs offered by Musitek including all associated documentation 
and materials. Use of SmartScore is governed by the license agreement printed on the media 
envelope or within the installer encoded in the program. SmartScore source code is a confiden-
tial trade secret of Musitek. You may not attempt to decipher, reverse-engineer, decompile or 
develop any derivative code found within SmartScore or knowingly allow others to do so. 
SmartScore and its documentation may not be sublicensed and may not be transferred to any 
other entities without the prior written consent of Musitek.

SmartScore is licensed and not sold to you. You may install and use it on up to five (5) different 
machines solely for your own use before having to request more installation permissions from 
Musitek. You may not copy the installer or executable program onto any media even if at the 
same location. You are authorized to store copies of generated files for your own use. You are 
free to distribute SmartScore-generated files without any restriction from Musitek. Successful 
installation of SmartScore is confirmation that you agree with the terms outlined in the Musitek 
end user license agreement (EULA). 

Your right to reproduce this manual is restricted by international copyright laws. Making cop-
ies, adaptations or compilations of this publication without prior written consent of Musitek is 
prohibited by law and constitutes a punishable legal violation. 

MUSITEK PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE 
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PUR-
POSE. Musitek may revise this publication from time to time without notice.

Introduction to SmartScore X2 and Using SmartScore X2; Written by Chris Newell
SmartScore was designed and developed by Chris Newell, Ojai, CA
Programming by Moniusoft S.A. and Conficode S.A., Warsaw, Poland
SmartScore and Musitek are registered trademarks of Musitek Corporation, Ojai, CA
Microsoft and Windows are registered trademarks of Microsoft Corporation
Apple, Macintosh and OS X ares registered trademarks of Apple Computer, Inc.
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Important Information about Copyright 

Copyrighted material is protected from infringement by U.S. and international law. Title 
17 of the US Code governs the making and reproduction of works protected by copyright. 
Under this code, reproduction, distribution and display of works protected under copy-
right is illegal if done without the permission of the copyright owner unless the proposed 
use falls under the definition of “Fair Use”. If you have reservations that your proposed 
use of SmartScore may be in violation of copyright law, consult with your attorney before 
using this product.
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1) Installation and Introduction

1.1 SmartScore X2 Installation procedures
SmartScore requires personalization and verification of ownership the first time it 
is opened. You will be able to install SmartScore 5 times on up to 5 computers you 
own and use exclusively. Contact Musitek Technical Support if additional installs 
are necessary. For details, please read the SmartScore licensing agreement.

a. You will need to be connected to the Internet during the installation. If you 
do not have Internet access you will be given a confirmation number 
which will require entering a response from Musitek (Verification ID). To 
complete manual verification, contact technical support at tech@musi-
tek.com (805-646-5841).

NOTE: Turn firewall & virus protection OFF during installation. Copying the 
installed program to other media will to cripple the program. 

Download Installations

a. After purchasing SmartScore for downloading, you will be taken to a 
“Thank you” page which will give you your new ID and serial number. Be 
sure to print this page out and store it for future reference. You will then be 
directed to a link for downloading. (If you are upgrading from a previous 
Musitek product, you will first be required to enter your previous ID and 
serial number).

b. In the “Download Product” page, you will be able to choose to download 
the complete installer (SmartScore X2, Aria Player and Garritan sounds) 
or just the SmartScore X2 product you purchased. The full download 
installer is over 600MB and may be slow or possibly even time out if you 
have a slow Internet connection.

c. If you choose to download only the SmartScore X2 installer, you will be 
given a link where you can purchase the full DVD for $5 plus shipping.

DVD Installation

d. Insert the SmartScore X2 DVD into your computer’s DVD drive.

e. (Windows) Inserting DVD should launch Auto-run. If not, Push Start > 
Run and Browse to find your DVD drive. Double-click 
Install_SmartScoreX2.msi. 
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f. (Macintosh) Insert the DVD and open the Macintosh folder. Double-click on 
the file Install_SmartScoreX2.

All Installations

g. After successful installation, launch your copy of SmartScore X. Follow 
personalization and verification steps. You will need to enter your unique 
Customer ID and Serial Number which is printed on the DVD box or was 
given to you when you downloaded the software.

h. Installation requires online registration and verification. File saving and 
printing will be disabled after 30 days if registration is not completed. If you 
are unable to register online, please contact technical support at 805-646-
5841 or by e-mail at tech@musitek.com.

1.2 How to use this manual

This manual is a reference. It is not intended for bedtime reading. The best method 
for learning or solving an issue is to go directly to the Index on page 243, find your 
topic or issue then find the corresponding page number. We strongly suggest new 
users walk through the Tutorial, Chapter 2), page 4 before diving in. A Quick Refer-
ence Guide is included within the program and can be accessed from the Help menu.

NOTE: We’ve produced a number of helpful support videos. You can find them at: 
www.musitek.com/videos.html 

1.2.1 What Edition symbols mean

Not all features described apply to every SmartScore edition. Symbols in the left mar-
gin identify editions that do not apply.

• SmartScore Pro Edition

The Pro edition has no restrictions. All features and descriptions in this manual apply 
to SmartScore Pro Edition.

• Not found in MIDI Edition

Indicates the feature or description does not apply to MIDI Edition.

• Not found in MIDI or Guitar Editions

Does not apply to either MIDI or Guitar Edition.
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• Not found in MIDI or Piano Editions

Indicates the feature or description does not apply to either MIDI or 
Piano Edition.

• Not found in Piano or Guitar Editions

Indicates the feature or description does not apply to either Piano or 
Guitar Edition.



2)  SmartScore X2 Tutorial

2.1 Recognition of Sample Files (Fandago.tif)

SmartScore includes several pre-scanned TIFF files. For the purpose of this tutorial. we 
will start with sample file, Fandango.tif. 

a. If the SmartScore Task Window is open (Ctrl + “W” will open it at any time), 
push the “Recognize Scans” button. The Navigator and the Toolbar also have a 
Recognition button. 

NOTE: The Task Window opens automatically only at program start. It can be launched 
at any time with Ctrl + “W” or by selecting Recognition from Windows menus 
(on Windows) or from the File menu (on Macintosh).

The Begin Recognition window opens. This is the window you will use to select previ-
ously-scanned music for recognition.  

FIGURE 2 - 1: Begin Recognition window

b. Press Add Files to List. In the Open dialog box, double-click on the sample file, 
Fandango.tif, inside the SmartScore folder. This will add the pre-scanned file to 
the list. 

c. Press Begin Recognition.

This is where the magic happens.)
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2.1.1 System Report

Once recognition is complete, you will see list giving the total number of systems found as 
well as the largest and smallest number of parts found in any given system. This is espe-
cially important information if you are working with large scores or scores with expanding 
and collapsing systems. Click “Open SmartScore File” to proceed normally.

NOTE: If the information in the System Report differs significantly from your original 
score, there may be problems with your scanned image, such as broken systems 
or missing parts due to poor originals or incorrectly scanned pages. 

2.1.2 Unify Key and Time

In the Unify window, click OK to accept the default (Unify key signatures based on the 
topmost staff line in each system). Accepting the defaults after recognition is usually fine.

The name Fandango.enf will appear in the Save As file name window. SmartScore’s file 
extension is ENF (Extended Notation Format). The .enf extension will automatically be 
added to all file names after recognition. Click on Save. 

2.2 Editing Sample Files

2.2.1 What you will see first

After recognition of the Fandago file, the screen will fill with a number of colorful and 
interesting windows. Don’t be afraid. It’s all good. 

FIGURE 2 - 1: Opening screen after recognizing a file
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2.2.2 Aria Player and Playback Console

The information window is important, but may be a bit incomprehensible at first. For now, 
just push OK. (Do not click “Don’t show this again” unless the message is clear to you.)
In order to play back the music, you will need to load some instruments into Aria player. 

a. Left-click in the lower left hand corner of the “Ensemble” window in the Aria 
player, choose “SmartScore” and select “All_Piano”.

b. Move your cursor to the “Playback Console” and in the transport controls, push 
the Play button.

c. To stop playback, hit the Spacebar. The Spacebar starts and stops playback.

d. With your cursor, click and drag an edge of the Playback Console and drag it to 
the right side of the screen. Do the same with the Aria player. For more informa-
tion about the Aria player, see (Section 4.1, "Working with the Aria Player and 
Garritan sounds" on page 39). Now, lets discover SmartScore’s notation editor...

2.2.3 Notation Editor

The original scanned image is displayed in the upper pane and the newly recognized 
SmartScore version appears below it in white. file appears below it. Use the scroller bars,
mouse wheel, or arrow keys on your keyboard to scroll up and down the page. 
Mac Users: Try the “overlay” mode controlled by the variable opacity slider in the Tool-
bar. In the main menu, select View > Split screen > Overlay.

Only one staff line is active at a time. The active staff displays black while inactive staff 
lines display in grey. Move your cursor within the boundary of a staff until it highlights 
black. Caps Lock will “lock in” an active staff until it is hit again. If you want all staves to 
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display in black, go to the View menu and un check Show Active Staff. If you do this, 
remember to move your cursor within a staff line first before doing any editing within a 
staff line.

To see all staff lines in black, check “Show Active Staff” in the View menu. 
Since editing is done a staff-to-staff basis, turn this back on if you are unsure 
which staff line you are editing. 

2.2.4 Editing Fandango

Once you have recognized Fandango.tif, it’s time to edit the few mistakes...

Deleting symbols / Expanding palettes / Grace notes

The beamed grace note in the first measure was recognized as a quarter note.

a. Hit “X” key on your keyboard and with your mouse, left click on the quarter note 
to delete it.

b. Click and hold on the quarter note button in the Note and Rests palette. In a sec-
ond or two, all possible note values will appear.

FIGURE 2 - 1: Expanding Tool Palettes (Notes) and selecting Beam direction

c. Select the 16th note (two flags).

d. In the Notes and Rest palette, click on the beam direction button. Hold down 
for a second or two and select “right beam”. 

e. Now click on the “Grace note” button to the right of the beam button.

NOTE: Use the “S” key on your keyboard to toggle whether the inserted note will be 
“stem up” or “stem down”.

f. Move your cursor to where first “grace note” should appear and click to insert.

g. Move your cursor to where the second grace note should appear and click. You 
should now see two grace notes joined together with a double beam
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Changing note values using Quick-select method

Notice Measure 3 is highlighted pink. This means there is a rhythmic problem. The beam 
notes in the treble clef should all be 8th notes, not 16ths. We will use Quick-select to fix it 
without having to go back to the tool palette.

a. Position you cursor over the middle note of the 8th note beam group in the next 
measure (Measure 2) until it highlights yellow. With Ctrl button down, click on 
it. Notice the cursor immediately becomes a middle-beamed 8th note.

This action is called Quick-select. With Ctrl down, clicking on any object will inherit its 
attributes. You may find Quick-select to be the fastest and easiest method for selecting 
most musical symbols while editing.

b. Position you cursor over the first 16th beamed note in Measure 3 until it high-
lights yellow and click on it. The note will change to an 8th beam. 

c. Notice the measure’s pink color disappears. This means there is no longer a tim-
ing error in the measure.

d. Push the Space bar to begin playing the piece. To pause, hit Space.

NOTE: If the target note turns light blue, a new note will be inserted. Only objects that 
highlight yellow will become changed. If a mistake is made, push the Undo but-
ton or Ctrl + “Z” (Cmd + “Z” for one-button Macs).

Copying and pasting several notes at once / Pitch shift

In Measure 23, notice a grace note was mis-recognized, again as a quarter note.

a. Hit the “X” key and click to delete the first, incorrect quarter note.

b. Zoom out (right-click) and return your cursor to the beginning of Measure 1. Hit 
the “O” key (or push the “Selector” icon in the ENF toolbar) and right-drag to 
highlight both grace notes. Select Edit > Copy or push Ctrl + C/Cmd + C.

c. Position your cursor in Measure 24. Push Ctrl + V / Cmd + V and click to paste 
the grace notes where they should be. 

d. The pitch of the first grace note should be e, not d. Zoom in with zoom too. 
While holding the SHIFT button down, drag the head of the first grace note up a 
step to e.

Transposing the key

a. Push the “Transpose” button in the Toolbar (or select Edit > Transpose).

b. In the Transpose window, click the scroller upwards to change the target key sig-
nature from 1 flat (Dm) to 1 sharp (Em). 

c. Push OK to effect the key transposition.
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Unifying irregular staff sizes

This piece comes from an older edition with somewhat irregular sized staff lines. Notice 
the bass staff is slightly larger than the treble staff. SmartScore measures and displays staff 
and systems distances exactly as the original.

a. Locate the blue “staff height” tab left of the bass staff in Measure 15. Move the 
blue tab upward to slightly decrease staff height so it matches the staff width of 
the treble clef. Once you are satisfied with staff and line spacing, hit the “Caps 
Lock” key to “lock in” the active system.

b. Push the “Unify” button in the Navigator. Select “Unify System, Staff and Line 
Spacing” (Based on active system). Push OK.

c. Hit the “Caps Lock” key again to release the active system.

Prepare for printing (Page setup / centering / adjust margins)

In unifying system spacing, it’s possible that the last system may have rolled over to a new 
page. Here, we will center the score and readjust page margins...

a. Push the “Setup” button in the Navigator or select File > Page Setup. Notice 
default Document Layout is From Recognition.

b. Change Document Layout to Center on Page. The print preview pane in the 
background will change to reflect actual page size. Push Apply.

c. If necessary, reposition the green header/footer tabs located inside the left margin 
ruler. 

d. Push the Print icon at the top of the Page Setup window. 

Visualizing contrapuntal voices

Turning on voice color will display contrapuntal voices as different colors. This allows 
you to view secondary voices (both notes and rests) in red and tertiary voices in green. 
Any notes belonging to a 4th voice will appear in blue.

a. In Page Setup view, push “Main View” button at top of screen.

b. In the Toolbar, push the “Voice Visibility” button.

Notice in Measure 2 how notes and rests appear as either black or red. They rep-
resent two of the four possible contrapuntal voices. Voices can be assigned differ-
ent MIDI instruments if desired.
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c. Push the Console button to open the Playback Console or use the keyboard 
shortcut, Ctrl + 9 / Command + 9. 

FIGURE 2 - 2: Playback Console with Voice Visibility on

Changing Instrument sounds in Playback Console

The left and right-hand piano parts have been automatically recognized as piano and 
assigned the General MIDI patch of Grand Piano.

a. In the Instrument column of Track 2 / Voice 2 (red track), change the instrument 
to Timpani. Press the spacebar or Play button. You will hear that the secondary 
voice of the left hand will be different from the others. 

b. Move volume slider left or right to increase or decrease volume on one or more 
parts. Close Playback Console. 

2.2.5 Editing Chorale

Many scores are written with multiple voices within a single staff line. Solo 
piano, guitar and choral music typically include different voices moving indepen-
dently in and out of measures. “SmartScore’s voiceline threading allows for easy 
isolating and manipulating of voices.

NOTE: SA/TB scores will have voices separated either by opposing stems or by two 
noteheads joined to a single stem. Many hymnals combine SA and TB to a single 
stem (cluster). To separate two-note clusters into separate voices, see "Voice 
Splitting (Select + “H”)", Section 4.5.2, on page 45.

The sample file, Chorale.tif, is a well-known Lutheran hymn with four voices: Soprano, 
Alto, Tenor and Bass written in two staff lines.
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a. Push the Recog button on the Navigator. Press the Add Files to List button in the 
Begin Recognition window. Select Chorale.tif from the SmartScore folder

b. Press the Begin Recognition button. Once Recognition is complete, press “Open 
SmartScore File’ and save the file.

c. Hit the spacebar to hear the playback.

Quick-select

Hold the “Ctrl” button down and in the upper staff, click on the green note in Measure 3. 
Now hit the “X” key then click to delete it. Hit the “C” key and drop the selected note into 
the lower staff line at f3.

Correct playback of pickup and closeout measures

Pickup and closeout measures are commonly found in hymns and other vocal scores. 
Notes may be correctly recognized within these incomplete (pink) measures but playback 
will hesitate because SmartScore normally locks playback to the time signature. There are 
two ways to force such measures to play unconstrained notation (free rhythm):

1.Push the Properties tool (Esc key). Click on the barline at the beginning of the 
first measure. In the Barline Properties window, change the Playback pull-down 
menu from Current time signature to As written. Repeat for Measure 5. This 
will affect only individual measures. It will not affect playback of any other mea-
sures in the piece.
2.To have the entire score ignore the default time signature, go to Playback menu 
and select “Play as written”. 

Apply different MIDI sounds to each part

Make sure you see both black and red notes. If not, push the “Voice Visibility” button 
found in the lower toolbar. 

In the upper staff, the Soprano voice is black (Voice 1) and the Alto voice is red (Voice 2). 
In the lower staff, the Baritone voice is black and Bass is red. Up to four voices are possi-
ble within each staff.

a. Hold down the Ctrl key and hit the “9” key (Cmnd + 9 for Mac). This opens the 
Playback Console. Or push the “Console” button in the Toolbar.

b. Change MIDI Instrument assignments of the two voices in the top part, PianoR 
(Track 1). Change Voice 1 (black) to Choir Aahs and Voice 2 (red) to Voice 
Oohs.

c. To hear separate voices, push the Play button, manipulate the volume sliders and 
the solo or mute buttons. Press Close to close the Playback Console.
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2.2.6 Editing Gluck 

a. Push the Recog button in the Navigator. In the Begin Recognition window 
press Add Files to List. Double-click the file Gluck.tif inside the SmartScore 
folder. 

b. Press Begin Recognition button to start the recognition process. Accept the 
post-recognition defaults. Select Open SmartScore File in the System 
Report window and Save the ENF file.

c. To listen to Gluck, simply press the spacebar. Hit the spacebar again to stop.

d. A natural sign is missing from a half-note in Measure 18. Quick-select
(Ctrl+click) on the natural sign in the right-hand piano part. Move the cursor into 
the flute part and click on the half-note to insert the natural. 

Using Properties tool to change playback characteristics

In Measure 20, the words “rit.” (ritard or ritenudo) and “poco rit.” were recognized and 
applied to gradually slow playback down for that measure. The word “poco” (a little bit) 
was also recognized, but not necessarily applied. To change playback characteristics of 
nearly any musical symbol, use the Properties tool.

a. With Properties tool active (Esc key), click on the word “rit.”. 

FIGURE 2 - 3: Ritenudo Properties window

b. Change the tempo value of the Ending of the measure by moving the slider to 
something like 70 or 80% of the current value. 

c. Push OK. The measure will slow a bit more.

d. Repeat in the bass clef, this time by clicking on the marking, “poco rit.”.

NOTE: With Properties tool active, try clicking on the “tr” and “f” signs in Measure 19 
to get a sense of how this tool can work.
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Selecting a few measures for playback

You may want to hear back only Measures 19 through 20 to test the playback settings 
which you changed using the Properties tool.

To playback a small range of measures,

a. Push the Select tool in the Toolbar or hit the “O” key on your keyboard.

b. Hold down the right mouse button (alt + click for Mac) and drag inside a 
selected range of measures. Measures will highlight blue and are staged for play-
back using Spacebar or the Play button. 

c. Press the Spacebar again to replay the selected range from the beginning. 

d. Click anywhere outside of the range of measures to deselect the range.

e. To play back a larger range of measures or to continuously loop playback, choose 
Playback > Set Play Range from the main menu. The Set Play range window 
will float and remain open until closed.

Extracting a part in Score Structure

a. Push the “Structure” button in the Navigator palette to the left of the screen. 
Score Structure is an environment that will display all open ENF files in a 
hierarchy and allow you to manipulate the arrangement and visibility of 
parts and voices. You can even move parts from one open ENF file to 

another simply by dragging the selected part to the other file.

FIGURE 2 - 4: Extracting a part in Score Structure window
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b. Click to highlight PianoR and PianoL parts then push the “Remove” button at the 
bottom of the window.

c. To create a new document containing only the flute part, select “Apply to New”.

d. A new ENF file will open displaying only the flute part.

e. Your original 3-part score will remain open and unchanged.

2.2.7 Editing Songbook

a. Select Recognition. 

a. Press the Add Files to List button in the Begin Recognition window. Select 
Songbook.tif and press Open. In the Options area, make sure the box to the 
left of Text is checked. 

b. Press the Begin Recognition button. Once Recognition is complete, accept 
“Open ENF” and save the ENF file, Songbook.enf. 

Pickup, closeout and error measures

In the Aria player, click on the lower left-hand corner of the Ensemble window and select 
SmartScore > OneVoice_Piano. This will add a vocal sound to the topmost staff line.

Hit the Spacebar and listen to the first line of music. Notice there is a delay after the first 
and last measure. The first measure with 1 1/2 beats is a “pickup” measure and the last 
with 3 beats is a “closeout” measure. SmartScore applies the default time signature to each 
measure so we need to tell it to “Play what’s written”. 

a. In the Playback menu, select “Play as Written”. Now, all measures will play 
exactly what is written and the time signature will be ignored. 

b. Go to View menu and in the “Show” submenu, uncheck “Error measures”. This 
will turn off the pink color which highlight measures having incorrect beats.

NOTE: Individual measures can be assigned to “Play as written” by clicking the barline 
preceding the measure with the Properties tool and checking “Play as written.”

Editing Lyrics

The first word in the second system lost the “W” because it was broken up.

a. In the lower toolbar, locate the “L” button (for Lyrics) and push it.

b. Click on the first eighth note in the vocal line. The lyric cursor will jump to the 
beginning of the first lyric syllable. Type the letter “W”. 

c. At the end of the same line, find the blue lyric syllable, “noats”. Click the quarter 
note above it and hit the delete key. Now type “fl” and click outside of the staff.
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d. Move to the next line down and correct the words “otr” and “tmst” in the top 
lyric line using the same method as you did before. 

e. Hit the down-arrow key to move to the next line down. Now correct the words 
“noat” and “yon”. Use the left and right-arrow key to move along the lyric line.

f. In the next measure, the word “bough” in the top line was associated with the 
wrong note. It should be attached to the half note. Use the arrow keys to position 
your cursor at the beginning of the word. Click and drag right to highlight the 
word “bough” and with the Ctrl key down, hit the “X” key to cut it to clipboard.

g. Click on the half note to the left and when the cursor drops down, hold the Ctrl 
button down and hit the “V” key. The word “bough” will be pasted into position.

h. Click out of the staff line. Press the “L” button in the toolbar to exit Lyric mode. 
Restore error measures by going to View > Show and checking “Error mea-
sures”. Restore normal playback by going to the Playback menu and click on 
“Play as written” to turn it off. Most settings in SmartScore remain on until 
turned off.

NOTE: You may want to experiment with changing the Andante tempo marking. Hit the 
Esc key (Properties tool), click on the marking and adjust BPM value.

2.2.8 Editing Guitar

SmartScore includes some very useful and powerful features for solo guitar music includ-
ing recognition and editing of tablatures. 

a. Push the Recognition button. In the Begin Recognition window, push Add FIles 
to List. Double click on the file, GUITAR.TIF in the SmartScore folder to add 
the file to the list of recognized pages. 

NOTE: Solo guitar and violin music often contain fingering numbers. You may want to 
prevent SmartScore from interpreting fingerings as tuplets. To ignore tuplets, 
uncheck Tuplets in the Recognition Options area. Press Begin Recognition.

Adjust default tempo

The original tempo is marked “Poco allegro”. SmartScore recognized the word, “Allegro” 
which has a default tempo of 150 bpm. It’s too fast.
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a. Push the Properties tool and click on the mark, Allegro in Measure. Move the 
slider to change the speed to something slower.

NOTE: With “Apply this tempo to all similar marks” checked, all existing marks 
of Allegro will become updated to the new tempo after you push OK. 

Editing three or more voices

Solo classical guitar and solo violin scores are unique in the world of published music. In 
most music, usually no more than two voicelines are present; each being distinguished by 
notes having opposite stem directions. 

b. Save the file with the default name given.

c. Notice measures have notes in three colors, including green. The green notes rep-
resent the third or tertiary voice. Push spacebar to Play. Hit spacebar again to 
Stop.

Controlling part names

The part name (Nylon Guitar) overlaps the first measure. To turn off part names, go to 
View > Show > Part Names submenu. Check “Don’t Show”.

Assigning different instruments to voices

d. Open the Playback Console (Ctrl + 9 / Cmnd+ 9). Click into Instrument selec-
tion for Voice 2. In the Instrument pull-down menu, change Nylon String Guitar 
to Tango Accordion.

e. Change Voice 3 to Acoustic Bass or some other instrument.

f. Push the spacebar and listen to how contrapuntal voices become more distinct 
when they are assigned to different instrument sounds. 

Converting notation to guitar TAB

a. Select Properties tool from the Toolbar.

b. Click on the yellow triangle to the left of any staff line.

c. In the Staff Properties window, click in the “Apply Staff Type” checkbox. Select 
“6-string guitar TAB” from the pull down menu.

SmartScore also recognizes TAB-formatted scores. For more details, refer to Section 
3.5.1, "Recognition Options" "Recognize Tablature, Percussion and Split Systems 
(Codas)".
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2.2.9 Macintosh / Windows shortcut conventions

Most SmartScore keyboard shortcuts are identical on both Windows and Macintosh com-
puters. For Macs with a single mouse button, the right-click function is performed version 
by holding down the “alt” (Option) key and clicking the mouse.
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3) Scanning and Recognition

3.1 Preparing to Scan Music
To scan right away, locate the SCAN button in the toolbar or Navigator and push it.

If your scanner responds well to the SCAN command, you can jump to Section 3.5, "Rec-
ognition Sequence" on page 24. To learn more about scanning options in SmartScore, turn 
to Section 3.2, "Scanning in Macintosh®" on page 19.

If you are scanning with a Mac running Snow Leopard (OS 10.4) or later and your scanner 
fails to respond to the SCAN command, jump to Section 3.2, "Scanning in Macintosh®" 
on page 19.

Scanning in SmartScore on Mac computers is not quite as straightforward as Windows. 
Mac users, jump to "Scanning in Macintosh®", Section 3.2, on page 19.

3.1.1 Scanner Drivers

SmartScore uses “3rd-party drivers” for scanner control. These drivers are installed from 
the CDs packaged with your scanner. Windows drivers are usually WIA or TWAIN. If 
you encounter problems when attempting to scan, locate your scanner manufacturers’ 
website, download and install the most recent scanner driver before calling Musitek Tech-
nical Support.

NOTE: Some users may have to select “Custom” from their scanner installers. 

3.1.2 Selecting your scanner driver in SmartScore (Windows only)

a. Go to File > Scan Music > Select Scanner. Click on the driver name that corre-
sponds to your scanner.

FIGURE 3 - 1: File > Scan Music > Select Scanner

Start Scan (Toolbar) Start Scan (Navigator)
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Windows Users: Select the “WIA xxx” driver associated with your scanner / all-in-one 
device. If your scanner fails to respond to the SCAN command, try the TWAIN driver that 
corresponds to your scanner if one is listed.

3.1.3 Choosing a scanner

All scanners are not created equal. Most will work well with SmartScore; some better than 
others. For an updated list of recommended scanners, visit:
http://www.musitek.com/bundle.html

We’ve produced some helpful videos on scanning in SmartScore along with other topics. 
Visit our video page at:
www.musitek.com/videos.html 

To read more about scanning, scanning issues and work-arounds, go online to:
www.musitek.com/scanningnotes.html
or see “Scanning Issues” at www.musitek.com/faqs.html

3.2 Scanning in Macintosh®

Macs running Apple OS 10.6 (Snow Leopard) or later have scanner drivers imbedded in 
the operating system. This limits third-party scanning to those devices selected by Apple. 

If your scanner does not respond to the “Scan” command, scanning will have to be done 
outside of SmartScore. 

3.2.1 Scanning Outside of SmartScore

If your scanner does not respond properly in SmartScore’s scanning interface or if you 
cannot prevent your scanner from creating dithered/half-toned images, you will be a able 
to create usable images with the scanning software that came with your scanner. Returning 
to SmartScore, you will be able to Recognize these saved images.

a. Check that your scanner is on and connected to your computer.

b. Go to File > Scan Music > Choose Interface > Your Scanner’s. When you 
push the Scan button, your scanner’s software may open up. If not, launch the 
scanning software application that came with your scanner.:

• Place your music in the scanner as squarely as possible

NOTE: Some scanners, especially lower-cost all-in-one devices have limited settings. If 
you are unable to locate specific settings described below, choose Text or Docu-
ments. Normally, you will not select “Photos”, “Illustrations” or “Color”.

• Look for Scan type or Output option. Set scanning to Grey (Greyscale). 
• Set Brightness to -20 to -35% for average printed music.
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• Set Resolution to 300-400 dpi for average printed music.
• Scan between 300-400 dpi (for average-sized printed music). Scan at higher resolu-

tions for music printed in smaller-than-average print size. Do not exceed 600 dpi.
• In the preview pane, crop around but not into the area containing the music.
• Scan and save multiple-page scores as a PDF file. 
• Scan and save single pages as uncompressed TIFF files. Give a unique filename for 

each page... e.g. Page1.tif, Page2.tif, etc.

TIP:Optimum resolution is achieved when the distance between staff lines is about 20 
pixels. In SmartScore’s Image Editor, zoom into the image. Referring to the 
mouse position readout in the status bar, measure the distance between two lines 
in a stave (measure white space only).

3.2.2 Scanning Orchestral Scores

There are several methods that may be used to scan in oversized orchestral scores. Refer 
online to:
“My orchestral score is bigger and wider than my scanner.” found in the Support > FAQ 
section at www.musitek.com

3.3 Using the SmartScore Scanning Interface

a. Go to File > Scan Music > Choose Interface = SmartScore’s. This will ensure 
that SmartScore’s scanning environment is activated.

b. Push the Scan button found in the Navigator and in the Toolbar or choose File > 
Scan Music > Acquire.

When you start scanning, a low-resolution pre-scan will appear in the Preview window. If 
your scanner does not respond properly inside SmartScore’s scanning interface, select File 
> Scan Music > Choose Interface = Your scanner’s and try again. If your scanner still 
fails to respond correctly, turn to “Scanning Outside of SmartScore” on page 19.

3.3.1 Enhanced scanning functions

• Auto Cropping

If your music extends to the edge of the preview window, uncheck “Cropping” and push 
“Prescan” to scan again. This will allow for maximum scanning coverage. If cropping is 
checked, a bounding box will limit the scanning region. If you scan with cropping on, 
make sure about a 1/4” of clear white space is left on all sides of the music inside the pre-
view image.
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• Auto Deskew

If the preview appears slightly crooked, push the “Deskew” button to correct. If the pre-
view is very crooked or if some music is cut off, reposition the music in the scanner and 
scan again.

• Auto Resolution

This feature takes the guesswork out of choosing the correct resolution (dpi) setting for 
each scan. When selected, the image is analyzed and sized in order to obtain an optimum 
image resolution, thus achieving the highest possible recognition accuracy. Use this when-
ever possible.

If the preview image appears with white notes on black background, you will be able to 
invert image in the Image Editor (see Section 3.9, "Image Editor" on page 34).

NOTE: Selecting Next Page immediately activates your scanner. Before selecting it, 
position your next page onto the scanner and wait until the scanner bar resets. If 
you push too soon, you may get an error message that “Scanner is not ready.”

c. Push Next Page and continue to preview, deskew and scan until you have fin-
ished scanning your entire song, project, section or movement. Select Finish
when done.

NOTE: If the piece you are processing exceeds 10-15 pages, divide it into smaller, dis-
crete sections, e.g. Intro, Part1, Part2, etc.

3.3.2 Scanner settings

The following section lists image-enhancement and scanner settings which you can con-
trol within the SmartScore scanning interface.

• Brightness

The default brightness setting is -35%. For typical printed music, this setting should be 
fine. If beams smear together and whole and half notes appear closed or “blobbed”, then 
brighten the scan. If the original music is faded, if it is a weak copy you may want to scan 
even darker than the default setting. SmartScore wants to see solid, well-defined lines that 
are neither razor-thin nor smeared together. 

• Resolution 

It is recommended that you use Auto-Resolution whenever possible. 

NOTE: When scanning music with staves having different widths (e.g. containing both 
standard notation and TAB staves or smaller “cue” staff above a piano accompa-
niment) or if you continuously receive error messages suggesting alternative res-
olutions, turn Auto-resolution OFF and re-scan at 300 dpi.
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If you choose to set resolution manually, turn Auto-Resolution off. For most printed 
music, the recommended resolution is between 300 and 400 dpi. If the original music is 
printed in smaller type, you can increase resolution to 400 or 500 dpi. For miniature 
scores, try 600 dpi. SmartScore works best with an optimum resolution. Scanning at too 
high or too low a resolution will actually reduce recognition accuracy. It is not recom-
mended to scan music below 250 dpi or higher than 600 dpi.

3.3.3 Choosing an alternative scanning interface

If your scanner fails to respond properly to the Scan command in the SmartScore interface 
or your scanned image is unacceptable (partially scanned, distorted, etc.) your alternative 
is to scan using the software provided with your scanner. See Section 3.2.1, "Scanning 
Outside of SmartScore" on page 19 for details.

3.4 Processing PDF files for Recognition

SmartScore will recognize nearly all PDF music files. Before being processed, PDFs are 
converted to the TIF file format and saved to the default directory. PDF files must be prop-
erly pre-scanned to achieve good results. For PDF scanning requirements and procedures, 
see Section 3.2.1, "Scanning Outside of SmartScore".

To recognize PDF images of printed music,

a. Push the Open File button and select “Image” type. Or push one of the Recogni-
tion buttons in the Toolbar or Navigator. The Recognize function is also found 
under the File menu.

b. After the image is converted from PDF to .TIF, it will open in SmartScore’s 
Image Editor where you can set grayscale threshold levels as well as delete non-
notation pages such as the title page and front matter. While this step is recom-
mended, it can be skipped each time or bypassed permanently.
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c. A file-selection window Begin Recognition will open. This is where you list 
your pre-scanned files for recognition by selecting them, rearranging them, 
removing or reordering them.

FIGURE 3 - 2: Recognition - Selected Files / Options / Preview

d. In the Begin Recognition window, push Add Files to List.

e. Browse to where your images are stored. Click on an image file to select. If more 
than one page was scanned in the SmartScore scanning interface, the file will 
appear as a multi-page list.

NOTE: You may click on and drag image icon(s) to the selected files list of the Begin 
Recognition window. Some older Windows operating systems may not support 
drag-and-drop.

f. Preview pages prior to recognition to check that pages were scanned completely 
and that no page is severely skewed. Any of these issues will affect recognition 
results. Select the Preview tab and click on each page to view your pre-scanned 
pages. 

g. Refer to “Recognition Options” on page 25 for details on how recognition 
options operate.

3.4.1 Reordering the File List

Notice that one file may contain many pages. If you happened to have scanned a page out 
of sequence or if you notice pages out of order (e.g. “Page10” is listed before “Page2”). To 
reorder the list of pages to be recognized, click on any page and hit Move Up or Move 
Down. It will be repositioned. Hitting Remove Files from List will cause that page to be 
taken off the list and will not be recognized.
Using to SmartScore X2 23



3.4.2 Removing, replacing and re-saving scanned pages

If one page of a scanned group is incorrectly scanned or is missing altogether from a 
multi-page image file (Page group), you may reselect individual pages to form a new page 
group.

a. Select (or drag) the original multi-page file inside the selected files list of the 
Begin Recognition window.

b. Highlight a page to remove and push Remove Files from List. 

c. To add a replacement or additional page to the original page group, select or drag 
the page(s) to the selected files list. 

d. Reorder pages as necessary. 

NOTE: If pages were reordered, added to or deleted from the original image file, you will 
be able to re-save the newly listed pages.

To Save a modified list of grouped pages as a new image file,
• Select all pages so they are highlighted and push Save As.
• Select the existing name to over-write or type in a new name.

3.5 Recognition Sequence

When scanning pages is done, choose Save As and Begin Recognition to initiate recogni-
tion. Or you can choose Open Pages in Image Editor to view scanned pages and make 
alterations to the scanned image (e.g. cropping, deskewing, line drawing, cutting and past-
ing). Pushing Cancel before recognition is complete will exit the process and return you 
to the main window.

NOTE: Turn to “Image Editor” on page 34 to learn about editing scanned images (Open 
Pages in Image Editor). 

To save your scanned image file and begin recognition sequence, 

a. Push the Save As and Begin Recognition button.

b. Browse to a location for saving your SmartScore ENF files. You may wish to add 
a unique directory at this time.

c. Give the image file a name. If you are using Windows, the extension “.TIF” will 
be added automatically.

d. Push OK to begin the recognition process.
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The image file you have just saved contains all pages you scanned. The default file type is 
“Compressed TIFF” (CCITT Type 4), a multi-page, single-file highly-compressed TIFF 
file format. It will be approximately 10 times smaller than an uncompressed TIFF image 
file. 

NOTE: If you are going to open the scanned image in Adobe Photoshop®, you may want 
to save in the larger, uncompressed TIFF format; Photoshop does not currently 
support CCITT Type 4 files.

TIP:When you Save a file to a specific location, SmartScore will continue to save to 
that directory until you change it. The same is true when you Open a file. 
Remember that SmartScore may look in one directory when opening a file and 
then go to a different one when saving a file. Once changed, the new file path 
becomes the default.

3.5.1 Recognition Options

The following section describes options you can choose for recognition. When satisfied 
with your choices, push Begin Recognition. 

FIGURE 3 - 3: Recognition - Options

NOTE: If Recognition fails, refer to “Troubleshooting Scanning and Recognition” on 
page 31.

• Text 

Check this box if you wish to recognize lyrics and text in the music. 

TIP:If you are scanning in single-line parts for the purpose of joining them into a con-
ductor’s score, it is recommended not to recognize text. Otherwise, text from 
every score-part will be overlaid on the pages of the conductor’s score.
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• Recognize Lyrics Outside of Systems

Check this box if you are recognizing a score which has one or more lines of lyr-
ics written under the last staff line of each system or if it is a single-line score 
with lyrics underneath the staff. Otherwise, leave unchecked. 

• Suppress Chord Symbols

When checked, chord symbols and guitar fret diagrams will be ignored. Even if 
recognized, chord symbols and guitar fret diagrams can still be turned off later. 
Check only if you are sure you never want chord symbols to appear in your 
score.

• Suppress Lyrics

Check this box if you are recognizing a score which has one or more lines of lyr-
ics written under the last staff line of each system or if it is a single-line score 
with lyrics underneath the staff. Otherwise, leave unchecked. 

• Tuplets

Keep this box checked, unless you experience many false positive recognition of tuplets.
• Limit to Triplets

When checked, SmartScore will ignore non-triplet tuplets (duples, quintuplets, 
sextuplets, etc.). 

• Pedals

If pedal markings are written into the music, check this box.

• Bowings

If up/down bowing marks are written into the music, check this box.

• Hymnal Fonts

If you are scanning in music from a hymnal (with stubby flags and short stems), check this 
box. NOTE: “Shaped notes” do not apply.

• Ossias

Select if your score has one or more ossias (line above a staff suggesting an alternative 
passage) that you wish to have recognized.

• Recognize Tablature, Percussion and Split Systems (Codas)

Select to recognize TAB (guitar) notation or percussion staves having other than 5 lines 
per staff.
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NOTE: If your music includes a part with 4 lines, it will be recognized as 4-string TAB 
by default. If the 4-line staff is in fact a percussion part, check “Convert 4-line 
parts to percussion.”

• If the original score contains a coda system break, it’s important to indicate that prior 
to recognition. SmartScore will recognize split systems if Recognize tablature, per-
cussion and split systems is checked. 

• Join Offset Voices (“Y”)

Two notes belonging to opposite voices are often offset even though they’re meant to 
sound at the same time. By default, noteheads of different (colored) voices having no 
more than 1/8th of a notehead’s space between them will share the same “time event” and 
will sound simultaneously after recognition and appear in different colors.
• If your music has offset noteheads which are meant to sound simultaneously but gen-

erally exceed 1/8-width of a notehead, choose a greater distance. The amount of white 
space between note heads determines this distance.

• If your music has dense polyphonic texture, like that found in solo guitar music or 
tightly-spaced orchestral passages, it may be necessary to “tighten up” the allowable 
distance between offset voices. In these cases, choose a distance of less than 1/4 of a 
notehead.

• Setting “Join Offset Voices” to “Exactly aligned” will join only those voices with note-
heads that are exactly vertically aligned.

For editing details on joining / un-joining offset voices, see Section 4.5.5, "Correcting Ver-
tical Alignment" on page 47). 

• Part linking (Ctrl + “L”)

When a score is “optimized”, parts (i.e. stafflines) will appear only when they are meant to 
be played. Otherwise, the parts remain invisible. Optimized systems can be referred to as 
either “collapsed” or “expanded”. Usually, parts are added to the top of a system, e.g. after 
a piano introduction, the vocal line will appear above the piano part. This “top-down” 
arrangement is the default. However, some scores may have parts are added to systems in 
a “bottom-up” fashion, e.g. existing staves are bumped upwards. If your score is struc-
tured in this way, change default to “Add Parts to Bottom”. Orchestral scores, being 
grouped by instruments, may have no pattern. For more information on part linking and 
maintaining playback continuity, see "Part Linking (Ctrl+L)", Section 7.7.7, on page 143

• Fretboard Strings

The default fretboard for recognition is the six-string guitar. If your music has ukulele fret-
boards (4 strings) or some other configuration, change the selection to the correct number 
of strings.
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3.5.2 Post-Recognition

Scanned pages will be saved as a .TIF file prior to recognition. When recognition is com-
plete, a System Report will list the number of parts found in the largest and smallest sys-
tems. If any of these do not agree with the original music, investigate the cause before 
spending a lot of time editing the score... it could be difficult to restructure your score later 
on.  

FIGURE 3 - 4: Post-recognition System Report

• Normally, you will select Open SmartScore file. You can accept or change the name 
and the destination directory. Press Save to save and open the file.

• If you selected Open Super System, you will be able to view a list of the largest sys-
tem. You can locate and edit any system that contains an incorrect number of parts. See 
for more details.

• If you selected Open Image Editor, the scanned image will open in the Image Editor 
where you can correct certain flaws in the scanned image. See Section 3.9, "Image 
Editor" on page 34 for more details.

A checkbox allows you to skip viewing the System Report in the future. To reset this 
option, go to Edit > Program Preferences > User Interface > Recognition. 

Another window will prompt you to Unify Key and Time signatures. Refer to  for more 
details.

3.6 Scanning Part Scores (Score-Parts)

SmartScore allows you to process and combine scanned pages of solo parts, 
duets, trios or quartets and play them back simultaneously. They may also be 
recombined into a conductor’s score.
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TIP:If you are scanning in Score-parts for the purpose of joining solo parts into a con-
ductor’s score, it is recommended not to recognize text. 

To scan and combine Score-parts into one ENF file,

a. Scan in all pages for each part. For easiest identification, give a unique name or 
number for pages belonging to one part, e.g. Flute_Pg1, Flute_Pg2 and 
Guitar_Pg1, Guitar_Pg2, etc.

b. In the Begin Recognition window, arrange files in order of parts then pages: e.g. 
Part1/Page1, Part1/Page2, etc.

FIGURE 3 - 5: Grouping pages to Score-Parts

c. Highlight the first set of pages that make up the first Score-Part.

d. Push Group to Score-Part. In the Part Name window, give the selected pages 
belonging to a score-part a unique name.

e. When all pages are properly grouped to score-parts, push the Begin Recognition
button.

SmartScore will internally organize score-parts following recognition. The ENF window 
will display pages for the first part followed by pages of the next part. Parts will play back 
simultaneously. 

3.7 Recognition Accuracy

If recognition accuracy is not as good as what you expected, examine the image up close 
by zooming into the image pane of your ENF view. You may also view your scanned 
pages in SmartScore’s Image Editor (FIle > Open > Image file type).

Determine the following by examining your image file close up:
• If large black areas are pitted with holes (stippled) instead of being solid black, your 

scan is probably half-toned / dithered and will not recognize well. If you are unsure, 
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send the .TIF file to tech@musitek.com. We will confirm whether or not it is half-
toned. If you were scanning from inside SmartScore’s scanning interface, scan instead 
using your scanner’s software observing the guidelines found here: “Scanning Outside 
of SmartScore” on page 19. For more information on half-toning, refer online to 
“Dithering” in the FAQ section at www.musitek.com under the Support tab.

• If objects such as note stems and staff lines are broken or thin or if objects appear weak 
and lack clarity, re-scan with -30% to -40% decreased brightness to fill in gaps. 

• If edges of objects are “stair-stepped” or ragged, it may mean, re-scan with the Auto-
Resolution setting checked (On) or increase scanning resolution manually. Optimum 
distance between horizontal stafflines is 20 pixels. You may use the cursor and readout 
in the Status Bar (pixel coordinates) to measure exact width of a typical staff line.

• If the source document is poorly printed or is faded and weak, try locating a better 
print copy of the music.

NOTE: Other scan problems such as crooked or offset pages can be corrected in Smart-
Score’s Image Editor. See "Image Editing Tools", Section 3.9.2, on page 34.

Following recognition, guitar chord fret symbols may sometimes overlay chord 
names recognized as text: Raw or “dumb” text chord names will not transpose. 
To remove “dumb” text fields, use Nudge mode (Shift) and drag the control han-
dles of each text field upwards. Use the Select tool and “group delete” all 
selected text fields.

Recognition accuracy is directly related to the quality of the source document as well as 
the quality of the scanned image. Very cheap scanners may always produce poor or half-
toned images. Remember the saying: “Garbage in / Garbage out”. If after examining the 
image and consulting the Troubleshooting chart, you are still unable to achieve good rec-
ognition results, we invite you to send us your TIFF file(s) for detailed analysis by our 
technicians. 

You can attach your image (TIFF) files to e-mail along with a short description of the 
problem you experienced to the following address: tech@musitek.com. We will reply as 
soon as possible. Most likely, we will be able to locate the problem and offer a solution or 
recommendation.
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3.8 Troubleshooting Scanning and Recognition

Table 1: Scanning and Recognition Troubleshooting

Problem Probable Cause Fix

Scanner does not operate. Scanner drivers not 
installed. (Win only)

Install WIA or TWAIN 
software from scanner 
manufacturer’s site.

Scanner not selected. 
(Win only)

Ensure proper scanner 
driver is selected (File 
> Scan Music > 
Choose Scanner).

Scanner driver is 
incompatible with 
computer operating 
system. (Mac)

Scan outside of Smart-
Score. See “Scanning 
Outside of Smart-
Score” on page 19.

Scanner not connected 
or not turned on.

Check cabling and 
power. Use scan test 
program if available.

“This page should be 
scanned at xxx dpi. Re-
scan or Accept.

Staff widths not con-
sistent. Music contains 
cue, TAB or percussion 
staves.

Re-scan in Smart-
Score’s scanning inter-
face with Auto 
Resolution = off. 

Scanner model used 
does not support infi-
nitely variable DPI 
(only scans in large 
increments).

Re-scan with Auto 
Resolution = off. Man-
ually set resolution 
acceptable to scanner 
(300 to 600 dpi).

Printed area containing 
music is too wide or too 
long to scan on a standard 
sized scanner.

Actual image size of 
the music is what 
counts, not the size of 
the paper or page.

Refer to “Scanning 
Issues” section of 
www.musitek.com/
faqs.html for work-
around.

Reduce original size 
using photocopier.
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“Recognition failed for 
this page.”

Scanner set to screen 
resolution of 72 dpi.

Scan again accepting 
Auto-resolution set-
tings for best results.

Resolution of scanner 
set too low.

Manually set resolu-
tion to 300-600 dpi. 
Scan again.

Page was scanned with 
too light a setting. 

Re-scan with -30% to 
-35% brightness.

Scanner was forced to 
create a black & white 
image with “dither-
ing”.

Re-scan in Your Scan-
ner’s interface: 
Greyscale / 350 dpi.

Music not fully 
scanned or is severely 
skewed.

Re-scan making sure 
all the music is 
selected. Scan music 
straight or use 
“Deskew” function.

Image too large for 
selected resolution.

Re-scan ensuring Auto 
Resolution = On.

Accept setting. If rec-
ognition is poor, re-
scan with Auto-Reso-
lution off. Reset to 350 
dpi.

Scanner hangs or crashes. Driver conflict. Ensure latest scanner 
drivers are installed.

Scan outside of Smart-
Score using software 
that came with your 
scanner.

Table 1: Scanning and Recognition Troubleshooting

Problem Probable Cause Fix
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Poor recognition results. One or more scanning 
issues creating less-
than-optimum image 
quality.

Refer to "Recognition 
Accuracy", 
Section 3.7, on page 29

Missing barlines due to 
light obscuring right 
margin or to right mar-
gin having been cut off 
during scanning.

Open image file in 
Image Editor. Use 
Select Tool to delete 
obscured regions and 
the Line Draw tool to 
restore barlines on 
right side of systems.

Image too small for 
selected resolution.

Scan again accepting 
Auto-resolution set-
tings for best results.

Note stems “razor 
thin” due to laser print 
output.

Open .tif image in 
Image Editor and apply 
darker thresholding.

Handwritten or non-
standard notation. Poor 
print.

Scan well-printed, 
standard-sized sheet 
music.

Poorly printed music. Decrease brightness 
level. Find better origi-
nal.

Image not straight 
(skewed).

Open file in Image 
Editor (File > Open > 
Image). Use Deskew 
tool to straighten each 
page.

Stafflines and note 
stems of canned file 
are broken or too thin.

Re-scan page(s) with 
decreased brightness 
setting.

Table 1: Scanning and Recognition Troubleshooting

Problem Probable Cause Fix
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3.9 Image Editor

3.9.1 Opening files in the Image Editor

Following the final scan of music pages, you can choose to “Open Image Editor”. This 
choice will stop the recognition process and open the scanned pages in the Image Editor. 
At any time, you can open and edit an existing image file with the “Open” command.

The Image Editor allows you to manually draw in missing system brackets and/or barlines 
prior to recognition. You can erase or add details as well as being able to delete large areas 
of unwanted material from the image.

After touching up scanned pages, recognition can be launched directly from the 
Image Editor by pushing the “Recognition” button in the Toolbar. Launching rec-
ognition will ask you to first save the image with a new name.

• Loading a prescanned image file

To open an image file you have previously scanned, 

a. Press the Open button on the Navigator or choose Open (Ctrl + O) (Cmnd + O 
for Mac) from the File menu.

b. Change Files of Type pull-down menu to Image Files.

c. Browse and highlight an image file from the listed saved files. Press Open.

3.9.2 Image Editing Tools

• Image Information

Select View > Image Information to display characteristics about the current scanned 
image including resolution, file type and page size.

• Zoom

To Zoom in and out click the Zoom Tool in the Toolbar (Ctrl + Q). Click inside 
the image will increase the scale of your view (Zoom In), while right-click (alt / 
option + click for Mac) will decrease the scale of your view (Zoom Out).

• Page

To view pages of an image file, use the paging buttons in the Toolbar or select 
Next Page/ Previous Page from the View menu.
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• Image Toolbar

FIGURE 3 - 6: Image Editor Toolbar

3.9.3 Page Tools

• Select

Used for selecting a region for cropping, deleting, cutting or copying.

• Crop

To crop an image file (trimming unwanted portions of your image from outside a marked 
frame), 

a. Press the Select button in the Image Toolbar. 

b. With your mouse, drag a box around the area you wish to keep. If you want to 
extend the cropping region outside of the display, keep dragging; the page will 
scroll as you drag up or down.

c. To adjust the marked bounded area, move your cursor over a boundary line, click 
and drag the boundary to a new position.

d. Select Crop from the Edit menu OR press the Crop button in the Image Toolbar. 
The resulting image will be reduced to the area inside the bounded frame. 
Remember to Save when done.

• Correcting Skew

Page through each scanned image and check for relative straightness of each image page. 
If a page appears tilted or skewed, recognition accuracy will be compromised. The 
Deskew tool rotates the image slightly to correct skewed pages and will optimize recogni-
tion accuracy.

a. Press the Deskew button in the Image Toolbar or select Deskew from the Edit
menu. 

b. Position the cursor over a staff line. Starting from the left side, click and drag the 
mouse along the length of the staff line. A red “skew angle” line will display as 
you drag the mouse. When you are certain the red “skew angle” line parallels the 
staff line, let go. The page will automatically straighten. Repeat for each page. 
Remember to Save when done.

Crop 

Invert RotateL 

RotateR 

Freehand

Line Select 

Deskew 

Color

Thickness 

Delete

Threshold 
Page
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NOTE: If the page becomes incorrectly rotated, undo with Ctrl + z / Cmnd + z for Mac
(or select Edit > Undo).

• Invert

If the image you open in SmartScore is white-on-black (instead of the normal black-on-
white), then you should reverse the image output in your scanning software. SmartScore 
defaults to 0=white polarity. 

If your scanned image appears white on black, choose Edit > Invert or choose the Invert 
button from the Toolbar.

• Delete Page

If there is more than one scanned page in the image file, the Delete Page function is 
active. Use it to remove poorly scanned or duplicated pages. To re-scan and restore 
deleted pages, see Section 3.4.2, "Removing, replacing and re-saving scanned pages" on 
page 24.

• Freehand Draw (Brush)

To draw free hand lines in your image file, select Brush from the Edit menu OR press the 
Brush button in the Image Toolbar. Choose a line width then click and drag to paint.

• Line Draw

Some printed scores have weak or missing stafflines and/or brackets that can create prob-
lems during recognition and may result in missing or incorrectly bracketed systems. 
Sometimes, by accident, brackets and/or barlines are cut off during scanning. If this is the 
case, you can manually draw in staff line and brackets or enhance their thicknesses. 

To restore cut-off or missing system brackets,

a. Select Edit > Line or choose Line Draw in the Image Toolbar. 

b. Push the Pen Color push button in the Image Toolbar, if necessary, to choose 
Black Color. 

c. In the Width pull-down selector, choose a fairly wide thickness (10-20 pixels).
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d. Click and drag the mouse to draw a line along the missing or broken bracket 
along the left margin of the music.

FIGURE 3 - 7: Using Line Draw tool to restore missing bracket

e. When finished modifying the image. Select File > Save As and give it a name. 
You may then Recognize the file with corrections.

• Line / Brush Thickness

To change the width of brush or line tool, select a new size from the Width menu in the 
Image Toolbar. Select from 1 to 50 pixels.

• Black / White Color toggle (Eraser)

Push the “Eraser” button to activate white color. Push again to deactivate it for black color. 
Or choose Pen Color > Black or White from the Edit menu. 

• Rotate Left / Rotate Right

 To rotate an image file (for landscape formatted scores or upside down scans), go to the 
Edit menu and highlight Rotate OR press one of the Rotate buttons in the Image Toolbar.
• Rotate the image Left (90 degree rotation).
• Rotate the image Right (90 degree rotation).
• Select Edit > Rotate > Any to rotate at angles other than 90 degrees.

• Thresholding
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If note stems and/or staff lines are “razor thin”, recognition will be improved by darkening 
the image. Use this feature to manually convert grey images to black & white using a vari-
able threshold (75% lighter to 75% darker). Many PDF music files and sheets output from 
laser printers have thin lines (1 pixel wide.) Move the threshold slider far to the right in 
cases of “razor thin” lines.

• Begin Recognition

After modifying the image, you can save and begin recognition of it by pushing 
the “Begin recognition” button in the Toolbar.

3.9.4 Cut / Copy and Paste functions

• Cut (Edit > Cut)

To cut an area from the scanned image, hit Delete button. Or use the Select tool and drag a 
box. Cut with Ctrl + “X”. 

• Copy

To copy an area without removing it from the image, use the Select tool and drag a box 
with the mouse. Select Edit > Copy (Ctrl + C (Win) / Cmnd + C (Mac)). 

• Paste

To Paste the cut or copied region into an image file, select Edit > Paste (Ctrl + V / Cmnd 
+ V (Mac)). The cut or copied section will drop into the image. With the mouse, drag the 
fragment anywhere within the image and release the left mouse button. To fix the frag-
ment in place, click outside the pasted fragment.
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4) Playback

4.1 Working with the Aria Player and Garritan sounds

SmartScore X2 is configured to automatically open both the Playback Console and the 
Aria Player when a new file is opened or recognized. 

FIGURE 4 - 1: Aria player with SmartScore Playback Console

To load preset instruments for playback,

a. In the Aria player, select one of several instrument presets by clicking into the 
lower left corner of the “Ensemble” window. 

b. Click on “SmartScore” and select “All_Piano”. All channels will play a Grand 
Piano sound. Other combinations can be selected from “SmartScore” preset list.

To load individual instruments, 

a. Click on any of the 16 instrument/channel slots in the Aria player. 

b. Select an instrument from one of seven instrument groups under “SmartScore”.

IMPORTANT: The Aria player will play only those channels that are displayed in the 
channel list of SmartScore's Playback Console.
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Use the transport controls in the Playback Console or Mini Console to control playback. 
The spacebar can be used to start and stop playback, but not when the focus is on the Aria 
player. To activate spacebar for playback, click outside of the Aria player window.

Volume, Pan, Mute, Solo and Transpose pitch controls are all active in Playback Console.

If a part is not playing back or is playing the wrong sound, make sure you have the right 
instrument correctly assigned to each instrument/channel slot. Remember that only those 
channels listed in SmartScore’s Playback Console will sound in the Aria player. 

NOTE: Instrument names in the Playback Console are not active when using the Aria 
Player. Only those instruments loaded in the Aria player are activated.

4.1.1 Notes on working with the Aria player

• Manipulating playback windows

Both the Aria and Playback Console windows are “floating” and can be easily moved out 
of the way when editing the ENF notation file. When either window is closed, current 
instrument settings are saved. In order to reassign instruments, playback windows will 
need to be reopened.

To reopen Playback Console, push the “Console” button in the lower toolbar.

To reopen Aria player, push the VST or AU button in the lower toolbar.

To exit Aria player and revert to General MIDI Instrument playback, select General 
MIDI or MIDI Mapper from "MIDI Devices" under the Playback menu. This will enable 
you to insert multiple instrument changes. For details, see "Changing instrument sounds 
on the fly", Section 4.5.4, on page 47. 

The Aria player is loaded with useful features including effects and the ability to add more 
Garritan sounds. The Aria user manual can be found under the HELP menu > SmartScore 
manual (PDF) > Aria Player for SmartScore X2.

• Burning Audio to DVD with the Aria player

We recommended using Aria for playback whenever you save to an audio file or burn 
playback audio to DVD.

For information on saving to audio files or burning audio to DVD, refer to Chap-
ter "Recording to Audio (Save as file / Burn to CD)", Section 10.14, on page 212.
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4.2 Quick Playback Tricks

a. Press the spacebar to start playback. Press spacebar again to pause. Press again to 
resume play. Press the comma key (“,”) to rewind to start point.

b. You can change the instrument sound of a part anywhere within the piece. Press 
the “Program Change” button in the ENF toobar and position the down arrow of 
your mouse on the measure and beat of the staff for which you wish to change 
instruments. Left-click and select a new instrument sound. For details, see 
"Changing instrument sounds on the fly", Section 4.5.4, on page 47. 

NOTE: Instrument change is only functional when General MIDI is selected under the 
Playback > MIDI Device menu. Aria player does not support instrument change.

c. The Mini-Console transport controls Play, Rewind and Stop.The “spring-loaded” 
slider will accelerate or decelerate playback depending on how far the slider is 
dragged. The slider will snap back to the default tempo once it is released.

FIGURE 4 - 1: Mini-Console

4.2.1 Playing back a selected section

The quickest way to play back a snippet of the score is to use the “Select” tool 
and drag the mouse over a region of the page while holding down the right
mouse button (Alt + click for Mac). Measures selected for playback will high-
light light blue. Hit Space bar to play.

FIGURE 4 - 2: Selecting measures for limited playback
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For playing larger sections and for looping, go to Playback menu > Set Play Range.

FIGURE 4 - 3: Set Playback Range

d. In the From field, choose a starting measure. Then select an end point in the To
pull-down box. 

e. To repeat playback over the range, check the Loop box.

4.3 Playback Console

The Playback Console is opened from a button in the Toolbar, by holding down Ctrl + 9 
(Win) / Cmnd + 9 (Mac) or by selecting Playback console. from the Playback menu.T

FIGURE 4 - 4: Playback Console

NOTE: Channel numbers, tempo, volume, pan, mute, solo and transpose pitch controls in 
the Playback Console all function normally when the Aria player is activated or 
when General MIDI playback is activated.
Instrument assignments in the Playback Console are ignored whenever the Aria 
player is activated. Instruments assigned in the Aria player will respond only in 
channels that correspond to those in the Playback Console. 
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4.3.1 Playback Console controls

The playback transport controls works exactly as the Mini-Console. The General Vol-
ume slider controls overall volume. Tempo controls default tempo (if no metronome 
value was assigned in ENF). Measure/Beat slider resets playback position to desired 
measure and beat. 

Each horizontal MIDI track is linked to a contrapuntal voiceline found in a staff. Tracks 
are grouped with light or dark grey shading representing one part / staff line. Each track 
has its controls arrayed in columns: 

• Column 1 (Track): Indicates the MIDI track assigned to the staff. MIDI Tracks are 
assigned automatically and cannot be changed.

• Column 2 (Voice): Lists the contrapuntal voice number (1 thru 4) given to each voice-
line. Voice numbers appear inside colored boxes representing one of 4 possible voices 
(black, red, green and blue).

• Column 3 (Part Name): Each track (part) is linked to a Part Name. Part names are cre-
ated in the System Manager.

• Column 4 (Channel): SmartScore automatically assigns a unique MIDI channel to 
each track whenever possible. Since MIDI allows for only 16 channels, channel num-
bers may become repeated. Channel numbers can be edited manually by clicking 
inside the Channel number field. 

NOTE: If the part contains more than one contrapuntal voice, you will see more than one 
instrument channel assigned to that part. For more information see "Working 
with Contrapuntal Voices", Section 7.9, on page 148.

• Column 5 (Port) displays the current port (device) to which the MIDI track is being 
sent. If more than one MIDI device is available, the port assignment can be edited by 
clicking inside the Port field. 

• Column 6 (Lock): You may choose to lock the MIDI Channel of one or more parts to 
keep them from being changed dynamically.

• Column 7 (MIDI Instrument): Every track is assigned a MIDI Instrument. The 
default instrument is “Grand Piano”. Some recognized scores, depending on their 
structure, may have other instruments assigned. 

Set Instrument: This button will open the Instrument Settings window which is 
designed to reallocated MIDI Channels and to save and load custom MIDI instru-
ment settings.

• Column 8/9 (Mute / Solo): buttons control whether a track should be muted while all 
other tracks play or soloed, muting all other tracks.
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• Column 10 (Volume): This slider controls the default volume of each track.
• Column 11 (Pan): This slider controls the Left/Right balance for each track.
• Column 12 (Transpose): Each track can have its playback transposed up or down. Note 

that transposed instruments will already reflect a transposed playback value to com-
pensate for correct pitch.

4.4 Dynamics and Articulations

For detailed information on Dynamic and Articulations palettes, see "Articulations pal-
ette", Section 7.6.2, on page 127 or "Dynamics Palette", Section 7.6.3, on page 133.

4.4.1 Tuplets and Slurs (Legatos)

While in the Insert mode, select a triplet (“T” key) from the “Notes” palette or select 
Legato from the “Articulations” palette. 

FIGURE 4 - 5: Creating a Tuplet or Slur (legato)

a. Click and drag down to insert the tuplet or legato above the notes to be selected.

b. Click and drag up to insert the tuplet or legato below the notes to be selected.

To delete a tuplet or articulation

c. Ctrl+click on it, press the “X” key then click again on the object. Or use the 
Select tool (“O” key) to highlight one or more tuplets and/or legatos.

d. Once selected, push the Delete key.

NOTE: To resize or move a tuplet bracket, use Nudge mode and drag the control point 
located on either end of the tuplet.

If your score contains many repeated beamed triplets, they will automatically become 
filled in after you insert two identical sets of triplets. A dialog will appear asking if you 
want to apply triplets to similar beamed groupings. This includes “implied” triplets.

Creating a 
slur

Creating a 
triplet
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4.5 Voices and Playback

Control of contrapuntal voices is key to proper playback of your score.

4.5.1 Voice Visibility

To view contrapuntal voices as colors, push the Voice Visibility button in the 
Toolbar. Each ENF Part (each staffline of the score) can contain a maximum 
of 4 voices (represented by 4 colors, black, red, green and blue). For scores to 
play back correctly, it is important that voices appear correct and be properly 
manipulated. See "Working with Contrapuntal Voices", Section 7.9, on 
page 148 for additional details about editing voices.

4.5.2 Voice Splitting (Select + “H”)

Music ministers and choir directors will find this tool extremely handy: Most hymnals and 
many choral scores group voices into 2-note chord clusters (SA/TB) instead of opposite 
note stems for each voice. SmartScore treats chord clusters as a single contrapuntal voice. 
Using the voice-splitting tool, you can split two-note clusters into separate voices (black 
and red) where each voice will have a unique instrument sound and each voiceline can be 
extracted to a separate document (See "Extracting Voices", Section 7.4.4, on page 116 for 
more details on extracting voices).

To split all two-note clusters into two independent voices,

a. Hit the “O” key or Select button to activate the Select tool.

b. Select Ctrl+A (Select all) to highlight all symbols in the document.

c. Press the “H” key. This will separate two-note clusters into 2 voices.

FIGURE 4 - 6: Splitting two-note chords into 2 voices

TIP:Only two note clusters will split. If you wish to split clusters containing three or 
more notes, delete the least desirable note(s) from the cluster (“Z” key and “X” 
key) until you are left with two notes in each cluster. 
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4.5.3 Assigning instruments to voices

Assigning unique MIDI instruments adds richness and allows the user to distinguish con-
trapuntal voices during playback. There are two areas where you can change MIDI instru-
ment assignments for voices: inside the Playback Console and inside the System Manager.

To change an instrument assignment of a voice in the Playback Console,

a. Push the Playback Console button in the Toolbar to open it. The console may be 
opened with quick-keys (Ctrl+9 / Cmnd+9) or from the menu by selecting Play-
back > Console.

FIGURE 4 - 7: Changing MIDI instrument of a voice in Playback Console

b. In any of the Voice column, click to select a new MIDI instrument.

To change an instrument assignment of a voice in the System Manager,

a. Open the System Manager (Ctrl+M) or select System Manager from Edit 
menu. All staves are displayed in horizontal rows as “Parts”. Voices are arranged 
in columns above each part (1 thru 4). 

FIGURE 4 - 8: Changing MIDI instrument of a voice in System Manager
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b. Find the voice number within the part you want to change. Click the MIDI instru-
ment name assigned to that voice in the pull down menu. Select an alternative 
instrument. During playback, you will hear voices stand out from other voices 
provided you chose instruments with different timbres.

4.5.4 Changing instrument sounds on the fly

You can change instrument sounds anywhere in the score by applying a Program 
Change to a selected voices within any given measure.

To apply a Program Change in the ENF notation view,

a. Push the “Instrument Change” button in the ENF Toolbar.

b. Position the note-arrow on the first note where the change should occur. 

c. Select a new instrument sound for that voice. If more than one voice is present in 
the measure, you will need to select the voice to which you want to apply the 
change. 

FIGURE 4 - 9: Correcting offset voices not “glued” after recognition.

4.5.5 Correcting Vertical Alignment 

In printed music, noteheads belonging to different voices may appear side-by-side even 
though they are meant to sound simultaneously. During recognition, horizontal distances 
between offset noteheads are measured and a decision is made whether or not to join (or 
glue) notes to the same vertical event. It is possible that offset notes will not become glued 
due to excessive distance between the noteheads. It is also possible that notes will become 
incorrectly glued if they are too close. The default distance for joining noteheads to the 
same vertical event is 1/8th of a note head. This distances can be adjusted prior to recogni-
tion. See "Recognition Options", Section 3.5.1, on page 25 for details on resetting the dis-
tance for joining notes. 
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Following recognition, check that Voice Visibility is on (See "Voice Visibility", 
Section 4.5.1, on page 45). If two notes with opposing stems both appear black and are 
meant to play simultaneously, they can be aligned as follows:

To vertically align offset voices, 

a. Use the Select tool (“O” key) and highlight notes or rests that are horizontally 
offset (likely, they will both be black).

b. Press the “Y” key to group the selected, offset notes into a single vertical event. 
Selected voices may move a bit and one should turn red.

FIGURE 4 - 10: Correcting offset voices not “glued” after recognition.

Similarly, if you see notes that belong in a single voice each displaying a different color 
(most likely black and red) and nearly touching, they are joined to the same vertical event 
and can easily be “unglued”...

To “Unglue” offset notes which are not intended to play simultaneously,

a. With the Select tool (“O” key), carefully select the incorrectly glued notes 
(NOTE: they will each have different colors). Be sure to select only the notes 
which are incorrectly joined.

b. Hit the “Y” key. Joined notes separate and change color. Select again and hit the 
“Y” key once more to rejoin.

See “Join Offset Voices” in "Recognition Options", Section 3.5.1, on page 25 to reset 
default distances prior to recognition. See also "Working with Contrapuntal Voices", 
Section 7.9, on page 148 for more information on editing voices and their affect on score 
playback.
Using to SmartScore X2 48



4.6 Repeats

SmartScore will repeat properly-marked sections including multiple repeats and repeated 
endings. Also, playback can jump forward or jump back when properly marked. For more 
information, see "Jumps", Section 4.8, on page 52.

To insert a repeat barline, repeat measure or any other repeat symbol,

• Toggle the “C” key to enter Insert mode. Select any repeat symbol from “Bar-
lines & Repeats” palette and click to place it. 

To change any current barline to a repeat barline,

• Select a repeat barline from the “Barlines” palette. Click on any existing barline 
to change it to the selected barline.

To delete any barline,

• Quick-select (Ctl+click) on a barline (or select any barline from the “Barlines” 
palette). Hit the “X” key and click on the barline to delete it. 

NOTE: Do not delete a barline at the end of a system to change it; the following mea-
sures will become reformatted. See "Deleting numbered endings and barlines at 
the end of systems", Section 4.7.1, on page 51.

To insert a “Repeat Previous Measure” mark,

a. Select the Repeat Previous Measure mark from palette.

b. In Insert mode, click into an empty measure. 

All notation present in the previous measure will automatically repeat itself during play-
back.

4.6.1 Repeated verses

Many scores have multiple verses that repeat several times even though the music is writ-
ten once and may or may not even have barlines (e.g. hymnals). Other scores have sec-
tions marked only by single repeat barlines but are intended to repeat several times (e.g. 
the ending of a song with “repeat and fade”).
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To change how many times a section should be repeated,

a. With the Properties tool selected, click on the Left Repeat barline that begins the 
section. The Barline Properties window will open.

FIGURE 4 - 11: Selecting the number of verses to be repeated

b. Select the number of desired repeats in the Repeat Section pull-down menu. 
Choices are from 1 to 8 repeats.

4.7 Numbered Endings

SmartScore can cope well with repeats, jumps and endings both simple and complex. For 
proper playback to occur, repeats and endings must be unambiguous and logical. 

With SmartScore’s alt repeat tool you are able to set the sequence of numbered endings as 
well as how many times they should repeat.

To create a numbered ending or edit an existing numbered barline,

a. Select Start Alt Rep button from the “Barlines and Repeats” palette then click 
on the appropriate barline to assign its sequence properties. 

b. The Repeats window will open. Choose “1” to assign the next repeat sequence as 
the first ending.

c. The Close Ending tool will appear on the cursor. Click on the last barline that 
terminates the first ending. The cursor then switches again to the Start Ending
tool. 
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d. Click on barline that begins the second ending (it may be the same barline that 
closes the first ending). Choose “2” as the sequence number of the second end-
ing. 

FIGURE 4 - 12: Multiple Endings

e. Finally, click the barline that “closes out” the last ending.

Occasionally, you may wish to change an existing numbered barline to a “normal un-num-
bered” barline. This would apply to a barline that was mis-recognized as being numbered 
or to undo a one that had been previous edited as numbered.

To change a numbered ending barline to a “normal” barline,

a. Ctrl + click on a nearby barline (or pick it off the Barlines palette). Click directly 
to the left of the numbered ending. This inserts the selected barline.

b. Delete the numbered ending (hit the “X” key and click to delete).

NOTE: Repeat barlines are critical for correct playback. Remember, the number given 
to each ending represents the order each ending will play within a repeated sec-
tion. You can have multiple “1st & 2nd endings” provided each set of endings is 
placed inside repeat barlines. Without repeat bars, SmartScore will interpret it 
as “Repeat last section this number of times.”. Jumps are different... they are not 
sequential. For more information about non-sequential jumping, see "Repeated 
verses", Section 4.6.1, on page 49.

4.7.1 Deleting numbered endings and barlines at the end of systems

Numbered endings and barlines at the end of systems have special properties. They cannot 
be changed to “normal” barlines using the usual “Ctrl-click” or “Insert/Change” function. 

To delete and replace a numbered ending or barline at the end of a system,

a. Insert the desired barline type to the left of the numbered ending that you wish to 
remove.

b. Delete the original ending (hit “X” key and click). The measure will shift slightly 
to the left.
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4.7.2 Change of key/time and the double barline

Usually, changes of time and key signatures at the end of a system are preceded by a dou-
ble barline. If for any reason playback hesitates after a change of key or time signature, 
make sure the barline preceding the signature is actually a double barline. Two single bar-
lines will cause playback to hesitate.Jumps

4.8 Jumps

Jump symbols may include segno, da capo, coda, to coda, fine and other markings indi-
cating where playback should stop and jump back, jump forward or be repeated and 
finally stop. To avoid discontinuity or endless looping (what we call the “bowl of spa-
ghetti” problem), it’s important that jumps be used logically.

4.8.1 Working with the Coda

A Coda sign generally marks the concluding passage of a piece. A To Coda sign is used to 
mark where a jump to the Coda begins; usually from inside a repeated passage. 

To insert a “jump to Coda” sign and mark the beginning of a Coda,

a. Select the To Coda sign from the palette. Find the measure where playback 
begins its “jump” (usually at the end of a repeated section or numbered ending). 
Click on the barline to insert the To Coda sign. It will appear above the bar.

b. Select the Coda sign from the “Barlines and Repeats” palette. In Insert mode, 
click on the barline where the coda is to begin, (usually near the end of the 
piece).

NOTE: The Coda will not be played back until it is activated by the To Coda or d.s. al 
Coda sign. 

4.8.2 Working with the Segno

Segno means “sign”. It marks the beginning of a final repeat or ending. Segnos 
are usually positioned early on in the piece.

To mark a final repeat with a segno, 

a. Select Segno from the “Barlines and Repeats” palette. 

b. Insert the Segno by clicking the barline that begins the last repeated ending or 
section. 

c. To stop a final repeat or ending, return to the Segno and continue on to the Coda, 
select d.s. al Coda (meaning “from the sign to the Coda”).
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To have a final repeat or ending return to the beginning of the piece and terminate at the 
Segno sign, 
• Select d.c. al Segno (meaning “from the beginning up to the sign”) and insert it by 

clicking on the barline in the last ending or repeat where playback is to return. The 
repeated section will return to the beginning of the score and play through to the 
Segno.

NOTE: To Coda, Segno, d.s. al Coda, D.S., D.C. and d.s. al Fine signs are all ignored 
until an ending or repeat is played once.

4.8.3 Working with the da Capo (D.C.), dal Segno (D.S.), and Fine signs

D.C. (da capo) means “from the beginning” or “return to the beginning”. 

To have playback return to the beginning of the piece and play through to the end,
• Select the D.C. button from the “Barlines and Repeats” palette.

D.S. (dal Segno) means “from the sign” or “return to the sign”. 

To have a final repeat or ending return to the Segno and play through to the end,

a. Select the D.S. button from the “Barlines and Repeats” palette.

b. Click on the desired barline to insert the D.S. sign.

Fine means ending. It is usually placed in the middle of a repeated ending and terminates 
the song.

To have the last repeat stop, return to the Segno and continue on to the end of the piece,

a. Insert a Fine sign by clicking on the barline that marks the final end point. 

b. Select d.s. al Fine (meaning “from the sign to the end”) from the “Barlines and 
Repeats” palette.

c. Insert either the d.s. al Coda or d.s. al Fine mark by clicking the barline where 
the last repeat is to begin. 

To have the final repeat or ending return to the beginning and play through to the Fine,
• Place the Fine sign at the appropriate barline. Select and insert d.c. al Fine in a mea-

sure following the Fine sign.

Repeat signs, ending markings (including Codas and Segnos) are found in the “Barlines 
and Repeats” palette. Using repeat signs properly will alter playback accordingly. 
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4.9 Playback Properties

Playback values of dynamic and articulation markings can be altered by use of the “Prop-
erties” tool. Changes can be applied individually to the marking itself or globally to all 
similar markings in the score. Finally, default values can be reset for that particular mark 
for all future SmartScore files. Certain changes to barline properties will also affect play-
back. See 4.9.11 on page 59 and 4.6.1 on page 49 for barline properties details.

To activate the Properties window of an object:

• Hit the “Esc” key or select the Properties icon from the Toolbar and click on one 
of the objects below to open and modify its playback and display properties:

4.9.1 Note Properties

Clicking on any note head will open the Note Properties window. 

FIGURE 4 - 13: Note Properties

• Note duration: Change basic note value.
• Dots: Add or change dots of prolongation.
• Staccato: Change default duration when staccato is applied.
• Tenuto: Change default duration when tenuto is applied.
• Accents: Change default velocity when accent is applied.
• Fermata: Change default tempo when fermata is applied.
• Notehead types: Noteheads can be altered to several alternative shapes configurations 

including triangle, empty triangle, diamond, empty diamond and “x”.
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4.9.2 Property Options (All Properties windows)

• Apply (changed property) to All:
Selecting this option will update playback properties of the same mark throughout the 
score. 

• Apply Setting(s) to All Future Files:
Selecting this option will permanently reset the default value for the selected property 
to its new values for all future ENF files.

• Back to Default:
This will reset values to application launch defaults.

• Reset Defaults;
This will return values to new installation defaults.

4.9.3 Slur (Legato) Properties

FIGURE 4 - 14: Dynamic Marking Properties

• Extend duration: Duration of notes associated with the slur.
• None: No increase of note duration.
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4.9.4 Tempo Marking Properties

Tempo values can be changed by clicking any tempo marking with the Properties tool. 
Changes can be applied to all tempo marks in the document or to all future instances of the 
selected tempo mark.

FIGURE 4 - 15: Tempo Marking Properties

• Tempo slider: Reset tempo value.
• Uncommon Name: Enter an alternative name for the tempo marking (e.g. “really 

fast”).

4.9.5 Accelerando, Descelerando and Ritard Properties

• Starting and ending tempos (as a percent of default tempo)

• Use an uncommon name (e.g. “gradually slower”)
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4.9.6 Hairpin, Cresc. and Decresc. Properties

FIGURE 4 - 16: Hairpin Properties

• Velocity sliders: Start value and Ending velocity values.

4.9.7 Trill Properties

FIGURE 4 - 17: Trill Properties

• Permutations: The number of half-step movements.
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4.9.8 Dynamic Marking Properties

FIGURE 4 - 18: Dynamic Marking Properties

• Volume slider: Resets the volume for the current part.
• Range: 10 to 127 (General Volume)

4.9.9 Tuplet Properties

• Divisions = The number of beats to be applied to the tuplet. Value = The number of 
(equal) notes that would be in the group if no tuplet were applied. See 4.4.1 on page 44 
for more details.

• Hide = Do not show (uncheck to show) Value number or Symbol bracket.
• Apply to: Only this symbol or All symbols in current file.

FIGURE 4 - 19: Tuplet Properties
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NOTE: Default settings for how tuplets appear can be changed in Text Symbols and 
Score symbols tabs found in Program Preferences or Document Preferences.

4.9.10 Multi-Measure Rest Properties

• Measures = Number of measures the multi-measure rest applies.

FIGURE 4 - 20: Multi-measure Rest Properties

4.9.11 Barline Properties (Pickup measures and Codas)

Pickup, measures normally begin a piece or section with a truncated measure having less 
beats than the time signature calls for. It is often associated with a “closeout” measure at 
the end of the section. Split-measures are divided between the final measure of one system 
and continue through the first measure of the following system. 

FIGURE 4 - 21: Pickup and split measures

Incomplete, pickup, closeout and split measures will normally cause playback to hesitate. 
By default, SmartScore applies the exact number of beats to each measure (Lock to Time 
Signature). 

To play individual measures exactly as written, 

a. Select Properties Tool and click on the barline that precedes the measure in 
question. 

Pickup Measure (Typical) Split Measure (Typical)
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b. In the Playback combo box, choose “As written”. 

FIGURE 4 - 22: Barline Properties

Sometimes a score will contain so many split or incomplete measures that you will simply 
want to play it entirely without hesitation. In this case, you will want to apply “Play as 
written” to the Playback tab in Document Preferences.

To play all measures in the document exactly as written, 
• Go to Edit > Document Preferences. In the Time Signature (Lock to Time Signature) 

pull-down menu, select “Play as written”. All measures are now unlocked.

FIGURE 4 - 23: Document Preferences > Playback > Play as Written

In Barline Properties, you can also create system breaks (Codas) and page breaks. 

NOTE: If the original score contains a coda system break, it’s important to indicate that 
prior to recognition. SmartScore will recognize split systems if Recognize tabla-
ture, percussion and split systems is checked in the Begin Recognition dialog. 
For more information, see "Recognition Options", Section 3.5.1, on page 25.
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To create a Coda (Split system)
• Select Properties Tool and click on the barline that begins a measure of interest. 

Choose Actions > “Split System”.

FIGURE 4 - 24: Creating Codas (Split Systems)

4.10 Other Playback Options

4.10.1 Karaoke View 

Feel like singing out loud? Hey, you only live once...

To view moving lyrics with familiar bouncing ball,

a. Press the Karaoke button in the Navigator palette.

b. The Options menu allow for changes in the Karaoke display. These options are 
also available in Edit > Program Preferences.

c. Open the Playback Console (Ctrl + 9 / Cmnd + 9 for Mac) to adjust tempo and 
change instrument assignments for parts and voices. 

4.10.2 Instrument Templates

Instrument Templates is the “source” from which instruments are created and linked to 
parts in the System Manager (See Section 7.4 on page 113.).
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a. To open Instrument Templates, select Edit > Instrument Templates or hit Ctrl 
+ F Win (Cmnd + F Mac) or push “Open Instrument Templates” from inside 
System Manager. 

FIGURE 4 - 25: Instrument Templates

To change or add a new instrument template,

a. Hit (Ctrl+FCmnd+F) or Edit > Instrument Templates.Click in the Name
field of any template and type to change the given name of an instrument.

b. To change an abbreviation, click then type inside the Abbr field.

c. Click and select a different MIDI instrument from the Instrument list to change 
default MIDI instrument assignment.

d. Transpose displays the default playback transposition for selected instruments. 
The MIDI representation will reflect the transposed shift in pitch.

e. Various sets of MIDI instruments can be selected in Instrument Settings pull-
down menu. Instrument sets acquire their names by clicking on the Instrument 
Settings button and selecting a set.

f. To save settings for future ENF files, check “Save for Future”.

4.10.3 Transposed instruments

Transposed instruments do not actually play the pitches notated in the score. To play them 
back in tune with the other non-transposed instruments, they must have their playback 
adjusted up or down by certain intervals. This “playback transposition” is already preset in 
Instrument Templates for most transposed instruments. The number in this column repre-
sents the amount of pitch change (+/-) in half-step increments.
Using to SmartScore X2 62



4.10.4 Adding instruments

You can add new instruments with unique names and playback parameters as well as 
change existing names and parameters for any existing template. All templates are acces-
sible in the Part Name column of the System Manager. For more information on the Sys-
tem Manager, turn to "System Manager", Section 7.4.

4.10.5 Add drum tracks 

Adding an automatic drum track will add more pizazz to the mix. 

Push the Drum Pattern button in the Toolbar to select an appropriate pattern for 
your piece. For more information on adding or creating drum tracks, go to "Auto-
matic Drum Patterns", Section 9.5.

4.10.6 Swing

This feature applies standard swing rhythm to straight 8th and 16th notes notated in 
beamed groups. SmartScore will modify playback and the underlying MIDI representation 
as follows:

To apply swing to playback,

In the Playback menu, click on Swing.

4.11 ENF Graphical controllers 

With the Velocity graphical controller you can vary note velocities of each note cluster 
quickly and smoothly. With the Tempo controller, you can “draw in” tempo variations 
smoothly over time. Controllers can be accessed either in the ENF Toolbar or below the 
Piano Roll window in MIDI view. 

FIGURE 4 - 26: Text and Controllers
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4.11.1 Velocity Controller 

In ENF score view, push the “Velocity controller” button to activate. Click and 
drag your mouse along the vertical bars which represent each note’s velocity. The 
higher the bar, the more the velocity.

FIGURE 4 - 27: ENF Velocity Controller

4.11.2 Tempo Controller

Push the “Tempo controller” button to active. The horizontal line in the topmost 
staff represents default tempo. To vary tempo, click and drag your mouse up or 
down. The last tempo point will be fixed until changed.

FIGURE 4 - 28: ENF Tempo Controller

NOTE: For ritards, accelerandos and descelerandos, use the Properties tool instead of 
the Tempo Controller. You will have much more predicable results. See 4.9.5 on 
page 56 for information on these properties.
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4.11.3 Normalize controllers

After making changes to Tempo or Velocity controllers, you may find you have created 
greater-than-desired changes to playback. If so, you may globally reduce the effects of 
either controller by applying normalizing.

FIGURE 4 - 29: Normalizing Tempo

To reduce effects of either Tempo or Velocity graphical controllers

a. Choose Playback > Graphical Controller

b. Select either Normalize Tempo or Normalize Velocity.

c. Choose amount of reduction desired: 20% / 40% / 60% or 80%. Controller dis-
play and playback will change accordingly. 

d. Choosing Reset removes all controller changes and resets the default settings. 
Tempo markings inserted into ENF will still take effect. The end result is an aver-
aging of all tempo values.

Normalize Tempo Controller (Before)

Tempo Controller after normalizing by 80%
Using to SmartScore X2 65



4.12 Working with Finale® and other scorewriters or programs.

SmartScore full version works seamlessly with MakeMusic’s® Finale® program. 
If you already own a version of Finale or Print Music with SmartScore Lite, 
SmartScore can be made to launch automatically when “Music Scanning” is 
launched in Finale...

To launch Finale and import the current SmartScore file,

Push the “Save as XML and open in Finale” button in the lower Toolbar. The cur-
rent ENF file will be saved as an XML file. Finale is then launched (provided it is 
installed) and the SmartScore file will import as a MusicXML file.

4.12.1 Converting SmartScore files to other file types

To save SmartScore files in one of several different file formats...

In the File > Save As (File type/Format) pull-down menu, choose one of the following 
formats to save the ENF score to:

• MusicXML (.XML) MusicXML has quickly become the most widely used file 
format for the exchange of music notation files between scorewriters. Most well-
known notation scorewriting programs now support importing and exporting 
MusicXML files including Sibelius®, Finale®, Notion®, Personal Composer®

and others.

• MIDI files (.MID) will import playback data into most other music software programs 
with no page formatting. All graphical information about note position, stem direction, 
voices, etc. are lost. MIDI is to music what ASCII is to text.

4.13 Maintaining playback continuity

Playback may loose continuity for several reasons, e.g. system braces/brackets were cut 
off during scanning or in the case of optimized scores, where the number of parts varies 
between systems.

4.13.1 Merging Systems

For parts to play simultaneously, they must be joined by a bracket along the left-hand mar-
gin. If during scanning, brackets of the original score are cut off by mistake or if some-
thing “breaks” the solid line of a bracket, one or more parts become separated and will 
appear in ENF as single-line systems. If so, all parts will not play back simultaneously. 
SmartScore has a tool to rejoin broken systems; forming a larger, corrected system. 
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To merge two systems into one larger system,

a. Position your cursor over the topmost broken system or staff line. Hit Ctrl+L / 
Cmnd+L (Mac). The Re-link Parts window will open up.

FIGURE 4 - 30: Re-link Parts / Merging Systems

b. The active system highlights in grey. Using the checkboxes, reassign each high-
lighted staff to its correct part name and position in what will become the final, 
reformed system. Apply to = System.

c. Press the Next System button and reassign each highlighted staff line to its cor-
rect part name as you did above. Return to the first staff of the final, reformed 
system by selecting Previous System. 

d. Now, check the Merge with checkbox. When the Next System button is pushed, 
the two systems will join into a single system. Continue using Next System 
again until all separated parts are correctly joined. Review Part Name check-
boxes for correctness. 

4.13.2 Restoring a missed or “invisible” staff line

Occasionally, a staff line inside a system may have been missed during recognition due to 
flaws in the original score. Or in the case of an optimized score, you may want to restore a 
“hidden” (optimized) staff.

a. First, you want to check that parts in the shorted system are properly linked. Posi-
tion the cursor inside the system and hit Ctrl + L to open Re-link Parts.

b. Put a check next to the appropriate visible parts. Leave the missing part 
unchecked. Make sure the order of the parts you check correspond to the actual 
staffline and the missing part remains unchecked. Hit OK.

c. Select the Properties tool (Esc key). 
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NOTE: Yellow arrows along each system bracket indicate all possible parts, visible or 
invisible. They correspond to the “Super System” in System Manager.

d. With your cursor in the affected system, click on a “floating” yellow arrow that 
corresponds to the missing staff line you wish to restore.

e. In the “Staff Properties” window check “Visibility”. Make sure “Show Staff” is 
also selected.

f. In the “Apply To:” pull-down menu, select “Current Staffline or System”.

TIP:Hit the “U” key and select Unify Key Signatures (based on First System). Hit 
OK and the key signatures of the score will become unified. Now you need only 
to fill in the missing notes. Remember you can always use Copy and Paste to 
clone measures of notes at a time whenever possible.
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4.14 Re-linking parts 

Occasionally, scores will contain collapsed or expanded systems (sometimes referred to as 
“optimized systems”). Unless you re-link parts, these systems will not playback with the 
correct instrumentation.

The Re-link Parts function allows you to reassign each visible staff with its correct part 
(as defined by Part Name in System Manager). By re-linking parts of optimized scores, 
parts will play back correctly as they disappear and reappear throughout the score. 

NOTE: Parts listed in Re-link Parts window are derived from the Part Name column of 
the System Manager (see "System Manager", Section 7.4, on page 113 for more 
information). Checked boxes identify which parts are assigned to the active sys-
tem. Before re-linking, make sure all possible parts have been created.

To re-link parts in a system, 

a. From the FILE menu, select “Part Linking”. Or, hit Ctrl+L (Win) / Cmnd+L 
(Mac). This will open the Re-link Parts window:.

FIGURE 4 - 31: Re-link Parts window

b. Check the part names that are associated with each staff in the active system. Be 
sure to remove checks from parts that are not associated with the active system. 
Larger systems may require scrolling down the list. The program will not allow 
you to select more or less parts than actually appear in the active system. 

c. To view adjacent systems, press Next or Prev System. 

d. In the Apply To box, press Apply to apply to active system. System+ will apply 
to the active system plus all subsequent systems.
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Page #1 of Orchestral Score

Page #2 of Orchestral Score

In this example, the first page consists 
of one system having 15 parts (15 
staves per system). With the cursor 
positioned over the system and Re-link 
Parts opened, 15 parts will be checked.

The second page contains 3 systems 
each with 6 staves. Many parts that 
appeared on the first page have dropped 
out. With the cursor positioned over 
one of the systems, 15 Part Names will 
be listed but only 6 will be checked in 
the Re-link Parts window. In this case, 
it was necessary to remove all check 
marks and then check the top six parts 
to reestablish proper part linking. 

See FIGURE 4 - 31:. Notice that the re-
linked parts were applied to all subse-
quent systems (System+) from the top-
most active system.

FIGURE 4 - 32: 
Re-linking an orchestral score
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4.15 3rd-party VST (Windows) and AU (Mac) audio setup 

SmartScore hosts third-party sound libraries compiled for VST (for Windows) and Audio 
Units (for Macintosh). Some sound libraries may not be supported. 

a. Go to the Playback menu again and select VST or AU Setup. Push Add and 
browse to the plug in folder created when your sound library was installed. If the 
plug-in folder cannot be located, reinstall the library and be sure to install the 
audio plug-in.

FIGURE 4 - 33: VST (Win) and AU (Mac) Setup

b. Go to Playback menu and select MIDI Devices. Click on “VST Plugins” (Win) 
or “Audio Units” (Mac) from inside the Output window. Click OK.

FIGURE 4 - 34: Playback > MIDI Devices 

c. To return to your computer’s wavetable sound set, open Playback > MIDI 
Devices and reselect the desired driver.

Once the desired plug-in is selected, push OK. In the main ENF view, push the VST (or 
AU) button in the Toolbar to open the plug-in player.
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4.15.1 MIDI Setup

It may be necessary to identify the MIDI device attached to your system in order for 
SmartScore to play General MIDI instruments. In the Playback menus, select MIDI 
Devices and choose General MIDI or MIDI Mapper. Most computers today provide 
built-in MIDI synthesis. This allows you to select and play General MIDI (GM) sounds 
without installing an outboard synthesizer or soundcard. 

To set the MIDI input and output devices,

a. Select MIDI Devices from the Playback menu. The MIDI Devices window will 
open.

FIGURE 4 - 35: Playback > MIDI Devices

b. Click on the MIDI Output device you wish to use for MIDI playback. The MIDI 
device window will display all installed MIDI device drivers. 

c. If you intend to record in SmartScore, select the desired MIDI recording device/
interface in Input window.

NOTE: If the desired device is not listed in the MIDI Devices window make sure your 
MIDI device driver has been properly installed.

d. Press OK to set the selected MIDI devices as your MIDI sources.

NOTE: You may need to close any open MIDI programs. Some MIDI programs prevent 
playback by blocking the MIDI Out port.
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4.15.2 Audio MIDI Setup (Macintosh)

To access Audio MIDI Setup in Mac OS X, locate “Utilities” folder inside the “Applica-
tions” folder. Double-click on Audio MIDI Setup.

FIGURE 4 - 36: Applications > Utilities > Audio MIDI Setup (Mac)

If you have external MIDI devices installed such as an external synthesizer module and 
MIDI interface, they should appear as icons in the window. Using your mouse, drag the 
“Out” arrow of the source device to the “In” arrow of the receiving device and vice-versa. 
Internal connections should then be established. Close Audio MIDI Setup.f

FIGURE 4 - 37: Connecting MIDI Devices in Audio MIDI Setup

With SmartScore ENF file open on your Mac, go to Playback menu, click and select Play-
back at the bottom of the list. Choose CoreMIDI Playback to activate devices connected in 
Audio MIDI Setup. To activate built-in soft-synthesizer (Macintosh QuickTime Musical 
Instruments), choose QT Internal Playback.
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5) Basic Score Editing

This section describes basic SmartScore editing features. For information on advanced 
editing techniques such as part extraction, optimizing scores, managing systems, applying 
or changing instrument templates, reformatting, respacing, page reformatting, print setup 
and part linking, turn to Chapter "Detailed ENF Editing", Section 7), on page 104. Many 
editing and playback default settings are accessible in either Document Preferences or 
Program Preferences under the Edit menu. See "Preferences", Section 11.1, on page 214 
for details.

5.1 Navigating Inside an ENF Document

5.1.1 Active staffline

Only one staff can be edited at a time. Positioning your mouse over a staff will cause it to 
highlight black. Objects associated with the highlighted staff (including text and lyrics) 
can then be edited. You can choose to display just the active staff or to all staves in black. 

To display all staff lines in solid black, 
• Go to the View menu and uncheck Show Active Staff. 

To lock the active staff and allow the mouse to move anywhere,
• Hit the Caps Lock key. To unlock the active staff, press again.

5.1.2 Page View Display

Several ENF page view layouts are available after scanning. 

To select a different page view layout,
• Click on any one of four page view buttons in lower Status Bar.

FIGURE 5 - 1: Page View Buttons

• View ENF pages horizontally
• View pages vertically
• View pages in book format (facing pages)
• View score in horizontal scroll format (long view)
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NOTE: Whenever the ENF and TIFF view panes loose synchronization, e.g. in Long 
View mode or after score reformatting, the Image display pane will close and the 
“Scan View” window will appear instead. Closing the Scan View window will 
re-initialize normal Image / ENF view panes.

5.1.3 Scan View Window

The TIF/ENF split screen format can be changed to display only the ENF view with a 
floating “scan view window” corresponding to the same region in the scanned image 
where your cursor is placed.

To view full-screen ENF pane with a floating scan window:
• Go to the Window menu and select Scan View window.

By dragging the Split Pane control up or down, you can quickly view more of the TIF 
pane or more of the ENF pane.

FIGURE 5 - 2: Window pane shade control bar (View > Split Screen > Vertical)

The slider to the right of the Toolbar controls both the TIFF / ENF window shade bar. 

5.1.3a TIFF / ENF Overlay view (Mac Only)

An opaque ENF-over-TIFF view is available on Macs. The ENF-TIF slider adjusts the 
opacity of the ENF overlay from 0 to 100%.
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To edit using ENF variable-opacity overlay,

Go to View > Split Screen > Overlay. 

FIGURE 5 - 3: ENF / TIFF overlay view (Mac only)

To change zoom level in any view window,
• Select one of 3 zoom levels in View > Scan View window.

5.1.4 Zoom 

To Zoom in and out,
• Click the Zoom icon in the Toolbar or press Ctrl + Q. 
• Left click will increase the scale of your view (Zoom In), while right-click 

(Option + click for Mac) will decrease the scale of your view (Zoom Out). Ctrl
+ scroll wheel works for zooming in and out as well.

For additional information on navigating inside an ENF document, see "Split-screen and 
scan view reference views", Section 7.11.1, on page 153.

5.1.5 Paging

To page forward or backward in an ENF document, 
• The Next / Previous page control buttons are located to the far right of the ENF 

Toolbar.

To add a new page with empty systems,
• Push the Add New Page button in the Status Bar.

5.1.6 Status Bar options

The status bar at the bottom of the SmartScore window contains information about the 
current page being viewed. Clicking inside any of these fields will open a control window: 
Page Number (Go To), Page Size (Page Setup) or Zoom Level (Zoom). 
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5.2 Editing the Music

For editing, we recommend a “left-hand-on-keyboard” technique as shown below. The left 
index finger is over the “C” key, the left middle finger is over the “X” key, the left ring 
finder is over the “Z” key and the small finger is over the “CTRL” key.

NOTE: You will find editing fast and easy once you begin working with this “Quick 
Keys” method:

FIGURE 5 - 4: Left-Hand Position for ENF Editing

5.2.1 Pitch shift (Nudge mode)

To change the pitch of any note, 

Position the mouse over a staff line. Hold the Shift key down with your 
small left finger then click and hold on the control point in the center of the 
notehead. Drag the note head up or down to shift its vertical position in the 
staff.

To change the pitch of several notes at once,
a. Press “O” key to activate the Select tool in Toolbar.

b. Click and drag a box around any series of notes.

c. Hold down the “Shift” key and drag the notes up or down.

5.2.2 Rhythmic errors

Measures highlighted in a reddish color indicate that one or more rhythmic errors were 
found inside a voiceline. 

FIGURE 5 - 5: Measure with rhythmic error (1 beat is missing)
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For neatness sake, many scores intentionally truncate second and third voicelines. Nor-
mally, truncated voices will not cause playback problems provided notes on the same beat 
are vertically aligned.

FIGURE 5 - 6: Voice #2 (stem down) is truncated causing measure to highlight

Pickup measures and measures split between systems play back without pauses by select-
ing Properties Tool (Esc key), clicking the beginning barline of the pickup, closeout or 
split measure and choosing “Play as written”. 

NOTE: The red color used to highlight flag error measures can be turned off by uncheck-
ing “Show Error Measures” under the View menu. 

5.2.3 Inserting Notation Symbols

Musical symbols can be selected from one of several floating tool palettes posi-
tioned on the left side of the screen. Symbols with multiple values are grouped 
inside a single “master’ button identified with a small arrow. By holding down
any button containing an arrow, the entire set of selectable symbols will expand 
to the right.

FIGURE 5 - 7: Expandable Palette Buttons (Notes and Rests)

5.2.4 Quick-select (Ctrl + Click):

You can select any symbol on a page without having to find it in a palette. Hold the Ctrl
key down and click on any object The cursor will inherit that object’s properties. 
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5.2.5 Insert mode

Insert mode (Insert button on the Toolbar.) is activated by hitting the “C” key on 
your computer keyboard. It also activates with Quick-select (Ctrl+click on an 
existing symbol) or when a symbol is picked from the Tool Palette. The selected 
symbol will insert into a staff line or will change an existing symbol when its 
clicked on. 

To change the value an existing note, rest or other symbol:
a. Select a note or rest within the same symbol class but with a different value.

b. Position your cursor over the symbol to be changed until it highlights yellow. 
Then click to change the new symbol.

NOTE: When a note highlights light blue, clicking will insert a new note in another voice
at the same vertical event. See "Working with Contrapuntal Voices", Section 7.9, 
on page 148 for more about vertical events.

5.2.6 Stem direction

In Insert mode, the default stem direction of a note switches when the cursor crosses the 
middle line of a staff.

To insert a note with the opposite stem direction as shown by your cursor, with a right-
click (option + click for Mac). 

To reverse the stem direction of one or more selected notes,
• Select one or more notes with the Select Tool (“O” key). Hit the “S” key to change 

stem direction of the selected notes. 

To change the stem direction of an existing note,
a. In Insert mode, right-click (option + click for Mac) on any note once it high-

lights yellow. 

5.2.7 Deleting objects

There 4 methods for deleting objects. They are:

• “Click Delete”: Hit the “X” key (or push the “Delete” button in the Toolbar). 
Click on any symbol to delete it.

• “Group Delete”: Use the Select tool (“O” key) and drag the selector box over 
one or more objects highlighting them in yellow. Selected objects will appear 
grey-green. Hit the “Delete” key to delete all selected objects.
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• “Control Delete”: Quick-select (Ctrl+click) any symbol. Hit the “X” key. Click 
on any object of the same class to delete it. NOTE: In this mode, note clusters 
will be deleted.

• “Clustered Note Delete”: Hit the “X” key (or push the “Delete” button in the 
Toolbar). Now hit the “Z” (cluster) key. In this mode, single noteheads of clusters 
will delete.

5.2.8 Undo / Redo

To undo any single action,
• Click the Undo or Redo button to reverse the last editing action. Or hold the Ctrl 

down and hit the “Z” key (Cmnd + Z for Mac). 

To Undo or Redo one or more previous actions
• To select one or more actions to be reversed, click the small arrow to the right of the 

Undo or Redo buttons. Drag to select multiple actions. Push “Undo Actions” or “Redo 
Actions”.

FIGURE 5 - 8: Undo multiple actions

5.2.9 Editing note clusters

To insert additional note heads to existing note stem: 

In Insert mode, additional noteheads can be added to an existing note stem sim-
ply by clicking above or below an existing note provided the selected note value 
(displayed by the cursor) is the same as the existing note stem. Position the cur-
sor on the correct line or space and when the note highlights yellow, click to 
insert.

• To add a notehead to any existing note stem (regardless of what is shown on your 
cursor), hit the “Z” key (“Cluster tool”). When the existing note highlights yel-
low, click to insert new notehead. 
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To delete a notehead from existing cluster: 
• Select Cluster tool from the Notes palette (“Z” key). Then hit the “X” key Click-

ing on any notehead in a cluster will remove a single notehead. The Delete clus-
ter tool also works to delete single-headed notes.

NOTE: Always use the Cluster tool to remove single note heads. The single greyed note 
and arrow will delete entire note cluster.

5.2.10 Inserting, changing and deleting beamed notes

To edit beamed notes:

Hit the “C” key (or click on the Insert button for Insert mode) and select a 
flagged note from the “Notes” palette. Then choose a beam direction from the 
“Beams” palette or the “A” key on your computer keyboard. If a similar beam 
note is nearby, Ctrl + click on it to select it.

FIGURE 5 - 9: Editing Beamed Notes

• To form a beamed group, insert the selected beamed note by clicking into a staff (not 
adjacent to another beam group). Repeated clicks will form successive 2-note beam 
groups when “left” or “right” beam direction is selected. One continuous beam group 
will be created when the “middle-beam” is selected. Auto-Beam can be used, but it 
may also cause re-coupling of other beams in the measure. See "Score Properties", 
Section 7.3, on page 109 for more details.

• Inserting a “right” or “middle” beam to the left of an existing beam group will cause 
that note to attach itself to the beam on its right. Likewise “left” and “middle” beams 
will attach to the right of an existing beam. Clicking inside an existing beam group 
with the “middle” beam selected will insert a beam note inside the beamed group.

• Clicking on an yellow-highlighted beamed note will change its note value and/or beam 
direction as indicated by the cursor. 

• To delete a beamed note, Quick-Select it, hit the “X” key and clicking again to remove 
it. Deleting an end beam will cause the beam to join to any adjacent beamed groups. 

Notes palette (expanded) Beams palette (expanded)
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5.2.11 Forming beam groups (Select + “B”)

To create a single beam group from adjacent flagged or beamed notes: 
• Use the Select tool (“O” key) and highlight any number of adjacent flagged notes. Hit 

the “B” key to join the notes into a single beamed group. The “B” key will also join 
two or more adjacent beam groups that are selected.

5.2.12 Barlines

a. While in the Insert mode, hit the “I” key (or select any barline from the “Bar-
lines & Repeats” palette). 

b. Click anywhere in the active staffline to Insert a barline.

5.2.12a Deleting / changing barlines at the end of systems.

Deleting a barline at the end or beginning of a system will cause that measure to roll up or 
down to an adjacent system. Follow this step to delete or change a barline type that ends or 
begins a system...

To change a barline at the end of a system to another barline type,

a. Insert the desired barline type to the left of the barline that you wish to remove.

Delete the barline (“X” key then click). The measure will shift slightly to the left but not 
roll to an adjacent system.

5.3 ENF Symbol Properties

The Properties tool is found in the Toolbar. Certain playback and display proper-
ties of most symbols can be edited by clicking with the Properties tool. Changes 
can be applied to all similar symbols in the score as well as all identical symbols 
created in future files.

5.3.1 Score Properties

Options for changing the structure and formatting of your score such as staff spacing and 
adding and deleting parts can be found in the “Score Properties” window. Select Score 
Properties from the FILE menu. Or, with the Properties tool selected, Score Properties is 
opened by right-clicking anywhere inside a staff line. For detailed description of the Score 
Properties window, see "Score Properties", Section 7.3, on page 109.

The “Score Structure” environment lets you view and edit all open ENF docu-
ments in a graphical, hierarchical display. For details, see "Structure and hierar-
chy", Section 6.5.1, on page 100
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Adding and removing parts and voices can also be controlled from inside the 
“System Manager”. For more details, see "System Manager", Section 7.4, on 
page 113.

5.3.2 Barline Properties

With the Properties tool selected, click on the barline preceding the measure of interest. 
For details on controls, see "Barline Properties (Pickup measures and Codas)", 
Section 4.9.11, on page 59.

FIGURE 5 - 10: Barline Properties
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5.3.3 Note Properties

With Properties tool selected, click on any note head. Here you can change note values, 
dots and even the appearance of the notehead.

FIGURE 5 - 11: Note Properties

Refer to "Playback Properties", Section 4.9 for details on Note Properties and other play-
back properties including:

• Articulations & Dynamics (trill, arpeggio, dynamic marks, etc.)

• Slur (to shorten or extend legatos)

• Tempo marking (to change default tempo speeds)

5.4 Transposition by Key and Clef 

Transposing all or part of a score can be accomplished in one of several ways. 
The most common is “transpose globally by key”, e.g. change an entire song 
from the key of E-Flat to the key of C.

Other transposition methods such as transpose-by-clef, transpose within a 
selected range and transpose-notes-only are all possible. To transpose the key of 
a score, first check that the “source” key signature is correct before applying any 
transposition function...

a. Push the Transpose button or hit Ctrl +T Win (CmndT Mac).
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b. The “source” key signature will appear in the main window with its signature 
name listed in both major and relative minor keys.

FIGURE 5 - 12: Key Transposition

c. Choose to transpose either by Key or by Clef or by Pitch.

d. Use the scroller to select a new key signature if by Key or a new clef sign if by 
Clef.

e. With Closest selected, SmartScore will transpose to the target key, up or down, 
with the least number of intervals. Choose Up or Down if you wish to make your 
own choice. Push OK.

For information on additional transposition methods turn to "Transposition", Section 7.2, 
on page 106.

5.5 Printing and exporting your final score
If your score was scanned, ENF pages will probably not be centered. Page Setup
provides various tools for controlling print layout. The simplest way to center 
music on each page is to select the Fit to Page layout option.

To center ENF frames prior to printing...
• Open Page Setup. In the Document Page Setup pull-down menu, choose 

Center on Page. Click Apply.

NOTE: Various document layouts can be applied in Page Setup. For exam-
ple, you may want to have alternating left/right margins for bound 
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scores. To explore other printing layout options, see "Changing 
default margins", Section 6.3.2, on page 95.

To print your score,
• Select File > Print or push the Print button in the Toolbar.

To save your ENF score as a PDF file,
• Select File > Save As PDF.

Windows Users: CutePDF is the default PDF creator application, but several other alter-
natives may be installed and used.

To select an alternative PDF creator application for Windows,

a. Open Edit > Program Preferences and click on ENF-PDF.

b. Install an alternative PDF creation program and select it in the pull-down menu 
in the upper part of the window.

5.5.1 Optimizing oversized and undersized scanned scores

Modern “intelligent” scanners can (and will) do some unexpected things... in order to 
attain required resolutions (dpi), some scanners will actually re-scale the size of the image. 
An 8.5” x 11” page may end up becoming 9” x 13”. Since SmartScore matches the size of 
music scanned exactly, the resulting ENF file may print off the page. If this is the case, 
you can “optimize” the size of the SmartScore frame to fit precisely inside the margins of 
your default page size and orientation.

To re-scale (optimize) your ENF pages,

a. Center the score on the page. (See "Page Centering", Section 6.3.1, on page 94)

b. Go to File>Format Score. Check Scale score. Push Find Optimal. OK.

FIGURE 5 - 13: Format Score window
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TIP:The Reset Workspace button (or F1 key) will reset all windows and palettes to 
their default “startup” positions. It’s useful if your workspace gets messy. 

5.6 Saving and Exporting ENF Files

You can save the current ENF file at any time by pushing the Save button in the 
Toolbar or by hitting Ctrl + S (Cmnd + S for Mac). 

5.7 Working with Finale® and other scorewriters or programs.

SmartScore full version works seamlessly with MakeMusic’s® Finale® program. 
If you already own a version of Finale or Print Music with SmartScore Lite, 
SmartScore can be made to launch automatically when “Music Scanning” is 
launched in Finale...

To replace SmartScore Lite with SmartScore full in Finale:

• In SmartScore, open Edit > Program Preferences. In the User Interface tab, 
place a check in the “Integrate with Finale” option. Push OK to apply.

FIGURE 5 - 14: Program Preferences > User Interface

Always edit your music in SmartScore before bringing it into Finale. You will loose a lot 
less in the translation. You may find it more convenient to work entirely in SmartScore 
(e.g. transposition, playback and printing) or you may decide at some point to bring the 
SmartScore file into Finale. 
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To launch Finale and import the current SmartScore file,

Push the “Save as XML and open in Finale” button in the lower Toolbar. The cur-
rent ENF file will be saved as an XML file. Finale is then launched (provided it is 
installed) and the SmartScore file will import as a MusicXML file.

5.7.1 Converting SmartScore files to other file types

To save SmartScore files in one of several different file formats.

a. In the File > Save As (File type/Format) pull-down menu, choose one of the 
following formats to save the ENF score to:

• MusicXML (.XML) MusicXML has quickly become the most widely used file 
format for the exchange of music notation files between scorewriters. Most well-
known notation scorewriting programs now support importing and exporting 
MusicXML files including Sibelius®, Finale®, Notion®, Personal Composer®

and others.
• MIDI files (.MID) will import playback data into most other music software programs 

with no page formatting. All graphical information about note position, stem direction, 
voices, etc. are lost. MIDI is to music what ASCII is to text. See "Saving MIDI Files", 
Section 10.13, on page 211.

b. Press Save. The proper extension will automatically be added.

The music notation equivalent to text is: MusicXML is like “rich text format” and MIDI is 
to music like “raw” ASCII text.

5.7.2 Copying a SmartScore page for pasting into other programs

To copy and paste a region or page into another application (e.g. Microsoft™ Word®, 
Adobe™ Photoshop®, e-mail programs, etc.), 

To copy a full page:

a. Ctrl + A / Cmnd + C (Select All) then Ctrl + C / Cmnd + C (Copy).

b. Open 3rd-party application, position cursor and Ctrl + V/Cmnd+ V (Paste).

To copy a region of a page

a. Press the “O” key to activate the Select tool.

b. Right click (option + click for Mac) and drag to select a region in an ENF page 
that you wish to copy to the clipboard. 

c. Select Edit > Copy (Ctrl +C / Cmnd+C) to copy selected (highlighted) region 
to the clipboard as a bitmap image. 

d. Open application that supports bitmap graphics and select Paste.
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TIP:Use this feature to take “snapshots” of musical snippets and Paste into word pro-
cessors or other non-music programs.

5.8 Creating a New ENF Score from Scratch

SmartScore isn’t only about scanning. It is also a full-featured scorewriter as well. When 
creating a new score from scratch, certain defaults will turn on such as auto-beaming and 
auto-spacing.

5.8.1 New score

To create an empty ENF score using one of several basic templates,

a. Push the Score button on the Navigator or select New > New ENF under the File
menu (Ctrl + N (Win) / Cmnd+ N (Mac)). 

FIGURE 5 - 15: New score window

b. Type in a Title for the new score.

c. Add the Composer’s name for the first page score header.

d. Press the Page Setup button to change the basic page layout of your score. See 
"Custom document layouts", Section 6.3.5, on page 96 for details.

• Page Setup opens document size and layout window.

• Tempo will insert a metronome mark for playback.

• Uncheck Insert Clef Signs automatically to create an ENF document without clefs.
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5.8.2 Using Built-in Templates

SmartScore has 15 preset 2-page templates including solo instrument, piano, duet, com-
mon vocal and orchestral scores and a custom setup.

a. Select a desired template from System Type in Score window.

b. Once the score is open, you can edit normally.

To add a new page, 

a. Push the “Add New Page” button on the right of the status bar. 

b. Or, push the Properties Tool, right-click into any staff line and select “Add 
Empty Page” from the Score Properties window.

c.

d.

To delete an empty page,
• To delete a page, all systems on the page must first be removed. Right-click (alt for 

Mac) into each system of the page you wish to delete. Select “System > Remove” in 
the Score Properties window. Repeat as necessary.

5.8.3 Real Time Recording

An alternative to entering notes in by hand is to record MIDI-based performances 
using a MIDI keyboard or some other MIDI instrument. For more about this, see 
"MIDI Recording", Section 10.8, on page 206.

5.8.4 Step Time Recording

An alternative to Real Time Recording is Step Time Recording. Step Time 
Recording is done in MIDI and can be a very fast method of entering in notes 
(when you can’t scan it in of course!). For more, turn to "Step Time Recording", 
Section 10.9.
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6) Reformatting, Part Extraction & Page Setup 
(Score Structure)

The MIDI Edition will allow you to edit the score and even reformat 
page layout, etc. However, since MIDI Edition does not print, it doesn’t 
make a lot of sense to spend time changing score layout because this 
edition will only create MIDI files and/or burn to CD.

6.1 Reformatting scores in ENF view

Measures, staff lines, systems and even pages can be resized, compressed or expanded 
while maintaining proper note spacing. Parts can be extracted from the score and/or 
recombined to form conductor’s scores. Page layout and margins can then be selected, 
modified and previewed prior to printing. 

NOTE: It’s best to correct mistakes before reformatting the score because synchroniza-
tion between the ENF window and the original scan window (in yellow) will 
probably become lost. Even if synchronization is lost, a floating Scan View refer-
ence window is available. For more details, see "Split-screen and scan view ref-
erence views", Section 7.11.1, on page 153.

6.1.1 Nudge Mode (Barlines)

Several interesting and useful reformatting possibilities can be applied when barlines are 
repositioned in Nudge mode:

• Resizing adjacent measures by dragging barline horizontally. See "Nudge mode (Shift 
button)", Section 7.5, on page 120.

• Shuttling measures in/out of systems by dragging last barline. See "Repositioning 
measures using barlines", Section 7.5.6, on page 121.

6.1.2 Adjusting measures

Measures can be compressed or expanded in Nudge mode. This may cause measures to 
scroll from system to system. Also, the number of measures per line may be set to a fixed 
number. These actions will cause the score to reformat.

For more details, see "Repositioning measures using barlines", Section 7.5.6, on 
page 121. For setting fixed number of measures per system, see “Set Number of Mea-
sures” in Section 7.3.2, "Staff Properties" on page 111.
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6.1.3 Horizontal Reformatting

System widths can be changed one-by-one or globally. 

To globally change system widths, 
• See "Changing default margins", Section 6.3.2, on page 95.

Single system widths can be changed in the ENF main view by dragging either of the 
green tabs in the upper ruler margin.

FIGURE 6 - 16: Using tabs to change staff distances and system widths

The lower green tab towards the left margin adjusts the position of instrument Part Names.

6.2 Vertical Reformatting (Line, staff and system spacing using tabs) 
You can change distances between stafflines and systems using the red or blue tabs inside 
the left ruler of the active system. Changes made to a staffline or system spacings can then 
be applied globally to all other staff lines and systems using the Staff/Line spacing option 
inside the Staff Properties window (right click inside any system). See "Line/staff spac-
ing", Section 7.3.1, on page 110 for more details.

6.2.1 Changing line spacing and distances in the active system (red tabs)

To increase or decrease distances between staves and/or systems...
• Position the cursor over a staff to make it active. The top and bottom red tab control 

the distance between the active system and the systems above and below it. The mid-
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dle red tabs adjust the distances between staves. The “T” tab on top controls the over-
all spacing above the system.

FIGURE 6 - 17: Using tabs to change staff distances and system widths

6.2.2 Changing staff line spacing in the active (Blue tabs)

Moving the blue (staff height) tabs not only increases the height of a single staffline, it 
also increases the size of all musical symbols inside that staff. To apply a staff height 
change to all remaining staves, use the “Copy to” command. See "Line/staff spacing", 
Section 7.3.1, on page 110

To increase/decrease the height of individual staves...
• Drag the blue tab aligned with the bottom line of any staff up or down. The staff will 

resize vertically.

FIGURE 6 - 18: Using tabs to change staff distances and system widths

Changing staff distances
(Red tab)

Changing system distances
(“T” tab)

Active
Staff

Resizing staff height
(Before dragging blue tab)

Resizing staff height
(After dragging blue tab)
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6.3 Document Page Setup

Your finished score will probably be printed out so you’ll want to control how it will look 
beforehand. You may want to resize staves and systems or reformat the entire score. You 
may also want to extract and recombine parts and voices or create a conductor’s score 
from separate parts. This chapter includes changing score structure, reformatting margins, 
page layout control and print preview.

To preview and change a document’s page layout, 
• Push Page Setup button in the Navigator (File > Page Setup)

If your score was created out of recognition, the Document Layout pull-down menu will 
show “From Recognition”. Each page frame represents the exact area cropped when each 
page was scanned. Choices include selecting a default page size and orientation as well as 
centering music on the page or else choosing one of several preset layouts as described 
below. 

6.3.1 Page Centering

To apply selected page size / orientation and center music on pages, 

a. Make sure your Page Type is correctly set to your paper size.

b. In the Document Page Setup pull-down menu, select 
Center on Page. 

FIGURE 6 - 19: Document Page Setup (Center on Page)

c. Push Apply. Score pages in the background update with changes.

NOTE: Each page can be fine-tuned by dragging either of the frame tabs in the left mar-
gin up or down. Use the bottom scroller to view and reposition each page up or 
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down if necessary. Once you are satisfied with the layout of your document, push 
OK.

6.3.2 Changing default margins

Page margins can be changed in the Page Setup window after selecting a layout choice 
and page type/orientation. Changes to margins must be made on a page-by-page basis.

FIGURE 6 - 20: Document Page Setup (Center on Page)

• In Page Setup, change margins of each page by moving tabs inside the vertical and/or 
horizontal rulers.

NOTE: Changing margins is done on a page-by-page basis. Tabs inside vertical and hori-
zontal rulers will affect only the active (highlighted) page. Move cursor over a 
page to make it active. To change width of a single system, see "Vertical Refor-
matting (Line, staff and system spacing using tabs)", Section 6.2, on page 92.

6.3.3 Changing page orientation of an ENF score

To change page orientation of an entire ENF score (e.g. from Portrait to Landscape). 

a. If you are changing layout from Portrait to Landscape, you should increase the 
number of measures per system (e.g. from 4 to 7). If Landscape to Portrait, 
decrease the number of measures per system (e.g. 8 to 4). See "Staff Properties", 
Section 7.3.2, on page 111.
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b. In Page Setup, choose the layout (e.g. Centered) then choose a page type and 
orientation (Landscape or Portrait). 

c. Move the left and right margin tabs to achieve the desired system width / margin 
spacing for each page.

In the page preview, you may see systems too close to the top or bottom of the page. Or 
you may see large gaps at the bottom or top of pages. You will need to change system dis-
tances in these cases. 

d. Push Main View button at the top of the page and zoom out to full-page view as 
necessary. Adjust staff and system distance spacing using the tabs along the left 
margin. For more information on vertical spacing tabs, see "Vertical Reformat-
ting (Line, staff and system spacing using tabs)", Section 6.2, on page 92

6.3.4 Default Page Size and Type

In the English version of SmartScore, the default page size and type is Letter / Portrait. In 
European versions, A4 / Portrait is the default page type. The default for Page Type can be 
reset in Edit > Program Preferences.

To permanently change your default Page Type and orientation,

a. Go to Edit > Program Preferences > Page Type

b. Select “Letter”, “Legal” or “A4” for your default page type / size.

6.3.5 Custom document layouts

Custom document layouts (other than Center to Page) are intended for publishing printed 
scores that will be spiral bound or stitched together. Page margins and system widths will 
be altered depending the page size and orientation of the layout scheme you select. Since 
pages will probably become reformatted, you may see systems move from page to page. 
We recommend that you correct (edit) the full score first while the TIF-ENF panes are still 
synchronized. 

NOTE: In the English version, Page Type size is “Letter”. In European versions, “A4” is 
the default page type. The default for Page Type can be reset in Edit > Program 
Preferences.

• To select an alternative (custom) document layout, 

Select the layout you want to apply from the Document Layout pull-down menu as 
described below:
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6.3.6 Document Layout Defaults

Page Layout: Loose Leaf 
Single-sided pages with music centered in the middle of the page

Page Alignment: Centered
Page Margins: 0.5” Top, Bottom, Left, Right

Page Layout: Loose Leaf with Header Page 
Single-sided, centered pages with first page having a 2” header:

Front Page: Centered
Page Alignment: Centered
Page Margins: 3” Top (1st page). 0.5” inch Top, Bottom, Left, Right (remaining pages).

Page Layout: Facing
Left / Right pages with increased inside margins for binding

Left Page: 1.5” right margin
Right Page: 1.5” left margin
Page Margins: 0.5” Top, Bottom, Side (default)
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Page Layout: Facing with Header Page
Left / Right pages with first page having a 2” header

Front Page: Centered
Left Page: 1.5” right margin
Right Page: 1.5” left margin
Page Margins: 3” Top (1st page). 0.5” inch Top, Bottom, Left, Right (remaining pages).

You may wish to create your own personalized layout and add it to the existing layout 
schemes.

To create a new document layout:

a. In Document Layout pull-down menu, select a Custom Layout (other than Center 
to Page). Push the Add button.

b. Give a name to the new layout.

c. Reset the numerical scrollers on Left, Right, Top and Bottom or simply click and 
drag the margin guides inside the preview window. You may also change page 
orientation and page type from the pull-down menus on the right. 

d. Push OK to create the new layout.

FIGURE 6 - 21: Default Page Margin Control
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6.4 Edit > Format Score

This window provides tools that can reformat the ENF score including line and staff spac-
ing, measures per system and even a tool that re-scales (optimizes) the ENF frame should 
your scanner force re-scaling the image instead of resetting dpi.

FIGURE 6 - 1: Format Score window

• Measures per system
Select a fixed number of measures for every system in the score.

• Apply punctuation
Apply auto-spacing to reformatted measures.

• Setup indents
Set indent for 1st system.

• Setup spacing.
Set staff and system spacing.

• Scale entire score (optimize score size)

Following recognition and before printing, scores can be resized up or down to fit the 
default page size. This is particularly useful when scores were incorrectly scaled by some 
scanners (e.g. all-in-one scanners); correcting overly large-scale or small-scale ENF files.

To rescale the ENF score (optimize page size for printing)

a. Push Find Optimal button in Format Score window. The optimal ENF page 
resize amount is calculated and will appear in percentage window.

b. Push OK to apply change in page size.
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c. Open Page Setup (File > Page Setup) and change Document Layout to “Center 
on Page”. Push Apply to view changes in Preview mode. Push OK to close Page 
Setup.

6.5 Using Score Structure to Extract & Join Parts

6.5.1 Structure and hierarchy

Score Structure (Edit > Score Structure) is a powerful tool that allows you to create 
entirely new scores by removing, creating and re-linking parts. By simply dragging links 
around, you have the ability to remove parts, extract parts and join individual part scores 
into multi-part “conductor” scores. See "Recognition Sequence", Section 3.5, on page 24 
for more info.

NOTE: Using Score Structure is a graphical method for extracting / recombining parts. 
Another method is to use “visibility” control in the Master System. For more 
details, see "Extracting Parts", Section 7.4.3, on page 115

6.5.2 Extracting parts in Score Structure

a. With multi-staff score open in ENF vies, select Edit > Score Structure.

FIGURE 6 - 2: Score Structure (Typical Piano/Vocal Arrangement)

b. To isolate the part/s you want to extract, click on all the parts you don’t want and 
push the “Remove” button at the bottom of the screen.

c. Push Apply to New. The extracted part/s will open in a new ENF document. 
Your original document will remain open and unaffected. 
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6.5.3 Creating a conductor’s score from individual parts

a. An ENF file was recognized from 3 part scores (each having one Part per Score-
Part). A “Score-Part” consists of all the pages of a single instrument in a part 
score. Some Score-Parts may contain more than one Part (a piano Score-Part has 
2 Parts and an organ Score-Part has 3 Parts). Let’s view the structure of a part 
score and then combine all parts into one document. 

FIGURE 6 - 3: Score Structure (Typical 3 Score-Part structure)

To view score hierarchy & create a conductor’s score from score parts, 

b. Click on any Score-Part to highlight it and push the Insert button at the bottom 
of the window. You will see a blank Score-Part appear.

FIGURE 6 - 4: Inserting new Score-Part

NOTE: Inserting a new ENF Document will work just as well. In either case, applying 
the change (Apply to New) will create a brand new ENF document, leaving the 
original file untouched.
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To the left, a new, empty 
Score-Part was Inserted (you 
could also re-link parts to an 
existing Score-Part). Here, 
the new Score-Part is given a 
name (Win: Right-click /
Mac: Option + click to open 
its Properties). To relink any 
structural object, click on the 
object and drag it to another 
object in an adjacent column. 
Here, the three existing parts 
are relinked to the newly cre-
ated Score-Part (named Con-
ductor’s). 

FIGURE 6 - 5: Creating a 
Conductor’s Score

Highlight the unlinked Score-
Parts and push Remove. Push 
Apply to New. The modified 
structure is transformed to a 
new ENF document.

NOTE:Newly-created docu-
ments will have the same 
name of the source file plus 
“1”, “2” etc.

6.5.4 Creating Part Scores from Ensemble Scores

Extracting instrumental parts out of a conductor’s score in Score Structure is similar to 
creating a conductor’s score from score-parts, just reversed. NOTE: All SmartScore files 
(ENF documents) must contain at least one Score-Part linked to at least one Part.

a. Open an ENF file with 2 or more staves per system. 

b. Select Edit > Score Structure.

Naming new Score-Part in Properties

Re-linking Parts to new Score-Part

New Conductor’s Score (Apply to New)
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Here is a typical “ensemble” 
score containing several parts 
linked to it. Since all parts are 
joined, there is only one Score-
Part. 

Click on the empty Score-Part 
and push Insert to create three 
new Score-Parts. Drag each Part 
(child) to new Score Parts (par-
ent) to deconstruct the ENF doc-
ument. Right-click (option + 
click for Mac) in Properties and 
give a name to each. 
FIGURE 6 - 6: Creating Score Parts 

from Ensemble scores

Push Apply to New. This will 
create a new document with 4 
Score-Parts arranged in order (all 
pages of Part 1 first, then all 
pages of Part 2, etc). Playback 
remains synchronized. Again, 
the original ENF document will 
remain open and unchanged.

Inserting New Score-Parts

Naming and re-inking 
Parts to New Score-Parts

Ensemble score having 4 parts
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7) Detailed ENF Editing

7.1 Quick Keys

TIP: Refer to the Quick Keys map (FIGURE 7 - 4:) for a graphic depiction of all 
SmartScore keyboard shortcut keys.

7.1.1 Quick-select (Ctrl + Click)

The fastest way to choose any object for inserting, deleting or changing is to Quick-select
it first. Ctrl + Click on any object inside the active staff and the cursor inherits all of that 
object’s attributes.The cursor becomes any object that is Quick-Selected.

7.1.2 Inserting and changing symbols (“C”)

To insert a symbol anywhere in the active staffline, 

a. Toggle the “C” key to activate the Insert mode.

b. Quick-select any symbol or select it from a tool palette.

c. Click inside the active staff to insert the object. 

To change the rhythmic value of an existing note or rest,

a. Quick-select (Ctrl+click) a nearby note or rest having the desired value. Or select 
a new value from the “Notes” or “Rests” palette.

b. Position the cursor over the symbol to be changed until it highlights yellow. 
Click to change it to the selected value.

NOTE: When you Quick-select on any object inside the active staff, the palette associ-
ated with the object will open.

7.1.3 Deleting notes and symbols (“X”)

To delete an object in the active staff,

a. Quick-select (Ctrl + Click) a note or non-lyric symbol.

b. Press the “X” key and click on any note or non-lyric symbol to delete it.

To delete one or more object using the Select tool,

a. Press the Select tool icon in the Toolbar.

b. Click on an object or drag a region to select one or more objects.

c. Hit the Delete key to delete selected object(s).
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7.1.4 Select tool (“O”)

Use the Select tool to highlight one or more objects for single or mass editing 
functions such as copying, deleting, splitting voices, flipping stem directions and 
joining notes of different voices to a vertical event. The “O” key activates this 
tool. Its button is found in the Toolbar.

TIP: Use the Select tool + Delete key to remove any object other than lyrics and bar-
lines. It is especially useful for removing a large number of spurious or 
unwanted text or multiple objects that do not delete easily with the “X” key. 

To delete one or more objects including notes, rests and symbols,

a. Push the Select tool icon in the Toolbar (“O” key) and click on an object or drag 
to select multiple objects to delete. 

b. Hit the Delete key. 

NOTE: Occasionally, you might find an area full of incorrectly recognized ties and/or 
slurs or hairpins. Use this tool to “mass-delete” these objects.

7.1.4a Cut, Copy, Paste, Insert and Merge selected symbols

Refer to Section 11.3.3 through Section 11.3.5b for details on how to use the Select Tool 
to clone measures or entire score segments and place them elsewhere in the music.

7.1.5 Using the Select Tool (“O”) to edit selected objects

A group of selected notes on the same staff can be transformed into one beamed group if 
they are flagged or they can be pitch-shifted at once.

To convert a sequence of flagged notes into one beamed group,

a. Use the Select tool (“O”) to select a group of adjacent flagged notes to be 
beamed together.

b. Hit the “B” key to form the flagged notes into a beamed group.

To move a selected group of notes upwards or downwards in pitch,

To delete spurious articulations on a page,

c. Use the Select tool (“O”) to select an entire region for cleanup. Edit > Select All 
(Ctrl + A) will select everything on the current page.

d. Hit the “G” key. Only articulations will be deleted. All other notation objects 
remain unaffected.
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7.2 Transposition 

SmartScore offers several types of transposition options depending on your needs. You 
can transpose by key, the most common type of transposition. Transposing by clef is use-
ful for transforming one instrument to another written in another clef sign. You can also 
choose to transpose by altering note pitches only, either considering the active key signa-
ture or by ignoring the active key signature. Using the Limit option, you can choose a 
specified range, part or voice to transpose.

To Transpose your entire ENF document to a new key, 

a. Position your cursor inside the first staffline of the score. Press Ctrl + T / Cmnd 
+ T for Mac or select the Transpose button in the Toolbar or select Transpose
from the Edit menu. The window in Transposition always displays the key signa-
ture or clef sign of the active staff. This is your source key. 

FIGURE 7 - 7: Transposition window

b. Select a new target key or target clef for the score by selecting either the Key or 
Clef tab. Scroll up or down to select a target key signature or target clef.

c. Closest allows SmartScore to automatically choose up or down based on the 
least number of intervals. To choose the direction manually, select either Up or 
Down.

NOTE: It is recommended that you fully edit your score before transposing. If your score 
contains incorrect change-of-key signatures and/or guitar fret and chord symbols, 
it may be hard to Undo properly. Also, the scanned score won’t transpose and 
visual checking of pitches will be difficult after transposition.
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7.2.1 Transposition Strategy

You can choose two “strategies” for transposing your scores: Link Accidentals to Key
and Keep Line-space. 

• Link Accidentals to Key

This choice will consider the target key signature during transposition. If the target key 
belongs to the opposite class than that of the source key (e.g. transposing from a key with 
sharps to a target key with flats), then accidentals may be swapped to their harmonic 
equivalents. 

• Keep Line-Space

This choice will retain exact relationships between intervals after transposition is com-
pleted. Accidentals will generally remain fixed. No attempt will be made to swap har-
monic equivalents of accidentals. For example, c and d# may transpose up to c# and d 
double-#.

• Transpose Symbols

To transpose guitar fret and chord symbols to match the new target key, check this box. 
This selection will also move articulations, such as slurs, up or down along with notes and 
rests. If necessary, guitar fret and chord symbols may move up to avoid collisions with 
upwardly-transposed notes.

• Ask For New Chord Symbol

This option allows you to accept or change each transposed guitar fret and chord symbol 
during transposition. Use this option when you know you won’t accept default fretboard 
patterns or when you know you will need to add new fret and chord symbols to the library.

• Adjust Stems

Stem directions will be maintained unless this box is checked. It is important to remember, 
however, that adjusting the direction of stems may create voicing problems. Automatic 
voiceline recognition relies heavily on stem directions. Flipping stems as they cross the 
mid-staff point can create unexpected results. Best Bet: Adjust Stems = Off. Use Undo 
(Ctrl + Z / Cmnd + Z for Mac) if necessary.

• Move Notes

Uncheck this box to leave the notes in their original positions. This will transpose only 
key signatures, leaving notes unchanged... good for mental games, but not much more.
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• Change Pitch

This transposes notes without changing the key signature. Select the number of half-steps 
to move selected notes (harmonic pitch shift). Pitches are moved by a uniform interval 
while considering the key signature. Change Pitch can be used in conjunction with Limits 
tab.

TIP: To shift the pitch of a small range of notes, it is easier to use the Select tool (O). 
Hold the Shift key down, drag the selected notes up or down.

7.2.2 Limit Transposition

You may limit transposition to a part or voice or to a selected range within the ENF score.

To limit transposition by part, voice or range,

a. Click on the Limit tab at the top of the Transposition window.

FIGURE 7 - 8: Limit Transposition

b. Choose All Parts, or select individual parts by name to transpose. If you select a 
single part, you may also limit the scope of transposition to a single voiceline. In 
the Part Voice box, select the voice to transpose.

c. To limit transposition by range, choose Selected Area (range must already be 
highlighted by the Select tool) or by Measure number.

d. Click OK to transpose with selected limits applied.
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7.3 Score Properties 

The “Score Properties” window contains powerful options for controlling staff and system 
spacing, bracketing and part linking (for re-linking parts in optimized systems). Other 
major editing functions include adding or removing a part (staff) to the score (Section 
7.3.8), adding or deleting a system(Section 7.3.7) and appending a score-part to the ENF 
file (Section 7.3.9).

a. Select “Score Properties” from the FILE menu, Or, with Properties Tool
selected, right-click (alt / option + click for Mac) inside any staff line of any 
system.

FIGURE 7 - 9: Score Properties (Right-click inside staff line)
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7.3.1 Line/staff spacing 

With the Score Properties window open, select “Staff / Line Spacing”. 

FIGURE 7 - 10: Line/staff spacing window

The Spacing window provides a method to make and uniformly apply changes in staff 
and system distances to the remainder of the score. Measurements shown are numerical 
representations of distances for all staff lines the active system. Changes to staff line and 
system spacing can be made on a system-by-system basis using colored spacing tabs along 
the left-hand ruler. See "Vertical Reformatting (Line, staff and system spacing using 
tabs)", Section 6.2.

Here are some practical examples:
• Improve page layout by optimizing number systems in pages. 
• Create piano accompaniments with smaller (reduced) solo parts.
• Create large-notehead (“E-Z Read” format) scores.
• Resize staves converted from TAB to melody and vice-versa.

To numerically change staffline and system spacing,

a. Select FILE > “Score Properties”.Or, Right-click (alt + click for Mac) inside a 
staff line. In Score Properties, choose “Line/staff spacing” among the options.

b. Make changes to staff line distances and to top / bottom staff spacing in the active 
system. Push OK to view changes.
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To apply distance changes to other systems in the score,

a. Once changes in distances are confirmed in the ENF display, right-click on the 
source system and select Staff Line Spacing again to continue.

b. In the Copy Settings To area, select either “Next Systems” or “All Systems”. 
Next Systems will change subsequent systems and All Systems will change all 
systems in the score.

c. Push Copy to apply the changes. 

Push OK to close the window.
• Use the Next System or Previous System buttons to compare settings. To visually 

check changes in the ENF display, push OK and examine changes made.

7.3.2 Staff Properties

With Properties Tool arrow, click into any yellow marker to the left of a staff line. 
Staff properties for that part are shown in the window.

FIGURE 7 - 11: Staff Properties window

Editable properties include:

• Visibility: View or hide active staff line. 
NOTE: Turning off visibility permanently removes all notation symbols.

• Apply Staff Type: Change the characteristics of the staff (e.g. change a “melody” staff 
to a TAB or percussion staff). For information on creating and editing TAB and per-
cussion staff lines, see Chapter 9, "Working with TAB & Drums"
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• Apply Current Line Spacing: Select to apply current staffline spacing to other staves 
in the system or score.

• Set number of Systems: Select number of measures per line to apply to current or 
other systems.

• Apply to: Select which staff lines will have selected property changes applied: Cur-
rent, subsequent (System+) or all (Score).

7.3.3 Bracketing: See "Bracketing", Section 8.4.3, on page 172.

7.3.4 System Manager: See "System Manager", Section 7.4, on page 113.

7.3.5 Part Linking: See "Re-linking parts", Section 4.14, on page 69.

The following sections of the Score Properties window (File > Score Properties) 
addresses adding/removing parts (staff lines), systems, pages and score parts to the score.

7.3.6 Add empty page

This command will append an empty page to the end of the score.

7.3.7 System > Insert above/Insert below/Remove

Select one of these commands to insert a new, empty system above or below the active 
system or to delete the active system. 

NOTE: Added systems will include every part contained in the Super System. See Sec-
tion 7.4.6, "Super System" for details. If it’s necessary, individual parts (staff 
lines) within any system can be optimized or made “invisible”. Refer to “Visibil-
ity” in "Staff Properties", Section 7.3.2 for details

7.3.8 Staff / Part > Insert / Remove

Use to insert a new part into the score or to remove the active staff line from the system. 
The “Insert” command is identical to the “Add Part” button found in the System Manager 
(see "Adding a new part to the score", Section 7.4.5, on page 116). The “Remove” com-
mand removes only the active staff line from the current system. To remove an entire part 
from the score, refer to "Deleting parts", Section 7.4.8, on page 118

7.3.9 Score-Part > Insert above/Insert below/Remove

Select one of these commands to insert a new, empty Score-Part or to remove the active 
Score-Part. A Score-Part is one of a multiple set of pages for a piece that is scored for sep-
arately-sheeted parts. For details, see "Scanning Part Scores (Score-Parts)", Section 3.6, 
on page 28.
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7.3.10 Ossia

Use this tool to delete or insert an ossia above or below the active staff. Inserted ossias are 
editable just as any normal staffline except that ossias are not played back. 

FIGURE 7 - 12: Ossia

To resize an ossia,

a. Hold the Shift key down (Nudge mode) and drag either of the control points at 
either end of the ossia. Barline, key and time signature information is inherited 
from its associated staffline. 

b. Re-space ossias using tabs in the left margin just as any staffline.

7.3.11 TAB

This command opens the “Staff Properties” window and applies “6-string guitar” TAB 

7.3.12 Go to.

• Use this tool to jump to a new measure, page or score part.

7.4 System Manager

Use the System Manager to add, assign or change instrumental parts, change part 
names and to extract parts and voices by controlling visibility. 

FIGURE 7 - 13: System Manager window



The System Manager displays information about what is found in the active system (the 
highlighted system). Changes made can be applied to the current system, current plus sub-
sequent systems, to the entire score or limited to the current Score-Part.

To open the System Manager, 

a. Position the cursor over a given system in the ENF view. 

b. Press (Ctrl+M / Cmnd+M) or select Edit > System Manager from menu. All 
parameters of the active system will be displayed including part name, visibility 
and assigned MIDI instruments.

Parts of the system run vertically along the far left column. Checkmarks identify whether 
parts are “visible” in the active system. Voices run horizontally with checkmarks below 
which identify the status of their visibility. 

7.4.1 Part Names

When a Part Name is selected in the System Manager, playback parameters are inherited 
from Instrument Templates, including pitch shifting of transposed instrument. 

To select a Part Name,

a. Click into a desired instrument name in the Part Name column. Select one of 
preset instruments Notice that MIDI instruments for each voice become updated. 

b. If you wish to add a new part name with a unique MIDI instrument assignment, 
select “Add New Part” from the top of the pull-down list. This will open Instru-
ment Templates and allow you to create a new template, name it and assign any 
MIDI instrument and alter transposition pitch shifting. 

Abbreviated Part Names are shown by default in the first system of the ENF main view. 
To change or remove Part Name display, see "Document Preferences", Section 11.1.1

7.4.2 Assigning MIDI Instruments to Voices (General MIDI Playback only)

Voices inherit MIDI instrument assignments from Instrument Templates initially. You can 
change MIDI instrument assignment for voices (in Voice mode) or parts (Part mode) in the 
System Manager or Playback Console. 

TIP: Assigning each voice a different instrument adds richer sound texture and helps 
in hearing “inner voicings” of the music. Highly recommended for classes in 
composition.

NOTE: Playback Console and System Manager are linked. Changes made to MIDI 
instruments in one environment will update the other. MIDI instrument assign-
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ments in Instrument Templates are not changed automatically. They can only be 
changed manually.

To change MIDI instruments for voices in System Manager, 
• In System Manager, click on any voice of any part and select a new MIDI instrument 

in the pull-down menu. 

NOTE: Changes made to instruments in System Manager or the Playback Console will 
not be applied to playback when the Aria player (VST or AU) is active.

7.4.3 Extracting Parts

NOTE: Part and voice extraction can be accomplished using either System Manager or 
the Score Structure environment, a graphically-based score display. Many find 
Score Structure to be easier to use for part extraction. See "Using Score Structure 
to Extract & Join Parts", Section 6.5, on page 100 for details.

In the System Manager, look for “Visibility” checkboxes along the far left side and along 
the bottom of the list of parts. Checkmarks identify which parts are active (visible) in the 
current system. Individual parts and/or voices can also be made “visible” or “invisible” by 
selective use of these Visibility checkboxes. 

Let’s say we want to extract a contrapuntal voice from the right hand part of a vocal / 
piano arrangement.

To extract a voice from an existing part,

a. Select Edit > System Manager (Ctrl+M (CmndM Mac)).

b. Remove check marks of all parts and voices except for the part and voice you 
wish to target.

FIGURE 7 - 14: Selecting Voices to be extracted

c. Make sure “Visibility” in lower left-hand corner is checked.
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d. Press Apply to New to create a new score, leaving the current file unaffected. Or 
press OK to isolate the part in the open document.

The extracted vocal part from the vocal/piano score will appear like this:

FIGURE 7 - 15: Extracted Voice

7.4.4 Extracting Voices

To extract a voice from the score, 

a. Highlight a visible part by clicking on the dot next to Part Name. 

b. Check or uncheck the Visibility box below the desired voice number depending 
on which voice(s) you wish to extract. 

c. Select Visibility in the Apply field and choose Apply to New from the Apply To
pull-down menu. This will extract all checked parts to a new ENF document 
while keeping the original document unchanged. The Apply option alters the 
current document. Apply to New will create a new, separate ENF document.

7.4.5 Adding a new part to the score

To insert a new part into the score, push the “Add Part” button in the System Manager. 
This is the same as choosing Staff/Part > “Insert” option in Score Properties window (see 
"Score Properties", Section 7.3, on page 109). To restore “invisible” parts to systems, see 
"Restoring a missed or “invisible” staff line", Section 4.13.2, on page 67.

To add a new part to the entire score,

a. Open System Manager (Ctrl+M or select File > System Manager from the 
menu).
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b. Push the “Add Part” button at the upper left corner of the window.

c. A similar, but more detailed window will open. This is the Super System. It rep-
resents all existing parts in the score, whether they’re visible or not in any partic-
ular system. The Super System can also be opened from the Controlling System
pull-down menu in the System Manager.

FIGURE 7 - 16: Creating a new part using Super System in System Manager

d. Highlight an existing part where you want the newly-added part to be placed by 
clicking on the black dot to the left.

e. Choose Insert Above or Insert Below and press “Apply”.

f. The System Manager window will appear displaying the active system and all 
visible parts including the newly-added part.

g. In the “Apply to” pull-down menu, choose how this current part configuration 
will be applied throughout the score: All systems, current system, current system 
plus all subsequent systems, current Score/Part or, in some cases, to the Super 
System.
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7.4.6 Super System

The Super System is a “receptacle” that holds all existing parts in the score. All parts 
(staff lines), whether visible or not, are stored and displayed in this special area. The Super 
System display is found in the System Manager window under the “Controlling System” 
pull-down menu. 

Sometimes “optimized” music is scored for more instruments than may appear in any sin-
gle system of the score. If the total number of possible instruments exceeds even the larg-
est system in the score, parts need to be added to the Super System as described above. 
SmartScore assumes that all possible instruments are equal to the system with the largest 
number of parts. For playback will sound correct, parts in optimized systems need to be 
reassigned to their appropriate instruments. See "Maintaining playback continuity", 
Section 4.13, on page 66 and "Re-linking parts", Section 4.14, on page 69 for more 
details. Parts (staff lines) can be added either from the System Manager or the Staff Prop-
erties window. 

7.4.7 Part Visibility

Any part of any system can be made “visible” or “invisible”. This is called “optimizing” a 
system. This is useful in those sections where a part is tacit or silent for several systems 
and/or pages. Optimizing systems can be accomplished using System Manager or the 
“Visibility” check box in the Staff Properties window (See "Staff Properties", 
Section 7.3.2, on page 111).

To make parts visible or invisible using System Manager, 

a. Make sure Controlling System is Active. 

b. Check (or uncheck) the Visibility box next to each Part Name you wish to affect.

c. Check Visibility in the Apply region below the parts matrix. 

d. Select the option, Apply To = All if you wish the part to be visible or invisible in 
all systems. 

e. Select System if you only want to affect in active system. 

f. Select System + if you want to affect the current and all subsequent systems.

g. Push OK.

7.4.8 Deleting parts

To permanently delete a part from a score.

a. Open System Manager (Cntl + M) and select Super System from the Control-
ling System menu.
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b. Click the dot corresponding to the part you wish to remove. Push Remove.

c. Push “Apply to New” to create a new document without changing the original. 
Otherwise, push “Apply” and “OK”.

Removing a part is not the same as “Part extraction”. To extract a part to a new document, 
see "Extracting Parts", Section 7.4.3, on page 115.

Besides the “Add Part” button, there are two other useful buttons visible in the System 
Manager: Instrument Templates and Format Score...

7.4.9 Instrument Templates

Many characteristics of parts in the System Manager are inherited from Instrument Tem-
plates including part name, abbreviation, MIDI instrument assignment and playback pitch 
transposition. To open, push “Open Instrument Templates” button in System Manager. 
See "Instrument Templates", Section 4.10.2, on page 61 for more details. 

7.4.10 Format Score

Changes to both horizontal and vertical formats can be easily made. For detailed informa-
tion, turn to "Reformatting scores in ENF view", Section 6.1.

7.4.11 Applying changes in System Manager to the score

Changes you make to System Manager will apply to the area of interest you select in the 
“Apply To” pull-down menu:

• System

Applies only to the currently active system.

• System+

Applies to the currently active system and all subsequent systems.

• Score/Part

Applies to the Score or Score-Part.

• Super System (Do not use except in extraordinary cases)

Changes will be applied only to the Super System.

• All

Applies the change to all systems of the score. Select this when you want your changes to 
be globally applied.

Once your changes have been set, select where you want the changes to be applied:

• Apply
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The selected changes will be applied to the currently open ENF document.

• Apply to New

This action will create a new document with your applied changes. The original document 
will remain unchanged.Both ENF documents will remain open. The newly-created docu-
ment will have “(1)” appended to its name.

7.5 Nudge mode (Shift button)

By holding the Shift button down, the display switches to a special edit mode. Active con-
trol points are shown as orange boxes. 

7.5.1 Changing note pitches 

• Click and drag the control point (center of notehead) up or down.

7.5.2 Moving notes and rests horizontally

• Each note contains two horizontal “anchors”; one above the staff and one below. 
Click and drag either control point to nudge a note or rest horizontally.

• To move multiple symbols horizontally, use the “O” key to select the objects. 
Drag the “pull point” of any object left or right.

• To compress or expand symbols within a measure or within an entire staff line, 
refer to "Repositioning measures using barlines", Section 7.5.6.

7.5.3 Resizing beam angles and note stems

• Dragging the endpoint of a beam or note stem will increase or decrease its length.

7.5.4 Repositioning text fields linked to an active staffline.

• All text fields are linked to an active staff line. To reveal the control point for 
each text field, position your cursor over its associated staffline and then locate 
the control point of the text field.

7.5.5 Reshaping arcs and slurs

Slurs (legatos) can be reshaped in two ways:
• By moving end points of the arc or
• By controlling the shape of the curve with either Bezier control handles.

End points con-
trol the place-
ment of the slur.

Bezier handles 
control the shape 
of the slur.
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FIGURE 7 - 17: Reshaping slurs

7.5.6 Repositioning measures using barlines

To horizontally reposition all symbols in adjacent measures:

• In Nudge mode, moving barlines to the left or right will reposition symbols in 
measures adjacent to the barline. Symbols will become more spaced out or more 
contracted depending on the direction. This is helpful when a particular measure 
becomes crowded. Try it! Notice that relative note spacing (punctuation) is 
retained when measures are expanded or contracted. 

To horizontally reposition all symbols in a staff line:

• Moving the barline at the end of a system will compress symbols in the entire 
system and all relative note spacing will still be kept intact. If a barline at the end 
of a system is moved far enough to the left, the first measure of the following 
system will reposition itself to become the last measure of the active system. 

NOTE: For more details, see "Vertical Reformatting (Line, staff and system spacing 
using tabs)", Section 6.2, on page 92.

7.5.7 Special fixes possible with Nudge mode

FIGURE 7 - 18: Improving flagged note positioning by lengthening its note stem

Flagged note in secondary voice After dragging note stem control
causes offset in primary voice. point downward, offset is corrected.
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7.5.7a Fixing offset notes & rests belonging to two voices

Notes and/or rests belonging to different voices (within the same vertical event) will auto-
matically offset when positioned next each other. This is meant to avoid collisions 
between the two. Depending on the situation, readjusting position offset objects is possi-
ble:

FIGURE 7 - 19: Offset due to rests too closely positioned

7.5.7b Fixing beam angles

Beam angles are a function of the length of note stems within the beam. By dragging note 
stems up or down, the angle of the beam will change. Control points at the end of beams 
can also be dragged up or down to adjust overall beam angle.

If a beam collides with note stems or appears at odd angles after moving or deleting notes, 
click & drag the control point on either beam end. Drag beam end until it is properly posi-
tioned. Stems of notes alternate as the beam angle is changed. 

Use the stem-lengthening method to control cross-staff beaming:

FIGURE 7 - 20: Controlling cross-staff beams 

Offset corrected after dragging.vertical proximity. 
Offset rests due to close

Beam colliding with 
note stem

Drag beam control 
point to flip stem direc-
tion

Drag beam control 
point to change beam 
angle
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7.6 Tool Palettes

All notation symbols used in SmartScore can be selected from the Tool palettes. By 
default, up to 3 palettes remain open at one time. Palettes “recycle” by default, but you 
may have all open at once. 

NOTE: Tool palette buttons are expandable. Any button with a small arrow in the lower 
right corner will expand to reveal all possible symbols when held down with the 
left mouse button for several seconds.

FIGURE 7 - 21: Expandable tool palettes

To replace an open Tool Palette with another palette type,

a. Right-click on any open Tool Palette. (Mac: Ctrl + click). 

FIGURE 7 - 22: Tool Palette Selection

b. Click to select an alternative palette.

NOTE: The F1 key (Reset Workspace icon in Toolbar) always resets win-
dows and palettes to their default positions.

To change palette display behavior,

a. Right-click (Ctrl + click for Mac) onto any open tool palette.

b. At the bottom of the Palette window, choose one of 4 alternative modalities for 
palette behavior including:

• Recycle (Default): 
This changes the secondary open palette when a Quick Key is activated. The 
Notes palette remains open and does not cycle.Show All opens all 9 SmartScore 
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Tool Palettes.

• Hide All:
This removes all Tool Palettes from view.

7.6.1 Notes and Rests palette

7.6.1a Inserting Notes and Rests (Numeric keys)

a. Select a note or rest from either of the Notes or Rests buttons located in the 
“Notes” palette. Left-click and hold for two seconds to expand the palette 
revealing all possible notes or rests.

b. Press the “C” key to activate Insert mode. 

c. The cursor will display the selected symbol along with a grey dot which 
indicates the line or space on the staff. Click to insert.

NOTE: Use “Quick-select” (Ctrl+click) to select any symbol on the page, 
including notes and rests, Press any numeric key from 1 through 0 to select 
a particular note value. “Shift + 1-0” will select rests. 

7.6.1b Cluster tool 

See "Editing note clusters", Section 5.2.9, on page 80.

7.6.1c Multi-measure rests 

a. Select the “n-measures” object from the “Rests” palette. 

b. Select the number of empty measures.

c. Click in an empty measure of the active staffline. 

7.6.1d Tuplets (T)

The “T” key opens the tuplet (Rhythmic Groups) Palette. Triplet is selected as the default. 
Drag the mouse to box in the notes/rests to become the selected tuplet. Drag downwards to 
insert the tuplet above the selected notes/rests. Drag upwards to insert the tuplet below 
selected notes/rests. For details, see Tuplets (Section 4.4.1 on page 44)

To delete a tuplet or articulation

d. Ctrl+click on it, press the “X” key then click again on the object. Or use the 
Select tool (“O” key) to highlight one or more tuplets and/or legatos.

e. Once selected, push the Delete key.

NOTE: To resize or move a tuplet bracket, use Nudge mode and drag the control point 
located on either end of the tuplet.
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• User-defined Tuplet

The D:B tool button allows for custom tuplets. 
Divisions = The number of equal beats to be applied to the group. 
Value = The number of note values (if they were not modified) that would be 
applied to give the same duration.

For example: The quintuplet (-5-) has a default D:B ratio of 5:4. When applied to a group 
of 5 eighth notes, its total duration value would equal 4 “normal” eighth notes. 

• Nested tuplets (tuplet within a tuplet)

Choose the value required from the “Rhythmic Groups” palette. Click and drag the cursor 
to select a tuplet group within another tuplet. A bracket will drop identifying the nested 
tuplet.

7.6.1e Beam tool

See "Inserting, changing and deleting beamed notes", Section 5.2.10, on page 81.

7.6.1f Grace Notes

While in Insert mode, select a rhythmic value and press the grace note button in 
the “Notes” palette. Click before any note in the active staff to insert a grace note. 
ENF playback will insert the grace note and truncate the duration of either the 
following or the previous note.

To control how grace notes play back
• Select Edit > Document Preferences > Playback

Change default playback characteristics for grace notes:

• On the beat (accaciatura)
• Before the beat 

• If “Before the beat” is selected and the grace note begins a measure, the grace 
note will have to be placed at the very end of the previous measure. For more 
information, see Grace notes (Section 7.6.1f on page 125)

7.6.1g Dots of Prolongation

• Select the “D” key, dot or double dot from the “Notes” or “Rests” palette. Click 
on any notehead to attach a dot of prolongation.

To delete a dot of prolongation, 
• Press the “D” key again and click on the notehead.
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7.6.1h Ties

Ties connect contiguous notes of the same pitch causing the first note to sound 
for the duration of both notes. Ties are not the same as slurs.

a. While in the Insert mode, hit the “V” key or press a Tie button in the “Notes” 
palette. 

b. Click on the notehead of the first note of a tied pair to insert the tie with a down-
ward arc.

c. Right-click (option + click for Mac) to insert a tie with upward arc. 

d. To delete a tie, hit the “X” key with a tie showing on the cursor and click the first 
note of the pair to delete. 

7.6.1i Accidentals 

FIGURE 5 - 8: Accidentals (in Notes palette)

To insert an accidental, 

a. Select any accidental from the expanding accidental button located in the 
“Notes” palette. 

b. Toggle the “C” key to activate Insert mode.

c. Click on the notehead that is to receive the marking.

To change an accidental,
• Select an accidental from the “Notes” palette. Click on a note with an accidental. It 

will change to the selected accidental.

To delete an accidental, 
• Quick-select (Ctrl + click) any accidental, press the “X” key and click on a notehead to 

remove its associated accidental.

7.6.1j Courtesy accidental tool 

A courtesy accidental is bounded by parentheses and acts as a reminder that a note has an 
accidental.

To insert a courtesy accidental, 

Press the parentheses button when any accidental is selected before clicking a notehead.
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7.6.2 Articulations palette

Articulations affect the playback of selected notes. These include slurs, turns, fer-
matas, mordents, trills, accents and tremolos.

7.6.2a Slur (Legato)

Note durations associated with slurs are increased about 10% giving an overlap-
ping or “connected” effect when played back.

To insert a legato (slur),

a. Push the Legato button in the “Articulations” palette.

b. Drag to select range of notes to be associated with the legato. Dragging down-
ward places the legato above notes. Dragging upward positions legato under the 
notes. 

c. Inserting Slurs and Tuplets (Detail)

Inserting and deleting slurs and ties are very similar. While in the Insert mode, select a 
triplet (“T” key) from the “Notes” palette or select Legato from the “Articulations” pal-
ette. 

FIGURE 7 - 1: Creating a Tuplet or Slur (legato)

a. Click and drag down to insert the tuplet or legato above the notes to be selected.

b. Click and drag up to insert the tuplet or legato below the notes to be selected.

Creating a 
slur

Creating a 
triplet
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To insert expression marks,

Many common expression marks can be inserted as text with the use of Expres-
sion tool. Available phrases can be found in English, Italian, French, German 
with English translation.

FIGURE 7 - 2: Expression Tool

a. Select the EXP (Expression) button.

b. Choose a language and an expression from the pull down menu or type your own 
expression in the text field. Press OK.

c. Position the cursor anywhere in the active staff.

NOTE: Expressions are simple text and have no affect on playback.

7.6.2b Turns, fermatas, accents and mordents (ornaments)

To insert turns, fermatas, accents, trills and mordents,

Ornaments can be inserted above or below notes by clicking the top of a notehead or near 
the tip of note stem.

a. Select the articulation.

b. Click on a note head to insert the articulation above the note head.

c. Click on a note stem to insert the articulation at the tip of the stem.

To delete a turn, fermata, accent or mordent,
• Quick-select the articulation. Or use “O” key to select. Press the “X” key and click on 

the notehead or stem of the associated note. 

• Trill

With tr (trill) selected, click on a note to insert a single trill marking. To create an 
“extended” trill, hold the Shift button down (Nudge mode) and drag the yellow control 
handle on the trill marking to the right. 
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To insert a trill,
• With tr (trill) selected, click on a note to insert a single trill.

FIGURE 11 - 8: Trill and Extended Trill

To create an “extended” trill, 
• Trills have a control handle to the right of the “r”. In Nudge mode, dragging the con-

trol handle to the right will extend the trill’s effect to all notes in the same staff below 
the extension.

FIGURE 7 - 1: Extended Trill

• Turn

Click on note head or note stem apply a turn. Turns play as follows:

FIGURE 8 - 1: Turn

• Fermata (bird’s eye)

Click on note head or note stem to apply a fermata. Tempo is slowed by 50% for the dura-
tion of the note to which the fermata is attached.

• Staccatos

Click on note head to apply a staccato. Duration of the associated note is shortened by 
25%.

• Tenuto

Click on note head to apply a tenuto. Duration of the associated note is extended by 125%.

Trill Extended Trill 
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• Accent

Click on note head to apply an accent. Accent increases the velocity of its associated note 
by 150%.

• Soft Accent

Click on note head to apply a soft accent. Soft accent increases the velocity of its associ-
ated note by 125%.

• Sharp, Flat and Natural

With one of these modifiers selected, clicking on a trill marking will insert the accidental 
above the trill and cause playback of the trill to “flatten”, “sharpen” or “neutralize” target 
pitches while considering the active key signature. 

• Mordent

Click on notehead to apply a mordent. Mordents play back as follows:

FIGURE 11 - 2: Mordent

• Inverted Mordent

Inverted mordent play back as follows:

FIGURE 11 - 3: Inverted Mordent

7.6.2c Tremolo (single, double, triple, quadruple)

Tremolos repeat the note affected by dividing the associated note by four times the 
selected tremolo value.

To insert a tremolo,

a. Select a tremolo from the Tremolo button of the “Articulations” palette. Avail-
able tremolos are single, double, triple or quadruple (Both single or beamed 
tremolos.
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FIGURE 7 - 1: Tremolos (Articulations palette)

b. Click on the head of the note to apply the tremolo value.

c. Adjacent half notes will join to become beam tremolos when the first half note is 
clicked with beam tremolo selected.

NOTE: Beam tremolos will playback only if the applied “half-beam” notes are posi-
tioned in measures as if they were quarter notes.

To change existing half notes to beamed tremolos,
• With a beam tremolo value selected, click on the first of two adjacent half notes. The 

notes will beam with tremolo mark inside.

7.6.2d Arpeggio

Arpeggiated chords will offset the start time of all members of a cluster and will keep 
them sustained throughout the duration of the chord.

FIGURE 11 - 8: Arpeggio

To insert an arpeggio,

a. Select the Arpeggio button (squiggly line) from the palette.

b. Click and drag the mouse to select a chord cluster (can include more than one 
voice).

c. Dragging the mouse in an upward direction will cause the notes to arpeggiate in 
an upward scale.

d. Dragging the mouse in the downward direction will cause the notes to arpeggiate 
in a downward scale. A down arrow is added.

To insert a glissando,

a. Select the Glissando button (two notes connected with a line) from the palette.

b. Clicking on any single (non-chord cluster) note will insert a glissando to the fol-
lowing note belonging to the same voice. During play back, the glissando will be 
heard.

Written Played
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To delete any articulation associated with a note,
• Quick-select the articulation. Press the “X” key, and click on the note associated with 

the articulation.

NOTE: To delete any articulation that is not note-specific, use the Select tool (“O” key) 
to highlight it and hit the Delete key.

7.6.2e Inserting or Deleting Multiple Articulations 

Any articulation can be applied to multiple notes at one time.

To assign an articulation to many notes at once,

a. Use the Select tool (“O” key) then drag to select a range of notes.

b. Select the articulation to be applied to all highlighted notes and insert it to any 
note.

To delete all articulation marks and slurs in a selected area,

a. Use the Select tool (“O” key) to drag a box around the area from which you wish 
to remove articulations.

b. Once the area is selected, hit the “G” key to delete all articulations in the selected 
region.

7.6.2f Glissando

Glissandos connect two adjacent notes into equal steps totaling the combined value of the 
connecting notes.

FIGURE 11 - 9: Glissando)

NOTE: Although it is part of the glissando, the last note always sounds its full value.

Written Played
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7.6.3 Dynamics Palette

Inserting dynamic markings, crescendo & decrescendo markings or hairpins will 
alter the velocity of selected notes in the active staffline. 

To apply dynamics and/or dynamic markings to more than one staff, enter the 
dynamic in each active staff that you wish to apply the effect. If you do not wish 
to have so many dynamics visible in every staffline, you may enter symbols in 
the Hidden Symbols mode. For more details, see "Hidden Symbols", 
Section 7.10, on page 152.

7.6.3a Crescendos and Decrescendos (Hairpin Tool)

To insert a hairpin, 

a. Select a dynamic hairpin from the “Dynamics” palette or hit Shift + “,” for cre-
scendo hairpin and Shift + “.” for decrescendo. 

NOTE: If a similar hairpin is nearby, Quick-select it by holding down the “Ctrl” key and 
clicking on it.The cursor will become that mark. 

b. Click and drag to select notes for which a hairpin is to be applied.

c. Dragging downward will insert the hairpin above the active staff. Dragging 
upwards will insert the hairpin below the active staff.

FIGURE 7 - 1: Hairpin crescendo (drag upwards)

To use keyboard shortcuts for entering hairpins (P, < and >)

• Press the “P” key to select p (piano) dynamic marking and open the “Dynamics” 
palette.

• Hold down “Shift” + “,” to select the crescendo hairpin.

• Hold down “Shift” + “.” to select the decrescendo hairpin.
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To insert a crescendo or decrescendo mark,

a. Select Cresc. or Decresc. from the “Dynamics” tool palette. Or, if the mark you 
want is nearby, Quick-select it by holding down the “Ctrl” key and clicking on 
the marking you want. The cursor will become that mark. 

b. In Insert mode, click and drag the mouse to highlight the range of notes over 
which you wish to apply the dynamic change.

FIGURE 7 - 2: Inserting a crescendo marking

c. Dragging downward while selecting the range of notes will insert the marking 
above the staffline. Dragging upward will insert the marking below the staffline. 

d. To change the range of cresc. / decres. markings, hold the Shift button down 
(Nudge mode) and drag the yellow control handle horizontally. Notes to be 
affected by the mark will highlight in a light grey color.

NOTE: Playback properties of articulations and dynamics may be changed using the 
Properties tool. See "Playback Properties", Section 4.9, on page 54.

7.6.3b Dynamic Markings

To Insert a Dynamic marking,

a. While in the Insert mode, select a dynamic marking from the “Dynamics” pal-
ette. 

b. Click anywhere above the active staff. A change in playback volume (MIDI Vol-
ume) for that particular active staff (MIDI track) then will apply. 

c. Changes in note volumes range as follows:
pppp = 30 / ppp = 40 / pp = 50 / p = 60 / mp = 70 / mf = 80 / f = 90 / ff = 100/ fff
= 110 / ffff = 120.

NOTE: Dynamics apply only to the active staffline. To apply dynamics and/or dynamic 
markings to more than one staff, enter the dynamic in each part in which you 
want the effect to apply. If you do not wish to have multiple dynamics visible, 
you may enter dynamics in the Hidden Symbols mode. For more details see 
"Hidden Symbols", Section 7.10, on page 152.
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To delete a dynamic or tempo marking, 

An alternative is to use the Select tool (“O” key), highlight the mark and hit Delete.

7.6.4 Tempo Palette

Default tempo for all time signatures is 120 beats per minute (120 bpm) except for “cut-
time” and 2/2 time, which play at 60 beats per minute. Tempos can be modified by insert-
ing one or more metronome marks, by inserting a tempo marking or with the ENF Tempo 
Controller.

7.6.4a Metronome Mark 

NOTE: The default tempo of all ENF scores is 120 beats per minute (BPM). Any tempo 
marking (whether recognized or inserted) will over-ride the default tempo. 
Default tempo can be reset by clicking the Default Tempo button in the Play-
back Console or from Default Tempo under the Edit menu. 

To insert a metronome mark or change-of-tempo marking, 

a. Select the metronome mark button in the “Tempo” palette or select a custom 
tempo by pushing the Metronome Mark button at the bottom of the palette.

b. If using a metronome mark, select a new tempo and baseline note value. Preset 
tempo markings ranges from 30 bpm (Lento) to 240 bpm (Prestissimo).

FIGURE 7 - 3: Tempo Change (Metronome Mark) window

c. In Insert mode, click anywhere above the topmost staff of a system to insert 
mark. Tempo will adjust accordingly at that point.
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7.6.5 Tempo Markings

Tempo Markings are found in the “Tempo” palette. Clicking anywhere inside a staffline 
will insert the selected Tempo Marking above the staff. Tempo will be altered at that point. 

FIGURE 7 - 4: Selecting Tempo Markings from Tempo palette

NOTE: Expression markings, found in the “Articulations” palette, are merely descrip-
tors and will not alter playback. 

To edit a metronome or change-of-tempo mark in the score,

a. Select the Properties tool from the Toolbar.

b. Click on a mark in the score to edit its properties. 

FIGURE 7 - 5: Tempo Marking Properties window

7.6.6 Using the horizontal slider, select a new tempo for the mark. Choose 
whether to apply the change to just the single mark, all similar marks or 
permanently apply the change for that mark.

7.6.7 Change of tempo (metronome mark)

Creating a change-of-tempo is accomplished by inserting a metronome mark above the 
staff line where you want the tempo to change. 
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7.6.8 Metronome mark

.The Metronome tool in the “Tempo” palette (also activated in Edit > Default Tempo) 
sets the tempo at the point the mark is inserted. 

FIGURE 7 - 6: Setting Default Tempo 

7.6.9 Ritards, Accelerandos, Descelerandos

Select the appropriate symbol and enter it by dragging the mouse over the range of notes 
you wish to apply the effect to. Use the Properties tool to modify the tempo change over 
the range of notes to which it applies.

NOTE: To view the selected range of accelerando/descelerando, push the Hidden 
Objects button. Range is shown with dotted line.

7.6.10 Tempo controller

Another method to change tempos is to use the Tempo Controller.

To activate the interactive Tempo Controller,

• Push the Tempo Controller button in the ENF Toolbar. Clicking the orange line 
changes the default tempo value. For more details, see "ENF Graphical controllers", 
Section 4.11, on page 63

7.6.11 Clefs and Signatures (Key and Time) palette

To insert a key or clef signature,

a. Hold either the “Treble clef” button or “4/4” button down for a few seconds and 
select the appropriate key or time signature from the palette.

b. Click at the beginning of the staff (or part) to which it applies. 

NOTE: Key signatures for that part will automatically update in all subsequent systems 
up to, but not including, any change-of-key signature should any occur. Clefs 
signs are not automatically updated but can be cloned using the “Unify” com-
mand. 

7.6.11a For time signatures, see "Unify Time Signatures", Section 7.8.4b, on 
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page 145

7.6.11b For key signatures, see "Unify Key Signatures", Section 7.8.4a, on 
page 145

To change an existing key or time signature to another signature, 

Entering or changing any time signature automatically updates time signatures in all parts 
of all systems; up to the first change-of-time signature if one exists. Entering or changing 
key signatures must be done one staff at a time. 

a. Quick-select (Ctrl+click) a desired key or time signature nearby or select a new 
signature from the tool palette.

b. Click on a highlighted signature to be changed. 

NOTE: The key of C major (A minor) does not have a visible sign to indicate its pres-
ence. If no key signature is visible in the first measure of the ENF display, the 
key signature will be C major (A minor) by default. 

To create a custom time signature to Insert or Change,

a. Select the Custom Time button from the “Signatures” palette

b. Using numeric scrollers, select a new numerator (beats per measure) and a new 
denominator (note value receiving the beat).

c. Click to insert signature immediately following any barline.

To insert a new key or time signature in the body of a score, 
• With a time or key signature selected from the “Signatures” palette, Insert mode, click 

to the right of any barline.

NOTE: The score will be parsed from the insertion point. Error measures likely disappear 
after correcting the new time signature.

To insert a new key or time signature at the end of a system:

According to the conventions of music notation, a change-of-key or a change-of-time sig-
nature that begins on a new line should also be indicated to the right of a barline at the end 
of the previous system. 

FIGURE 7 - 7: Time Signature at the end of a system
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To delete a signature
• Quick-Select a key or time signature. Hit the “X” key and click on the signature to 

delete it.

• To prevent the last measure from rolling to the next line, avoid deleting the final 
barline of any system.

a. Note positions do not move when a clef sign is changed. To change a clef while 
keeping original note pitches of a part or selected region, note positions must be 
shifted. Refer "Transposition by Key and Clef", Section 5.4.

a. Select a clef from the Clefs palette. 

NOTE: Left-click and hold on any palette button with a small arrow for 2 
seconds to expand it and reveal all symbols of that class.

b. Click anywhere in the active staff to insert the selected clef. 

7.6.11c Alto / Tenor / Mezzo-soprano (“C”) clefs

The midpoint of the “C” clef indicates where C below middle C (MIDI C3) is to be 
located.

7.6.11d Treble Octava / Bass Octava clefs

Playback in these clefs will be an octave higher than with a standard clef.

7.6.11e Treble Octavo / Bass Octavo clefs

Playback in these clefs will be an octave lower than with a standard clef.

7.6.11f Percussion clef

When the Percussion clef is inserted into a staff line, MIDI channel assignment 
of the staff switches to 10; the default drum channel. Notes are entered normally, 
but playback as MIDI drums. Note pitch-to-MIDI drum assignments are mapped 
in Drumset option under the Playback menu.

7.6.11g Octava / Octavo tools

These are not clefs per se. Rather than insert with a mouse click, they are applied to 
selected notes by dragging to select the notes to be modified. Playback of selected notes 
will be an octave higher when selecting with Octava tool and an octave lower when 
selecting with Octavo tool.

To assign Octava or Octavo to a range of selected notes

a. Select either Octava or Octavo tool. 
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b. Drag the cursor to select notes in the active staff.

FIGURE 11 - 8: Octava

Notice that the Octava or Octavo mark will appear at the beginning of the range of 
selected notes an the applied range will be indicated by a dashed line above the selected 
notes.

7.6.12 Barlines palette (I)

To change or delete a barline, 

a. Select a desired barline from the “Barlines” palette or Ctrl+click on a barline 
nearby. 

b. Click on a yellow-highlighted barline to change it to the selected barline.

c. To delete a barline, Quick-select it, press the “X” key and click on the barline. 


7.6.12a Deleting / changing barlines at the end of systems.

Deleting a barline at the end or beginning of a system will cause that measure to roll to the 
next system. Follow this step to delete or change a barline type that ends or begins a sys-
tem...

To change a barline at the end of a system to another barline type,

a. Insert the desired barline type to the left of the barline that you wish to remove.

Delete the barline (“X” key then click). The measure will shift slightly to the left 
but not roll to an adjacent system. For details on repeats and jumps, see 
"Repeats", Section 4.6, on page 49 or "Jumps", Section 4.8, on page 52.
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7.6.13 Text and tools palette

7.6.13a Text

Selecting the Text button sets the cursor to the Text Edit mode. See "Text 
mode", Section 8.2, on page 164.

7.6.13b Lyrics

Selecting the Lyric button sets the cursor to the Lyric Edit mode. See "Lyrics", 
Section 8.1, on page 162.

7.6.13c Guitar Fretboard

Selecting the Guitar chord fretboard button activate the “Insert Guitar Chord” cursor. For 
details, see "Guitar Fret and Chord Symbols", Section 8.3.1, on page 166.

• Rehearsal

Ten Rehearsal Markings can be placed anywhere in the ENF view.

• Pedals

Four Pedal Markings can be placed anywhere in the ENF view.

• Bowings

Two Bowing Markings can be placed anywhere in the ENF view.

• Breaths

A Breath Marking can be placed anywhere in the ENF view.

7.7 Keyboard Shortcuts

7.7.1 Unify (U)

See "Unify (U)", Section 7.7.1, on page 141 or "Unify Score (“U”)", Section 7.8.4, on 
page 144

7.7.2 Dots (D)

Hit the “D” key. This toggles between Insert a dot and Delete a dot modes. Notice how 
the cursor alternates between a solid insert dot and grayed-out delete dot.

Any note or rest may be selected with dots of prolongation assigned to it. Select a note or 
rest from the appropriate palette, then click on the single or double-dot button inside the 
palette. In Insert mode, the new note/rest will have a dot. 
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7.7.3 Ties (V)

Hit the “V” key. This toggles you between the solid Insert tie and grayed-out Delete tie 
modes. To tie two contiguous notes of the same pitch, click on the first note. The “V” tie 
tool will also insert multiple ties from one chord cluster to the next as long as note pitches 
match. 

NOTE: To over-ride default arc direction, insert ties with a right-click (option + click for
Mac). Inserted ties will have reversed arc directions.

To insert only one tie at a time, select the single tie button from the “Notes” palette.

7.7.4 Beam direction (A)

With any single flagged note chosen, hit the “A” key. This toggles between Left beam, 
Middle beam and Right beam directions.

7.7.5 Stem direction (S)

The “S” key changes the default note stem direction. When inserting a note, toggling the 
“S” key reverses the stem direction of an inserted note. 

Default stem direction of an inserted note is determined by its vertical position on the 
staff. Stem direction of inserted notes automatically changes when the cursor crosses the 
middle line of any staff. 

To place a note with a stem in the opposite direction of the cursor, 
• Hit the “S” key to flip the stem on the cursor. Or right-click while inserting a note 

(option + click for Mac).

To change the stem direction of an existing note,
• In Insert mode, right-click on any given notehead (option + click for Mac). The stem 

direction of the note will become flipped.

NOTE: In general, Voice #1 should have stems up and Voice #2 should have stems down.

To change the stem direction of several notes at once,

a. Hit the “O” key to activate the Select tool.

b. Click and drag a box around any series of notes.

c. Press the “S” key to reverse the stem direction of the highlighted notes.

To change the stem direction of ALL notes in the document,

a. Select Ctrl+A (Select all in document).

b. Press the “S” key to reverse the stem direction of every note with a stem.
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7.7.6 Voice Splitting (Select + “H”)

To split two-note clusters into two independent voices,

a. Hit the “O” key or Select button to activate the Select tool.

b. Select Ctrl+A (Select all) to highlight all symbols in the document.

c. Press the “H” key. This will separate two-note clusters into 2 voices.

FIGURE 7 - 1: Splitting two-note chords into 2 voices

TIP: Only two note clusters will split. If you wish to split clusters containing three or 
more notes, delete the least desirable note(s) from the cluster (“Z” key and “X” 
key) until you are left with two notes in each cluster. 

NOTE: You can select multiple clusters on the page using the Selector Tool or using 
“Select All” (Ctrl + A or Edit > Select All).

7.7.7 Part Linking (Ctrl+L)

a. Mis-matched parts can be properly reassigned with Part Linking. In addition, 
“orphan” staff lines can be reconnected to their proper system using this tool. 
With your cursor positioned over the system of interest, press Ctrl+L (Win) / 
Cmnd+L (Mac). An alternative method is to select the Properties Tool and right-
click (alt / option for Mac) over any staffline in a system that requires re-linking 
and select “Part Linking”. This will open the Re-link Parts window.

FIGURE 7 - 2: Re-link Parts window
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7.8 Navigator

7.8.1 Open (Ctrl+O / (Cmnd+M Mac)

Push to open / import a file compatible with SmartScore. Select SmartScore 
(ENF), Image (TIFF, BMP, PCX), XML or MIDI file from “Files of Type” pull-
down menu. Same as File > Open.

7.8.2 Scan

Push to initiate scanning. Same as File > Scan Music > Acquire.

7.8.3 Recognition

Push to initiate recognition on any pre-scanned image. Same as File > Recog-
nize.

7.8.4 Unify Score (“U”)

Unify updates key and time signatures, clef signs and staff spacing throughout 
the score based on choices made in the dialog window.

FIGURE 7 - 3: Unify Key, Time and Clefs

TIP: Check part linking (Ctrl + L) before applying Unify when editing optimized 
scores.

If your ENF score contains collapsing and expanding systems, it is recommended to per-
form Part Linking before Unifying. Unifying signatures and clefs will maintain part link-
ages as set in Logical Part Linking. Refer to "Re-linking parts", Section 4.14 for more 
details.
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7.8.4a Unify Key Signatures

• Based on topmost staffline. (Default)

All key signatures for every part are updated based on signatures found in the first staf-
fline of each system. Any change-of-key signs found in the topmost staffline will update 
subsequent stafflines within each system. Use when systems have the same key signature 
in each part.
• Based on 1st system.

All key signatures in every system are updated based on signatures found in the first sys-
tem on the first page. Any subsequent changes in key signatures will be removed. Use to 
unify scores that have transposed instruments with a fixed number of parts per system. 

NOTE: Manually edit key signatures when scores contain:
a) Transposed instruments AND change-of-key signatures
b) Transposed instruments AND have optimized systems.

7.8.4b Unify Time Signatures

All time signatures are updated based on signatures found in the first system on the first 
page. Change-of-time signatures are removed in any subsequent systems. Use when no 
change-of-time signatures occur.

7.8.4c Unify Clefs

All clef signs are updated based on clefs found in the first measure of the each system. 
Any change-of-clef found inside systems are removed. Use if many false change-of-clefs 
were recognized or if very few change-of-clef signs are found in the original.

• Parse every measure (Default)

Clefs are updated on a line-by-line basis. Change-of-clefs encountered updates each staf-
fline until another change-of-clef is encountered. Use when many change of clefs are writ-
ten into the original score.

7.8.4d Unify System, Staff and Line Spacing

Distances between systems, staves and line will be universally applied throughout the 
score based on:
• the active system (default)
• the first system of the score
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7.8.4e Do not launch Unify after recognition

Select the option if you choose not to have Unify open automatically after recognition is 
completed.

7.8.5 Setup

Opens Page Setup environment for page printing alignment & margins. For more details 
on Page Setup, see "Custom document layouts", Section 6.3.5, on page 96.

7.8.6 Print Preview

Use to check for proper page layouts. Also seen in Page Setup view.

7.8.7 Score

Push to create ENF score from scratch. Choose ENF score template from “System Type in 
Score” pull-down menu. Same as File > New > New ENF. To copy regions or pages of an 
existing ENF document to a new one, see "Copying a SmartScore page for pasting into 
other programs", Section 5.7.2, on page 88.

7.8.8 Record 

Push Record button to initiate MIDI Recording. All open ENF documents are closed 
when MIDI recording is launched. A MIDI Piano Roll view opens with Track 1 
staged for MIDI recording through an external MIDI device. Identical to Real-time > 
Record in MIDI View.

7.8.9 Karaoke View

Push to enter Karaoke playback environment. 

7.8.10 MIDI View (Ctrl + I / Cmnd + I for Mac)

Push MIDI button to view score in MIDI environment. Use also to change from one 
MIDI view to another; e.g. to change from Overview to Piano Roll view. Choose 
Overview or Piano Roll or Event List for a selected Part. Same as View > New MIDI 
View. ENF view remains open until or unless recording is initiated. To revert back to 
ENF view, close the open MIDI view. 

7.8.11 Tiling 

Viewing several displays of your score can be extremely useful. It is possible to view sev-
eral MIDI and ENF views simultaneously.
Using to SmartScore X2 146



• Push Tile button to display all open TIF/ENF views along with any open MIDI Over-
view, Piano Roll or Event List views. This is identical to selecting the Window > Tile 
menu.

FIGURE 7 - 4: Tiled view (typical)

7.8.12 CD Burn

Push this button to create a .WAV file of the ENF playback and/or burn to CD.

NOTE: DVD-Audio write devices must be located on the system. Some external devices 
may not be discoverable. In these cases, create the .WAV file and then use CD / 
DVD-R or CD / DVD audio burn software.
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7.8.13 Auto-Beaming

With Auto-Beam selected, beamed notes will automatically form into common 
groups based on the active time signature and standard notation beaming rules. 
Auto-Beam defaults to “off” after recognition. 

• To automatically insert and edit beams into preformed groups. 

• Push Auto-Beam button in the Toolbar

• Select a note value from the Notes palette.

• With any beam tool selected, clicking from left-to-right, will create beamed 
groups into pre-determined sets. 

7.8.14 Auto-Spacing

With the Auto-Space button selected, notes and rests will insert proportional to 
their relative value within a measure. After recognition, Auto-Space defaults to 
“off.” 

7.9 Working with Contrapuntal Voices

Each staff line has the potential of containing up to four contrapuntal voices. Contrapuntal 
voices are organized into “threads” (voicelines). See "Voices and Playback", Section 4.5, 
on page 45 for more about how voices affect playback.

To view contrapuntal voices as separate colors, 

• Push the Voice Visibility button in the Toolbar. 

7.9.1 Voice color

Contrapuntal voices display as one of four possible colors (Voice 1= black, Voice 2 = red, 
Voice 3 = green and Voice 4 = blue). Normally, you will see black (Voice 1) and red (Voice 
2). 

7.9.2 Overriding voice color assignments

Voice color/number assignments can be changed manually.

To override default voice color of a note or rest (change voice number),

a. Select desired voice number (and color) from Voice Tool combo button in the 
Toolbar.

b. Locate the note or rest for which you want to change voice color. 
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c. Click on a note or rest to change it to the selected color and voice. 

Voice color is automatically determined based on several factors (number of voices, stem 
direction, number of beats, vertical alignment, etc.) You can override voice colors manu-
ally. Changing voice color may change voice colors of other notes in a given measure.

NOTE: Do not override voice colors until a measure is entirely edited. Unusual color 
combinations usually correct themselves automatically after a measure is cor-
rected.

To vertically align offset voices, 

a. Use the Select tool (“O”) to highlight offset notes and/or rests.

b. Press the “Y” key to group the selected, offset notes into a single vertical event. 
Selected voices will move slightly.

FIGURE 7 - 5: Correcting offset voices not “glued” after recognition.

Similarly, if you see notes bunched together each displaying different colors (usually 
black and red and sometimes green), but which actually belong to only one voice, they are 
probably “glued” to the same vertical event. Joined notes can be “unglued” as follows:

To “Unglue” offset notes not intended to play simultaneously,

a. With the Select tool (“O” key), carefully select the incorrectly glued notes 
(NOTE: they will each have different colors). Be sure to select only the notes 
which are incorrectly joined.

b. Hit the “Y” key. Joined notes will separate and change color.
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7.9.3 Checking vertical alignment of voices

Measures with notes and rests that are incorrectly aligned will become highlighted reddish 
(“error”). In addition, all notes and rests that are glued will move together when dragged 
left or right in Nudge mode. 
• Hold the Shift button. Click and drag note control point to verify.

FIGURE 7 - 6: Using Nudge mode (SHIFT) to check vertical alignments

7.9.4 Swap position of note heads (Select + “L”)

Occasionally, you will want to swap the horizontal positions of a pair of joined offset 
notes. This can easily be done by selecting a vertically aligned pair with the Select Tool 
(“O”) and hitting the “L” key. The relative positions of these joined notes will be swapped 
without altering voice color or playback.

FIGURE 7 - 7: Note head swapping

7.9.5 Cross-staff voicing

Occasionally, notes of one voice may “visit” an adjacent staff. Technically, visiting notes 
belong to their “home” staff, but they obtain their pitch information from the visiting staff 
line.

To create cross-staff voicing, 
• Make sure the note to be moved across staff lines has its stem in the correct orientation 

(Select + “S” to change stem direction). Hold the Shift key down and drag the note-
head to the desired pitch of an adjacent staff. If cross-staff notes belong to a beamed 

Note heads
before swap

Note heads
after swap
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group and the beam does not interfere with the movement of the notehead, simply hold 
the Shift button down and drag the notehead into the adjacent staff to its desired pitch. 

FIGURE 7 - 8: Cross-staff voicing 

• Notes positioned in a “visiting” staff still belong to the “home” staff. To edit or move a 
note positioned in an adjacent “visiting” staff, press the Caps Lock key while the 
“home” staff is active. Press Caps Lock again to unlock the active home staff.

NOTE: Cross-staff indicator lines can be either solid or dotted. These attributes can be 
changed in Edit > Program Preferences > Systems > Cross-staff voicing line 
style.

To control cross-staff beams (beam collisions and flipped stems)
• If a beam collides with note stems or appears at odd angles after moving notes, hold 

Shift down (Nudge) then click & drag the control point on either beam end. Drag 
beam end until it is properly positioned. Stems of notes alternate as the beam angle is 
changed.

FIGURE 7 - 9: Controlling cross-staff beams 

7.9.6 Cross-measure beaming

To create a cross-measure beam,

a. Insert a flagged note on either side of a barline.

b. Use the Select tool to highlight both notes and hit the “B” key.

Beam colliding with
note stems.

Drag beam control point
to alter stem orientation

Drag beam control point
to change beam angle
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7.9.7 Overlapping or offset noteheads

Two notes in different voices can share the same pitch at the same time. You can choose 
whether note heads of different voices should overlap one another or become horizontally 
offset. 

To allow offset note heads, 
• Check off “Overlap Notes” in Edit > Document Preferences > Score Symbols > 

Overlap mode. Playback will not be affected whether note heads are offset or overlap.

7.10 Hidden Symbols

You can insert any symbol and have it hidden from normal view as well as keep-
ing it from being printed. You may need to add a extra rests for correct playback, 
but you don’t not want them all to be visible. Another example would be 
“implied” triplets... you may want to show only the first few and “hide” the rest. 
Hidden Symbols will also display the range of certain symbols such as 8va, 8vb,
ritard, accelerando or descelerando. Holding the SHIFT button down will also 
display effective ranges for these symbols (see "Pitch shift (Nudge mode)", 
Section 5.2.1, on page 77

To insert a hidden notation object,
• Push the Hide/Show Symbol button in the Toolbar. Insert any notation object nor-

mally. Symbols entered in Hidden Symbols will appear as a lighter color than when 
entered normally. 

In the following example, the measure in question has only 1 beat written into the upper 
part and 2 beats written in the lower part. Inserting 2 hidden rests in the upper and one hid-
den rest in the lower corrects error.

Recognized measure 
(w/ cross-staff voice)

Corrected measure 
(w/ rests placed in Hidden mode)
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To view ranges of dynamics and tempos,

a. Push the Hide/Show Symbol button. Dynamics or tempos which were applied to 
a range of notes will appear as follows:

FIGURE 7 - 10: Hidden range of an accelerando

Push again to exit Hidden Symbols mode. “Hidden” symbols do not appear in normal 
mode and will not print.

7.11 More ENF navigating

7.11.1 Split-screen and scan view reference views

Both the ENF view (white) and the image reference view (yellow) appear in “split screen” 
format immediately following recognition. Alternative reference views include a floating 
“Scan view window” and “Overlay with fader” feature (Mac only). 
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NOTE: After reformatting a system, page or score, the floating scan view window will 
automatically open. 

FIGURE  7 - 1: Scan Reference Views

To choose an alternative reference view,

a. Go to View > Split Screen and select an alternative reference view option.

Mac Only: Try the TIFF / ENF transparency overlay with fader.

To view a variable ENF transparency over the TIFF pane,

a. Go to View menu and select “Split Screen > Overlay”.

b. Use the variable transparency fader to the right of the Toolbar to adjust the 
opaqueness of the top ENF pane.

To activate the floating Scan View window,

a. Go to View menu, select “Scan View Window”. 

b. To increase or decrease zoom view of the window, choose either Zoom 25% or 
Zoom 50% from the View > Scan View window. 

Default Split Screen Floating Scan View window

TIFF / ENF Transparency Overlay (Mac only)
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7.11.2 Scrolling

Use the scroll bar and up/down arrows to the right of the ENF window. You may also use 
the arrow keys located on your computer keyboard to scroll up, down, left, and right in an 
ENF document.

7.11.3 Paging

To page forward or backward in an ENF document, 
• Use the “Next page” / “Previous page” buttons located in the Toolbar or push the 

double paging arrows at the lower right-hand corner of the SmartScore window.

7.11.4 Jump To Page: (Ctrl +G or Cmnd+G for Mac)

While editing, you can go to any page or measure in ENF file. 

To open the GoTo… window 

a. Choose the View menu and select Go To... (Ctrl+G or Cmnd+G for Mac).

FIGURE 7 - 2: Go To window

b. Select whether it is a Part, Page or Measure you wish to jump to.

c. Enter the Part, Page or Measure number.

Checking the Open Target in New View box will open a new ENF at the targeted Part, 
Page or Measure. Push OK to jump.

7.12 MIDI to ENF

SmartScore accepts any Standard MIDI file and converts it to an ENF file. Since 
printing is disabled, SmartScore MIDI Edition does not include MIDI to ENF.

To create an ENF document from a MIDI file,

a. Select File > Open and change the file type pull-down menu from SmartScore 
Files to MIDI Files. All MIDI files in the given directory will appear in the 
selection window. Double-click on a selected MIDI file to open.
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b. The Playback Console window will appear with a MIDI Overview representation 
in the background. To hear the file playback, push the Play button in the console.

c. To convert the MIDI file into SmartScore notation, push the Close button in the 
Playback Console. Closing the console will begin the conversion process. 

FIGURE 7 - 3: MIDI to ENF window
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• Staff Voicing

Choose the number of contrapuntal voices you wish to see in the converted ENF file. 

NOTE: It is unusual to have more than 2 voices in most music. For neatness sake, 1 or 2 
voices is a goo

• Density
• Measures per System determines the number of evenly spaced measures per 

system. Automatic is recommended.
• Systems per Page determines the number of evenly spaced systems per page. 

Automatic is recommended.

• Quantization

SmartScore can quantize the MIDI file that will be converted. Each note event will “snap 
to” the nearest beat boundary eliminating fluctuations in the timing of a MIDI perfor-
mance. 

MIDI files created with “free tempo” (rubato) will probably have many irregular note 
divisions and odd-looking timing as SmartScore attempts to “compartmentalize” notes 
“off-the-beat”.
• Check None to prevent the application of quantization.
• Use Note On/ Note Off to determine the smallest rhythmic values used to when spell-

ing note start times (Note On) and end times (Note Off) in the ENF document.
• Use Note On/ Note Duration to determine the smallest rhythmic values used to when 

spelling note start times (Note On) and the minimum length of each note (Note Dura-
tion) in the ENF document.
• Shorten each note to the last Note Duration value.
• Lengthen each note to the next Note Duration value
• Justify each note to the nearest Note Duration value.

TIP: If the resulting ENF file has many stand-alone flagged notes, try reducing the 
Quantization value (e.g. to 1/8th notes).

• Divide By Beats: When ON, resulting ENF file will interpret measure lengths by 
number of beats and insert change-of-time signatures if beats of each measure do not 
correspond to the default time signature. Turn OFF to lock default time signature.

• Smooth Voices: When ON, contrapuntal voices will be interpreted as continuous lines 
whenever practical. When OFF, contrapuntal voice will be interpreted loosely.
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7.13 Troubleshooting ENF Problems

Table 1: Troubleshooting ENF Problems

Problem Probable Cause Fix

Notes and symbols 
appear as large letters.

Font association lost. Reinstall Chopin10 font. 
Font is located in the 
SmartScore directory.

Measures outlined in a 
red color.

Incorrect rhythm in one 
or more voices.

Edit voicelines to agree 
with time signature.

Pickup or closeout mea-
sure highlights red & 
doesn’t play smoothly.

Voiceline durations do 
not agree with the current 
time signature

With Properties tool 
selected, click on barline 
that begins the measure. 
Select “As written”.

Only one system high-
lights black at a time.

View active staffline is 
ON (default selection).

Check off View Active 
Staffline in View menu.

Measure remains high-
lighted but measure plays 
back smoothly.

Secondary voice may be 
truncated (not fully com-
pleted in the measure).

This is a common con-
vention in music notation. 
May be left as is.

Can’t delete an object 
when “X” key is pushed.

Actual object must be 
selected first.

“Ctrl + click” the object 
before deleting. Or, sim-
ply use the Select tool 
(“O” key) & drag around 
an object then hit Delete.

New note is inserted 
when trying to change an 
existing note.

Existing note was not 
highlighted yellow when 
clicked.

Yellow-highlighted notes 
will be changed to new 
value. Blue inserts new 
note at same time slice.

Measures unexpectedly 
roll from one system to 
another. 

Barlines at the end or 
beginning of measures 
may have been deleted.

Restore the number of 
measures per system by 
opening Staff Properties 
with Properties tool.

Systems unexpectedly 
roll from one page to 
another.

Line, staff or system 
spacing may have been 
changed.

Readjust spacing tabs in 
left margin until systems 
are restored to page.
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Staffline missing from 
system

Staffline cut off or during 
scanning or was not 
localized during Recog-
nition.

Restore missing staff. See 
"Restoring a missed or 
“invisible” staff line", 
Section 4.13.2, on 
page 67

Wrong part suddenly 
plays.

Expanding / collapsing 
score; Part / instrument 
linking lost.

Reassign parts in system. 
See Section 4.14

Display shows notes as 
brightly colored or with 
green vertical lines or 
with a solid orange hori-
zontal line along the staff 
line.

ENF display is in Hidden 
Objects, Tempo or Veloc-
ity controller mode.

Exit Hidden mode. See 
“Hidden Symbols” on 
page 152, “Velocity Con-
troller” on page 64 or 
“Tempo Controller” on 
page 64.

Table 1: Troubleshooting ENF Problems

Problem Probable Cause Fix
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FIGURE 7 - 4: Quick Keys Map (Windows)
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FIGURE 7 - 5: Quick Keys Map (Mac)
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8) Editing Text, Lyrics & Symbols

This section covers editing text, lyrics and chord symbols. SmartScore attempts 
to distinguish between “dumb” and “smart” text when music is recognized. 
Dynamic and tempo markings written as text are “smart” as are chord symbols. 
Annotations, rehearsal markings and fingerings are “dumb”. 

8.1 Lyrics

A lyric “block” is a string of characters equivalent to a spoken syllable. Out of recogni-
tion, a lyric block becomes associated with a single note or rest in the staffline immedi-
ately above it. Locating the note or rest associated with a lyric block is as simple as 
searching directly above the center-justified lyric block. All lyric blocks within stafflines 
are horizontally linked and are separated from each other by dashes, underlines and/or 
periods. 

NOTE: Text and lyrics have different colors. Text is black, lyrics are blue. Text and lyric 
colors are changeable.

NOTE: Lyrics sometimes appear below a system (e.g. some choral scores) and a special 
option should be selected before Recognition. See Lyrics Under Last Staff of 
Systems in "Recognition Options", Section 3.5.1, on page 25.

TIP:Move notes in Nudge mode (Shift) to verify lyric-to-note associations.

To edit lyrics,

a. Push the “L” button in the Toolbar to enter Lyric mode. 

b. Click into a lyric block or on an associated note or rest. Once highlighted, text 
within the block can be edited like normal text.

c. Click and drag inside a lyric block to highlight characters for editing. Use the left 
arrow, right arrow or spacebar on your keyboard to navigate within a lyric 
block. Once positioned, type normally. 

d. Characters can also be cut, copied or pasted to other lyric blocks using standard 
Ctrl + “X”, “C” and “V” keyboard shortcuts (Cmnd + “X”, “C” and “V” for 
Mac).

e. To edit a lyric block below the current line of lyrics, click into the topmost line of 
lyrics and use the down arrow key. Cursor will enter the next block in lyric line 
immediately below. 
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f. To create a new lyric line, hit Return anywhere in a lyric line. A new lyric line 
will be created at the first note of the system. 

g. Push “L” again (Toolbar) to exit Lyric Edit.

To move lyrics up or down between staves,

a. Hold the Shift key down (Nudge mode), locate the yellow control handle along 
the left-most barline of the system.

b. Drag the control handle up or down to move entire lyric block.

FIGURE 8 - i: Nudge mode - repositioning Lyrics

TIP:You may also change lyric font size. See "Adding and changing styles of Text 
and Lyrics", Section 8.2.2, on page 165.

8.1.1 Dashes, spaces and underscores

Dashes, spaces and underscores are special characters used to separate lyric blocks. Typ-
ing any of these characters will move the cursor to the next block. The Backspace key 
deletes dashes, spaces and underscores.

In the following example, the block “der-” was missed in recognition. The cursor was 
positioned at the end of the previous block. A dash was entered to create a new “syllabic” 
block and the correct text was then entered. 

FIGURE 8 - 2: Editing Lyrics

• Dash = Moves the cursor to next lyric block and inserts a dash. Normally used to con-
nect multiple syllables within a single word.
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• Space = Moves the cursor to the next lyric block. Normally used to separate words. 
Does not insert a dash or an underline.

• Underline = Normally used as a “miasma”, an underline indicates that one vocal 
sound should be extended over two or more beats. Inserting creates an underline up to 
the next block. Entering multiple underlines will string them together over several 
lyric blocks. 

• Backspace = Deletes characters inside a lyric block. Also deletes hyphens when back-
spacing from one lyric block to the next.

• Enter = Creates a new lyric line and positions cursor in the first lyric block below 
beginning note or rest of the staffline.

8.1.2 Verifying vertically aligned voices

Nudging note heads horizontally is a good way to verify that a particular lyric block is 
indeed associated with a note stem. In a similar way, Nudge mode is useful in verifying 
that vertical events are properly aligned. Refer to "Checking vertical alignment of voices", 
Section 7.9.3 for more information.

To verify vertical alignment of two or more voices in Nudge mode,

Horizontally nudge the upper note (Voice #1) of a vertically aligned set of notes and/or 
rests. All vertically aligned (joined) notes or rests will move together.

8.2 Text mode

8.2.1 Entering and editing text

To enter Text mode for editing or creating “dumb” text,

a. Push the “T” button in the Text and Controller Toolbar. 

Text fields are associated with the nearest staffline. To ensure text is associated 
with a particular staff, move the cursor over the staff first.

b. Click anywhere and begin typing.

NOTE: It will not be possible to do other sorts of editing other than text or lyrics in either 
of these modes. It will be necessary to push “T” or “L” again to exit the mode 
first.

To edit a text field,

a. While in Text mode, click anywhere inside a text field.

b. Drag left or right to highlight one or more characters within the field. Typing will 
replace the characters. Hit the Delete key to remove highlighted characters. Text 
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can also be cut, copied or pasted elsewhere using standard Ctrl +“X”, “C” and 
“V” shortcuts (Cmnd+ “X”, “C” and “V” for Mac).

To delete text fields,

a. To delete more than one text field, use the Select tool (“O” key) to select and 
highlight text in yellow. Hit the Delete (Del) key removes all highlighted text 
fields. 

b. Quick-select (Ctrl+click) any text field, hit the “X” key (cursor goes grey) and 
click again on any text field to remove it.

8.2.2 Adding and changing styles of Text and Lyrics

Out of recognition, text and lyrics are matched to the closest font type and size available. 
You can modify the font type, size and color of all text or lyric styles. Changing the style 
of the lyric block will change ALL lyrics because lyric have only one style and text fields 
can be assigned many different styles.

FIGURE 8 - 3: Changing Text and Lyric styles

.To modify font styles of text fields and lyric blocks,

a. Push the “T” button to enter Text mode. Click into any text field. While the cur-
sor is blinking, right-click (alt/option + click for Mac) to open the Style window.

b. For lyrics, push the “L” button and click on either the associated note or rest or 
directly into a lyric field. Right-click to open the Style window (alt / option + 
click for Mac). 

The current text style will be highlighted in the Text Style window. 

c. Click on the style you wish to change. Select “Modify Style” and enter new font 
characteristics and push “OK”.
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You may also add a new style to the list for continued use later.

To add a new style, 
• Select “Add style” and enter new font characteristics. Push “OK” and then give it a 

name (e.g. “Fingering”).

NOTE: The styles window is also accessible by pushing the “Text Styles” button in File 
> Document Preferences.

8.2.3 Nudging text

To nudge text,

a. Hold the Shift button down to enter Nudge mode.

b. Each text field has a small yellow box to its left. 

c. Click and drag the box to reposition the text field to where you want it. 

To move multiple text fields,

a. Use the Select Tool and drag the cursor to highlight a multiple text fields. Release 
the mouse button. Selected text fields will turn from yellow to green-grey. 

b. Hold the Shift button down to activate Nudge mode.

NOTE: Dragging one control box of a highlighted text field will move all selected text 
fields together

8.3 Music Symbols

8.3.1 Guitar Fret and Chord Symbols

Guitar fret diagrams are recognized automatically. Chord symbols written as text 
can be recognized and automatically converted to fret symbols when Recognize 
Text Symbols as Chords option is selected prior to scanning. See "Recognition 
Options", Section 3.5.1, on page 25. When transposing key signatures, fret sym-
bols transpose and root names will automatically be updated. 

8.3.2 Choosing a fret / chord symbol from the library,

If no chord or fret symbol was recognized, one can be selected and inserted using the Gui-
tar Chord Library (GCL).

a. Push the fretboard button in the Toolbar or Ctrl + click on any chord symbol 
nearby.

b. Click above the topmost staff where you want the symbol to be inserted.
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c. The Guitar Chord Library and editor will open. 

FIGURE 8 - 4: Guitar frets and chord symbols library

d. Select a Root chord. Add a Sharp, Flat, Tonality, Extension and Augmenta-
tion as necessary. 

e. If the selected chord name matches one stored in the library, a corresponding fret 
configuration will appear in the right window. 

NOTE: If there are multiple fret configurations for the same chord name, the box next to 
Primary will be checked. Use the Index scroller to search for alternatives.

f. Push OK. The fret / chord symbol will appear where you previously clicked.

8.3.3 Changing Chord and Fret symbols

If a fret / chord is incorrectly recognized, you can quickly fix it; often by acquiring the 
value of a nearby chord which is correct.

To copy the value of one fret / chord symbol and apply it to another,

a. Ctrl + click on a chord symbol that is identical or similar to the correct chord 
name. That chord’s configuration will be inherited and stored by the cursor.

b. Right-click (Option + click for Mac) on the chord symbol that you wish to 
change. The stored (correct) chord will then appear in the Guitar Chord Library. 
If you are satisfied with the naming and fingering of the displayed chord, push 
OK. The correct configuration will be applied to the old chord.
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To change an existing chord by selecting one from the library,

a. Select “Guitar Chord Library” from the FILE menu. Or, Ctrl + click on a chord 
symbol to be changed. Click on the chord again to open the Guitar Chord 
Library.

b. Change the root chord, tonality or other extension. Fingerings associated with the 
selected configuration will appear in the diagram to the right.

c. Click OK once you have found an acceptable chord name / fingering configura-
tion. The chord will become updated.

If you are unhappy with the fingering diagram or fret positioning of any particular chord, 
you can permanently change it.

To change the fingering configuration of an existing fret symbol,

a. Push the Change button in the main GCL window to open the Change Guitar 
Chord editor.

b. Select the Frets tab to open the fingering and frets editor. Edit options are as fol-
lows:.

FIGURE 8 - 5: Guitar Chord Library - Fingering Editor

• Right-click (Option + click for Mac) on any finger marker inside the fretboard to 
remove it.

• Clear All (grid) removes all current finger markers in fretboard.
• String Marker (dot) places a finger marker on any string between frets on the fret-

board. Clicking above the fretboard nut (thick line) places an open string symbol (open 
dot) at any string position.
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• Barre Marker (arc) places a barre marker above the fretboard by dragging above the 
nut. When dragged across strings inside the fretboard, the barre marker is positioned 
between frets.

• Mute-string marker (x) places an X above any string position to indicate a muted 
string. When clicked above the nut, any finger marker of that string is deleted.

• For banjo, ukulele, bass or other non-six string fretted instrument or for chords that 
require more range than 4 frets, choose the configuration you wish from Strings x 
Frets combo box.

• To show fingerings in other than 1st position, choose from Position Selector. The 
solid line represents the fret position.

c. Once changes have been made, push Done. The original configuration will be 
permanently replaced when you press OK. If you made a mistake, push Cancel 
and try again.

8.3.4 Creating a new chord symbol / fret configuration

If the particular chord symbol or fingering configuration you want does not exist, you can 
add it to the chord library.

a. Push the Guitar Chord button in the Toolbar. The cursor will become a grid. 
Click where you want to insert a new chord above a staff line. (Be sure the cor-
rect staff is “active”)

b. In the main GCL window, select a Root chord name. Add Sharp, Flat, Tonality, 
Extension and Augmentation. If the selected configuration does not exist, no 
diagram will show.

c. Push the Add button to open the Add Guitar Chord editor.

d. Make chord configuration selections in the Label tab and desired fret and finger-
ing settings in the Frets tab.

e. Once changes have been made, push Done. In the main GCL window, push OK
is drop the new chord in place.

8.3.5 Adding additional fret configurations to the library

You may wish to add alternative fingering configurations to other chord symbols which 
share the same chord name. Also, following recognition, you may see some fret symbols 
without chord names. These can also be configured and added to the library.

To add alternative fret configurations to the Guitar Chord Library,

a. Ctrl + click on any existing chord symbol or push the fretboard button in the 
Toolbar so the cursor becomes a grid. 
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b. Click on top of any fret symbol or click anywhere above a staffline to open the 
chord library.

c. Push the Add button in the main GCL window to open the Add New Chord edi-
tor.

d. Make chord configuration selections in the Label tab and desired fret and finger-
ing settings in the Frets tab.

e. Push Done. A notice may appear telling you that another fret configuration with 
the same chord name exists. When asked if you want to add the new chord to the 
library, select “Yes”.

8.3.6 Guitar Library file management

To export, import, reset or clear a GCL library file, 
• Press File in the Chord Library window. The Library Management window will 

open.
• Export Library will save the current set of chord and fret configurations to your 

hard drive as a .GCL file.
• Import Library will load a saved guitar chord library from a directory and/or 

drive. Locate the .GCL file and push OK to load.
• Reset to Default will reload original guitar chord library as initially loaded dur-

ing installation.
• Clear All Chords deletes all current guitar chord library data.

8.3.7 Chord Symbol Preferences

To modify how all chord symbols appear in the ENF view,

a. Open the Chord Symbols tab in Edit > Document Preferences window. Change 
the default appearance of chords as follows:

FIGURE 8 - 6: Guitar Chord Preferences
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• Chord Symbol Appearance: Show Fret & Chord names / Frets only / Chords only / 
None

• Long Tonality: Check this off to display Major tonality as “M” and Minor as “m”.
• Guitar Chords Scale: Use the scroller to increase or decrease the size of all fret / 

chord symbols. Scale by percentage.
• Chord Name Font Style: Change the default font, style and size for chord symbol 

names.

b. Press Apply or OK to apply and close.

8.3.8 Editing chord and fret symbols in ENF

To Copy and Paste any fret or chord symbol,
• Ctrl + click on the chord symbol you wish to copy. With your mouse, click anywhere 

to paste the symbol you just clicked on. The Guitar Chord Library will open to confirm 
your choice. Press OK to insert.

To delete existing chord symbol(s),
• Hit the “X” key and click on the symbol you wish to delete. To remove several fret 

symbols at once, use the Select tool (“O” key) to highlight as many fret symbols as 
you wish and hit the Delete key.

To move one or more chord symbols,
• Use the Select tool (“O” key) and highlight one or more fret symbols. Hold the Shift 

key down (Nudge mode) (Shift) then drag the control point of any fret symbol. This 
will move to all selected chord symbols.

8.4 Non-musical Symbols

8.4.1 Using Text and symbols to mark up scores

Solo guitar, violin and other scores often contain many annotations and fingerings. Most 
can be entered using score symbols and even rehearsal markings.

To annotate fingerings and string numbers,
• Use Text mode to enter fingering numbers. If the default text size is too large, add and 

use a new text style with a smaller font (see "Adding and changing styles of Text and 
Lyrics", Section 8.2.2, on page 165)

• Use Rehearsal marks to enter string numbers with in circles. 
• Use Nudge mode (Shift) to position inserted symbols exactly.
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8.4.2 Document Preferences

Non-lyric and non-text symbols (e.g. dynamic and tempo markings) which appear as text 
are also editable. Default font, size and behavior of symbols can be changed in Document 
Preferences.

To edit Text Symbols,

Open Edit > Document Preferences. The Text Symbols tab appears as follows:

FIGURE 8 - 7: Document Preferences > Text Symbols tab

To edit Score Symbols font characteristics,

Open Edit > Document Preferences > Score Symbols tab.

8.4.3 Bracketing

Instrument families are grouped with the use of brackets. Grand staff and braces 
are recognized whenever possible. Use Bracketing to assign braces, grand staff 
brackets and to join selected parts into barline groups in an ENF document. This 
feature can be also be used to change the behavior of brackets and barlines. For 
example, barlines can be separated by stafflines and/or by instrument grouping.

To break barlines between stafflines

a. Select Bracketing from Edit menu (Ctrl + B (Cmnd + B Mac).
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b. Select “Break barlines by staff”. Click “OK”.

FIGURE 8 - 8: Bracketing window

To create braces, grand staff brackets and create barline groups,

a. Highlight two or more parts in list to select for grouping.

b. Choose Brace, Grand Staff or Barline Group set and press Set Sel.

c. Continue to select parts for any other type of group. Any selected group can 
overlap parts of another selected group.

d. Click “Break Barline by Brackets” checkbox to have barlines break according 
to instrument families which are already designated by braces, groups and grand 
staffs.

e. Choose Clear Sel or Clear Selected Parts in selected group or Clear All to 
remove groupings.
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8.4.4 Score Header

Score headers are not considered “text”. They are unique tags.

To enter a Score Header at the top of the first page of the ENF file,

a. Select Edit > Score Header.

FIGURE 8 - 1: Score Header

a. Enter a name for the ENF document in the Title field.

b. Enter a Composer name if desired. 

c. Type a part name if it is a Score-Part. For definition, see Score-Part on "Score 
Formats", Section 12.1, on page 239.

To move a Score Header vertically,
• With Selector tool active, drag the positioning tab associated with the score header 

found in the left-hand ruler up or down.
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9) Working with TAB & Drums

SmartScore supports recognition, editing and playback of percussion and tabla-
ture parts. Any existing part (or staff) can be transformed to and from a variety of 
staff types including TAB, percussion and standard notation. Individual MIDI 
sounds are linked to all staff lines & spaces. Drums and percussion instruments 
can be re-linked using the Drum Map editor. Playback can also be enhanced by 
adding automatic drum styles. New rhythmic styles can easily be imported, cre-
ated and added to the drum styles library. 

9.1 Recognizing music with TAB or Percussion parts

a. In the Options section on the left side of the "Begin Recognition” window, check 
the box: Recognize tablature, percussion and/or split systems. 

NOTE: If your score contains a 4-line part, SmartScore will, by default, consider it to be 
a TAB staff. If in fact it is a percussion part, be sure to check the box “Convert 4-
line staffs to percussion”. Staff types can be changed after the recognition, but all 
notation will be lost when converted.

FIGURE 9 - 1: Recognition - Selected Files / Options / Preview

9.2 Converting staff line types

You may convert staff properties simply by choosing an alternative staff type. For exam-
ple, you may want to convert a line of standard notation (melody) to guitar TAB (6-string 
guitar). Or reverse it: change TAB to notation. This is all done in Staff Properties.
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To change staff property types), 

a. Select the Properties Tool then click on the yellow arrow to the left of the staff 
you wish to change.

FIGURE  9 - 1: Staff Properties: Changing staff type

b. Check the “Apply staff type” box and choose a new staff line configuration from 
the list of available staff types in the pull-down menu.

c. Choose how to apply the change in the “Apply to” pull-down menu: 
Entire part, Current staffline or system, All parts in all systems, System + (active 
system forward). Push OK to apply the change.

NOTE: It is recommended to correct mis-recognized symbols before changing the staff 
height since this could cause the TIFF / ENF screens. to go out of sync. In that 
case, the floating scan window opens so you will still maintain some reference.

9.3 Working with tablature (TAB) parts

Parts written in TAB format are automatically recognized if the option “Recognize TABs 
and Percussion Staff Lines” is selected prior to recognition (see "Recognition Options", 
Section 3.5.1, on page 25). TAB scores are edited in a similar fashion as standard ENF 
notation. Parts written in standard notation (melody staff) can be converted to the TAB 
format. Recognized TAB music can also be converted to standard notation. Converting 
one to the other is done in the Staff Properties window. See "Converting staff line types", 
Section 9.2, on page 175.
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9.3.1 Tablature notation display in SmartScore

Tablature notes (fret numerals) are displayed as numbers on top of a string line (6 lines for 
guitar). The number represents the fret that string is to be played (with “0” representing an 
open or unfretted string). SmartScore uses an unique notation convention that not only 
displays the rhythmic value of each TAB numeral, but also its voicing. Note duration val-
ues (rhythmic cues) belonging to Voice 1 appear above the staff. Rhythmic cues belonging 
to Voice 2 appear below the staff (in red).

FIGURE 9 - 2: SmartScore TAB notation (typical)

9.3.2 Change fingering configurations

Changing fingerings is easily done in Nudge mode. Moving a fret numeral to a new string 
automatically updates its fret number.

To reassign a fret numeral to another string

a. Hold down the SHIFT button (Nudge mode).

b. Drag the handle of any fret numeral to an adjacent string.
The number will automatically become updated to reflect its new finger position. 
Its playback pitch remains the same.
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9.3.3 Editing TAB symbols

To enter a fret numeral inside a TAB staff, 

First select a note value: Ctrl + click on any nearby note with the desired value or select 
that note value from the Notes palette. Position the cursor on the line you wish to enter a 
numeral and left click to enter the numeral as Voice 1. Right-click to enter the numeral so 
it is assigned to Voice 2 (red / below staff).

NOTE: To add a TAB numeral to an existing chord cluster, position the cursor inside the 
vertical line of numerals until they highlight blue, then click to insert.

To change the fingering of any TAB numeral, 

Enter Insert mode by hitting the “C” key or selecting the “Insert” button from the lower 
Toolbar. Click on any numeral until a red box (numeral editor) appears. Enter a new num-
ber. 

NOTE: You will have 4 seconds to enter a new number before the numeral editor 
becomes inactive. You may change the default time period by going to Edit > 
Program Preferences > Tablature > Timer.

To change the rhythmic value of a TAB numeral, 

Ctrl + click on any nearby note with the desired value or select that note value from the 
Notes palette. Click on the rhythmic value displayed directly above or below the numeral 
you wish to change. Horizontal note spacing will automatically be adjusted. Measures 
with rhythmic errors will highlight in pink, exactly as “melody” lines behave. To interpret 
pink measures, see Section 5.2.2, "Rhythmic errors" on page 77

To change to voicing of a TAB numeral, 

You must first delete the numeral by hitting the “X” key and clicking on the numeral. Hit 
the “C” key to enter Insert mode and select the correct note value, if necessary. Position 
the cursor where you want to insert the numeral and right-click to insert it as Voice 2 (red) 
or left-click to insert the numeral as Voice 1 (black).

To delete a TAB numeral, 

Simply hit the “X” key and click on any numeral. This action will delete both single TAB 
numerals and numerals in chord clusters.
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9.3.4 Creating a guitar TAB staff below a melody line

You may wish to duplicate a part written in standard notation and have it display 
as guitar tablature. Or you may wish to take a guitar solo written in tablature and 
have it also display as standard notation. It’s simple...

To duplicate a notation staff and transform it to a TAB staff,

a. Open any ENF score. Go to Edit > Score Structure. 

b. Click on the box that represents the part you wish to copy. Push the “Duplicate” 
button. The new part will appear below the original box. Click on the newly-cre-
ated part and drag left to create an “association” line to the ENF Score Part box 
next to it. Select “Apply to New”. A new ENF document will be created, leaving 
the original unchanged.

c. In the ENF view, you will see the duplicated part beneath the original part. With 
the Properties Tool selected, click on the yellow triangle to the left of the new 
part. Select “5-line guitar TAB” from the Staff Type pull-down menu and unify 
staff and line spacing as described in 9.2 on page 175 and “Tablature notation 
display in SmartScore” on page 177.

To reverse the process (duplicate a TAB staff and transform it to standard notation), follow 
the same steps above but instead, choose “6-line melody” from the Staff Type pull-down 
menu.

After converting a “melody” to a “TAB” staff, you may want to change the fingering. 
Refer to "Change fingering configurations", Section 9.3.2, on page 177 for details.

9.3.5 Unifying TAB line distances and line spacing.

After converting “melody” to “TAB” or vice-versa, you may want to change line distances 
and unify those changes for a clean look.

To resize the TAB spacing and apply it to the entire part,

a. Position your cursor over a TAB staff line and manipulate the red (distance) and 
blue (line space) tabs per Section 6.2. The next step will unify all TAB staffs.

b. Select “Staff Spacing” from the FILE menu. Or, select the Properties Tool and 
right-click into the staff that has been altered. Choose Line/Staff Spacing. 

c. In the “Copy settings to” menu, select “All Systems” and push “Copy”. 

d. Push “OK”. All staves belonging to that part will adjust.

An alternative method for “unifying” layout is as follows:
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a. With your cursor over the modified staff line, hit the “Caps Lock” key to lock in 
focus on that staff. 

b. Push the “Unify” button in the Navigator (“U” key). Select “Unify System, Staff 
and Line Spacing” (Based on active system). Push OK.

c. Hit the “Caps Lock” key again to release the active system.

9.4 Editing and creating percussion parts

9.4.1 Editing a percussion part

SmartScore recognition acquires and reconstructs variable-line staves when “Recognize 
TAB and percussion staff lines” option is checked in the Begin Recognition window (See 
"Recognition Options", Section 3.5.1, on page 25).

To edit recognized notes on a percussion staff,

a. First, check that the number of lines of the percussion part is correct: If incorrect, 
you may change the number of lines as described in Section 9.2, "Converting 
staff line types". 

b. Then ensure that the percussion part has correct number of lines in all systems: 
Select “Staff Spacing” from the FILE menu. Or, select the Properties Tool and 
right-click into the percussion staff. Choose Line/Staff Spacing. In the “Copy 
settings to” menu, select “All Systems” and push “Copy”. When done, push 
“OK”. All percussion staves belonging to that part will become updated.

c. Edit drum notes exactly as any normal “melody” staff including note duration 
value and pitch. A MIDI drum instrument is associated with every line and space 
and will sound as you Shift + drag notes up or down. If necessary, you may need 
to reassign MIDI drum sounds using the

9.4.2 Playback > Drumset

To reassign drum instruments to percussion staff lines...

a. With Property Tool active, click in the yellow arrow associated with any percus-
sion staff.
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b. Push “Percussion Map” button in the Staff Properties window to access the 
drum instrument map.

FIGURE 8 - 1: Drum-to-pitch links (Drum Set) 

c. Click on a drum instrument name and drag to a new line or space. If another 
instrument is linked to the line or space, it will unlink.

d. Clicking and dragging a line or space to an instrument name will also create a 
new link and delete any existing link.

e. Press OK to finalize changes. Press Cancel to undo changes.

NOTE: Accidentals are ignored regardless of the key of the score. 

9.4.3 Creating a percussion staff from scratch

a. Position your cursor inside the staff line where you wish to insert a new percus-
sion line and right-click (Ctrl + click for Mac). 

FIGURE 9 - 1: Staff Line Options (Right-click)
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b. Select Staff > Insert (above or below).

c. See "To change staff property types),", Section , on page 176 to change the part 
from notation to percussion.

d. Select eighth note from “Notes” palette and using beam direction tools, create 
the following pattern. Hit Spacebar to play back.

FIGURE 9 - 2: Creating a drum pattern

NOTE: Simultaneous drum sounds must be contained in the same voice. Therefore, you 
will need to use the Cluster tool to add additional drum “note heads” to an exist-
ing note stem. Holding down Shift and dragging a notehead up or down will 
allow you to hear each drum sound associated with each space and line.
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9.5 Automatic Drum Patterns

It’s more fun if it’s got a beat! Simply select a drum accompaniment or you can add cus-
tomized patterns to the drum library yourself.

9.5.1 Play back with automatic drum pattern

To select an instant drum pattern for ENF playback,

a. With any ENF file open, click on the Drum Pattern button in the Toolbar.

b. Sort each column by clicking on its name in the column header.

FIGURE 9 - 3: Automatic Drum Track Window

c. Click on a pattern that matches the time signature and style of your ENF file. 

d. Choose a starting measure in the “from measure no.” field and push the Insert
button.

e. To enter another drum groove at another location, repeat steps c. and d. above.

f. If you wish to mute drum playback for one or more measures, select the starting 
measure and push the “Insert Silents” button.

NOTE: Insert Silents are automatically inserted if the Begin and End points of 2 or more 
patterns are not sequential.

g. Press OK to accept the selection.

h. Press the spacebar to hear your file playback with drum accompaniment.
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To Remove a drum pattern from the library, 
• Locate the Styles folder inside the SmartScore application folder and delete the .ssd

file you wish to remove.

9.5.2 Adding custom drum patterns from ENF

The drum pattern library is expandable. You can add new patterns that you have either cre-
ated yourself or imported from a MIDI file which contains a drum track on MIDI Channel 
10.

To add an ENF drum pattern to the automatic drum pattern library,

a. Open an ENF file which contains a percussion part (written with a percussion 
clef) or, 

b. Open an ENF file in which you have created your own drum pattern. Refer to 
"Creating a percussion staff from scratch", Section 9.4.3 for more information on 
how to create drum patterns. 

c. Click the MIDI button in the Navigator to open the MIDI Overview. See 
Section "Selecting MIDI views", Section 10.1.1, on page 187 for more 
details on changing MIDI views.

d. Select Edit > Create Automatic Drum Pattern.

FIGURE 9 - 4: Creating a drum pattern from a MIDI file

e. Locate the track in which the drum is played and select it in the Track field. Note 
that MIDI drums will sound only if they are assigned to MIDI Channel 10. 

NOTE: To check the channel number of a track, right-click (alt + click for Mac) next to 
the track number in MIDI Overview then select Piano Roll. The channel number 
(and its color) will appear in the upper left corner of the Piano Roll View. Close 
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the Piano Roll window to return to Overview window. Another option is to sim-
ply open the Playback Console (Ctrl + 9). Next to each track number listing is a 
colored box containing the MIDI channel number assigned.

f. Enter the name you wish to give the pattern in the Name field.

g. Select a musical style to classify the new pattern and enter it in the Style pull-
down menu.

h. Locate the first measure where you wish the pattern to begin and enter it into the 
Beginning Measure field.

i. Decide how many measures you wish the pattern to contain and enter it in the 
Length (in Measures) field. This is a very important decision if you want to have 
proper-sounding patterns. 

j. Click Generate to add the pattern to the library. It’s name will then appear in the 
Automatic Drum Pattern window.

TIP:Add “fills” to longer patterns (8 or 12 measures). Repeated fills in patterns hav-
ing 1 or 2 measures usually sound dumb.

• Importing MIDI drum patterns

a. Push the Open button in the Navigator (File > Open) and click 
to select MIDI from the “Files of Type” pull-down menu. 
Browse to a MIDI file containing a drum track and double-
click.

b. Push the Play button to hear the MIDI file play back. Push Close.

c. The imported MIDI file will appear in the MIDI Overview window. 

d. Repeat the process from Step d) above.

9.6 Virtual Drum Kit

This option allows you to create a drum track to accompany any ENF playback without 
requiring a drum machine or any other external MIDI device. It maps selected MIDI drum 
sounds to the keys of your computer keyboard. MIDI quantization to sixteenth notes is 
applied by default. For more information about quantization, see "Snap to", 
Section 10.8.3, on page 208.

9.6.1 Recording a virtual drum track

To create a virtual MIDI drum track,

a. Open MIDI View.
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b. Right click inside any number the Track Number column. Select “New Track”.

c. A MIDI Record view will open. Test drum sounds by hitting the center keys on 
the two front rows of your computer keyboard.

d. When ready, hit the Record button. You will hear a metronome sound for one 
measure. Playback and drum recording begins.

e. Hit Stop when finished. Close the MIDI window to return to ENF.

9.6.2 Defining Virtual Drum Kit

To change a MIDI drum and link to your computer keyboard,

a. Select Options > Virtual Drum Kit Definition

FIGURE 9 - 5: Virtual Drum Kit Definition

b. Click on an instrument / key in Instrument list.

c. To reassign a MIDI drum instrument, push Change Instrument and make 
another MIDI drum selection in the pull-down menu.

d. To reassign a keyboard key for that instrument, push Change Key and press any 
keyboard key to be linked to that instrument.

e. When finished, press OK.

To add a MIDI drum and link it to your computer keyboard,

a. Push Add.

b. Press a key to become associated with the sound. 

c. Select a new drum sound from the pull-down menu.

d. When finished, press OK.
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10) MIDI Editing and Sequencing

Underlying MIDI data of an ENF score can be viewed and manipulated in one of 
three MIDI views: Overview, Piano Roll and Event List.

10.1 MIDI Views

10.1.1 Selecting MIDI views

To open MIDI environment from ENF and select a MIDI view, 

a. Press the MIDI button in the Navigator or choose View > New MIDI View
(Ctrl +I / Cmnd+I (Mac)). 

The New MIDI View Window will open.

FIGURE  10 - 1: New MIDI View

b. In the Type window, select the type of MIDI view desired, Overview, Piano 
Roll or Event List).

• Overview

This view displays all MIDI tracks (parts) found in the open Score-Part.

• Piano Roll

This view displays all MIDI note events found in the selected track.

• Event List

This view lists all MIDI events and every detail associated with them.

The above MIDI view buttons are accessible from the MIDI Toolbar.
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10.1.2 MIDI Toolbar

The MIDI Toolbar (View > Toolbars > MIDI Toolbar) includes buttons for opening 
Overview, Piano Roll, Event List views. Also visible are the Shuttle tool, Record, Record 
to New Track, Record Virtual Drum, Delete Track and Insert Instrument Change buttons.

FIGURE 10 - 2: MIDI Toolbar

10.1.3 Closing MIDI Views

Each MIDI view (Overview, Piano Roll and Event List) has its own “close” 
icon in the upper left-hand corner of the window. Click to close an active MIDI 
view window. Or select File > Close. Closing the last MIDI view will return dis-
play to its associated ENF view.

10.2 Track Overview

Overview provides a “bird’s eye view” of all existing MIDI tracks. Some editing 
functions are limited

FIGURE 10 - 3: Track Overview window

10.2.1 Selecting tracks and MIDI events

Right-clicking (option + click Mac) into a track’s Name field in Overview will display the 
track properties. Double-clicking into a track’s Name field will open its Piano Roll view.

FIGURE 10 - 4: MIDI Track Properties
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No
Rec
The Track Properties window allows for editing of the Track Name and its Transposition. 
It is also used to create new MIDI tracks. Push Piano Roll or Event List buttons to view 
selected track in one of these views. 

NOTE: The Transpose selection window will actually move all the note events of the 
selected track by half steps.

• New Track will create an empty new track.
• Selecting Duplicate Track will create an exact copy of the active track and insert it at 

the bottom of the track listing.
• Delete Track will erase the highlighted MIDI track completely.

10.3 Playback

10.3.1 Spacebar

• Press the spacebar to Play. Press again to Pause. Press again to resume Play. Press the 
comma key (“,”) to Rewind to the start.

10.3.2 Mini-Console

The Mini-Console is a dock-able (tear-off) Toolbar that plays, records, rewinds 
and stops playback. 

FIGURE 10 - 5: Mini-Console Transport

The “spring-loaded” tempo slider will increase or decrease tempo speed depend-
ing on the distance it is pulled from the center. Releasing the mouse will return 
playback tempo to the default speed.

• Play button initiates/resumes playback of the active MIDI file. Once playback 
has begun, the Play button becomes Pause. Use this button to retain MIDI data 
after returning to ENF display.

• Stop button stops playback/recording of the MIDI. Play/Record is re-initialized 
at 0 (rewinds to the beginning).

• Rewind button resets playback to the beginning of the range.
• The Record button will be active only when a MIDI Out device is selected. Push-

ing the Record button will create a new MIDI track and will launch a new record-
ing session. When Record is lit, press Play button to begin recording a new MIDI 
performance to a new track. When recording to a new MIDI track, existing MIDI 

 MIDI
ording
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data, instruments, channels and transpositions of the original ENF or imported 
MIDI file will be maintained.

NOTE: All playback functions are also available in the Realtime menu (in MIDI) or
Playback menu (in ENF).

TIP:To select an entire track for cutting and pasting, go to Overview and click 
(option + click for Mac) in the track’s Name field.

10.3.3 MIDI Devices

To set the MIDI input and output devices,

a. Select MIDI Devices from the Options menu. The MIDI Devices window will 
open.

FIGURE 10 - 6: Options > MIDI Devices

b. Click on the MIDI Input device / interface you will use for recording new MIDI 
data. 

c. Click on the MIDI Output device you wish to use for MIDI playback. The MIDI 
device window will display all installed MIDI device drivers. MIDI Mapper is 
the default in Windows and is most commonly used for sound cards although a 
specific soundcard driver may be selected from the Output list.

d. Press OK to set the selected MIDI devices as the current SmartScore MIDI 
sources. The selected device then moves to the top of the list.

NOTE: If the desired device is not listed in the MIDI Devices window make sure the 
device driver has been properly installed. Check any software that was installed 
with your MIDI device and/or download MIDI driver from manufacturer’s web-
site. When installing a new MIDI driver, reboot to initialize the new driver.
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10.3.4 Playback Range

To specify part of the score for playback, 

a. Select Set Play Range from the Realtime menu. 

FIGURE 10 - 7: Set MIDI Play Range

b. Set the first measure and last measure of the Play Range.

c. Mark Play All to play the entire score.

d. Check Loop to continually repeat the assigned playback range.

10.4 Piano Roll

In the familiar MIDI piano roll view, it is possible to alter MIDI note events and fine tune 
other playback parameters. MIDI events are only editable when “Show Actual Playback” 
option in the View menu is checked off. When “Show Actual Playback” is checked, artic-
ulations (trills, tremolos, etc.) display but cannot be edited since articulations are con-
trolled by Properties. The Piano Roll view is track-based. 

10.4.1 Selecting MIDI tracks

• To move from track to track, click the Track Paging buttons located in the Toolbar.

To select and display a track in Piano Roll view:

a. Select the MIDI button in the Navigator. In the New MIDI View window, select a 
track or Part Name. Pushing OK will open the selected track in piano roll format.

FIGURE 10 - 8: Overview - Selecting a track
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b. Select the MIDI track you wish to display and press OK.

c. Select the magnifying glass from the Toolbar. Left click to zoom in and right 
click (option + click for Mac) to zoom out of the Piano Roll view.
.

FIGURE 10 - 9: MIDI Piano Roll View

d. Another method of zooming in or out is to drag measure markers horizontally. 
Dragging to the right zooms in and dragging to the left zooms in.

FIGURE 10 - 10: Horizontal zoom by dragging measure markers
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10.4.2 Tiling ENF and MIDI views

Using the Tile Windows feature, you can view both ENF and MIDI windows 
simultaneously. This is useful if timing problems are encountered while editing 
ENF notation. By switching to MIDI Piano Roll view and pushing the Tile Win-
dows button, it is possible to examine underlying MIDI events while referring to 
the same region as notation in the associated ENF window.

To tile all open document windows,
• Push the Tile Windows button located both in the Toolbar and in the Navigator palette.

FIGURE 10 - 11: ENF / MIDI Tile View (with floating Zoom window)

10.4.3 Inserting program changes (Assign new MIDI instrument for 
playback)

You can insert any number of instrument changes into a MIDI track.

NOTE: This same function (inserting a change of instrument for playback) can be done 
in the ENF notation view. See "Changing instrument sounds on the fly", 
Section 4.5.4, on page 47 for details.

To insert a Program Change (MIDI instrument change) in a MIDI track:

a. In Piano Roll view, position cursor and click to drop the red marker where you 
wish to make a MIDI instrument change. 

Tile Windows
Menu Button
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b. Push the Program Change button in the MIDI Toolbar or select Edit > Program 
Change. 

FIGURE 10 - 12: MIDI Program Change (Piano Roll)

c. Select a new MIDI Instrument from the pull-down menu.

In the Voice pull-down menu, select the voice number you wish to apply the new instru-
ment sound to. For more about Voice Color Mode, turn to "Working with Contrapuntal 
Voices", Section 7.9.

d. Press OK.

NOTE: List of instruments is determined by the selected Instrument set selected in 
Options > Instrument Settings. Instrument set is also able to be selected in the 
Playback Console (see "MIDI Setup", Section 4.15.1, on page 72).

e. An inverted red triangle will indicate the point where the program change was 
inserted. Clicking on any Program Change triangle will open the Program 
Change window for additional changes.

NOTE: SmartScore supports multiple MIDI channels within each MIDI track. This 
allows for contrapuntal voices within ENF staff lines to be assigned to different 
instruments within each MIDI track. In other words, multiple voices in ENF are 
equivalent to multiple channels within a MIDI track. This is a sort of hybrid 
MIDI type (MIDI Type 1/Type 0 hybrid).
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10.4.4 Velocity and Tempo Graphical Controllers

In Piano Roll view, the bottom pane of the window displays a graphical, continuous-
change MIDI controller. Click into Controller Selector pull-down menu and select a new 
MIDI controller you wish to view.

FIGURE 10 - 13: Velocity and Tempo controllers in Piano Roll view

• With the pencil mouse pointer, click and drag a curve over the range you wish to apply 
the effect.

10.4.5 Shuttle Tool

The Shuttle Tool allows you to sound MIDI events forward or backward by dragging the 
mouse over a range of events.

To operate the Shuttle Tool,

In Piano Roll view, the “S” key toggles the Shuttle Tool off and on. To manually 
select, press the Toggle Shuttle button in the MIDI Toolbar or go to the Options
menu and select Shuttle On. Click and hold anywhere in an Overview or Piano 
Roll and drag the Shuttle Tool to the right to play the MIDI file at your own 
tempo. Drag the Shuttle Tool to the left to rewind and hear the MIDI file simulta-
neously. 

To insert or change the voice assignment of selected note event(s):

a. Use the Voice Selection pull-down menu located above the piano keyboard to 
select a voice number.

b. Right-click and drag to create a note event.
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10.4.6 MIDI Instrument settings

To change MIDI instrument parameters,

a. Select Instrument Settings under the Options menu. In Playback Console, push 
the Set Instrument button. This will open the Instrument Settings window.

FIGURE 10 - 14: Instrument Settings

b. Select the MIDI Port of the MIDI instrument you will be adjusting with the 
MIDI Port pull-down menu.

c. Choose a specific Instrument Bank or all Banks from the selected MIDI Port if 
numerical banks are supported by your MIDI device.

d. Select the type of MIDI Instrument (GM, MT32, GS, Yamaha XG, Numeric or 
Custom) from the Instrument pull-down menu.

e. Use the radio buttons to activate or deactivate specific MIDI channels for 
selected Instrument set and Drum set. The default MIDI channel for drums is 
10.

f. Use the Drum pull-down menu to select the type of MIDI Drum set your device 
supports (GM, No Drums, Roland GS Drums, Yamaha XG Drums, Numeric or 
Custom).

g. Push Custom to create a formatted text document for displaying custom instru-
ment names for your MIDI device. Edit to change.

h. Save will save Custom patch names as a formatted text document (.TXT). Save 
this file then open it in a word processing application and enter your patch 
names. Then save as a text document.

i. Load will allow you to load the Custom text file. Your custom patch names will 
display throughout SmartScore’s MIDI patch selection windows (Instrument 
Templates and Playback Console).
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10.4.7 MIDI event selection

Under the Edit menu choosing Select opens the Select Window. 

FIGURE 10 - 15: Select Event window

Select All tracks or an individual track or voice to highlight for cut, paste, pitch shifting or 
assigning parameters. Choose Full time to display the full length of the MIDI file or des-
ignate a portion of the file to display by entering the measure, beat, and tick into the From 
and To fields.

NOTE: Edit > Select All is only available from a Piano Roll or Event List view.

Selecting MIDI events using mouse click-and-drag can be done from any view. Mouse 
functions work the same in all views.

To select a note or group of notes:
• Click on the individual note or click and drag to Group Select many notes.

To add note(s) to the Group:
• Hold down the Control key and click on the un-selected note(s).

To select note events within a given time frame: 

a. Click in Piano Roll to mark the beginning of the time frame.

b. Hold down the Shift key and click again to set the end of the time frame. The 
selected range will highlight in grey.
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10.4.8 Changing MIDI event attributes

To change the start time of selected note event(s):
• Click and drag the left edge of the note(s) to the position you want. 

FIGURE 10 - 16: Editing MIDI note on/off events

To change the duration of selected note event(s):
• Click and drag the right edge of a note to change a note’s duration.

To change the velocity (loudness/note attack) of selected note event(s):
• Drag the top and bottom edges of a note adjust the note’s velocity.

FIGURE 10 - 17: Editing MIDI note velocities and pitches

To change the pitch or position of selected note event(s):
• Click and drag the center of the note to change pitch (vertical drag) or note placement 

(horizontal drag).

NOTE: The arrow keys on your computer keyboard can also be used to adjust the pitch 
and start time of the selected note. 

NOTE: To realign MIDI events to the nearest starting point (quantization), go to Options 
> Snap to and select the base rhythmic value.

To delete selected note event(s):
• Hit the Delete key to remove any highlighted notes.

Changing note velocity Changing note pitch
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To change the velocity and/or the duration of selected note(s):

a. Select the Velocity/Duration option from the Edit menu. The Velocity and Dura-
tion window will open.

FIGURE 10 - 18: Velocity and Duration window

b. Use the sliders or type in numbers to increase or decrease the velocity or duration 
of the selected note(s) by a percentage. Example: You wish to double the dura-
tion of a group of selected notes. In the Velocity/Duration window move the 
Duration slider to 200%. 

c. Press OK.

10.4.9 Note Event window

Double-clicking on any note event will open the Note Event window.

FIGURE 10 - 19: Note Event window

The Note Event window allows access to and adjustment of an individual note’s parame-
ters.
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• Raise or lower the Pitch of the Note Event
• Start Time changes when the Note Event begins
• The Duration of the Note Event can be shortened or lengthened 
• Increase or decrease the Velocity of the Note Event
• Select a different Voice for the Note Event

10.4.10 Cut/Copy and Paste

Click and drag the mouse or use Edit > Select to select a region that you would like to cut, 
copy or paste. 
• Cut removes the highlighted notes from the score and places them in the clipboard.
• Copy stores the selected notes to the clipboard without removing them from the score.
• Paste will insert the contents of the clipboard back into the score without deleting the 

existing notes. Click where you want to insert the music into the score. 
• Paste Special will open the Paste Special window.

FIGURE 10 - 20: Paste Special

The Paste Special window offers several options for pasting the contents of the clipboard 
back into the music.
• Add to existing events will add the contents of the clipboard to the selected area with-

out erasing the existing notes.
• Replace existing events will replace the existing music with the contents of the clip-

board.
• Move to make room will push the existing music backward and then insert the con-

tents of the clipboard.
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• Use Repetitions to determine the number of times the contents of the clipboard will be 
inserted.

• Start from time designates where the inserted music will begin by choosing the mea-
sure, beat, and tick.

• Select Start from track to paste to a selected track number. 
• All to track will insert the contents of the clipboard, no matter how many tracks were 

originally selected, into one track.

10.5 Event List

To view and edit detailed MIDI events, meta events, note events, controllers, program 
changes, key and time signatures, etc. in a selected track, 

a. Press the MIDI button of the Navigator or in the menu, select 
View > New MIDI View or Window > Event List. 

b. Choose Event List from the Type pull-down menu

c. Select a track to view and press OK. 

The Event List displays every MIDI event and note attribute of the selected track:

FIGURE 10 - 21: Event List

• Select what event types are displayed in the Event List by checking or un-checking the 
Event Type boxes along the top of the Event List. 

• To scroll the Event List display during playback, check the “Scroll when playing” box 
in the Event List window.

• To page from track to track, click on Track Paging buttons in the Toolbar.
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10.5.1 Changing parameters of selected notes

To change parameters of a group of selected notes:
• Click in any of the columns to change the parameters of an existing MIDI event or 

double click in the Type column of a Note Event to open the Note On window.

FIGURE 10 - 22: Note On window

The Note On window, like the Note Event window, allows for adjustment of an individual 
note’s parameters: Channel, Time, Duration, Pitch, and Velocity.

10.5.2 Inserting note events

To insert new events in the Event List view, 

a. Click the Event you want the Note to follow. Select New from the upper left-
hand corner of the Event List. The Create New Event window will open.

b. Scroll to Note On in the Event Type menu.

c. Press OK.

d. A Note On event will be inserted into the Event List. 

e. Enter the Voice, Time, Duration, and Pitch of the new event by clicking in the 
corresponding columns or double-click in the Type column to open the Note On 
window.
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10.5.3 Editing Key, Time and Tempo

Click in any column to make changes to any existing MIDI events. To insert a new tempo, 
key, or time signature click the event you want the new event to follow. Press the New but-
ton. The Create New Event window will open. 

FIGURE 10 - 23: Create New Event window

Use the scroll bar to select Meta Event. A Meta Event is a MIDI file instruction. Scroll 
through the Event Subtype window to choose Tempo, Time Signature, or Key Signature. 
Press OK. Use the Other column to select the new tempo, time signature, or key signature 
OR double-click in the Type column to open an event-specific window. You may type in a 
new value.

10.5.4 Inserting Non-Note Events

Any MIDI event that is not a note-on or note-off event is a non-note event. This includes 
MIDI Control Changes, Program Changes, Channel Pressure, Pitch Bend information, and 
Meta Events. 

To insert a non-note event in the Event List view:

a. Select the event you want the non-note event to follow.

b. Press the New button. 

The New Event window will open. 

c. Use the Event Type menu to select the event to be added. 
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NOTE: Some events, such as Control Change and Meta Event, have Subtype event list-
ings. Choose one if applicable.

d. Press OK.

• Program Changes 

Program Change inserts a MIDI event that changes the instrument playback for a given 
channel / voice. 

To insert a Program Change of the voice/channel in Create New Event:

a. Program Change is the default New Event, so simply press OK.

The selected Program Change will be inserted into the Event List. 

b. Use the Voice pull-down menu to designate the voice to which the Program 
Change applies.

c. Use the Other pull-down menu to select a new instrument.

• Control Changes 

Control Changes send adjustable parameters to your selected MIDI device i.e., vibrato, 
hold, volume, pan, effects, etc. You can add specific changes to these controls from within 
SmartScore’s Event List. To find out more about what each control change will do, refer to 
the user’s manual of your MIDI device.

• Meta Events 

Meta Events are MIDI file instructions written to the MIDI file. They provide information 
such as file and track headers, SMPTE code, tempo, key and time signatures, etc. and can 
be added to any MIDI file using SmartScore’s Event List

10.6 Playback Console

The Playback Console is available in Overview and Piano Roll 
views and allows for detailed viewing and control of playback 
and provides real-time editing of the active MIDI file. Push 
MIDI in the Navigator and select Piano Roll or Overview. 

Push the Playback Console button in the Toolbar or choose Real-time > Playback Con-
sole (Ctrl +9 Win / Cmnd+9 Mac) to open the Playback Console.

NOTE: The console can act as a “window shade”. To shrink vertically, drag the bottom 
edge of the console up or down.
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10.6.1 Adjusting Playback Console Settings

General;
• Adjust global playback volume using the General Volume slider.
• Adjust channel volumes using individual Volume sliders.
• Use Pan to adjust stereo balance for each channel.
• Default resets all MIDI tracks to their original settings.
• The Close button will close the Playback Console.
• Mute any voice while all others continue to play or Solo a single voice for playback.
• Change the MIDI Instrument or Channel of any voice.

To play back at a given point in the file; 
• Use the Measure / Beat slider and scroll to the desired measure and beat in the score.

To select the MIDI output device; 
• Use the Port pull-down selector.

To transpose playback globally; 
• Use the General Transposition pull-down selector. 

To transpose an individual track / voice;
• Use the Transposition pull-down selector in any track / voice.

10.7 Display Controls

10.7.1 Time

To choose whether the timing of MIDI note events is displayed by Measure: Beat: Tick or 
by Tick Number;
• Go to the Options menu and select Time Format.
• Choose by Measure: Beat: Tick or by Tick Number.

10.7.2 Velocity

To choose whether the velocity of MIDI note events is displayed with absolute numbers (0-
127) or as percentages;
• Go to Velocity Format under the Options menu.
• Choose by Value (0-127) or Percent.
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No M
Recor
10.8 MIDI Recording

10.8.1 Recording Options

To activate the Record mode and adjust the recording options choose Record 
from the Realtime menu.

• Synchro Start 

Recording is synchronized to start with the first MIDI note played. To “un-synchronize” 
the start of recording with the first played MIDI event uncheck Synchro Start from the 
Realtime menu OR choose the Metronome Settings listed under the Options menu and 
uncheck Synchro On.

• Thru

Sends new MIDI events to the selected MIDI output device. The active Piano Roll deter-
mines the parameters of the MIDI Thru sound. If no Piano Roll is open, MIDI Channel 1 
is used.

10.8.2 Metronome

The Metronome is on by default. The metronome is useful in keeping time while record-
ing and as a “count-in” tool to mark the beginning of the recording session.

Sometimes, you may want to record “freely”... that is, you simply want to capture a per-
formance in MIDI without worrying about timing or about trying to convert the perfor-
mance into notation. For this purpose, you will want to turn the metronome off. To make 
the metronome inactive during recording, uncheck Metronome from the Realtime menu 
OR choose the Metronome Settings listed under the Options menu and uncheck Metro-
nome On.

IDI
ding
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To make changes to SmartScore’s metronome;
• Choose Metronome Settings from the Options menu. The Metronome Settings win-

dow will open.

FIGURE 10 - 24: Metronome Settings

NOTE: The Metronome On check box must be selected for the metronome to sound 
during recording. To record without a metronome uncheck the Metronome On 
box.

With Synchro On, SmartScore will synchronize the start of recording with the first played 
MIDI event.

Select which MIDI Port the metronome will play through.

Choose the metronome’s MIDI Channel. 

NOTE: The de facto drum channel, MIDI Channel 10, is the default channel. But you can 
change it if you wish.

Determine the number of Lead-in Measures that will play prior to the start of recording. 
The metronome will click at each baseline beat (derived from the time signature) for as 
many measures as you choose.

The Primary Beat (down beat) will sound when its On check box is selected. The Pitch 
pull-down menu displays all General MIDI drum sounds. Use the Volume scroll box to 
increase or decrease the volume of the Primary Beat. The default accents the Primary 
Beat. 

The Secondary Beat will sound when it On check box is selected. The Pitch pull-down 
menu displays all General MIDI drum sounds. Use the Volume scroll box to increase or 
decrease the volume of the Secondary Beat.
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10.8.3 Snap to

MIDI recording is very strict. Any fluctuation in timing or speed may result in strange or 
even useless notation. To prevent this, you can apply quantization to your performance. 
Select Snap to from the Options menu prior to recording. Choose the smallest rhythmic 
value that you think you can accurately play while recording. The resulting MIDI events 
will be justified, each event beginning at the nearest selected rhythmic timing mark.

You can reset start times of selected events to the nearest value set in Options > Snap to
will also reset start times of all selected MIDI events and will fix the increment at which 
selected MIDI events can be moved, when using the mouse or arrow keys to move events 
horizontally.

10.8.4 Recording New Tracks / Voices

To Record a new track to a MIDI file, 

a. Select Record from the Realtime menu OR press the Record button in the Play-
back Console. The New View window will open if any MIDI data already exists 
in an active file.

FIGURE 10 - 25: Selecting Track to Record

b. Select an existing track to record a new voice within the same track.

NOTE: The new MIDI data will be added to the existing track without overwriting any 
material. 

c. Select New Track to record a brand new MIDI track.
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NOTE: A Piano Roll will open for the selected track. A Piano Roll must be open to 
record in SmartScore. A new voice and MIDI channel will automatically be cre-
ated when recording into any track.

d. Use the Playback Console to assign the MIDI parameters for the new track / 
voice.

e. Press the spacebar or select Play from the Realtime menu, or press the Play but-
ton in the Playback Console to start recording at measure 1, unless a Punch In 
point has been set (see "Setting Punch In and Punch Out points" below). 

While recording:
• Pause (spacebar) will temporarily halt recording. 
• Play button (spacebar) will resume recording the same track / voice
• Stop will end the current recording session. SmartScore will return to the standard 

MIDI editing environment.

10.8.5 External Timer

• To run SmartScore’s MIDI recording from an external timer, select External Timer 
from the Realtime menu.

10.8.6 Setting Punch In and Punch Out points

To set Punch In and Punch Out points for recording, double click any measure number in 
an Overview or Piano Roll. The Measure Settings window will open.
• Check Punch In to start recording at the beginning of this measure.
• Check Punch Out to set this measure as the last measure for recording.

The Punch In and Out points are marked with red triangles in the Overview and Piano Roll 
displays.

10.9 Step Time Recording

Recording a “live” MIDI performance to a metronome may be very useful to an accom-
plished keyboardist, but many of us do not have the timing skills required to record a per-
formance meaningful enough for conversion to notation. Even if using “Snap to” 
quantization will result in note positions that are offset with a mix of strange note values 
and, usually, many rests. A logical alternative to live recording is Step Time Recording. 
Using this method, you will be able to quickly select exact note durations as well as 
“skips” (rests) from the number pad of your computer keyboard. With your other hand, 
enter notes and chords from your MIDI keyboard or MIDI instrument.
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To activate Step Time Recording,

a. Make sure your MIDI keyboard or MIDI instrument is properly connected to 
your computer and that it or its interface is selected under Input in the MIDI 
Devices window (See "MIDI Devices", Section 10.3.3, on page 190 for more.)

b. From the Realtime menu, select Step Time Record.

c. Select a track. The default is set to “New Track”. If you wish to record onto an 
existing MIDI track, select that track in the New View window.

d. Press OK.

e. A floating window representing the computer keyboard number pad and associ-
ated note durations appears. Record is now staged. 

FIGURE 10 - 26: Step Time recording (Number Keypad)

f. Click on a note value or control button in the floating key pad window. Or, you 
may select the corresponding value / control function using the numerical keypad 
on your computer keyboard. 

g. Press the Play button of the Mini Console. Recording will begin at Measure 1.
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h. Press a note or chord on your MIDI instrument. Notes of the selected value will 
insert. The next note you enter will begin at the same point the last note ended. 
e.g. In 4/4 time with quarter note selected, hitting a note four times will fill up 
one measure.

i. To insert a rest, choose a note value and hit Enter or right arrow.

10.10 Virtual Drum Kit

In any MIDI view, you can record your own drum tracks onto existing tracks using noth-
ing more than your computer keyboard. To activate Virtual Drums, go to the Realtime
menu and select Virtual Drum Kit. See "Virtual Drum Kit", Section 9.6, on page 185 for 
more details.

10.11 Playback Considerations after MIDI Editing

If you return to the ENF view after editing in the MIDI environment, playback will retain 
changes made in MIDI views until the ENF display is updated with “MIDI Refresh”. If 
notation is subsequently edited in ENF or if MIDI Refresh is selected, you will be given a 
choice of A) Keeping current MIDI playback B) Refreshing ENF and clearing previous 
changes made in MIDI or C) Saving the current playback as a MIDI file.

10.12 MIDI to ENF

SmartScore accepts any Standard MIDI file and converts it to an ENF file.Turn to "MIDI 
to ENF", Section 7.12 for details.

10.13 Saving MIDI Files

When saving a MIDI file, remember that you are not saving a music notation file. The 
more “humanized” the MIDI file sounds, the less likely it will appear correctly when 
imported into a music notation application, such as SmartScore. Saving SmartScore files 
derived from scanning will normally give reasonably good results because the music is 
already “quantized” into discreet start and stop times.

To save a SmartScore MIDI file,

a. Select FILE > Save As, click the “Save as Type” pull down menu and select 
either MIDI Type 0 (Single Track/Multiple Channels) or MIDI Type 1 (Multiple 
Tracks / Multiple Channels).

b. Push the Save button. A window appears saying the following:
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Articulations such as slurs, staccatos and legatos will result in a MIDI file that will not 
import properly into a notation program. Choose whether you want your MIDI file for 
importing into a notation program or for playback only.

c. Choose Remove or Keep Articulations according to your need.

10.14 Recording to Audio (Save as file / Burn to CD)

Using the CD Writer feature, you will be able to record one or more ENF (MIDI 
playback) performances as a audio file or burn to a playable in your car, home 
stereo, etc. In order to burn to CD, it will be necessary to have a CD-R (CD Writ-
able) device installed and connected to your system. 

NOTE: Some external CD/DVD-R devices may no respond to the Writing “burn” com-
mand. In this case, you should record to .WAV file and use dedicated CD burning 
software to record CD audio.

NOTE: For best results and sound quality, it is recommended that you use the Aria player 
for playback whenever saving to an audio file or burning audio to CD.

To record ENF or MIDI files and burn them to audio CD,

a. Push the CD Burn icon at the bottom of the Navigator or choose .

Push “Add Files” and select one or more ENF or go to FILE > CD Writer. MIDI 
files to be recorded to CD.
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FIGURE 10 - 27: Audio CD Writer window

b. Each selected file must undergo a conversion to an audio format. (.WAV is the 
default). After converting, the selected file(s) will appear in the “Files to Burn” 
list as an audio. 
Files may be reordered using the “Move Up” or “Move Down” buttons. They 
may be removed from the list separately or all together with “Remove” or 
“Remove All” buttons.

c. Insert an unused writable CD (CD-R) into your CD/DVD tray. Burn Method = 
Auto. Change to another method if you have trouble.

d. Push “Burn Last Track and Finalize CD” to record and finalize your ENF files 
to DVD. All selected files will record on a single CD track. To record individual 
tracks, use “Burn New Track” as described below.

NOTE: “Finalizing” a DVD is necessary before a can be played back. Once Finalize is 
applied, you will not be able to record anything more to the CD.

e. If you wish to continue burning new selections without finalizing the CD, push 
“Burn new track”. Each set of converted files in the “Files to Burn” list will 
record to one track. Select “Burn Last Track and Finalize CD” to record last 
track and finalize the CD.
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11) Reference

11.1 Preferences

Default ENF display characteristics can be changed. From the EDIT menu. 

Select Document Preferences or  Program Preferences depending on whether it is doc-
ument or program-dependant.

11.1.1 Document Preferences

• Text symbols

Reset default font size and type for text symbols such as triplets, dynamics and expression 
marks. For text and lyric defaults including part names, push the “Text Styles” button. 
Push Apply to change. See "Adding and changing styles of Text and Lyrics", 
Section 8.2.2, on page 165.

• Systems

Reset display characteristics for systems including part names, measure numbers, lyric 
display, clef visibility and printing, cross-staff pointer lines and constraining system 
scrolling when the score is reformatted.

FIGURE  11 - 1: Document Preferences > Systems
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• Select how to display part names: Choose how to abbreviate part names and 
whether to show or don’t show part names. 

• Change options for showing measure numbers.
• Change whether or not to display clefs in every system.
• Select whether to show and/or print lyrics.
• Change the line style for cross-staff voicing.
• Editing Defaults (may be turned off): 

- Minimize symbol repositioning when reformatting music.
- Display rhythmic errors (highlight measures in red).
- Suggest Auto-tuplets after the same rhythmic grouping is inserted more than 
twice.

• Score symbols

Change display options for:
• Triplet bracketing (square, arc, none)
• Note overlap control (overlap voices or offset noteheads)
• Rehearsal symbol display (numbers or letters).

• Page number
• Change display options for page number display, visibility and position on the 

page.

• Chord symbols

Change display options for chord symbols and fretboard font type, size and color, fret-
board size scaling and how chord symbols will be displayed:

• Show both chord name and guitar fretboard symbols.
• Show only guitar fretboards.
• Show only chord names.
• Show neither chord nor fretboard symbols.
• Long Minor will display “min” instead of “m” for the word “minor”.

• Playback

Change GLOBAL playback characteristics:
• Grace notes: On the beat (accaciatura) / Before the beat 
• Lock to Time Signature: Lock (Default) / Play as written
• Randomizer: Place check in checkbox to apply. Adjust sliders to increase/

decrease random changes to start time and note velocities. 
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11.1.2 Program Preferences

• User Interface

Control tool palette behavior, turn display of active staff and margins off and on and show 
Task Window at startup. Reset default windows settings including post-recognition pop-
up notifications.

• Page type

Reset default page size and orientation.

• Units and Zoom

Reset default ruler display units and reset zoom - screen size ratios.

• Tablature
• Select whether or not to print note value symbols. 
• Change the length of time to enter fret number values.

• Color settings

Reset color properties of notes and other symbols.

• MIDI channel color

Reset the colors displayed for MIDI channels 1-16

• Karaoke settings

Control appearance during playback including scroll and ball behavior as well as back-
ground and lyric colors. These options are also available in Karaoke mode under the 
Options menu.

• Autosave

Reset default Autosave rules.
• Every n minutes - even if no editing takes place.
• Every n actions - based on number of editing actions, e.g. Inserting, Changing, 

Deleting, etc.
• What is first - based on which is first; the number of minutes selected or the num-

ber of actions performed.
• Never - deactivates Auto Save of the ENF file.

• Notifications

Control whether or not to display certain warning and caution notices.

• MusicXML

Change default options for saving ENF to Music XML files.

• ENF - PDF (Win Only)
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Select alternative PDF creation application. These 3rd-party applications may redirect 
your browser to the publisher’s website for upgrading or other offers when launched.

• Systems

See "Systems" under “Document Preferences” on page 214.

• Score Symbols

See "Score symbols" under “Document Preferences” on page 214.

• Page Number

See "Page number" under “Document Preferences” on page 214.

11.2 ENF EDITOR > FILE Menu

11.2.1  New ENF / New MID

Select between a new ENF or a new MIDI. Choosing New ENF will open the New Smart-
Score Document window. Select a Template or use Custom to create a unique score. 
Choosing New MIDI will open a blank MIDI Overview and Piano Roll for MIDI input.

11.2.2  Open (Ctrl +O Win / Cmnd+O)

Opens File Selection dialog box and lists saved files. A selected file will be 
loaded into memory and will display on the screen. 

11.2.3  Close (Cmnd+W)

Closes active ENF document. If changes have been made, a Save As dialog box will open.

11.2.4  Save (Ctrl +S / Cmnd+S for Mac)

This will save an open SmartScore document to the same drive the file was 
opened from. The original name remains unchanged. If ENF and Image are dis-
played, only the ENF file is saved. 

11.2.5  Save As

You can save files in several file formats other than SmartScore’s native ENF format. 
These include MIDI (.MID), NIFF and MusicXML (.XML) file. 

a. Go to  Save As. 

b. In the File type/Format window, choose a format to save the file.

c. Browse to another directory and change the name if necessary.

d. Press OK. The file will be saved in the last directory used to “save”.

NOTE: Use  Save (Ctrl +S /Cmnd+S) to update the current ENF file.
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NOTE: When saving ENF to MIDI files, a dialog box will open to explain that articula-
tions such as slurs, staccatos and tenutos will create MIDI events that are not 
quantized. You will be given a choice to save the MIDI files with articulations 
removed or kept. For the purpose of playback only, it is recommended that artic-
ulations be kept. If t is recommended that articulations be removed if MIDI files 
are to be imported into other notation-based programs.

11.2.6 Save & Open XML in Finale (Toolbar button)

Use this function, also found in the lower Toolbar, to launch Finale and import the current 
ENF file (saved as an XML file).

11.2.7  Save as PDF

This opens file browser and saves current active ENF file as an Adobe® Acrobat® PDF 
format file. (Windows requires PDF 995 from installer)

11.2.8  Scan Music

• Acquire: Initiates scanning. Same as Scan in Navigator.

• Select Scanner: Opens list of available TWAIN drivers to select.

• Choose Interface:

> SmartScore’s = selects the SmartScore scanning interface. Refer to "Selecting your 
scanner driver in SmartScore (Windows only)", Section 3.1.2 for details.
> Your Scanner’s = selects scanning software from your scanner. 

11.2.9  Recognize

This initiates the recognition sequence for recognition of pre-scanned images. 
See "Scanning in Macintosh®", Section 3.2, on page 19 for details.

11.2.10  Page Setup

This opens the document layout control panel. See "Custom document layouts", 
Section 6.3.5, on page 96 for details.

•  Print (Ctrl+P / Cmnd+P)
Print out your score.

11.2.11  Print Preview

Check for proper page layouts. Adjust individual page margins using green tabs. 
Also seen in Page Setup view.
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11.2.12 Most recently opened ENF files

The last four ENF files are listed and may be opened by clicking their names. 

11.2.13 Exit

Saves and closes all open ENF files and closes SmartScore.

11.3 ENF EDITOR > EDIT Menu

11.3.1 Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine layers of 
Undo. 

11.3.2 Redo (Ctrl +Y / Cmnd+Y)

Reapplies the last action that has most recently been Undone. 

11.3.3 Cut (Ctrl+X / Cmnd+X)

To view selected objects from the score and place them on the clip-
board, 

a. Hit “O” key or choose the Select tool from the Toolbar. 

b. Click and drag a box with the cursor until objects you wish to cut (and store to 
the clipboard) are highlighted orange.

c. Press the Cut button in the Toolbar, hit Ctrl + X / Cmnd+ X or select  Cut from 
the menu.

11.3.4  Copy 

To copy selected objects for pasting elsewhere in the score, 
a. Activate the Select tool then click and drag a box to select a region of interest.

b. Press Ctrl +C / Cmnd+C or go to  Copy.

a. To copy selected region of the page to the clipboard for pasting as a bitmap 
image into another program, activate the Select tool and drag a region with the 
right mouse button (Alt + click for Mac).

To copy a full page:

a. Ctrl + A / Cmnd + C (Select All) then Ctrl + C / Cmnd + C (Copy).

b. Open 3rd-party application, position cursor and Ctrl + V/Cmnd+ V (Paste).
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11.3.5  Paste (Ctrl +V / Cmnd+V)

To paste the contents of the clipboard into an ENF file, 
• Select Paste (Ctrl +V / Cmnd+V) from the Edit menu and click anywhere in the 

score. The contents of the clipboard will be added to the score and will not
replace any existing notes.

•  Paste Replace (Ctrl+R or Cmnd+R)

To paste the copied material into an ENF file and replace existing notation, 

11.3.5a Paste Replace

Select Paste Replace from the Edit menu (Ctrl+R or Cmnd+R) and click anywhere in the 
score. Use Paste Replace to quickly replace a complex passage that was poorly recog-
nized with an identical passage that is correct. 

11.3.5b Merging and Inserting (Paste option)

A special paste mode becomes available after selecting and copying symbols or entire sys-
tem segments. Clicking on the beginning barline of the section to be altered will open the 
following dialog box:.

FIGURE 11 - 2: Paste Option Dialog (Barline click)

• Merge with existing bars: Copied symbols will be added to current measures.
• Insert new bars: Copied measures will be inserted and follow-on measures will 

be rolled forward. 
• Replace existing barlines: This choice will replace existing measures (identical to 

Paste Replace).
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• Delete

In this mode, clicking on objects that are moused over (and highlight yellow) are 
deleted.

11.3.6 Select All (Ctrl+A or Cmnd+A)

To select all symbols on the current page for global editing functions such 
as split voices (Section 4.5.2), flip stems (Section 7.7.5) and ungluing 
joined voices (Section 7.5.7a):
Choose Select All from the Edit menu (Ctrl+A or Cmnd+A).

11.3.7 System Manager (Ctrl+M or Cmnd+M)

Refer to "System Manager", Section 7.4.

11.3.8 Score Properties

Refer to "Score Properties", Section 7.3

11.3.9 Score Structure

This special environment is used to perform useful functions such as creating a conduc-
tor’s score from different parts and for isolating or joining parts and voices. For detailed 
discussion on using this powerful feature, turn to "Extracting parts in Score Structure", 
Section 6.5.2.

11.3.10 Format Score

Refer to "Edit > Format Score", Section 6.4

11.3.11 Staff Spacing

Refer to "Adjusting measures", Section 6.1.2 for details.

11.3.12 Text Styles

Refer to ".To modify font styles of text fields and lyric blocks,", Section  for more details.

11.3.13 Part Linking (Ctrl+L or Cmnd+L)
(Collapsing and expanding systems)

Many printed scores “collapse” or “optimize” systems to show only actively playing parts. 
Similarly, instruments that appear in one part may split into two or more parts anywhere in 
the score causing systems to “expand” in size. SmartScore automatically senses expand-
ing systems when, for example, a piano solo introduction precedes a vocal/piano arrange-
ment. Expanding and collapsing parts are easily linked or re-linked in a simple-to-use 
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environment called Part Linking. Part Linking is also used when merging staves with 
brackets that were cut off. Turn to "Re-linking parts", Section 4.14 for details on this fea-
ture.

11.3.14 Instruments Templates

Refer to "Instrument Templates", Section 4.10.2.

11.3.15 Bracketing (Ctrl+B or Cmnd+B)

Refer to "Bracketing", Section 8.4.3.

11.3.16 Add Empty Pages

Use to add new pages. Also found in Status Bar (lower right corner).

FIGURE 11 - 3: Add Empty Page window

11.3.17 Unify Signatures (U)

Refer to "Unify Score (“U”)", Section 7.8.4.

11.3.18 Restore Default Voices (Ctrl + U)

Use this feature to revert a selected set of notes within a measure to their default voice / 
color assignment. Useful if voice / color assignments become confused after repeated 
over-riding of voices. 

11.3.19 Score Header

Refer to "Score Header", Section 8.4.4.

11.3.20 Default Tempo

To set the default tempo,

a. Select desired Beats per Minute from the horizontal slider.

b. Choose a base note Tempo Value (4/4 default = quarter note).
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c. Check the Metronome Mark Visibility box to display the Metronome Mark in 
the ENF document in the first measure.

FIGURE 11 - 4: Default Tempo window

Refer to "Tempo Markings", Section 7.6.5 for entering change-of-tempo (metronome) 
markings.

11.3.21 Automatic Drum Track

Opens the “assign drum pattern” window. See "Add drum tracks", 
Section 4.10.5, on page 63 for details on creating automatic drum tracks.

11.3.22  Guitar Chord Library

The Guitar Chord library contains preset guitar chords and associated chord sym-
bols. Add, change, delete and store any custom chords. Guitar frets and chord 
symbols automatically transpose with key transposition. Refer to "Guitar Fret 
and Chord Symbols", Section 8.3.1 for details.

11.3.23 Transpose (Ctrl +T / CmndT) 

Transpose your score by key or by clef. Limit to a part, a voice or select a range. Refer to 
"Transposition", Section 7.2 for details.

11.3.24  Edit Mode

• Zoom 
• Select tool (Ctrl+O / Cmnd+O)
• Insert / Change - See "Insert mode", Section 5.2.5, on page 79.
• Delete - See "Deleting notes and symbols (“X”)", Section 7.1.3, on page 104.
• Vertical Alignment (Y) - See "Working with Contrapuntal Voices", Section 7.9, 

on page 148.
• Beam Notes (B) - See Convert a sequence of flagged notes into one beamed 

group under 7.1.5 on page 105.
• Split Voices (H) - See "Voice Splitting (Select + “H”)", Section 4.5.2, on page 45.
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• Flip Stems (S) - See "Stem direction (S)", Section 7.7.5, on page 142.
• Delete Selected Ties/ Articulations (G) - See "Select tool (“O”)", Section 7.1.4, 

on page 105.

11.4 ENF EDITOR > VIEW Menu

11.4.1  Toolbars

• Navigator
• Opens and closes the SmartScore Navigator.
• Main
• Opens and closes Toolbar
• SmartScore
• Opens and closes Toolbar
• Image
• Opens and closes Image Editing Toolbar
• Text and Controllers
• Opens and closes the Toolbar containing control buttons for text and graphical 

controllers.
• Mini Console
• Opens and closes the Mini playback console in ENF view.
• MIDI Toolbar
• Opens the MIDI Toolbar in the active ENF view.
• Print Preview Toolbar
• Open and closes the Print Preview Toolbar when Print Preview is active.
• Status Bar

Opens and closes Status Bar at the bottom of display. Displays current page, cursor posi-
tion, image size, zoom, page view type and add page. 

11.4.2  Palettes

Refer to Section 7.6, "Tool Palettes" for details.

11.4.3  Show 

11.4.3a Active Staff

When selected, the ENF display to highlight the active staff in black while other staves 
become grey. The active staff line is the staff that the cursor was last positioned over.
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TIP:If you find that a certain staff line is stuck “on” regardless of the position of your 
cursor, it is probably is a result of having “Caps Lock” on. Turning on “Caps 
Lock” will lock in the active staff line to allow you to move about freely.

TIP:If an object does not delete even if it shows itself to be in an active staff, use the 
Select tool (“O” key) to highlight it and then hit Delete. All selected objects will 
be removed with the Delete key, whether they are in the active staff or not.

11.4.3b Error Message

This selection will highlight measures with suspected rhythmic errors in a pink color. If 
the total of beats in one or more voices in a measure do not equal the default time signa-
ture the measure will highlight pink. It does not necessarily mean the measure is “illegal” 
or that it will play back incorrectly. There are many accepted conventions that cause this.

11.4.3c Part Names

Select one of several choice to display Part Names along the left-hand side of systems. 
“Do Not Show” is also an option.

11.4.3d Measure Numbers

This option will display or not display measure numbers in the ENF display.

11.4.3e Chord Symbols

Choose to display chord symbols as guitar fret symbols, text or not at all.

11.4.3f Hidden Symbols

Refer to Section 7.10, "Hidden Symbols" for details.

11.4.3g  Lyric Show/Don’t Show

Checking this option off will remove the display and printing of lyrics.

11.4.4 Associate Image Files

Synchronization between the ENF and TIFF panes assumes exact ENF correspondence to 
the original score structure. Synchronization may become lost after systems are inserted, 
removed or if page margins are changed. Once a system rolls from one page to another, 
ENF-TIFF synchronization will become lost for all subsequent pages. 
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To synchronize ENF and TIFF views, 

a. Go to  Associate Image Files...

FIGURE 11 - 5: Associate Image File Window

b. Push Load Image to browse and locate the TIF file associated with the open doc-
ument. Double click to select the image. If the file contains several pages of 
images, they will appear as xxxP1, xxxP2, xxxP3, etc.

c. Click to highlight a page in the image-page list. A preview of the page will 
appear in the view window if Preview is checked. Then click on the appropriate 
ENF page in the list of ENF pages.

d. Push the Associate button to associate the image page with the appropriate ENF 
page. Continue as necessary.

11.4.5  Image Information

Provides information on the structure and type of the currently displayed image file.
• Next Page
• Displays next page of ENF document
• Previous Page
• Displays previous page of ENF document
• Go to Page (Ctrl +G / Cmnd+G)

Presents a dialog box to select a page number to jump to. Refer to "Paging", Section 5.1.5 
for details. 
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11.4.6 View Mode

Choose how you want to view pages in the ENF notation display: Horizontal, vertical, fac-
ing page (book orientation) or in long view (pageless scrolling format).

11.4.7 Zoom

Lists available view percentages. Changing zoom will affect both the image and the ENF 
file simultaneously. Range is from 8% to 400% view scale.

11.4.8 ENF EDITOR > PLAYBACK Menu

11.4.9 Set Playback Range

Refer to "Playing back a selected section", Section 4.2.1.

11.4.10 Play / Stop / Rewind

Used to control playback functions from menu.

11.4.11 Thru

Sets MIDI device to play “live” without MIDI Record on.

11.4.12 Console

Opens Playback Console (Ctrl+9 / Cmnd+9).

11.4.13 Mini Console

Opens and closes Mini Console Toolbar.

11.4.14 MIDI Devices

Opens MIDI device dialog box. Select MIDI input and output sources. Refer to "Quick 
Playback Tricks", Section 4.2 for details.

11.4.15 Swing

Turns swing playback on or off. Refer to "Swing", Section 4.10.6.

11.4.16 Play as written

Refer to "Barline Properties (Pickup measures and Codas)", Section 4.9.11.

11.4.17 Graphical Controller

Refer to "ENF Graphical controllers", Section 4.11.
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11.5 ENF EDITOR > WINDOW Menu

11.5.1 Task Window (Ctrl + W)

a. Opens the SmartScore task window:

FIGURE 11 - 6: Task Window

11.5.2 Scan View

Provides options for the floating zoom window including whether to display ENF or TIFF 
close-ups in the zoom window and selecting additional zoom views. Refer to "Split-screen 
and scan view reference views", Section 7.11.1 for details on the floating zoom window.

11.5.3 Clone Document

Duplicates and opens currently open ENF file.

11.5.4 View Panes

Choose to the screen view that makes sense to you: ENF/TIFF, ENF only or just the .TIF.

11.5.5 Split Screen

Activates the ENF / Scan view split control tool.

11.5.6 Cascade

Display, overlap and offset all open ENF files. 

11.5.7 Tile

Display all open windows of all open ENF files with no overlap.
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11.5.8 Split

This option activates the “window pane” puller. Use to control the split screen.

11.5.9 Overview / Piano Roll / Event List

Opens MIDI view window and displays the selected MIDI environment, Overview, Piano 
Roll or Event List. See "MIDI Views", Section 10.1, on page 187 for more details.

11.5.10 Karaoke

Opens the Karaoke view window. See "Karaoke View", Section 4.10.1, on page 61 for 
more details.

11.5.11 Reset Tools and Palettes (F1)

Resets tool palettes and toolbars to their default (program launch) positions and maxi-
mizes the ENF display.

11.5.12 New MIDI View (Ctrl +I / Cmnd+I)

Opens New MIDI View dialog box. Select type of MIDI view.
• Overview - Displays all staves as MIDI tracks.
• Piano Roll - Displays selected stave as MIDI track.

Event List - Displays MIDI events of selected staff line. 

11.6 ENF EDITOR > HELP Menu

11.6.1 SmartScore Manual (PDF)

In DVD versions, this selection will open the file, SSManual.pdf. This file is the full 
Using SmartScore 5 manual in Adobe Acrobat format. It is located in the SmartScore 
directory and is opened by Adobe Acrobat.

In download versions, this selection will attempt to open an Internet connection and begin 
downloading of the file, SSManual.pdf from the Musitek website. If the file is moved to 
the SmartScore directory, the local file will open when the SmartScore Manual (PDF) is
selection is made again.

11.6.2 Online Help

This selection will attempt to launch your Internet browser and connect to a special inter-
active help system online at musitek.com. The Online Help system is fully interactive and 
contains index links, table of contents links and text hyperlinks to related subjects.
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11.6.3 Check for Updates

Opens Internet browser and attempts to locate the SmartScore online updates page at: 
http://www.musitek.com/updates.html

11.6.4 Registration

Opens Internet browser and attempts to locate the Musitek online registration page at: 
http://www.musitek.com/registration.html

11.6.5 About SmartScore X2

Displays version / update number. Pushing the graphic icon reveals author / programming 
information.

11.7 MIDI EDITOR > FILE Menu

11.7.1  New

Select between a new ENF or a new MIDI. Choosing New ENF will open the New Smart-
Score Document window. Select a Template or use Custom to create a unique score. 
Choosing New MIDI will open a blank MIDI Overview and Piano Roll for MIDI input.

11.7.2  Open (Ctrl +O / Cmnd+O)

Opens File Selection dialog box and lists saved files. A selected file will be loaded into 
memory and will display on the screen. 

11.7.3  Close - (Cmnd+W Mac)

Closes all MIDI views. If any changes were made to the MIDI file, option to Save MIDI 
file. Return to main SmartScore window.

11.7.4  Save (Ctrl +S / Cmnd+S)

Writes currently displayed file to the hard disk. 

11.7.5  Save As 

Opens Windows File Selection dialog box

Save processed or modified MIDI files to hard disk following MIDI Recording or Editing 
procedures.

Use to save selected files to directory other than the working directory

11.7.6  Show Task Window (Ctrl + W)

Opens SmartScore Task Window.
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11.7.7  DVD Writer

Opens DVD Writer / Burn window. See "Recording to Audio (Save as file / Burn to CD)", 
Section 10.14, on page 212.

11.7.8  Recent (1,2,3, or 4)

Automatically loads one of the last four files accessed by SmartScore.

11.7.9  Exit/ Quit- (Cmnd+Q)

Exit SmartScore. Save current file. Go to Windows main desktop.

11.7.10 MIDI EDITOR > EDIT Menu

11.7.11  Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine layers of Undo. 

11.7.12  Redo (Ctrl +Y / Cmnd+Y)

Reapplies the last action that has been Undone. 

11.7.13  Select

Opens the Select window for defined note selection.

11.7.14  Select All (Ctrl +A / Cmnd+A)

Selects all MIDI events in every track. 

11.7.15  Cut (Ctrl +X / Cmnd+X)

Removes the highlighted notes from the score and places them in the clipboard. 

11.7.16  Copy (Ctrl +C Win / Cmnd+C Mac)

Places selected notes on the clipboard without removing them from the score. 

11.7.17  Paste (Ctrl +V / Cmnd+V)

Insert the contents of the clipboard back into the score without deleting the existing notes. 

11.7.18  Paste Special

Opens the Paste Special window. The Paste Special window offers several options for 
pasting the contents of the clipboard back into the music.

11.7.19  Delete (Del)

Deletes the selected section from the MIDI file. 
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11.7.20  Delete Track

Deletes the currently displayed MIDI track.

11.7.21  Program Change (Piano Roll only)

Opens the Change Instrument window. Insert a change to a new MIDI patch.

11.7.22  Velocity/ Duration

Opens the Velocity and Duration window. Adjust the Velocity and/ or Duration of the 
selected MIDI events.

11.7.23  Create Automatic Drum Pattern

If you wish to convert a MIDI drum pattern and add it to the SmartScore drum pattern 
library, load the MIDI drum pattern file and select this option. For more information, see 
"Adding custom drum patterns from ENF", Section 9.5.2, on page 184.

11.7.24  Convert MIDI to ENF

Converts MIDI data in the currently open file to ENF notation.

11.7.25 MIDI EDITION > VIEW Menu

11.7.26  Navigator

Opens and closes the SmartScore Navigator.

11.7.27  Toolbar

Opens and closes Toolbar.

11.7.28 Image Toolbar

Opens and closes Image Editing Toolbar.

11.7.29 Mini Console

Opens Mini Console transport control.

11.7.30  MIDI Toolbar

Opens the MIDI Toolbar.

11.7.31  Synchronize

Synchronizes measure sizes in all MIDI views to that of current MIDI view. All horizontal 
resizing is synchronized between all MIDI views.
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11.7.32  Show Actual Playback

When selected, all MIDI events (including articulations such as trills and tremolos) are 
visible in the Piano Roll view. When selected, MIDI events cannot be edited (behavior of 
articulations is controlled with Properties tool in the ENF view. Turn off to edit MIDI 
events.

11.8 MIDI EDITION > OPTIONS Menu

11.8.1 Snap to (Quantization)

Quantities selected MIDI “Note On” events to the nearest “tick” specified. Also deter-
mines default quantization value for MIDI recording and for horizontal nudging of 
selected MIDI events by mouse dragging or by use of the arrow keys. Quantization values 
range from 32nd triplet to whole note. 

11.8.2 File Settings

Opens Sequence Settings window. Shows the MIDI header information including: tempo, 
time base, time signature, key, and MIDI instrument.

11.8.3 Track (not in Overview)

Opens Track Properties dialog box. Select a different track view, delete, duplicate, 
rename, or transpose the selected track.

11.8.4 MIDI Devices

Opens MIDI device dialog box. Select MIDI input and output sources.

11.8.5 Instrument Settings

Opens Instrument Settings dialog box. Allows for selection of Port, Bank, and MIDI chan-
nel assignment for Instrument and Drum sources.

11.8.6 Metronome Settings

Opens Metronome Settings dialog box. Allows for selection of Port, MIDI Channel, num-
ber of lead in measures, MIDI sound and volume for Primary and Secondary beats.

11.8.7 Shuttle On

Activate/ deactivate SmartScore’s shuttle tool.
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11.9 MIDI PLAYBACK Menu

11.9.1 Set Playback Range

Opens Set MIDI Play Range dialog window.

11.9.2 Play/ Pause “Spacebar”

Begins/ pauses/ resumes playback of current MIDI file. In Record Mode will start and 
pause MIDI recording.

11.9.3 Stop

Stops playback or recording of current MIDI file.

11.9.4 Rewind “,” (comma)

Rewinds to beginning of Set Playback Range. 

11.9.5 Record 

Check to activate MIDI Record mode

11.9.6 External Timer 

Set recording to begin from an external signal.

11.9.7 Synchro Start 

Active only in Record Mode, check to synchronize start of MIDI recording with first note 
played on MIDI keyboard.

11.9.8 Thru

Allows MIDI input to sound without having to be in Record mode.

11.9.9 Metronome

Activates/ deactivates Metronome in recording

11.9.10 Playback Console (Ctrl + 9 / Cmnd+9)

Opens the Playback Console.

11.9.11 MIDI WINDOW Menu

See "ENF EDITOR > WINDOW Menu", Section 11.5, on page 228.

11.9.12 Image Realtime Menu

• Realtime > Thru
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Allows MIDI input to sound while recording.

• Realtime > MIDI Devices

Opens MIDI Device window.

11.10 IMAGE EDITOR> FILE Menu 

11.10.1  New

Select between a new ENF or a new MIDI. Choosing New ENF will open the New Smart-
Score Document window. Select a Template or use Custom to create a unique score. 
Choosing New MIDI will open a blank MIDI Overview and Piano Roll for MIDI input.

11.10.2  Open (Ctrl +O / Cmnd+O)

Opens File Selection dialog box and lists saved files. A selected file will be loaded into 
memory and will display on the screen. 

11.10.3  Save (Ctrl +S / Cmnd+T)

Writes currently displayed file to the hard disk. 

11.10.4  Save As

Opens Windows File Selection dialog box

Save processed or modified Image files to hard disk following Scanning and Editing. Use 
to save selected files to directory other than the working directory.

11.10.5  Save As PDF

Saves currently open TIFF image as a PDF file (Windows requires PDF 995 from 
installer). 

11.10.6  Scan Music

Selects scanner or initiates scanner to acquire image.

11.10.7  Recognition

Initiates Recognition to begin processing saved image file(s).

11.10.8  Print (Ctrl +P Win / Cmnd+P Mac)

Initiates Windows Print Monitor. Current Image file is output to default printer from 
selected printer port. 
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11.10.9  CD Writer

Opens audio CD Writer / Burn window. See "Recording to Audio (Save as file / Burn to 
CD)", Section 10.14, on page 212.

11.10.10  Recent (1,2,3, or 4)

Automatically loads one of the last four files accessed by SmartScore (Win). Select any 
recent files by type (Mac)

11.10.11  Exit/ Quit (Cmnd+Q Mac)

Exit SmartScore. Save current file. Go to Windows main desktop.

11.11 IMAGE EDITOR > EDIT Menu

11.11.1  Undo (Ctrl +Z / Cmnd+Z)

Reverses the last action you performed. SmartScore has ninety-nine layers of Undo. 

11.11.2  Redo (Ctrl +Y / Cmnd+Y

Reapplies the last action that has been Undone. 

11.11.3  Cut (Ctrl +X / Cmnd+X)

Removes the selected section from the image file and places it on the clipboard 

11.11.4  Copy (Ctrl +C / Cmnd+C)

Places selected section on the clipboard without removing it from the image file. 

11.11.5  Paste (Ctrl +V / Cmnd+V)

Insert the contents of the clipboard back into the image file 

11.11.6  Delete (Del)

Deletes the selected section from the image file. 

11.11.7 Select All

Selects the entire image for moving / centering.

11.11.8  Crop

Trims the image file down to the selected region

11.11.9  Invert

Switches the colors of the image file.
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11.11.10  Rotate

• Left: Rotates the image file counter-clockwise
• Right: Rotates the image file clockwise
• Any: Opens the Rotate window for rotation by defines degrees.

11.11.11  Delete Page

Deletes currently displayed page. Does not delete the entire file.

11.11.12  Selection

Activates the Area Selection tool.

11.11.13  Line

Activates the Line drawing tool.

11.11.14  Brush

Activates the Brush tool.

11.11.15  Deskew

Activates the Deskew tool for straightening “crooked” scans

11.11.16  Selection Mode

• Opaque

When a selected area is moved to the clipboard the background will be included

• Transparent

When a selected area is moved to the clipboard only the black portion of the 
selected area with be moved.

11.11.17  Pen Color

Select the color used by the Brush and Line drawing tools.

11.12 IMAGE EDITOR > VIEW Menu

11.12.1  Navigator

Opens and closes the SmartScore Navigator.

11.12.2  Toolbar

Opens and closes Toolbar
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11.12.3  Toolbar

Opens and closes Toolbar

11.12.4  Image Toolbar

Opens and closes Image Editing Toolbar

11.12.5  Status Bar

Opens and closes Status Bar at the bottom of main SmartScore Window. Displays current 
page, cursor position, image size, and zoom percentage.

11.12.6  Palettes 

Opens and closes tool palettes for ENF document editing.

11.12.7  Image Information 

Provides information on the structure and type of the currently displayed image file.

11.12.8  Next Page

Displays next page of ENF document

11.12.9  Previous Page

Displays previous page of ENF document

11.12.10  Go to Page (Ctrl +G Win / Cmnd+G Mac)

Presents a dialog box to select a page number to jump to. Use scroller to select desired 
page and click OK. 

11.12.11  Zoom

Lists available view percentages. Changing zoom will affect both the image and the ENF 
file simultaneously. 

11.12.12  Reset Tools and Palettes (F1)

Resets windows, toolbars and palettes to their default position.
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12) Glossary

12.1 Score Formats

Score - A musical piece compiled as a document. A score usually contains more than one 
part with all the parts to be played together. In SmartScore, it is a single computer file; an 
ENF file. A hand-written score is called a manuscript.

Part - A part is represented by a staff line either alone (solo part) or grouped into a system 
with other instruments (ensemble part). A part is usually an single instrument, but in the 
case of two-handed instruments (piano, organ, xylophone, etc.), it may represent one 
hand’s part.

Voice - Derived from choral music but applied to instrumental music as well, contrapun-
tal voicing (sometimes referred to as polyphonic voicing) refers to a unique melodic 
thread distinct from other voices in a measure by its harmonic direction and possibly its 
timbre. Contrapuntal voices reside in the same measure of the same staff. Voices are often 
distinguished by stem direction and sometimes by offsetting the horizontal position of 
notes. For the purposes of SmartScore, a “voice” written in its own staff line is referred to 
as a “Part”.

Score-Part - Scores that are printed in sets for each individual instrument. Players read 
from their own unique set of pages. For example, a duet for guitar and flute would be 
printed in two separate sets: one for the flute player and one for the guitar. Staves of part 
scores flow like a book where each staff line appends to the one above it. 

Ensemble - Scores that have multiple staff lines connected by a vertical bar or “bracket” 
(usually along the left-hand edge of the music). When joined in this way, each staff line 
represents a different part or instrument. All parts are played “ensemble”. Piano music, 
(with left-hand and right-hand staves) are joined into one system, is regarded as “ensem-
ble”. SmartScore assigns each stave to separate MIDI tracks.

Landscape - Some scores are wider than they are high. These “landscape” layouts need to 
be rotated prior to processing.

Folio - Large sized and conductor scores may need to be scaled down during scanning or 
reduced on a copy machine before scanning. If the score must be reduced more than 50% 
in order to fit the imaging area of your scanner, you may consider scanning each full-sized 
page twice and treat each scan as one “image-page”.
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12.2 Score Components

System - A grouping of multiple staves linked together by a solid line or bracket along the 
left margin is called a “system”. All staves belonging to a system are played simultane-
ously. In ensemble scores, each system appends to the one before it. A single page of a 
symphony conductor's score, containing 10 or 20 staff lines per system, may represent 
only a few seconds of music!

Staff (Stave) - The field on which notes are represented is called a staff. “Staves” is nor-
mally used as the plural. At the core of every staff are five horizontal lines. Each succes-
sive line and space are equivalent to a full step in note pitch. The higher the note appears 
on the stave, the higher its pitch. Every staff line anomaly begins with a clef sign and a key 
signature.

Voiceline - An individual melodic line formed by a voice within one measure. When a 
staff contains more than one voiceline in any given measure, note stems of each voiceline 
usually point in the opposite directions. The sum of all note and rest values of each voice-
line in any given measure should be accounted for, but sometimes are not. Refer to "Work-
ing with Contrapuntal Voices", Section 7.9 for more on dealing with this rule in 
SmartScore.

Clef - The clef sign at the beginning of each stave identifies which pitch “class” that stave 
belongs to. The lowest instruments are written in the bass clef, intermediate instruments 
and voices often use one of three “C” clef classes while higher-pitched instruments, in 
addition to the right-hand part of a piano score, are scored in the treble clef. The clef sign 
always appears at the beginning of every staff line and in the first measure if a change of 
clef occurs. Change of clef signs are smaller than normal clefs.

Key Signature - The key signature, along with the clef sign, appears at the beginning of 
every line; it is also found in the measure where a change of key occurs. The key signature 
defines the “tonal center” of the piece. The number of sharps or flats in the key signature 
determines the key tone (or tonic).

Time Signature - Time signatures usually appear only once: at the beginning of the stave 
in the first measure of the piece. They will also appear when a change of time signature 
occurs. Time signatures indicate both the number of beats per measure (numerator) as well 
as which note value is given the fundamental beat (denominator). The sum of note dura-
tion values in a given measure must equal the value of the current time signature.

Note - A note is the fundamental unit of tone. The duration of a note is determined by its 
note value (normally between 1 and 128 divisions). The note’s vertical position on a given 
staff (with clef) determines its pitch. 
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Rest - Rests are equivalent to notes insofar as their durations; but represent silence. They 
act as “place-holders” used to keep the rhythmic structure of the measure intact. 

Measure - Staff lines are segmented into equal time divisions called measures. Measures 
are the building blocks that provide structure for music. The sum of note and rest dura-
tions within each measure must equal the value of the current time signature

Barline - Barlines are the vertical lines that define the beginning and ending of measures

Accidental - Note pitches often range outside of the tonal center defined by the key signa-
ture. An accidental shifts its associated note up (sharp) or down (flat) by 1/2 step. Acci-
dentals may also be doubled. An accidental remains effective only for the remainder of the 
measure in which it appears. A natural “cancels” a note’s current accidental.

Dot of Prolongation - Notes and rests that are dotted have the value of their duration 
lengthened by 1/2. For example, a dotted quarter note is equal in duration to three eighth 
notes. Double-dotted notes increase the note’s duration by 3/4 of the original.

Tuplet - Some notes belong to a special readmit class called “tuplets”. These include trip-
lets, quintuplets and sextuplets. A tuplet is a group of notes marked with a bracket that is 
subdivided into equal beats (divisions) with a total duration equal to the number of 
unmodified notes (value). For example, a (3:2) triplet applied to three eighth notes is equal 
in total duration to two eighth notes. 

Ties - A tie links two pairs of notes of the same pitch whose durations are combined so 
that both notes are played as if one note. Ties are often used to sustain the sound of a note 
across more than one measure. 

NOTE:Ties and slurs (legatos) often look alike, but they are different. Ties connect two 
notes of the same pitch and combine their durations into one note event and slurs connect 
two or more notes over a range of pitches forming a legato that when performed, creates a 
slight overlapping of the notes. 

Articulations - Performance markings that provide instructions for playback of the 
marked notes. For example, a staccato, a dot placed above/ below a notehead, means the 
note should be short, sounding for only a moment. 

Dynamics - Dynamic markings are used to denote the general volume and intensity of 
music. For example, “f” or forte means loud and “p” or piano means soft.

12.3 MIDI Terms

MIDI- Musical Instrument Digital Interface. Originally a hardware device that allowed a 
computer and a synthesizer to communicate, now a generally accepted term for hardware 
or software that operate according to General MIDI standards.
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Standard MIDI File (SMF) - The file protocol or format for music files saved as MIDI 
(.MID extension). Includes Type 1 (multiple track / multiple channel) and Type 0 (single 
track / multiple channel) formats.

Sound Device- A MIDI driven tone generator. Sound cards, synthesizers, and MIDI mod-
ules all fall under this category.

MIDI Event - Each piece of information contained within a MIDI file is an event. This 
includes Notes (attack and release), Control Changes, System Exclusive, Meta Events, 
Program Changes, etc.

Velocity - The speed at which the note was struck, measured with a number from 0-127.

Channel -A MIDI device sends and receives MIDI information along separate and dis-
tinct Channels. Each channel contains note and non-note event data. Most MIDI devices 
can support up to 16 MIDI Channels at one time.

Patch - Every MIDI channel has a MIDI patch assigned to it. A Patch is the instrument 
sound selected for a particular channel when playing back.

Program Change - Same as a patch. Indicates a change of patch within a given channel or 
track.

Bank - MIDI devices divide patches into groups of 128. One Bank of patches from a 
MIDI device can be accessed at a time by a MIDI computer program or another MIDI 
device.

Port - A computer can run several MIDI devices at a time with the proper hardware. Each 
device is connected to a unique Port.

12.4 SmartScore Terms

ENF - Extended Notation Format. This is SmartScore’s proprietary file format. 

Navigator - The floating window containing buttons designed to “navigate” through 
SmartScore’s main features and editing environments. 

System Manager - The System Manager is a sort of “virtual system” which allows for 
manipulating all or specific voices, parts and systems in the score. It contains the parts and 
voices that make up the active system. The Super System, within it, contains ALL possi-
ble parts.

Voice Line Threading - SmartScore will differentiate multiple voices within a single staff 
line by displaying them in different colors (Voice 1-black, Voice 2-red, Voice 3-green, and 
Voice 4-blue) while, at the same time, creating an independent MIDI channel for each 
voice.
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INDEX - SmartScore X2

A
accaciatura 125, 215
accelerando 56
accent

editing 128
playback 130

accidentals 241
accidentals, editing 126
accuracy, recognition 30, 35
active staffline 6, 74, 224

lock / unlock 74
active system 69
add empty 76, 90
adding parts, systems and pages 112, 116
Apply To

System Manager 119
apply to new score 120
Aria Player 39

exiting 40
troubleshooting 39

arpeggio 131
articulations 241

deleting 132
insert/delete multiple 132

articulations palette 127
Associate Image Files 229
Audio CD recording 212
Audio MIDI Setup 73

Audio Units (AU) 71
Auto Save 216
Auto-Spacing 148

B
barline properties 83
barlines 241

bracketing 173
deleting end of staff 51, 82, 140
editing 140
repositioning measures 121
reset number per line 112

beaming flagged notes 105, 223
beams

across measures 151
Auto-Beam 148
cross-staff voicing 150
making 81
reshape 120

Begin Recognition Window 4
bowings 26
bracket

broken or missing 66
bracketing 109, 172
brightness, scanning 21

C
CD Writer 212
centering music for printing 94
change

beamed note 81
notes and symbols 79

chord cluster 80
splitting into voices 45

Chord symbol preferences 170
chord symbols
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changing 167
copying 171
display 26, 215, 225
inserting 166
moving 171
new 169
preferences 215

clefs 240
editing 137
transposition 106
unifying 145
visibility 214

Clefs and Signatures palette 137
cluster, chord 80
Coda 52, 61

recognizing split systems 27
color

MIDI channels 216
overriding automatic color 148
preferences 216

conductor score from parts 25, 29, 101
contrapuntal voices (see also "voicelines") 
9, 148
Copy 219

ENF region to clipboard 88
to paste in other programs 88

courtesy accidentals 126
crescendos and decrescendos

hiding 152
inserting 134
properties 57

Crop 35
cross-measure beaming 151
cross-staff voicing 150

locking the active staff 151
preferences 214

Ctrl+A (Select all) 45, 143, 221

D
da Capo 53
dal Segno 53
darkness, scanning 21
defaults, restoring 216
delete 79, 104, 105

barlines at the end of staff 51
beamed note 81
entire part 118
note(s) from cluster 45, 80, 143
notes and symbols 104
numbered endings 51, 82, 140
selected group of objects 105
when all else fails (Tip) 105

descelerando 56
display, page view 74
document layout 94

custom 95
document preferences 172, 214
dot of prolongation 125, 241

delete 12
draw tool

freehand 36
drums

automatic drum patterns 183
virtual 185
working with 175

duplicate parts (TAB) 179
dynamics 241

markings 134
properties 58
range 153

Dynamics palette 133
Using to SmartScore X2 244



E
Edit

Format score 99
EDIT menu 219
endings

numbered 49
simple numbered 50

ENF 242
add new page 76, 222
blank templates 90
bracketing 172
cascade windows 228
CD recording 212
clone document 228
Cut, Copy and Paste 219
editing files 19
file formats 87
Graphical Controllers 63
header 174
image association 225
orientation of score 96
paging 155
playback 41
Preferences 214
reformat 91
region to copy 85
scoring 66, 88
status bar 76
System Manager 113
tempo marking 222
tile windows 228
using scrollers 155
visibility of parts 118
warning preferences 216
Zoom 76, 192, 195

ENF - MIDI

remove articulations 218
ENF playback 39

real-time settings 43
ensemble 239

creating part scores from 102
Error Message 225
errors, rhythmic 77
expanded systems 69
exporting ENF files 87
expressions 128, 136
Extended Notation Format 5
extracting parts and voices 115

Score Structure 100

F
fermata

editing 128
playback 129

file formats 66, 88, 217
import 144

FILE menu 217
Finale

exporting files to 66, 88, 218
replacing SmartScore Lite 87

Finale®, importing into 87
Fine 53
fingerings 171
flagged notes

beaming 105, 223
folio 239
fonts

changing style 165
setting default style 214

format score 91, 222
formatting

optimize print size 86
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free rhythm 11

G
Garritan sounds 39

troubleshooting 39
glissando 131
Go to… 113, 155
grace notes 125, 215
Graphical Controllers

ENF 63
MIDI 195

guitar
classical notation 171

Guitar Chord Library 166
guitar fret symbols

editing 166
see chord symbols 215

guitar tablature 176
convert from notation 175
copying from notation 179
recognition 26
scanning 21

guitar, classical notation 16
guitar, tutorial 16

H
hairpin

inserting 133
properties 57

Help 229
Hidden Symbols 152
hymnal and choral scores 45, 49

I
Image Editor 34

Cut/ Copy and Paste 38
grey thresholding 38
image info 34

image information 226
insert 104

beamed note 81
Installation 4
instrument change 47
Instrument Templates 54
instruments

changing during playback 47, 193
selecting for playback 46
transposed 62

J
Jumps 52

K
Karaoke view 61

preferences 216
Keep 26
key signature 137, 240

at end of line 138
change 138
unifying 145

key transposition 84, 106
Keyboard shortcuts 141

L
landscape 239
line spacing

using tabs 92
Long view (horizontal display) 74
lyrics 162

default font preferences 214
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font size and style 165
recognizing 25
show/don’t show 214, 225
when found under last staff 26

M
map, Quick Keys 160, 161
margins, changing 96
measure number

display 214, 225
measures 241

change number per line 112
error 77
inserting and merging 220
pickup 59
reformatting 91
resizing 121
shuttle between systems 121
split 59

merging
measures 220
parts or systems 66

metronome marks 135
MIDI

bank 242
channel 242
closing MIDI views 188
Cut/Copy and Paste 200
display controls 205
Event List 201
event selection 197
Graphical Controllers 195
importing files 155
inserting note events 202
Instrument settings 195
measure settings 201

metronome 206
note attributes 198
Note Event 199
patch 193, 242
playback 189
playback range 191
port 242
program change 47, 193, 242
recording 206

new tracks 208
select by time frame 197
selecting view 187
Setup 41
Show Actual Playback 191, 233
shuttle tool 195
snap to 208, 233
Step Time Recording 209
switching tracks 191
synchronize views 232
Track Overview 188
velocity 242
velocity and duration 199
viewing in an ENF document 229

MIDI Devices 190
MIDI Event 242
MIDI Files

import 144
MIDI instruments

assigning 114
changing 47

MIDI Menu Items 230
MIDI Setup

Mac 73
MIDI to ENF 155
miniatures, scanning 22
Mini-Console 41
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modes
Hidden symbols 152
Insert or change a symbol 79
Lyric 162
Nudge 120
Text 164

mordent
editing 128
playback 130

Multi-measure rest properties 59
multi-measure rests 124
music editing 77
MusicXML 66, 88, 216

N
navigating around ENF 74
navigating ENF screens 153
Navigator 143, 242
NIFF 218
normalize graphical controllers 65
notation display 227

image association 225
notes 240

adding to existing 80
adjusting stems 120
associated with lyric block 162
Auto-spacing 148
change 79
changing pitch 77, 120
changing values 104
color 148
color properties 216
deleting 79
dotted 125
editing beamed 81
editing clusters 80

grace notes 125
insert, change & delete 104
inserting 124
inserting and changing 79
moving horizontal 120
overlap or offset 27, 152, 215
properties 54
punctuation 121
Quick-select 8
splitting 45, 143
stem direction 79, 142
swap position of 150

Nudge mode 120
barlines 91, 121
moving multiple symbols 120
repositioning measures 121
reshaping angles 120
special functions 121
text 166

numbered endings 50
deleting / changing 51

O
online help 229
optimize score size 99
optimized systems 69, 109, 118, 221
Ossia 113
Ossias 26
overlap/offset notes 152

P
page

add empty 112, 222
page layout

centering 9
page number display 215
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Page Setup 9, 96
Center on Page 94
optimize page size 99
simple centering 85

page type
orientation 96
preferences 216

page view layout 74, 227
palettes, expanding 7, 78
part linking 66, 69, 109, 143
Part names

editing 114
showing 225

parts 239
adding new 116
extracting 13, 115
maintaining continuity 66
making visible/invisible 118
merging separated systems 66
naming in System Manager 114
re-linking / optimized 69
show names in ENF 114
visibility 111

Paste 220
page or region into other programs 88

Paste / Replace 220
PDF

recognition of 22
Save as 86

pedals 26
percussion 175

editing 179
noteheads 54
recognition 26

Percussion clef 139
Piano Roll 191

pickup and close-out measures 11
pickup measures 14, 59, 60
pitch shift (see Nudge) 120

selected notes 105
Playback

change instrument 47
changing instruments on-the-fly 41
Console functions 42
free rhrythm 11
hesitating 59
inserting instrument change 193
instrument change - ENF View 47
jumps 52
Lock to time signature 11, 59, 215
maintaining continuity 66
pickup measures 11
Program change 47, 242
Properties tool 12
Quick tricks 41
Randomizer 215
repeats 49
selecting a range 13, 41

Playback Console 204
Set Instruments 43

polyphonic voices 9
Preferences

Document 214
Program 216

Print Preview 85, 94, 218
printing 85

centering pages 94
optimizing page size 86, 99

Program Change
ENF View 47
Event List 204
Piano Roll 193
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Program preferences 216
Properties

barline 59
Note 54
playback 54
staff 111

Properties tool 12
punctuation 121

Q
quantization 233
Quick Keys 141

Barlines 140
Beam Direction 142
Dots 141
Dynamics 133
QuickSelect 104
Rests 124
Select Tool 105
Stem Direction 142
Ties 142
Tuplets 124
Vertical Alignment 48, 149

Quick-Select 8, 78, 79

R
recognition

adding a staff missed by 67
bowings 26
chord symbols 166
fretboard 27
hymnal fonts 26
joining offset voices 27
lyrics and text 25
optimized scores 27
options and preview tabs 25

PDF 22
pedals 26
poor 29
sample files 4
System Report 5, 216
thresholding to improve 37
triplets 26

record a CD 212
record new MIDI track 208
reference views 153

overlay 154
reformat score 91, 113, 214, 222
Reformatting 91
registration, product 230
rehearsal symbols 215
Re-link parts 66, 69

after Unify 144
before inserting staff 67

Repeat previous measure mark 49
repeated endings 51
repeated verses and sections 49
Repeats 49
reset windows and palettes 87
Resolution (dpi) 21
rests 241

associated with lyric block 162
moving horizontal 120

ritard 56
Rotate scanned image 37
ruler preferences 216

S
Save ENF 39, 86
scan view window 153

display 228
floating 228
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overlay 75
split control 228

scanning music 18
all-in-one scanners 99
choose interface 20
Macintosh 19
outside of SmartScore 19
resolution (dpi) 21

score
annotations 171
create from scratch 90
display 74
formats 239
header 174
large notehead 111
reduced part 110
reformatting 91

score from scratch 89
Score Properties 82, 109
Score Structure 100
Score-Part 101, 112, 239

adding 112
scanning in 28

screen grab 88
Segno 52
Select All (Ctrl+A) 221
Select tool 105
shaped notes 54
shortcut conventions 17
Shortcuts, keyboard 141
Sibelius

exporting to 66, 88
signatures

unifying 145
Slur 127
slurs

editing 127
playback 127
properties 55
reshaping 120

SmartScore Lite, replace 87
soft accent

playback 130
solo violin tutorial 16
spacing 92, 110

applying to other staffs and systems 
112

unifying staff and system 111
Split into separate voices 45
split pane tool 75
splitting chords into voices 143
staccato

playback 129
staff 240

active 224
adding / rremoving 112
adding new 116
invisible or unrecognized 67
properties 111
spacing 92, 109, 110
visibility 111

Staff Properties 16, 67, 111
stem direction

changing 79, 142
Step Time Recording 209
Super System 68, 118
symbol preferences 215
symbol select 78
symphonic music

adding missing parts 118
scanning 24

system 240
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add / remove 112
apply changes to 119
changing widths

global 95
single 92

collapsed 69
display characteristics 214
merging 66
optimize 69, 118
re-linking parts in 69
spacing 92

System Manager 113, 242
Part Names 114
Visibility 115

System Report 28
System+, apply changes to 119

T
tablature (TAB) 175

change fingering 177
duplicate notation staff 179
editing 176
rhythmic cues 177
scanning 21

tablature(TAB) 113
change staff to 111

tabs,spacing 179
distances 92
margin control 95
staffline spacing 93
system width 91
unifying staff & line distances 9

Task Window 4, 216, 228
tempo

markings 136
properties 56, 136

setting default 135, 222
Tempo Controller

ENF 64
MIDI 195

tenuto
playback 129

Text
adding new style 166
deleting 165
Document preferences 214
editing 164
font size and style 165
nudging 120, 166

Text and tools palette 141
ties 126, 241
tiling views 146
time signature 137, 240

change 138
at end of line 138

unifying 145
Tool palettes 122, 123

expanding 78
resetting 87

Toolbars 224
transposed instruments 62
Transposition 84, 106
tremelo 130

beamed 131
playback 130

trill
editing 129
playback 128
properties 57

triplets 44, 127
change bracket type 215
implied 44, 152
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nested 125
tuplets 241

properties 58
user-defined 125

Turn 129
turn

editing 128
playback 128

Tutorial 4

U
Undo 80
Unify 145
Unify key, time and clefs 144
updates, online 230
user interface preferences 216

V
Velocity Controller

ENF 64
MIDI 193

velocity, note 242
verses, repeated 49
vertical alignment 27

correcting 47
Recognition Options 27
verifying 150, 164

vertical event 47
View > Scan View Window 76
views, tiling 146
violin, solo 16
visibility

part 118
voice 45

voice color 7
voiceline 77, 148, 240

threading 10, 242
visiting another staff 150

voices 9, 239
affecting playback 45
assigning instruments to 46, 114, 

194
color 148
extracting 13, 116
gluing and ungluing 48, 149
offset 27
splitting 45, 143
swap position 150
using hidden rests 152
vertically aligning 48, 149
visibility 45

VST 71

W
window synchronization 76
Working with Finale® 87

X
XML

export 216
import 144

Z
Zoom

ENF 76
preferences 216
Scan Window 76
screen size 216

zoom 227
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