
   

SmartScore Quick Tour

                 
Installation

With the packaged CD, you will be able to install SmartScore an unlim-
ited number of times onto your computer. Application files should not be
copied to other computers. SmartScore will operate only when installed
correctly. Both the Internet and CD installers are copy-protected as a pre-
caution against software piracy. Internet installers can be installed up to 5
times (using ID and Password) before it becomes necessary to call Cus-
tomer Service to obtain a new download ID. 

a. Insert the SmartScore CD into your computer’s CD drive.

b. (Windows) Push Start > Run and Browse to find your CD drive
under “Look In”. Double-click SSxINSTALL.EXE. 

c. (Macintosh) Double-click SmartScore CD icon on your desktop.
Double-click SSxINSTALL.

d. Follow all installation steps including entering Serial Number, Cus-
tomer ID and registering your copy of the product.

Recognition of Scanned Music

SmartScore includes several pre-scanned TIFF files. Launch SmartScore
by double-clicking its icon. We will start the tutorial with the sample pre-
scanned file, FANDANGO. 

a. Find the Navigator toolbar and push the Recognition button. 

FIGURE 2 - 1: Navigator toolbar
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The Begin Recognition window opens. This is the window you will use to
select previously-scanned music for recognition. 

FIGURE 2: Begin Recognition window

b. Press Add Files to List. In the Open dialog box, double-click on
the sample file, FANDANGO.TIF, inside the SmartScore folder. 

c. This will return you to the Begin Recognition window. Turn off
Triplets, Endings and Text Recognition. Press Begin Recognition.
SmartScore will begin to recognize the sample file. When Recogni-
tion is complete, the name FANDANGO will appear in the Save As
filename window with SmartScore’s own filetype listed as ENF
(Extended Notation Format). The ENF extension will automati-
cally be added to all filenames after recognition. Click on Save. You
will now see a split screen view of processed music. 
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FIGURE 3: Sample TIFF / ENF view

The original scanned image is displayed in the upper window and the
newly recognized ENF file appears below it. Use the scroller bars, mouse
wheel, or arrow keys on your keyboard to scroll up and down the page.
Notice the image and ENF windows are synchronized for comparison.

In ENF, only one staff line is active at a time. The active staff displays
black while inactive staff lines display as grey. To make a staff line active,
move your cursor to within the boundary of the staff until it highlights
black. If you want all staves to display in black, go to the View menu and
uncheck Show Active Staff. If you do this, remember to move your cursor
within a staff line first before doing any editing within a staffline.

Editing an ENF File

NOTE: In this manual, Quick Keys (keyboard shortcuts) are indicated in
bold parentheses: e.g. (C).

Macintosh / Windows shortcut conventions

Most SmartScore keyboard shortcuts are identical on both Windows and
Mac machines. These include “Ctrl + Click” or “Ctrl + key + Click”.
Occasionally, however, an entirely different command is required, specifi-
cally the familiar Windows Right Mouse Click. Since most Macs do not
have a right mouse button, the Windows right-click function is performed
on the Mac version of SmartScore with “Option + Click”.

As accurate as SmartScore is, you should always check for errors in recog-
nition. Sometimes only a few simple edits are all that is required.

• In order to see all staff lines in black, go to the View menu and un-
check “Show Active Staff”. Editing is done a staff-to-staff basis. If
you are unsure to which staff a note belongs, turn this back on.

Unify Key and Time

It’s a good idea to “Unify” key and time signatures after recognition. This
piece does not have transposed instruments in different keys and has no
“change-of-key” or “change-of-time” signatures. So we will unify based on
the signature found in the topmost staffline (1 flat).
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a. Select Unify from the Navigator and accept the key and time
default: Based on topmost staffline. Hit OK.

Entering Grace Notes

NOTE: Grace notes can play back on the beat (accaciatura) or before the
beat. To select, go to Playback > Sound Grace Notes.

a. In Measure 1 / Treble clef, press the “X” key on your computer key-
board until you see a grayed-out X or grayed-out note next to the
cursor arrow. Click on the misrecognized half note to delete it.

b. Select a 16th note from the “Notes” tool palette or press the “5” key
on your computer keyboard. Hit the “C” key to toggle to Insert
mode (mouse pointer becomes a note. Press the “A” key to change
the beam direction until it points towards the right. In the “Notes”
palette, click on the “Grace note” button. Move your cursor into
Measure 1 and position the notehead of the grace note on D. Press
the “S” key to flip its stem direction. Left-click to insert the first
grace note. Notice the cursor’s beam direction has gone from right
to left. Position the cursor notehead on F and click to insert the sec-
ond grace note. See “Insert and Change Modes (C)” on page 104.

TIP: Move your cursor over any tool palette on the left-hand side of
your screen and right-click (Win) / Ctrl + click (Mac). This
allows you to select any available SmartScore tool palette. 

Dynamics

a. Select the “Dynamics” Palette (F8). Choose nnnn from the “Dynam-
ics” tool palette. In the Insert mode the cursor becomes the object
you have selected. Click in Measure 1 to Insert the nnnn dynamic
marking. 

Triplets

a. In Measures 2 and 3 the first group of beamed eighth notes are actu-
ally triplets. Press the “T” key of your keyboard. Then left-click and
drag a box around the first triplet group. A triplet will appear over
or under the highlighted notes. Repeat for the triplet in Measure 3. 

b. In the Notes palette, push the 32nd note and grace note buttons. In
Measure 9, Zoom in (Ctrl + Q) to get closer. Hit the “A” key until
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the beam points to the right. Insert the first grace note on G. Notice
the cursor automatically beams to the left. Enter the last grace note
on A. Hit “A” key to toggle to “middle beam” and enter mid notes.

NOTE: To Undo any editing action, select the Undo button in the tool-
bar (Ctrl + Z (Win) /   + Z (Mac)).

Chord clusters, barlines and the Quick Select tool

a. A note is missing from the chord in the treble clef of Measure 9.
Press the “Z” key to activate the Cluster Tool. The Cluster Tool is
used to build chords or remove single notes from a chord. Click
where the D belongs below the F to insert the missing note.

b. In Measure 10, a barline is missing. Press the “I” key and click to
drop the barline to the right of the 1/4 note cluster.

c. The 32nd note cluster in the treble clef of Measure 11needs fixing.
To delete a single note from any chord, first hit “Z” (the cluster
tool), then “X” (the delete mode). Now click on the G, the higher
note of the cluster, to delete it.

d. Hold down the Control button of your keyboard and click the first
32nd note of the 13th measure. Notice how the cursor changes to a
32nd note. This action is what we call Quick-Select (Ctrl + Click).
Press the “S” key to flip the default stem direction. Move the cursor
back to Measure 11 and click to insert the G.

e. The first beat of the bass clef in that measure was recognized as a
quarter note. Quick-Select a beginning beam eighth note from the
next measure. Hit the “C” key to toggle to the Change mode (with
white arrow). Click on the F to change to “eighth note-start beam”.

f. Enter a new dynamic marking in Measure 11. Select Piano (P) from
the “Dynamics” palette. Click in Measure 11 to insert the new
dynamic marking. 

g. Measure 15 has a new dynamic level. Click the m marking in the
“Dynamics” palette and Insert the m into the beginning of Measure
15.

h. A barline needs to be inserted at the end of Measure 18. Press the
“I” key to activate a single barline. Click between the two E notes to
drop the bar.
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i. Measure 19 returns to v, press the “P” key again and click to drop.

j. In Measures 23 and 24, a flat was recognized instead of a grace note.
Select the s from the “Notes” palette. Press “X” on your keyboard to
toggle to the Delete (grayed flat) mode and click on the noteheads,
G in Measure 23 and the D in Measure 24 to delete each accidental.

k. Quick-Select (Ctrl + Click) the flagged eighth note from the last
note in Measure 22. Push the Grace Note icon in the “Notes” pal-
ette and click to insert the grace note in Measure 24. Now go back
to the “Notes” palette and select a 16th note (5) and the “Right
Beam” icon (A). Click on the E in Measure 23 and then click on F
to complete inserting the grace notes.

l. Go to Measure 23, Quick-Select the sharp belonging to the C# and
then click on the head of the grace note in Measure 24.

Playback

SmartScore has scrolling playback, so you will be able to see which notes
are sounding while the file plays. The TIFF window closes during play.

• To listen to any file after recognition, press the spacebar of your key-
board. The Spacebar acts as a Playback / Pause toggle control. You
can also control ENF playback with the floating Mini Console.
Transport controls are colored and there is a handy tempo controller
that gradually speeds up or slows down playback the further the
slider is moved from the center. Letting go returns the “spring-
loaded” slider back to the center and the default tempo resumes.

FIGURE 4: Mini Console

“Spring-loaded” tempo controller
USING SmartScore 6



Help > Quck Tour
Ensemble Scores (Joined Parts)

We will now process a second sample of music and see how SmartScore
helps you edit parts, assign instrument sounds and isolate a part.

Most scores have parts joined together into “systems”. Each horizontal
staff of each system represents a “visible” part or active instrument. Nor-
mally all parts, represented by staff lines, play simultaneously. SmartScore
considers each staff of a system as a “Part” and also as a MIDI track. 

NOTE: A given part may or may not appear in every system.We call
these irregular or “expanding / collapsing” systems. See “Part
visibility” on page 115 and “Part Linking” on page 94 for more
details on controlling visibility and linking of parts.

a. Push the Recog button in the Navigator. If you have any open doc-
uments, you will be asked to save them. In the Begin Recognition
window press Add Files to List. In the Open window, select
GLUCK.TIF from the SmartScore folder and press Open. Press
Begin Recognition to start the recognition process. Save the recog-
nized file when prompted.

b. As with FANDANGO, UNIFY the score by pressing the “U” key.
Change the default selection to “Based on 1st system”. Hit OK.

c. To listen to GLUCK.ENF just press the spacebar of your keyboard. 

d. Press the “P” key of your keyboard to select vvvv (piano dynamic
marking). Insert the dynamic markings for each part in Measure 1.

e. In Measure 5, two eighth note rests were missed. In the “Rests” pal-
ette (F2), select the eighth note rest (Shift + R). Click to insert the
rests into their correct positions.

f. There is also a new dynamic marking in Measure 9. Click the mf
marking from the “Dynamics” tool palette (F8) and insert it into
the beginning of Measure 9 for each part.

Edit Shapes

a. The slurs (legatos) in the piano right-hand aren’t very pretty and
need adjusting. Push “Edit Shapes” button in the SmartScore tool-
bar. Position your cursor over the middle staffline to make it
“active”. Slowly move your cursor to the “handle” associated with
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the first “anchor” of the slur beginning in Measure 9. Click and drag
the handle up to increase the arc of the left half of the slur. Pulling
the handle associated with the anchor on the right side finishes the
job. Repeat with slurs in Measures 11 through 15. Push the “Edit
Shapes” button again to return to normal editing mode.

b. Hold the Ctrl button down and left click on the first note of the
eighth note beamed group in the solo part in Measure 11. Hit the
“C” key to toggle to Change mode and click on the quarter note C.

Accidentals

a. The B in measure 17 needs to be inserted back into the score. First,
the natural must be removed from the C. Select the d from the
“Notes” palette and press “X” to toggle to the Delete natural mode.
Click the C to remove the natural. Next, Quick Select any middle
beamed eighth note and click to insert the B.

b. The B in the right hand of the piano needs a natural. Select the d
from the “Notes” palette. Click on the notehead to add the natural.

c. Measure 19 has a new dynamic level. Select the m (forte) marking
and insert it into the beginning of Measure 19 in both parts.

d. Measure 21 returns to vvvv, press the “P” key again to insert the new
dynamic marking for each part.

e. In Measure 25, the second note in the bass clef of the piano part is
wrong, it should be an F. Hold down the “Shift” key, left-click and
drag the note on G to an F. Adjust the slur with “Edit Shapes”.

Changing Instrument sounds in Playback Console

The left and right-hand piano parts have been automatically recognized as
piano and assigned the General MIDI patch of Grand Piano. By default,
the solo part was automatically assigned the Flute patch. Let’s say you want
to hear the solo part as a clarinet sound instead.
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a. Push the speaker icon to open the Playback Console or use the
keyboard shortcut, Ctrl+9 /  +9.

FIGURE 5: Changing instruments in Playback Console

b. In Track 1, click on Flute in the Instrument column and scroll up 2
instruments and select Clarinet. Push the spacebar or Play button to
hear the solo part played as clarinet. Move volume slider left or right
to increase or decrease volume on one or more parts. Reset Track 1
to Flute or some other instrument. Close Playback Console. 

Working with the Master System

The Master System is a very powerful editing tool. It controls part and
voice visibility, part name and template assignment, staff and system spac-
ing as well as instrument assignments at the voice level within a part.
Here, we will isolate the solo part and copy it to a new document. 
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Extracting a part in Master System

a. Hit (Ctrl +M /  + M) or select Master System from Edit menu.
Remove the “Visibility” checkmarks for PianoR and PianoL parts
in the left-most column. Check “Visibility” in the “Apply” region.
Push the “Apply to New” button to create a new document which
will include only the part(s) selected by visibility checkmarks.

FIGURE 6: Extracting a part in Master System

Changing Parts and MIDI instruments in Master System

We will now use Master System to select parts and assign MIDI sounds.
MIDI instrument assignments can be changed in the Master System
either by choosing one of a number of preset Part Names or by changing
the MIDI instruments assigned to contrapuntal voices within a staff line. 

Flute part
extracted
from the
original
ENF
document.
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a. Return to the original Gluck.enf score and from the Edit menu,
select Master System again (or hit Ctrl +M /  + M). In the Part
Name column, click on the first part (Flute). Scroll down and select
Harpsichord from the list of Instrument Templates. Notice the
MIDI instrument assigned to Voice 1 becomes Harpsichord.

FIGURE 7: Changing MIDI instruments by selecting new Part Name

b. Even more interesting is to assign different instrument sounds to
contrapuntal voices within a single part or staff line. Refer to the
next figure, Changing MIDI Instrument of a voice in Master
System. Each voice (V1, V2, V3 or V4) can each be assigned a
unique MIDI sound simply by clicking on its current instrument
name and selecting one of 128 MIDI instruments.

FIGURE 8: Changing MIDI instrument of a voice in Master System

c. Press OK to apply the change and close Master System. Now hit the
spacebar to play back. Whenever the secondary voice in the right
hand is played, you will hear a harpsichord sound as distinguished
from the piano sound in the first voice of the same part.

Activating contrapuntal Voices

Voice color mode will display contrapuntal voices in different colors.This
will allow you to view secondary voices (both notes and rests) in red. 

a. Go to Options menu and select Color Mode > Voice. 
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a. Notice in each staff how notes and rests appear as either black or
red. This represents the two voices in each staff line. To see how
multiple voice colors are represented in MIDI, reopen the Playback
Console (Ctrl +9 /  + 9). Notice that Track 2 (PianoR in Master
System) has two voices: Black = Voice 1 / Red = Voice 2. 

FIGURE 9: Playback Console with Options> Color Mode > Voice selected

Manipulating a Multiple-voice Score

Many scores are written with multiple voices within a staff line. Solo
piano, guitar and choral music typically include at least a few measures
with different voices moving independently. This is called “horizontal
voicing” or what we refer to as “Voiceline Threading”, a method of writing
contrapuntal or polyphonic music. SmartScore treats voices as fundamen-
tal entities, not simply as notes with stems pointed in different directions. 

The sample file, CHORALE, is a famous Lutheran chorale. It has four
voices: Soprano, Alto, Tenor and Bass written in two staff lines (SA/TB). 

a. Push the Recog button on the Navigator. 

b. Press the Add Files to List button in the Begin Recognition window.
Select CHORALE.TIF from the SmartScore folder in the Open
window and then press Open. In Options area, leave Triplets, End-
ings and Text Recognition unchecked. 

c. Press the Begin Recognition button. Once Recognition is com-
plete, save the new ENF file, CHORALE.ENF.

In the upper staff, the Soprano voice is in black and the Alto voice is in red.
Because it is the first voice in the lower staff, the Tenor line is displayed in
black and the Bass line is displayed in red. SmartScore allows up to 4
voices per staff: black (V1), red (V2), green (V3) and blue (V4).
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d. Sometimes recognition inserts objects that do not belong. Because
the music was scanned from a book, stafflines curve downwards on
the right side. This effect created two “false positive” slurs in the top
two stafflines. Hit the “X” key a couple of times so the cursor
becomes a greyed X (Delete Any). Click on either of the false slurs
to delete them. Be careful not to click on any other object.

e. Hold the Ctrl button down and click on the natural sign in the alto
line of Measure 3. Hit the “X” key so the cursor displays a greyed
natural sign and click on the notehead of the quarter note E alto to
delete the natural. Hold the Ctrl button down again and click on
the flagged eighth note at the beginning of the measure. Hit the “S”
key to reverse the default stem direction from up to down. Position
the notehead of the cursor on G just between the two quarter notes
in the soprano line. Left-click to insert the eighth note.

f. Move the cursor down to the next line and with Ctrl held down,
click on the sharp sign to the left of the half note in the upper voice.
Position the cursor over the notehead of the eighth note you just
entered and click on the notehead to insert the sharp.

g. Move your cursor down to the next staff. Ctrl + click on the first
beamed note in the upper voice of Measure 3. Now hit the “C” key
to enter into Change mode. Click on the quarter note on beat 4.
Notice how the note becomes beamed. Notice too that the bass
notes turn green. Now click on the half note to the right.

h. Ctrl + click on the quarter note in the upper voice of Measure 2 and
hit the “C” key. Left click on the third ledger line (E) at beat 4. Be
sure you insert the note directly above the eighth note F below.

i. Ctrl + click on the second beamed note of the tenor part in Measure
1. Hit the “S” key to reverse default stem direction and insert the
second beamed note, C, in the bass part.

j. Right-click on any open tool palette (Ctrl+click for Mac) and select
Barlines and Repeats. Click on the Right-repeat sign. Hit the “C” key
to enter Change mode and click on the last barline in the staff.

k. Fermatas are not automatically recognized by SmartScore. Select
Fermata from the “Articulations” tool palette. While still in the
Change mode, click on the soprano and bass stems, away from the
notehead, in Measure 3. Repeat this step in Measure 6.
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l. Press the Spacebar on your computer keyboard to play back the
chorale. Push the “diskette” icon in the Main Toolbar to save the
edited file. You can also select Save from the File menu or Ctrl +
“S” ( + S for Mac) to save any open file.

Extracting Parts using Score Structure

a. From the Edit menu, choose Score Structure.

b. Click on the box titled “PianoL”. Push the Remove button.

c. Now push the Apply to New button. This creates a new ENF docu-
ment containing only the soprano and alto voices. The original file
will remain untouched.

d. Press the spacebar to hear just the women’s voices. Now, we will
extract the alto voice and hear it by itself.

Extracting Voices in Master System

a. Hold down Ctrl + “M” ( + M for Mac) keys to open the Master
System. Select the PianoR part by clicking on the black dot to the
left of the part name. Voice Visibility check boxes become active. 

b. Uncheck the box under Voice 1 to make the soprano part invisible.
In the Apply region below, check the Visibility box since the only
change we are making in the Master System is to visibility.

c. Press Apply to New to create a new ENF document containing only
the alto voiceline.

d. Press the spacebar to hear just the alto line.

Viewing all open files using Tile

a. Click on the “Tile Windows” icon in the Main Toolbar to view all
windows that are open in SmartScore. 

b. Using scrollers on the right margins, nudge each display up so that
all three views can be seen. Click into any of the documents and
press the spacebar to hear each document play back independently.
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Editing Lyrics and Text

a. Select Recognition. 

b. Press the Add Files to List button in the Begin Recognition window.
Select SONGBOOK.TIF and press Open. In the Options area,
check the box to the left of Text Recognition / No Spell Check.

NOTE: Spell Check is normally off because lyrics tend to be formed in
syllabic blocks. For best recognition of English lyrics, keep Spell
Check off. Non-lyric text may loose some accuracy, but most
music contains far more lyrics than non-lyric text. For non-
English languages, applying Spell Check may or may not
improve lyric accuracy. Experiment for yourself to get best text
and lyric recognition results.

c. Press the Begin Recognition button. Once Recognition is com-
plete, save the ENF file, SONGBOOK.ENF. 

d. UNIFY the score by pressing the “U” key. Change the default selec-
tion to “Based on topmost staffline”. Hit OK.

e. Notice the lyrics and the numbers “1.” and “2.” They are not quite
aligned (lyrics and text are recognized separately). 

f. Press the Edit Shapes icon in the Text and Controllers toolbar. In Edit
Shapes mode, all objects appear in brown. Move cursor to the top
line. Click and drag lyrics upward to align with the text on the left.

g. In the right-hand part of the piano, locate the end of the 1st slur.
Click into the “control” box above the far right anchor and drag up. 

h. Click the Edit Shapes icon again to return to normal edit mode.

i. In Measure 5, there is a small fragment in the word “you”. Using the
Zoom tool (Ctrl + “Q”). Left-click to zoom in on the word “you”
until you see the remnant between “y” and “o”. Activate the Select
Tool with Ctrl + “O” ( + O for Mac), select the remnant until it
highlights in a pink color. Hit Delete to remove it.

j. Right-click (hold down option + click for Mac) to zoom back out.

k. Press the L (Lyric) icon in the Text and Controllers toolbar. Locate
Measure 7. With the lyric cursor activated, click on the third quar-
ter note in the topmost staffline. The associated lyric “the” will
highlight. Hit the down arrow to move to the lyric block immedi-
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ately below. Hit the right arrow twice to move two characters to the
right and press Backspace to delete the period.

l. Hit Tab to move to the next lyric block. Hit the right arrow five
characters to the right and press Backspace to delete the apostro-
phe. Press the L (Lyric) icon again to exit Lyric Edit mode.

Editing Solo Guitar and Violin Music

Editing three or more voices

Solo classical guitar and solo violin scores are unique in the world of pub-
lished music. Usually more than two voicelines are present; each voiceline
represented by notes with opposite stem directions. In classical guitar
notation, different voices represent the four plucking fingers of the right
hand and in solo violin music, notes with stems in opposite directions rep-
resent the four strings of the instrument. A cluster of several simulta-
neously sounding voices may be represented as three or four disconnected
notes, stems pointing in either direction with their noteheads slightly off-
set and yet, close enough to one another to represent a “chord”. Such
interesting formulations pose real challenges to intelligent music-scanning
software...

a. Push the Recognition button in the Navigator. Press Add Files to
List in the Begin Recognition window. In the Open File window
select BOUREE.TIF from the SmartScore folder and press Open.
In Limit Voices of the Options area, choose “to three voices”. Leave
Triplets, Endings and Text Recognition unchecked. Press Begin Rec-
ognition to start the recognition process.

b. Push spacebar to Play. Notice as the music plays from Measures
12through 14 that notes have three colors, including green. Hit spa-
cebar again to Stop.

c. In Measure 14, there are two whole notes that were mis-recognized
from the numbers “0”. Hit the “X” key to get the “Delete Any”
cursor and click on the two whole notes in the measure. Repeat in
Measure 16 to delete the whole note there.

d. Open the Playback Console (Ctrl +9 /  + 9). Click into Instru-
ment selection for Track 1 / Voice 1. Change Nylon String Guitar to
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Accordion. Push the spacebar and listen to how voices become more
distinct when they are assigned to different instrument sounds. 
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