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Product Registration

Copies of SmartScore 64®, are licensed to individuals directly by the  
publisher, Musitek® of Ojai, CA. Institutional seat licenses are available 
at significant discounts under special arrangement with Musitek. 
Individual licenses can be transferred to other individuals provided the 
original holder contacts Customer Service and authorizes the transfer;  
whereupon, by agreement, the original holder of the license will be 
disallowed from using the software.

Additionally, current members of a school, church or non-profit are 
entitled to personalized licenses at a significant discount provided an 
active member of that institution is a registered owner of SmartScore 64. 
Interested parties should contact Musitek customer service. 

Licensing and End User License Agreement (EULA) details are found in 
the product packaging as well as in the software installation sequence 
itself.

Limits on number of installations

Each license holder is allowed up to 5 installations on any computer 
regardless of platform (Mac, Windows or Linux)*

*

Registration, Support and Contact

Registration, Support & Contact

In cases where a qualified user exceeds the installation limit, a simple e-mail 
or telephone call to Customer Service will initiate a reset of the counter to 
zero. Musitek reserves to right to withhold resetting the installation counter 
if fraud is expected.

Tech Support & Contact & Support Info

Due to the limited number of live bodies present  
at Musitek, we ask that technical issues be handled  
primarily by e-mail. In nearly every case, we will  
ask for your original .TIF and or .ENF files anyway.  
In the interest of time and convenience, please attach your problem 
files along with a (not too) detailed description and send to the address 
below. Of course, we will try to catch your tech support phone calls 
whenever possible. 

In additon to in-house support, there is a very active and helpful Smart-
Score forum on-line populated by experienced users and administrators. 
The URL for the forum is: 
https://bsmartscoreusertechresources.runboard.com/ 

Musitek Contact Info

Customer Service: 	 805-646-8051
			   admin@musitek.com

Tech Support:	  	 805-646-5841
			   tech@musitek.com
			   (phone support 10AM-2PM Pacifc Time M-F)

Web:	  		  www.musitek.com

FAX: 			   805-646-8099

A reminder ...

Don’t forget to attach your originating .TIF and/or .ENF files when  
contacting Tech Support. We’ll get right back to you. Thank you !

https://bsmartscoreusertechresources.runboard.com/
https://www.musitek.com
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Introduction & Tips

SmartScore 64 User Guide and other aids

User Guide
SmartScore 64 MIDI Edition for Windows

Use the table of contents and/or the Index to locate a topic of interest. 
This publication is not intended for bedside reading unless you believe it 
will help put you to sleep... 

Other helpful resources

We have some helpful videos located on our website at:
http://www.musitek.com/videos.html 

And don’t forget about our Online Forum at:
https://bsmartscoreusertechresources.runboard.com/ 

Introduction & Tips

SmartScore Editions & Serialization

SmartScore comes in 5 flavors or editions. You can tell which edition 
you own from the first characters of your Customer ID and serial  
number:

Customer IDs:

•	 (1) Download 				    Fxxxxxxx

•	 (2) Manual   				    Exxxxxxx

Serials:

•	 SmartScore 64 Professional Edition	 DZD-xxxx-xxxx-xxxx

•	 SmartScore 64 Songbook Edition 		 SZD-xxxx-xxxx-xxxx

•	 SmartScore 64 Guitar Edition		  GZD-xxxx-xxxx-xxxx

•	 SmartScore 64 Piano Edition		  PZD-xxxx-xxxx-xxxx

•	 SmartScore 64 MIDI Edition		  MZD-xxxx-xxxx-xxxx

Install the correct edition

When installing from a DVD, you will be asked to identify the edition you 
purchased. Be sure you know which edition you own when installing.

On first run, SmartScore will ask for your ID and serial number. This 
process is required to validate your ownership. Once validated, you will 
not be asked again unless you change computers. The software will not 
validate with an incorrect serial number.
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SmartScore 64 MIDI Edition

Scan & play! Sheet music to MIDI in seconds.

Scan multiple pages of printed sheet music or process any PDF file and 
watch as it reconstructs on-screen in seconds, ready for playback, and 
transposition. Simultaneously view and edit MIDI data in both notation 
& familiar Piano Roll, Overview and Event list format. Updating is auto-
matic. Export MIDI files to other programs, including Apple® Garage-
Band®, Acid®, Cubase®, Cakewalk®, Logic® or other MIDI-based 
software. Most notation symbols including key and time signatures are 
written to the MIDI file.  

But it’s not all work. It’s also fun to use. So let’s get started...

Welcome

Welcome

BLACK

BLUE

GREY

BLACK

BLUE

GREY

BLACK

BLUE

GREY! Access and control your scanner directly. Import and recognize music images downloaded as PDF or TIF.  
The MIDI edition will process a maximum of 4 parts grouped into systems.

Playback tools include full-featured console (and mini console) for selecting instruments, sound fonts, volume and
balance. Add a groove to playback with SmartScore’s automatic drum track feature.

Notation editing tools allow for inserting and deleting recognized symbols or for creating new  
score documents.

BLACK

BLUE

GREY

BLACK

BLUE

GREY

BLACK

BLUE

GREY

Full MIDI Editor with Piano Roll, Track Overview and Event List views.

BLACK

BLUE

GREY

Workspace Tabs

  Input

  Playback

  Note Editor

  MIDI Editor

Export finished files as MP3 or standard MIDI files.

BLACK

BLUE

GREY

  Output
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Getting started

Getting Started

The Task Window

This window appears immediately after SmartScore 64 starts. It displays the most important for beginning your work. It can be disabled at any time.

Each function can also be activated at any time using the corresponding commands in the File menu. The start window can be opened with the keyboard
command Ctrl + Shift + T or with the menu command, File > Task Window.

Access & control scanner
Defaults: 300 dpi /
Greyscale / Save to PDF

Begin Recognition
Load multi-page music 
images, re-sort or remove 
pages.

File browser
Open SmartScore (ENF),
PDF or TIFF files.

Ctrl Tñ

Shortcut:

Opens the Task Window (if hidden).

What’s inside the Task Window? 

•	 Open the last-saved SmartScore (ENF) file.

•	 Locate and control your scanner directly.

•	 Browse for files that SmartScore can open.

•	 Begin the Recognition process.

•	 Open and edit scanned / PDF images prior 
to recognition.

•	 Create blank music score from preset 
templates.

•	 Import MIDI files for playback or conver-
sion to standard music notation.

•	 To upgrade your MIDI Edition online 
click here.

Image Editor
Open PDF or image files prior to 
recognition (Very important for 
removing covers and front-matter.)                                           
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Program Presets

Global and Local Program Preferences

Program Preferences
Click on a heading to reveal 
settings and attributes in 
that category that you can 
change, if you wish to.

Page Formatting and Printing Defaults. 

1.	 From the EDIT menu, select Program Preferences.

2.	 Select Page Type & Printing.

3.	 Choose the page type and orientation you wish to set as a default (e.g. Legal or A4)

Global Preferences that apply to all documents are found under Edit > Program Preferences. Preferences that apply to the current  
document are found under  Edit > Document Preferences. The English version of SmartScore is preset to U.S. Letter page size (8.5 x 11“). 
Portrait orientation.
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Program Presets

Units of Measure

1.	 From the Units and Zoom category, you can control whether to choose inches or cm.

Setting up your scanner

Scanning from inside SmartScore

It’s preferable to allow SmartScore to control your scanner. The scanning interface will automatically detect print size and set the optimum resolution.  
 

Using your scanner’s software for scanning

If necessary, you can scan outside of SmartScore using the software that installed with your scanner.  

Basic defaults:

•	 Scan at 300 to 400 dpi. NOTE: Higher resolutions DOES NOT necessarily equate to higher accuracy !

•	 NOTE: Full orchestral and miniature scores may need to be scanned in at 400-600 dpi.

•	 Scan in grayscale (not color or black & white)

•	 Scan multiple pages and save to PDF (Larger scores should be broken up into bite-sized sections of no more than 50 pages).

Inches or cm...



QRG E2021-1.2

11SmartScore 64 MIDI Windows

Setting up your scanner

Getting it right ...

Check these items if any issues occur when you are scanning your music:

1.	 Is the scanner connected and turned on?

2.	 Does your scanner work with other applications and/or the software it was installed with?

3.	 Is the “WIA” driver installed? Older “TWAIN” drivers may be incompatible with SmartScore.

Connecting SmartScore to your scanner

1.	 From the File menu, choose: Scan music > Select Scanner.

2.	 In the Select Source dialog box, look for your scanner’s name or model. This will be the scanner’s “driver”.

3.	 Push “OK” to select your WIA driver.

What should you look for?
If your scanner is not shown in the Select Scanner window, then a WIA driver  
for your scanner was not installed or it is not supported by your operating  
system. Visit your scanner manufacturer’s website then download and install  
the WIA driver for your scanner model.

Alternative Scanning Methods?

SmartScore will process PDF files downloaded from the Internet. Select File > Open 
then browse to the PDF file saved to your computer. It will automatically be convert-
ed to SmartScore’s preferred format, TIF. We recommend processing only scanned 
TIFs and PDFs. We don’t recommend capturing music scores using cell phone cam-
eras or video scanning devices. Flatbed scanners work best.

More about alternative Scanning Methods on Page 89.
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Scanning music

Scanning music scores

Pay attention when scanning pages

Good scanning technique is essential for getting the best recognition accuracy from SmartScore. 

Place the first page in the scanner. Make sure that the area containing the music itself lies within the borders of the scanning area (white margins can be 
outside the glass). Keep the page as square to the glass as possible. Do not scan double or multiple pages in one pass since SmartScore turns each pass 
into a page. Avoid scanning in  handwritten manuscripts... the results will probably create more problems than it’s worth.

Good dog. Bad dog.

Center the image area of the music onto the glass, keeping the page as square as possible.
Avoid skewing the page. NOTE: Don’t worry if there is some twisting. You can de-skew later in the Image Editor.
Do not allow any part of the music to be cut off.  SmartScore needs to see everything on the page ! 
If scanning from a book, avoid light leaking onto the image. MAKE SURE you apply plenty of pressure onto the spine.
Don’t scan in multi-page sheets. Scan one page per pass.
Don’t waste a lot of time trying to process handwritten manuscripts.
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Scanning music

Start scanning

Once the first page is properly positioned...

a)  Click on the Scan Music button in the SmartScore Task Window or ...

b)  Click the Scan button from the  toolbar in the Input/Output tab or ...

c)  From the main menu, select File> Scan Music>Acquire.

BLACK

BLUE

GREY

SmartScore’s Scanning Interface

The Scan dialog box will immediately open and a low- 
resolution image  should quickly appear in the preview pane.

SmartScore’s scanning interface controls your scanner’s  
settings. By default, Automatic Resolution is selected. This  
allows SmartScore to choose the optimum resolution for  
each page. If you wish to set resolution manually, uncheck  
Resolution and enter your desired setting, e.g. 300 dpi.

1.	 Once previewed, user your cursor to drag a box around the 
image of the music leaving about 1/4“ of white on all sides.

2.	 Uncheck Auto-Resolution if you wish to set DPI manually.

3.	 Click on Final Scan to begin scanning the first page.

4.	 If you wish to review the scan again, push Preview.

Define a bounding box 
The bounding box defines 
the area that will be scanned. 
Leave some room on all sides 
of the image.

Resolution (DPI)
Auto-resolution allows 
SmartScore to determine 
the optimum resolution for 
each page. Turn off “Au-
to-resolution” if necessary. 
(300 dpi is nominal.)

Final Scan
Click to initiate scanning 
for the previewed page. 
You will have the opportu-
nity to scan the next page.

Should a dialog box appear, Scanning resolution is too low/too 
high - Reset / Ignore, it is most likely due to variations in  staff line 
widths which may have confused SmartScore's auto-resolution 
algorithm. If so,  you would normally choose Reset and manually 
set the resolution to 300 dpi.
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Scanning music

Scanning multiple pages

SmartScore allows you to scan and recognize multiple music pages. When finished, all scanned pages are grouped into a multi-page file format (CCITT 
Group 3 TIF format). Following recognition, each scanned page becomes a page in SmartScore’s .ENF file format.

Scanning successive pages ...

1.	 After scanning the first page, you will be prompted to place the  
next page into the scanner.

2.	 Click the Next Page button. Continue this process for all  
remaining pages.

When you have scanned all the pages of your score...

1.	 Click the Finish.

2.	 You will be prompted to Save As and Begin Recognition or 
Open Pages in Image Editor.   
 

NOTE: We always recommend you open your scanned music in  
SmartScore’s Image Editor. This will allow you to fine-tune darkness/ 
lightness of greyscale images using the Thresholding tool. You will  
also be able to De-skew, Crop, Draw, Erase and Cut and paste the  
images prior to Recognition.

Click Next Page after 
each page of your score is 
scanned until ....

Once you’ve scanned the 
last page of the score, click 
Finish. If you wish to inter-
rupt the scanning process, 
click Cancel.

We always recommend 
you open your scanned 
music in SmartScore’s Im-
age Editor. This will allow 
you to fine-tune  
darkness/lightness of  
greyscale images using  
the Thresholding tool.  
You will also be able to  
De-skew, Crop, Draw, 
Erase and Cut & paste 
objects inside the  images 
prior to recognizing the 
scan.

See Page 20 for more information on working with the Image Editor.

Processing PDF files...

If you've downloaded PDF files from the Internet or saved your scanned music sheets as PDF, then you can move directly to 
Recognition. Select File > Open, browse to your PDF file location and double-click on the filename. The PDF file will automatically 
convert to multi-page TIF and open in SmartScore's Image Editor for previewing, editing and recognition. Or simply push the  
Recognition button in the Input / Output toolbar. For more information on processing PDF files see Page 19.
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Recognition

Saving scanned files and converting PDF files

In SmartScore, you’re always working with two files: the scanned 
file (TIF or PDF) and the recognized file (ENF). If you click on the 
button Save and start recognition after scanning or a PDF con-
version or if you call up the save function in the image editor, you 
can save your note templates in the TIF graphic file format.

BLACK

BLUE

GREY

Recognition

The Begin Recognition Window

The Begin Recognition window will open after the last page 
is scanned or whenever you activate the following ... 

a)  Click the Recognition button in the Task Window.
b)  Click the Recognition button in the Input / Output toolbar.
c)  Select File > Recognize from the main menu.

BLACK

BLUE

GREY!

See Page 19 for more information on PDF recognition.

TIFF CCITT G4
This is the preferred file type. 
Other file types may not be 
able to save multiple pages 
or have the same high level of 
lossless compression.

Filename
Enter a name and Save the  
converted .TIF file. When 
recognition begins, the name 
you give will be assigned to the 
resulting SmartScore .ENF file.

Scanning Outside of SmartScore 
In some cases, whether with an older scanner or one without a WIA driver, SmartScore's scanning interface may not be available. If so, simply use the software that 
installed with your scanner or use an 3rd party imaging app to scan in your music. Be sure to follow these guidelines:

1.	 Look for scanner “Settings” (sometimes called “Advanced”, “Details”, “More”, etc.)
2.	 Resolution = 300 dpi (As a rule, this will be the optimum resolution. Scores with smaller print can be scanned at 400-600 dpi).
3.	 Image Type = Greyscale (sometimes referred to as “Text” or “Document”. Never scan in “Color” or “Black & White”.
4.	 Format = PDF (most scanners will not save multiple pages as a multi-page .TIF file).
5.	 Carefully scan in all your pages. You should be prompted to scan “next page” until you are finished. Then select “Finished”.
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Recognition

Once pages are scanned and saved, you can now begin the recognition process. Recognition is activated after scanning or from inside the Image Editor, 
pages are automatically loaded into the Begin Recognition window. 

Preview and Options
The Preview tab allows you to view each 
scanned page prior to recognition.  
The Options tab includes various preset pa-
rameters that may assist in recognition.

List of pages
All pages contained in your TIF or PDF file appear, in 
order, inside the list of pages window pane. Individual 
pages can be added, removed, reordered, and re-saved 
into a highly-compressed CCITT 3 TIF file format. 

Add Files to List...
If you find one or two pages were mis- 
scanned, you can easily remove and 
replace the bad pages with good. Simply 
Remove, Add and Move pages up or down.

Reorder pages
Select one or more pages 
and press the Move Up or 
Move Down button.

Re-save list of pages
Recombine selected TIF- 
pages into a single, multi- 
page, highly-compressed 
image file (CCITT Group 3 
FAX format).

Begin Recognition
Click to begin the Recognition 
process on pages shown in 
the List of Pages.Recognition Options

The most common and useful options are pre-selected.  
Normally, you can simply accept the pre-selected defaults.

BLACK

BLUE

GREY!
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Recognition

Recognition Options

You may or may not want to recognize specific elements in your scanned score. The Options tab in the Begin Recognition window contains a list of those 
elements; some of which are selected and some which are ignored by default. In general, selected default should simply be accepted. 

Tuplet numeral

Pedal markings

Bowings

Hymnal Fonts (stubby flagged notes)

Ossias

1

2

3

4

5

NOTE: If you need more recognition options, check the Musitek website for upgrades.

1

1

2 2

2
2 2 2

3

3

4 4

5

https://www.musitek.com
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Recognition

The Recognition Process

1.	 Ensure all pages of your score are loaded in proper order. Re-order list of pages, if necessary with Move Up or Move Down buttons. 
NOTE: Once pages are recognized and a SmartScore .ENF file is created, you will not be able reorder pages or append one file to another.

2.	 Select or change default Recognition Options.

3.	 Click Begin Recognition button.

4.	 Wait for the recognition function to complete. It shouldn’t take more than a few seconds for each page.

5.	 Following recognition, a System Report will appear. We recommend you check the number of parts in Largest System Found before continuing to the 
ENF editor. NOTE: While you are able to reconnect “broken” systems in the editor, you will not be able to break a system up into smaller ones. 

6.	 If System Report looks good, select the default button, Open SmartScore File. If not, Open Image Editor will allow you to make changes to the image 
(such as erasing lines that mistakenly connect one system to another or using the Line Draw tool to reconnect broken system brackets). After that, 
you can re-recognize again. Open Super System will allow you confirm the correct number of parts were recognized and nothing more.

7.	 In the Unify Score window, we recommend you accept the default, Based on Topmost Staff line. 
NOTE: If yours is an orchestral score with “optimized” system (disappearing/reappearing parts), we suggest 
un-checking the Unify Key Signatures.
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Processing PDF files

The Internet provides access to vast quantities of printed sheet music in PDF format 
ready to download and recognize using SmartScore. Processing a PDF file is simple ...

1.	 Select File > Open and browse to the location of the PDF file you wish to work on.

2.	 Double-click on the PDF filename. It will immediately begin converting to .TIF.

3.	 Following conversion, all score pages will open in SmartScore’s Image Editor.

4.	 Check the quality of the image. Use the Thresholding tool to darken or lighten the 
scanned image. You can preview the change before saving the change.  
 
 
 
 
 
 
 
 
 
 
 

5.	 Push the Begin Recognition button in the Input/Output toolbar (or select  
File > Recognition from the main menu). The Recognition window will open and all 
converted pages will appear in the list of pages. Push Begin Recognition.

Processing PDF files BLACK

BLUE

GREY!
BLACK

BLUE

GREY

BLACK

BLUE

GREY!

BLACK

BLUE

GREY

What if the PDF fails to recognize?

a) Check that the number of pages in the list of pages does not exceed 50 pages. 
b) Check that the PDF is greyscale or bitmap, not color.
c) If you get a warning that the PDF is password-protected, try printing it out and 
then scanning the pages in.

BLACK

BLUE

GREY
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Image Editor

Image Editor

Working with the Image Editor in SmartScore

When you open a .PDF file or a  scanned or saved .TIF file in SmartScore, it will automatically appear in the Image Editor as a black and white image. If the 
image file is multi-page, the first page always shows first. Use the paging buttons to step through each page as necessary.  The Image Editor can be used 
to correct imperfections that may affect recognition such as skewed/tilted pages, missing system brackets and removal of black masses due to light 
leakage.  The image editor can also be launched from inside the Task Window at program startup.	

Edit Menu
Basic functions available in the 
Image Editor are listed and  
activated here.

Recognition
Remember that the image you see 
in the Image Editor  is just that, an 
image. Before you can do anything 
with the music itself, the image 
must be processed by SmartScore’s 
recognition engine.

BLACK

BLUE

GREY!
Toolbar
Here are tools such as the Selector, 
Skew corrector, Page delete,  Line draw 
and Erase tools.

This Manual was written and designed for Musitek by DocJoeLin, Germany (2019 - January 2021).
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Image Editor

Functions of the Image Editor toolbar

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17

Open and Save files.

Scan: Activate connected scanner.

Begin Recognition: When you are satisfied with the edited image, 
push here to start the recognition process.

Zoom: Zoom in and out of image.

Paging buttons: Page forward or page back.

Rotate page: Use to correct upside down or sideways pages.

Selector tool: Use to select an area to be deleted (such as large 
black masses) or to copy and paste a portion of the music image 
(see Page 22).

Cropping tool: Use to define a region of the image for cropping 
which will remove everything outside the cropping frame (see 
Page 22).
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Skew correction: Drag a line across a horizontal staff line to 
straighten pages that are crooked. This improves accuracy (see 
Page 23).

Invert image: Reverses scans that may appear white on black.

Delete page: Click to delete the displayed page (see Page 23).

Draw tool: Create a line by free-drawing with the mouse.

Line tool: Create a straight line. See Line thickness and Erase.

Line thickness: Select the thickness of the line, free draw or  
eraser.

Eraser: Click to turn free draw or line draw tool into an eraser.

Thresholding tool: If your image file was scanned in greyscale 
(and it should be), this tool will let you fine-tune the balance  
between lightness and darkness of the image (see Page 24).

Undo / Redo: Undo or redo prior action or several prior actions. 
Click on the selector box to the right of the icon to reverse multiple 
actions.
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Useful Image Editor tricks

Good recognition is always starts with a good image. Here are some hints that may help give better results ...
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     Delete unnecessary elements that aren’t necessary

SmartScore will pick up most everything on the page. You may  
want to remove text fragments, graphic elements, handwritten  
notes or stubborn artifacts prior to recognition.

1.	 Click on the  Selector tool button..

2.	 Click and drag a box around the area in question.

3.	 Hit the Delete button on your keyboard to erase whatever is  
inside the bounding box. 

DEL1

     Crop the image to reveal only the music

Often light can leak onto the side of a scanned page and appear  
as a dark mass. Leaks can affect recognition quality. Using the  
Crop tool can quickly eliminate such noise.
 
NOTE:  
Cropping will change the resulting page size after recognition. That 
is easily corrected later in Page Setup by selecting Center on Page.

1.	 Click on the  Selector tool button..

2.	 Once selected, click the Crop tool button.

2
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     Correcting skewed pages

It’s not always easy to get pages squared up in the scanner. 
There’s no need to rescan a crooked page when you can easily 
straighten it in the Image Editor prior to recognition ... 

1.	 Click on the  De-skew tool.

2.	 Click and drag the red alignment line along any horizontal  
staff line.

3.	 SmartScore will calculate the skew angle and correct it  
automatically.

3
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     Delete pages not containing music

PDF scores downloaded from the Internet often include cover /  
title pages, front matter, table of contents, etc. These pages  
should be deleted in the Image Editor prior to recognition.

1.	 Once opened in the Image Editor, navigate to the first page  
that does not contain music.

2.	 Click the Delete page button.

3.	 Click the Page forward button and delete front matter and other 
non-essential pages until the first page of music appears.

4

BLACK

BLUE

GREY

Image Editor



QRG E2021-1.2

24 SmartScore 64 MIDI Windows

     Rotate pages 90° or 180°

Music is often published in Landscape format and must be scanned 
with the head of the page along the side of the glass. This is not a 
problem since you can rotate the page in the Image Editor.

1.	 Click the  Left rotate or Right rotate, button to rotate each  
page so that it becomes right-side-up. If the page was  
scanned upside-down, click either rotate button twice to  
rotate the page 180°.

5
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     Thresholding tool

If your score was scanned in grayscale (and hopefully it was),  
you will be able to adjust it’s relative lightness / darkness to  
achieve a nice balance of solid black symbols against a stark  
white background. 
 
NOTE: Thickness counts for good recognition accuracy !

1.	 In the Thresholding window,  drag the slider a bit and push  
Preview.

2.	 Examine the notation and compare. Repeat until you see a nice 
balance between thick black lines against solid white back-
ground.

3.	 Once satisfied, click OK. 
 

It’s not always necessary to apply thresholding. It’s useful only  
if the original scan is particularly weak or too dark.

6
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Image Editor
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Following recognition, two panes appear. The top half in yellow displays the original scanned page (TIF pane). The bottom half in white displays  
SmartScore’s recognized version (ENF pane). Under normal conditions, they should appear nearly identical. If not, that’s where the editor comes in. 
Use your mouse wheel or the scroller along the right side to move up and down the page. Select the Zoom tool to move in and out of each view.

Note Editor (ENF - TIF view panes)

Tabbed Views
Each of these five tabs are organized based on 
usage: File management / Notation editing /
Special tools / Playback / Image Editor. 

Main Menu
Common functions are  
accessible from the menu 
bar including custom  
functions.

Mini-console
Contains playback transport 
controls as well as spring-loaded 
scrubber and positioning slider.

Notation Symbols
The most commonly-used 
symbols are permanently 
displayed on top of this  
stack. “Last selected”  
symbols appear at the  
bottom of stack.

Window Shade control
Pull the window shade up  
or down to reveal more or 
less of either pane.

Open Symbol Selector
Click either of these buttons 
to open the main Symbol 
Selection window where all 
symbols are organized into 
groups by category.

TIF pane
The original scanned page.

ENF pane
SmartScore’s recreation 
after recognition.

Note Editor (ENF - TIF panes)
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Display formats

In SmartScore, you can arrange the arrangement of the TIF view (image template) and ENF view (recognition result) in the way that best suits your way  
of working. The program is also extremely flexible when it comes to displaying the individual note pages within these views.

Choose how corresponding ENF and TIF panes behave 

You can arrange the TIF and ENF views horizontally or vertically.

•	 The menu selection:  Window > Split Screen allows you to dis-
play panes in either in Horizontal view or Vertical view.

Also, you can view a small area of the original scan corresponding  
to your mouse position in the ENF pane:

•	 The menu selection: Window > Scan View Window > Show  
displays a small, floating window of the area in the original  
scan that corresponds to where your mouse is positioned in  
the ENF pane. The floating Scan View window is resizable  
and both views responds to Zoom control.

Another option is to remove the TIF view from the  
program window and display it in a separate window  
on a second monitor.

Note Editor (ENF - TIF panes)
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Arranging various page views

To the right in the status bar at the bottom of SmartScore’s window 
are four buttons that will change how pages will be displayed: 
  
•	 Horizontal view

•	 Vertical view

•	 Double page view

•	 Long view

 

 

The menu commands for these views can also be found here:
View > View Mode.

1
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Long View 
This is a page-less, seamless view of the 
entire score in linear format. 

Show only ENF or only TIF pane
You can choose to show only one pane by going 
to the menu selection: Window > View Window > 
ENF only or TIF only .

Note Editor (ENF - TIF panes)
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Navigating inside the document

SmartScore offers various ways to navigate in and around ENF documents ...

Scrolling and moving

•	 Drag the scroller tab along the right side of the window up or down. TIF and ENF panes are synchronous and move together.

•	 Use the wheel of your mouse to move up and down.

•	 Use the Hand drag tool. The button is located in the Note Editor toolbar.

Zooming in and out

•	 Select the Zoom tool button found in the Note Editor and Playback toolbars. Right click = zoom in. Left click = zoom out.

•	 With the zoom tool selected, zoom in and out by holding down the Ctrl button and rolling your mouse wheel up or down. 

•	 To the far right of the status bar at the bottom of the window you will find another zoom command.

Jump to Measure / Page / Score part

•	 Use the Page forward / Page back buttons found in the toolbar of each tabbed view.

•	 Click on either of the Part or Page selectors found in the status bar. The Go To dialog box  
appears. Choose the measure you wish to jump to or select Page and choose a page then  
press OK.  
 
You can also use the keyboard shortcut CTRL + G to open the dialog box or use the menu  
command View> Go To.
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Noteneditor (TIFF/ENF-Ansicht)
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Tabs, Toolbars and their functions

Buttons that activate certain functions are organized into one of five activity tabs: File management (Input/Output), Editing (Note Editor), Advanced tools 
(Tools), Playback and the Image Editor.

Note Editor toolbar

Properties tool: When activated, the Properties tool can be used  
to investigate and change playback properties of many symbols 
that are clicked on. It also activates staff & system spacing tabs 
(see Page 50).

Selector tool: The Selector tool is used to grab and highlight  
objects by a dragging around them. Dragging over a range of  
measures with right-mouse down = Select temporary play  
range.

Insert mode: When activated, symbols will drop wherever you  
right click inside any active staff line (see Page 33).

Delete mode: When activated, right clicking on any object in the 
active staff line will be deleted (see Page 33).

Contrapuntal voice colors: This button activates and deactivates 
contrapuntal voiceline colors (black, red, blue and green).

Voice Override: Occasionally, contrapuntal voices of one color or 
another need to be reassigned to another color (voice).

Undo / Redo: Undo / Redo last edit action or with the action  
history list, you can undo/redo multiple actions by clicking and 
dragging to select any number of prior actions.

2 3 74 5 61
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Tabs & Toolbars
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Tools toolbar (unique to Tools tab)

Unify key and time signatures: Activate this function if you want 
key and/or time signatures to become unified throughout the 
score. You can choose to unify based on the topmost staff line of 
each system or the first measure of the first system (helpful for 
orchestral scores).

Automatic spacing: When activated, this function will automati-
cally arrange notes and rests within the measure you are working 
with. Symbols will become properly spaced based on the duration 
value of each symbol in the measure (referred to as “pagination”). 
 
NOTE: This tool may cause consternation. Use with caution.

Automatic beaming: When activated, this function will automati-
cally attempt to beam notes with values less than a quarter note 
into acceptable groupings.

Tile Windows: Arranges all open documents in vertically split win-
dows so that they are visible at the same time. 
 

1
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Score Properties 
Right-clicking inside any  
active staff line will open  
the Score Properties win-
dow containing a number 
of important tools for 
controlling and format-
ting the score.
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Tabs & Toolbars
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Inserting, changing and deleting notation symbols is probably the most important part of editing a SmartScore document. Since you’ll be starting off  
with a lot music already on the page, it will be just as important to CHANGE an existing symbol as it is to  insert one. Clicking on an existing symbol in  
the score will change that symbol to the one you have just selected (it appears on your cursor). Here are the two methods of selecting notation symbols:

Editing notation symbols

Selecting symbols

Choose the symbol you wish to edit. Quick-select (Ctrl + click) is the easiest method. Or you can pick any one of all possible symbols from the Symbol 
Selection window.

Symbol palette and Symbol Selection window

•	 The most commonly-used symbols (notes and rests) are  
permanently displayed in two vertical columns (Symbols  
palette).

•	 To access all possible symbols, click the Open Symbol  
Selection window button. Symbols will appear grouped  
into basic categories for easy identification.

Quick-Select (Ctrl + click)

Unlike most notation programs that start with nothing, SmartScore 
starts with A LOT of symbols on the page. The fastest way to select 
any symbol for editing is to use the Quick-Select method: 

Hold the Ctrl button down and click on ANY symbol you wish to 
select. The cursor will become that object then you’re ready to edit. 
You can now insert the symbol anywhere. You can even change an 
object belonging to the same class (e.g. change a quarter note to a 
16th note) simply by clicking on it.

Ctrl

1 2

Whenever you select a symbol from the Symbol  
Selector tool, it will temporarily appear in this column 
at the bottom of the palette. Six of the Last Used 
symbols will stack up and rotate as they’re used.

Editing the notation

Function keys (F1 to F12)
You can also use the function keys on your computer 
keyboard to open the Symbol Selection window and 
to switch between the different Symbol sections. 
See next page and Page 86 for a complete list of 
keyboard shortcuts.

F1

F2

F12

. ..
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Complete list 
See Page 86 for a complete 
list of keyboard shortcuts.

Editing the notation

Keyboard Shortcuts  
(Left hand position)

Here are the most import and  
keyboard shortcuts. Hold your index 
finger over the “C” key and your hand 
becomes perfectly positioned:

Shift: Nudge mode 
Z: Cluster (chord) mode 
X: Delete mode 
C: Insert mode 
Ctrl + click: Quick-Select

3 Quick-keys Map4

NOTE: Probably the most useful  
of all the keyboard shortcuts is  
Quick-Select (Ctrl + left click).  
Clicking on any existing symbol  
(note, rest, key signature, clef) will  
select that symbol for editing and  
the cursor will display the newly- 
selected symbol.

Click	 Quick-Select (Ctrl + Click)
1 - 3	 #, b, Natural
9	 Playback Console
Q	 Zoom
Y	 Redo
A	 Auto-spacing
G	 Go to Page / Measure
L	 Part Linking
Z	 Undo

Only	 Nudge Mode
1 - 8	 Rests
R	 Rubato
H	 Reposition
V	 Velocities
,	 Crescendo Hairpin
.	 Decrescendo Hairpin

+ +

ESC	 Properties Tool
1 - 9	 Note Values
T	 Triplet
Y	 Glue / Unglue Selected Voices
U	 Unify Key, Time, Clef
I	 Barline (Insert / Delete)
O	 Select Tool / Lasso
P	 Dynamic / piano
A	 Beam Direction Toggle
S	 Stem Direction Toggle
D	 Dot (Insert / Delete)
F	 Change Half-beam Direction
G	 Delete Selected Articulations
H	 Split Selected Clusters
L	 Swap Noteheads
Z	 Single / Cluster
X	 Delete Mode
C	 Insert Mode
V	 Tie (Insert / Delete)
B	 Beam Selected Notes

Symbol Selection Window 
Notes (F1), Accidentals (F2),  
Rests (F3), Dynamics (F4),  
Articulations (F5), Tempo (F6),  
Tuplets (F7), Text & Tools (F8),  
Key Signatures (F9), Time Signatures 
(F10), Clefs (F11), Balines &  
Repeats (F12)

...

Caps	 Lock Active Staff 
Lock	

Space	 Play / Pause
,	 Rewind
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Editing Notes (Selecting/Inserting/Deleting)

1.	 When you select a symbol, either with the Quick--Select method or from the Symbols Selection window, Insert mode is automatically 
activated.

2.	 Automatic spacing is on by default. If not, we recommend it be activated prior to editing notes.

3.	 To enter the selected symbol, simply position your cursor where you wan to drop the symbol
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Colored measure? 
Measures highlighted with a color (default = yellow) indicate 
that there MAY be a rhythmic error somewhere in the measure. 
Colored measures may be turned off and on in the menu,  
View > Show > Error measure. 
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Deleting notation symbols

Deleting a single symbol is easily done by activating the Delete mode (hitting the “X” key on your keyboard).

How to delete any symbol

1.	 Press the X key on your keyboard to enter Delete mode. Or you can  
click on the “Delete” button from the toolbar.

2.	 Position the arrow of the cursor over the object you wish to delete.  
It will highlight in color. Left-click to delete the highlighted object.

1
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Editing the notation
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Deleting specific symbols

1.	 You may need to delete a specific symbol and not anything nearby.

2.	 Select a symbol (Quick-Select or Symbol Selector). In this case, a  
tenuto symbol needs to be deleted from a note head.

3.	 Click on the note head associated with the tenuto. Only the tenuto is  
removed and not the note itself.

2
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Delete a range of symbols using the Selector tool

1.	 Activate the Selector button from the toolbar or simply hit the O key.  With your mouse, click and drag a box around the objects you wish 
to delete. Selected objects will highlight in color. Hit the Delete key on your keyboard. All selected symbols will be removed. 
A single click on any object can also be selected with the Selector tool.

3
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Delete multiple articulation symbols at once.

1.	 It may be difficult to select only certain articulations without highlighting notes and rests nearby. Here’s how ...

2.	 Hit the O key and drag a box roughly around the area containing articulations you wish to delete (such as slurs and hairpins).

3.	 Now hit the G key. Or you may select this menu item: Edit > Special > Delete Selected Articulations.  

4

Editing the notation
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Selecting content from measures (partial content or all content) in measures and systems

1.	 Activate the Selector tool (“O” key). The Selector button is also found in the Note Editor toolbar.

2.	 To select specific symbols inside measures, LEFT-drag you mouse around the symbols you wish to delete. Symbols will highlight green.  
You can shift the pitch of the selected notes (Shift + drag) or delete highlighted symbols with the Del key.

3.	 To remove ALL content from many measures, RIGHT-drag your mouse button and drag a frame inside multiple measures in a staff or multiple staves 
of a system. When selected measures will turn blue. Push the Del key on your keyboard to delete.

5
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Selector tool + LEFT-drag selects a specific 
group of symbols within one or more 
measures for the purpose of pitch-shifting 
(Shift+drag) or for deleting (Del key). 
Highlighted symbols will turn green.

Selector tool + RIGHT-drag selects ALL 
symbols within highlighted measures for 
the purpose of deleting. Partially-selected 
measures will highlight blue and ALL 
symbols inside highlighted measures will 
be removed with the Del key.

Removing LOTS of content at once

If you need to remove a large part of the score, the best method is to switch your view to Continuous View  
(VIEW > View Mode > Long View). Or pick the continuous long view icon located at the far right of the status bar 
along the bottom edge of the ENF view window. Zooming out will give you a bird’s eye view of the entire score.

Editing the notation
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Changing notation symbols

You can easily change the value of any existing symbol (note, rest, tempo or dynamic marking) by locating the same symbol then selecting  
a different value. Once the cursor registers the new value, the symbol in place will inherit the new value when it is clicked on.

Changing the value of a given symbol

1.	 Quick-Select: The easiest way to change the value of a symbol is to locate a similar symbol nearby with the correct value. Quick-select the symbol 
by holding down the Ctrl button and clicking on it. Your cursor will immediately inherit the symbol and it’s value. Then simply click on the symbol to be 
changed. For example, Quick-select a half note. Notice the cursor inherits the symbol and its value. Then click on a nearby quarter note. The quarter 
note immediately becomes a half note. 
 
 
 
 
 
 

2.	 Of course you can always activate the Selector Tool          and choose a new symbol and value.
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Changing note pitches

1.	 Hold the Shift key down (Nudge mode). Green control handles will appear.

2.	 Click inside the note head and drag to up or down to change its pitch (see 
also Page 37).

2
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Editing the notation
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Changing pitches of a group of notes

1.	 Choose the Selector tool (or hit the O key).

2.	 Click and drag a region around the notes you wish to shift pitches.

3.	 Hold down the Shift key (Nudge mode).

4.	 Click and drag ganged notes up or down to a new pitch. NOTE: This is not the usual method for transposition. See Transposition on Page 55.

3
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Shift

Repositioning symbols using NUDGE mode

Shifting symbols horizontally or vertically is done in Nudge mode. Hold the Shift key down and notice that most objects will appear with green control 
“handles”. Drag note heads to change pitch up or down. Drag handles of other objects to move horizontally. 

Shift

Beam angle

Bar line drag

Text

Note Pitch

Note stem length

Note head 
pitch shift

Slur (legato) curve 
controls

Horizontal
Repositioning

Hairpin positioning and angle controls Horizontal repositioning

Tuplet angle

Editing the notation

The Nudge tool is found in the 
Text & Tools category inside 
Symbols Selection window.
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Inserting notes and voices

We put as much engineering effort in SmartScore’s notation editor as we did building the Recognition module. Music is rich in its 
complexity and  therefore, any notation editor worth its salt must be able to cope with that complexity as well as with its exceptions.
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Creating chord clusters

1.	 To add multiple note heads to an existing note stem, hit the  Z key on  
your keyboard.

2.	 Your cursor will show a double-note glyph and arrow. Position the pointer  
over the existing note stem and click onto a line or space to insert the note 
head.

3.	 Hit the X key and you will be able to delete single note heads from the cluster.

1

Adding another voice (Contrapuntal voices)

1.	 Select the note or rest you wish to insert as another voice.

2.	 Position your cursor exactly under or over the note or rest that corresponds  
to the same beat (time slice) that they both will share. 

3.	 The existing note will highlight PURPLE indicating notes are now synced.

4.	 Be sure that the stem direction of the new note is pointed in the opposite  
direction as the original. 

•  Insert with left click = Note stem points in same direction as cursor. 
•  Insert with right-click = Note stem will insert in opposite direction as cursor.
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Swapping a note stem 
You can easily change the stem direction of any note by  
positioning your cursor over the note until it highlights then  
hit the S key on your keyboard. Or select from the menu:   
Edit > Special > Swap stem direction).

Contrapuntal voice colors 
The primary voice color is black and the 
secondary voice color is red, etc. Voice 
number and color can be changed using 
the Voice Color button or suppressed 
using the Voice Visibility button.
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Editing the notation

Articulations, dots, ties and accidentals

Dots of Prolongation

1.	 Press the D key on your keyboard to activate a single dot.

2.	 Position your cursor over a note head you wish to attach a dot to.  
The note will highlight in color, then click.

3.	 To delete a dot, simply hit the X key and click on the  note head again.
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Entering multiple dotted notes 
Select your note value from the Notes category in the Symbols 
Selection window. Then select the “dot” symbol located nearby. 
Notes will insert with dots attached wherever you click.

Accidentals

1.	 The easiest way to select an accidental is to Ctrl + click (Quick-Select)  
on any accidental you find nearby. Otherwise, you can hold the Ctrl  
button down and hit the numerals 1, 2, or 3 on your keyboard.

2.	 Position your cursor over the note head you wish to attach an  
accidental to and left-click.
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Ctrl 1 Ctrl 2 Ctrl 3

Inserting individual articulations

1.	 Select the required articulation from the Symbol Selection window.

2.	 Click on the note head to attach the articulation near the note head  
itself.

3.	 Click on the lower part of the note stem to attach the articulation to  
the tip of the note stem.
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Where you click matters 
Clicking near the tip of the note stem attaches the articulation there. Clicking on the note head attaches it near there.
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Editing the notation

Assigning an articulation to many notes at once

1.	 Choose the Selector tool from the toolbar or simply hit the O key on  
your keyboard.  

2.	 If you see the articulation you want nearby,  Ctrl + click on it. Otherwise,  
choose and articulation from the Symbols Selection window. 

3.	 Hit the C key on your keyboard or select Insert mode button from the  
toolbar.

4.	 Position your cursor over any of the highlighted notes and click. Your  
selected articulation will attach to all highlighted notes.
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To de-select a highlighted region, simply left-click outside of the active staff line.

Inserting Ties

1.	 The V key on your keyboard activates the Tie symbol.

2.	 Left-click on the first note head of a tied pair of note heads. A tie will  
connect two adjacent notes of the same pitch.

3.	 The default shape of the arc depends on whether the note heads are  
above or below the center staff line. To insert a tie with the opposite arc  
shape, left-click.
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Single tie / Multiple tie 
If you need to insert a single tie (and ignore other notes in the same cluster)  
you can find the single tie symbol in the Notes category of Symbols Selection 
window.
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Editing the notation

Articulations over a range of notes

Certain articulations as well as tempo and dynamic markings are meant to be applied over a range of  
several notes. These include slurs (legatos), Crescendo/Decrescendo hairpins and dynamic markings.

Slurs (Legatos)
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IMPORTANT 
If the frame is dragged from top to 
bottom, the symbol appears above the 
notes. When dragging from bottom to 
top, it appears below.

NOTE: Acciaccaturas will not sound if placed before the first note of a 
measure. If you wish to insert a grace note before the first note, it must 
be an appoggiatura in order to be heard.

Working with Grace Notes

Grace notes are a kind of ornament that precede and “lean into” the note that immediately follows. SmartScore 64 supports two types of grace notes:  
the appoggiatura (with a slur mark) and the acciaccatura (with a slash mark). Grace notes can appear signally or joined together in a beam group.

•	 An appoggiatura sounds before the beat. It is heard before its ornamented note which plays precisely on the beat.

•	 An acciaccatura sounds on the beat. It’s ornamented note will be heard slightly after the beat. Acciaccaturas are 
more accentuated than appoggiaturas.

1.	 To insert a grace note, open the NOTES sub-menu in the Symbol Locator  
tool and select either the appoggiatura icon (with a slur mark) or the  
acciaccatura icon (with a slash mark).

2.	 Choose a duration to be applied to the grace note by selecting an  
appropriate note value. You must choose between an eighth and  
thirty-second note. 

3.	 Click anywhere in the staff to insert.

4.	 You may insert more than one grace note. To beam multiple grace notes  
together, activate the Selector Tool (Arrow or Esc key), draw a box so they  
highlight then hit the “B” key.

BLACK

BLUE

GREYor+
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Inserting slurs

1.	 Select the Slur button from the Articulations category of the Symbol  
Selection window. Or Quick-Select (Ctrl + click) on a nearby slur.

2.	 Click and drag a frame over the notes (from top to bottom or from bottom  
to top) depending on how you want the arc to appear (above or below)  
the notes.

3.	 In Nudge mode, you can control he shape of the arc by adjusting either one  
of two “Bezier” control handles near the endpoints of each slur.

2

Inserting hairpins (Cres. & Decres. markings)

1.	 Select one of the hairpin markings from the Articulations category in the  
Symbol Selection window. Or simply hit the  > or the < characters on your  
keyboard. 

2.	 If necessary, hold down the Shift key and change the angle of the fork by  
dragging one of the endpoints. Dragging either endpoint horizontally  
extends the dynamic effect over a longer range of notes.

3

Inserting Dynamics, Tempo and other multi-note markings

1.	 Select the desired symbol from one of the categories in the Symbol  
Selection window.

2.	 Drag the cursor glyph over the range you wish to apply the dynamic or  
tempo marking.

3.	 You can change the positioning of the inserted symbol in Nudge mode.

4

BLACK

BLUE

GREY

Shift

BLACK

BLUE

GREY Shift

BLACK

BLUE

GREY Shift

Editing the notation
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Triplets and Tuplets

1.	 Hit the T key on your keyboard to activate Triplets. Or go to the Symbol Selection window and click on Tuplets. 

2.	 Drag a box around the notes/rests to be assigned the tuplet. Letting go of the mouse button inserts the symbol.

3.	 To include or exclude more notes in the tuplet, hold the Shift button down and drag one of the two green handles on the tuplet endpoints..

4.	 To delete the inserted tuplet, hit the X key, hover over the tuplet and click on it. It will be removed.

5

BLACK

BLUE

GREY Shift

Custom tuplet (beats over value) 
Tuplets actually subdivide a selected 
range of notes and rests into “extra- 
metric” groupings. You can define a 
unique ratio that represents the  
DIVISION of beats over the number  
of beats (VALUE).

Multi-measure rests

1.	 Select Multi-measure rests from the Rest category in the Symbol Selection window.

2.	 Enter the number of measures that will be paused during playback.

3.	 Click inside an EMPTY measure to insert the multi-measure rest. To change the value of a multi-measure rest, hit the  ESC key and click of the  
multi-measure rest you wish to edit.

BLACK

BLUE

GREY

Clock and Measure count 
Once you have inserted a multi-measure 
rest, measure count and timing are auto-
matically updated..

BLACK

BLUE

GREY

Editing the notation

T or
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Inserting Tempo markings

Many tempo markings are automatically recognized by SmartScore. Following recognition, you may find that playback is faster or slower than the default 
tempo. That’s because recognized as well as inserted tempo markings (e.g Adagio, Andante, etc.) have pre-set tempo values. Any tempo marking will 
over-ride the default tempo (set in the Playback Console). You can reset Tempo marking values permanently or just for the active document.
Tempo markings are found in the Tempo category of the Symbol Selection window.

Resetting default Tempo values. Creating custom tempo markings.

1.	 Choose any Tempo marking from the Tempo category of the  
Symbol Selection window.

2.	 Hit the ESC key on your keyboard or select the Properties tool arrow  
from the toolbar. 

3.	 Left-click on any Tempo marking. The Tempo Marking Properties  
window will open up.

4.	 Move the tempo slider or select a new BPM value from the readout  
window.

5.	 Click OK to apply the change. The new value will be applied ONLY to  
the current open ENF document.

BLACK

BLUE

GREY

Apply change locally or globally 
Uncheck both boxes to apply 
change only to the selected 
marking. Check “Apply setting for 
all future files” to permanently 
change the tempo value for that 
marking.

Editing the notation

Esc or

Create a custom tempo mark 
Give a name for the custom 
mark and it will appear in the 
score as such.  
NOTE: UNCHECK BOTH  
Apply to... boxes so you don’t 
permanently over-ride the  
standard tempo marking.
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Editing the notation

Inserting Expressions

Expressions in a score convey information about how a particular section of the music ought to be performed. Expressions are generally 
simple phrases and are more suggestive than say, a metronome marking, which would be considered strict. SmartScore comes with a library 
containing hundreds of the most common Expressions in German, Italian, French and English. You may edit the wording of an existing 
expression or simply type in your own wording when the Expression dialog opens.

How to insert an Expression

•	 Click on one of the Open Symbol Selector buttons located in the main palette  
along the left margin. The Symbol Selection window will open.

•	 Select Expressions section then choose the Expressions tool. 
 
 
 
 
 
 
 
 

•	 Click inside the score where you wish to insert the phrase. The Expression  
window pops open.

•	 Type in your own custom phrase or select a preferred language. Scroll down  
to select a phrase from the list. Click OK to insert the expression.

•	 If necessary, you can reposition the inserted Expression in Nudge mode  
(SHIFT button).

1

Changing an existing Expression 
Changing an existing Expression phrase is easy. Choose the 
Expressions tool from the Symbol Selection window again. 
Select Expressions and the phrase you would like to change. 
Edit your selected phrase.
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Repeats, jumps and endings

In the Barlines & Repeats window of the Symbol Selector tool, you will find all the 
necessary symbols for entering and editing repetitions, jumps and numbered endings.  
 
Clicking on one of the Open Symbol Selector buttons located in the main edit palette will 
open the Symbol Selection window.

Inserting and changing repeat symbols

•	 Choose any repeat character from the Symbol Selection window.  
Left-click anywhere to insert the symbol at the desired position.

•	 To change an existing barline to a repeat sign or numbered ending,  
select the appropriate symbol then position your cursor over the  
existing barline you wish to change. It will highlight green. Click on  
the barline to effect the change.

1

Left and right repeat barlines (multiple repeats)

You can specify the number of times a section repeats when it is  
bracketed between left-repeat and right-repeat barlines.  

1.	 Select the Properties tool from the toolbar (or simply hit the ESC key).

2.	 Click on the repeat barline that begins the section (the right-repeat barline).

3.	 In the Repeat Section area of the Measure Properties dialog, select the number of 
times you want the section to repeat.

4.	 Click OK.

2

BLACK

BLUE

GREY

Repeats, jumps and endings
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Working with numbered endings

Repeated sections can be simple, but they can also be quite complex. Sections may repeat several times but then have a different 
ending for the last repeat before moving on through the piece. Numbered endings allow for a set of measures that end a section to  
play but then to jump to an entirely different ending on the last repeat, skipping the first set of ending measures before continuing on.

1.	 You need to establish the start and finish of both the initial ending and the final ending using specific symbols. Select the start alt repeat  
barline symbol from the Barlines & Repeats category of the Symbol Selector dialog. Hover over a barline where the first ending sequence  
should begin. The barline will highlight green then click on it.  
 
 
 
 
 
 
 
 

2.	 In the Repeats dialog, check the number of boxes that correspond to the number of times you wish the sequence to repeat.chteten Klammer.  
 
 
 
 
 
 
 

3.	 The end alt repeat         barline symbol should automatically appear on your cursor.  
Locate the left-repeat barline that ends the first ending of the sequence and click on it.  

4.	 Your cursor should automatically revert to the start alt repeat symbol again. Click on the  
same left-repeat barline that ends the first ending. This will establish the last sequence.

5.	 In the Repeats dialog, choose the number of ending(s) to be repeated. Be sure to “close out” 
the last repeated sequence by clicking on the final barline that ends the last sequence.

3

IMPORTANT ! 
Numbered endings must be “closed out”  
with an end alt repeat barline otherwise the 
playback engine won’t know where the final  
sequence ends. Not all printed publication 
include this symbol.

Repeats, jumps and endings
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Working with jumps, segnos and codas

It’s common in printed music to have sections that leap between measures, even pages. These “jumps” use a kind of shorthand (e.g. d.c.al segno, 
d.c.al fine, d.s.al fine, d.c.al coda, d.s. al coda, da capo, dal segno, Segno, Finale, Coda,To Coda). Jump symbols are found in the Barlines & Repeats 
category of the Symbol Selection window. SmartScore will respond properly to jumps during playback provided they are entered properly. tIt’s 
important that the “threads” that link jump symbols together are logically connected so they don’t end up creating a “bowl of spaghetti”.

•	 Jump symbols are attributes of barlines. You insert them by clicking on the barline  
where the jump either starts or finishes. 
 
 
 
 
 
 
 

•	 Jump symbols can be relocated to avoid collisions. 
Hold the Shift button down, click into the green 
handle below the symbol and drag to reposition.

4

Creating a “coda fragment”

To split a system and create a “coda fragment”, follow these steps:

1.	 Select the properties tool (ESC key) and click on the bar line where you want to  
split the system.

2.	 In the Barline Properties dialog, select “Split Systems”  then push OK.

5

BLACK

BLUE

GREY

Repeats, jumps and endings
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Tips for deleting repeat symbols 

Deleting barlines represented by numbered endings should be done carefully so as not to mess up their underlying logic. Numbered ending barlines 
do not delete like “normal” barlines. When deleted, they revert to single, non-numbered barlines. Left and right repeat barline do delete normally.

Deleting barlines at the END of a system creates a special problem. Deleting a barline at the end of a system will cause the last measure of the  
system to roll over to the next system. So if a barline at the end of a system needs to be deleted do the following:

•	 Insert a single barline just to the left of an ending barline. Go ahead and delete the ending barline. Notice the new barline moves to the end of the 
system and the last measure will remain in place and not roll over.

5

Rehearsal and orientation markings

You can use create an unlimited number and type of rehearsal / orientation markings. They are automatically bordered by a frame when they are created 
and can be easily repositioned.

1.	 Select the Rehearsal mark button from Text & Tools in the Symbols Selector. 

2.	 Click where you want the rehearsal mark to appear. A frame with a text entry cursor appears.

3.	 Enter the text you wish to appear inside the frame. Click outside the frame when finished.

To reposition a rehearsal or orientation 
marking, hold the Shift button down, grab the  
green handle in the upper left of the marking 
and drag.

BLACK

BLUE

GREY

BLACK

BLUE

GREY

BLACK

BLUE
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Repeats, jumps and endings
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This tool reveals practically everything!

The Properties tool is the go-to tool for examining and editing all the underlying details and playback properties for nearly every symbol in your score: 
staff systems, bar lines, notes, rests, time and key signatures, dynamics and tempo information, legatos, arpeggios, trills, you name it.
To activate, hit the Esc key or push the Properties button in the toolbar.

Here’s an example of some objects you can inspect and change with the Properties tool. Each selection will offer up a unique and editable dialog box.

The Properties tool BLACK

BLUE

GREY

How to call up properties dialog windows 
for any given symbol

1.	 Hit the ESC button on your computer keyboard.

2.	 Position your mouse over the symbol you wish to examine and click on it.

3.	 A properties window unique to that symbol will open. All editable values,  
playback features and functions appear in the dialog box.

Open Staff Properties
Clicking inside the green triangle 
on the left of every staff opens the 
Staff Properties window. There you 
can control staff line visibility or 
transform the part to tablature (TAB) 
notation.

Click on an Arpeggio to open the 
Arpeggio properties.

Properties Tool
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SmartScore’s Secret Weapon: The Properties Tool

Playback values for nearly every notation symbol can be edited on a one-time or permanent basis with a single click of the Properties Tool. 
Variable sliders make changing values intuitive. Don’t like the effect? Simply restore to the default and try again.

Clicking on this notation symbol ...

•	 Notes

•	 Rests / Fermatas

•	 Multi-measure rests

•	 Dynamic markings

•	 Hairpins (Cresc. & Decresc.)

•	 Tempo markings (Allegro, Lento, etc.)

•	 Tempo modifiers (rit., ascel., etc.)

•	 Trillls, turns and mordents

•	 Arpeggios

•	 Slurs (Legatos)

•	 Metronome inserts

•	 Time signatures

•	 Key signatures

•	 Barlines and repeat signs

•	 Staff Properties (green triangle)

•	 Triplets and other tuplets

opens this dialog window

•	 General Properties

•	 General Properties

•	 Multi-measure Rest Properties

•	 Dynamic Marking Properties

•	 Hairpin Properties

•	 Tempo Properties

•	 Accelerando-, Decelerando Properties

•	 Trill Properties

•	 Arpeggio Properties

•	 Legato Properties

•	 Tempo Properties

•	 Time Signature Properties

•	 Key Signature Properties

•	 Barline Properties

•	 Staff Properties

•	 Tuplet Properties

Change multiple note values with one click 
Using the Selector Tool, (ESC key), select a range of notes. With the Properties Tool, click on any 
note and change its value. All highlighted notes will become updated.

BLACK

BLUE

GREY

BLACK

BLUE

GREY

Properties Tool
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For copying, cutting and pasting individual notation objects, entire measures and even larger music areas always use the selection tool.  
When using the tool, carefully consider what you are copying and how or where you want to use the material again.

Cut, Copy, Paste and Duplicate BLACK

BLUE

GREY

Copy and cut individual notation objects  
or notes from a measure.

1.	 Activate the Select tool (“O” key).

2.	 Click and drag a frame around the elements or notes you want  
to copy or cut. Selected object will become highlighted.

3.	 Ctrl + C copies the selected objects. Ctrl + X cuts them out.

1 Copy and cut multiple measures  
or whole sections.

1.	 Activate the Select tool (“O” key).

2.	 Right-click over the range of measures and/or parts.  
Selected measures will highlight BLUE. 

3.	 Ctrl + C copies the selected objects. Ctrl + X cuts them out.

2

BLACK

BLUE

GREY

BLACK

BLUE

GREY

Copy & Paste
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Paste copied objects

1.	 To insert the copied material into empty measures, hold down Ctrl + V (or Edit > Paste), position your cursor where you want the material inserted 
and click to paste.

2.	 To replace existing notation with the copied material, hold down Ctrl + R (or Edit >  Insert / Replace) and click to paste.

3.	 Ctrl + V pastes material and Ctrl + R replaces material. A Paste options dialog box will open. Select the options you wish to apply to the new  
material, merge, insert before/after bar line or replace existing bar lines.

3

Ctrl V / Ctrl R
Cursor tip 
Holding Ctrl + V or Ctrl + R down will display this glyph onto the cursor to 
indicate the position where copied material will be inserted.

Copy & Paste
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Parts & Systems

Working with Instruments (Playback Console)

Following recognition, SmartScore automatically assigns a default instrument name and its associated MIDI sound to each part of the system. Each 
Instrument name and sound can be changed inside the Playback Console.

Changing instrument names and  
associated MIDI sounds

1.	 Open the Playback Console (Ctrl + 9).

2.	 Select the desired Part Name and Instrument (sound).  
You can control how part names are displayed by going 
to this menu item: View > Show > Part Names.

Staff names and Instruments (sound) can be selected 
in the Playback Console. You can even enter your own 
Part Names. Simply type what you want.

Parts & Instruments

1

Permanently removing a part and adding a part

1.	 Activate the Properties tool (ESC key).

2.	 Right-click into a part. 

3.	 Select Staff / Part > Remove or Staff / Part >  
Insert above/below from the Score Properties menu.

2
BLACK

BLUE

GREY

Hiding a part

1.	 Activate the Properties tool (ESC key) then  
click into the green triangle to the left of the  
part you wish to make invisible. The Staff  
Properties dialog box will open.

2.	 Check the Visibility box and select Hide  
Staff under Part name.

3.	 In the Apply to: area, select the range of the  
score that the part is to be kept hidden. 

3
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Part Linking

Re-linking parts (optimized scores)

Printed scores may not show all parts in all systems. Parts can appear then disappear from system to system. When SmartScore recognizes these 
“optimized” scores, it may incorrectly assign parts to staff lines in successive systems because the order in which the parts appear may change from 
system to system. 

Should your recognized score contain such optimized systems, you can easily re-link incorrectly identified staff lines to their correct parts using 
SmartScore’s Re-link parts tool.

Re-linking staff lines to their  
correct part names. 

1.	 Position your cursor over the system  
whose parts names are not correctly  
assigned and hold down Ctrl + L. This  
will open the  Re-link Parts dialog. The 
dialog is also accessible by right-clicking 
anywhere inside a system and selecting 
“Part Linking” from the Score Properties 
pop up menu. Part Linking is also found 
under the Edit menu.

2.	 The Part name list displays all possible 
parts. Uncheck staff lines that are not 
properly assigned and re-link part names 
to their correct staff lines (in top-down 
order).

3.	 Click Apply to apply the change to the  
current system. Click Next System to 
re-link parts of the following system if 
necessary. Click OK when all successive 
systems are correctly re-linked to their 
respective parts.

1
You can easily identify 
which part names are  
assigned to staff lines 
in the score by selecting 
Part Names & Abbrevia-
tions under View > Show 
menu. Part names and 
abbreviations are also dis-
played when you open the 
Re-link parts dialog box.

These buttons allow you 
to navigate forwards and 
backwards without having 
to close the Re-link parts 
dialog box.
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Part Linking (Broken system brackets)

Merging disconnected parts (Broken system brackets)

During recognition, SmartScore determines which staff lines should be joined into systems by looking at the continuous, connecting bracket along the 
left side of the score. If system brackets are broken or missing (due to hole punches or incorrect positioning of the page during scanning), then some 
staff lines may become disconnected from their systems and will appear to “float” by themselves. This may happen well into a score. And if you had 
spent time editing up to that point, it would be a shame not to be able to correct it immediately rather than having to go back, fix the missing bracket 
in the Image Editor, re-recognize the score and begin editing all over again. Fortunately, we have a tool that will prevent all that ...

2

1.	 Position your cursor over the disconnected 
part (or parts) and hold down Ctrl + L to open 
the  Re-link parts dialog box. 

2.	 A check will appear next to the part name that 
SmartScore “thinks” belongs to that staff line. 
If it’s not correct, uncheck it and check the  
correct part name that should be applied.

3.	 Check the Merge with box.

4.	 Click on Next System >>  if it’s located above 
the connecting system or  << Previous system 
if it belongs with the system above.

5.	 Repeat until all broken systems are rejoined 
together. Then push OK.
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You can change spacing between systems and staves including staff line width on a one-to-one basis or by applying changes globally. There are several 
methods and strategies you can use to make sure your finished score is attractive and properly laid out. Let’s look at some of the tools available ...

Controlling the layout

With Properties Tool activated (from the Note Editor toolbar or 
by hitting the Esc key), several spacing tabs along the vertical and 
horizontal ruler will appear. These tabs control only the active 
staff line and system where your cursor is located. But as you will 
see, changes made to one system can be applied to some or all 
other staff lines and systems in the score ...

Part name/Abbreviation tab

System indent tab (left)
System indent tab (right)

Vertical Spacing Tabs: Score Header vertical spacing tab. (If one was created with EDIT > Score Header)
System header spacing tab
Staff spacing tab
Staff line distance tab

Layout
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Navigation 
Use these buttons to 
navigate from system to 
system or page to page.

Copy
This copies changes made 
to the all or some of the 
systems that  you choose.

Layout

BLACK

BLUE

GREY

Apply spacing changes made in one system to all systems

Changes to line, staff and system distances made on one staff can be applied to all or some of the remaining staves in the score.

1.	 Make your changes to a single staff line in the ENF view using the spacing tabs as described on Page 57. 

2.	 Position your cursor inside the staff you wish to use as a spacing template and right-click (or chose EDIT > Score Properties). In the  
Score Properties menu, select Staff/Line Spacing.

3.	 If necessary, manually change Top distance, Bottom distance and Line distance values in the appropriate spin boxes.

4.	 To apply changes globally or to successive pages, click into the Copy settings to: pull-down menu and choose All Systems or Next Systems.

5.	 Push Copy to apply the change. 

NOTE: If you’re not satisfied with how the changes look, hit Undo.
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Reformatting your score

The Format Score dialog is a powerful tool that allows you to automatically adjust the layout of your score by re-scaling the music so it fits nicely within 
the document’s default page size and orientation. Remember that SmartScore maps to the scanned image during recognition, which is usually smaller 
than the actual page size of the original score. Applying scaling in the Format Score dialog gives your document a finished look. The Fit to Page function 
is particularly useful because it performs rescaling of your score automatically with just one click. Additionally, you can make global changes to all the 
systems of document; such as specifying the number of measures per system, resetting system spacing and indents. 

Where is the Format Score dialog found?

•	 Choose EDIT > Format score.

Manual re-scaling:  
Check the box, Scale entire score. Push 
the Find Optimal button. SmartScore 
will calculate the amount to up-size or 
down-size the score. Accept or adjust 
the percentage amount shown in the 
readout. Push OK to apply the format 
change.

Applying number of measures 
per system will assign the num-
ber you select to each system in 
the score. If you want to adjust 
the number of measures per  
system to just one system or  
to a limited range of systems,  
use the Staff Properties dialog 
(see Page 63).

This sets the initial indent of the first 
system.

Reset system spacing param-
eters here. Selected values will 
apply to all systems of the score. 
More flexible staff and system 
spacing options are found in the 
Score Properties > Line/staff 
spacing dialog.

Checking this box will automatically 
apply Auto-spacing to each measure of 
the score. NOTE: This action may cause 
systems to roll over to the next page.

Fit to page will automatically  
calculate optimum resizing  
of the score to fit nicely within  
the default margins, page size  
and orientation.

Layout / Format Score
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Besides simply hearing your scanned music play, you can also enjoy numerous useful and enjoyable playback tools that SmartScore provides.
Among these are a complete MIDI sequencing environment, MIDI-to-notation functionality, automatic drum track and drum pattern library,  juke box and 
more. Let’s dig in.

Playback 

Setting up MIDI Playback

SmartScore is already set up for high-quality playback of your recognized or  
imported music files. Default playback is via the FluidSynth-SoundFont.  
You can change playback sound fonts as follows:

1.	 From the Playback menu select MIDI Devices.

2.	 The Output window displays all available MIDI sound-generators, including  
Microsoft Wavetable module. FluidSynth SoundFont pre-selected. 
 

Transport Controls

•	 Hitting the Comma key automatically brings you to the Playback tab.

•	 Press the Spacebar on your keyboard to start and stop playback. 

•	 The Mini Console has controls for Play, Stop, Rewind as well as a  
spring-loaded Speed Scrubber that gradually speeds up or slows  
down playback.

•	 The main Playback Console (Playback > Playback Console) also  
contains the basic playback transport controls as well and default  
tempo.

Playback devices 
The Output window of the MIDI Devices 
dialog lists all available sound generators.

The Mini-console also includes 
a Quick-locator slider that will 
relocated playback to the measure 
indicated in the readout window.

Playback

Speed Scrubber
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The Mini-console

The Mini-console is a floating playback tool that contains useful playback controls in a neat little package. Following recognition, it will 
automatically appear in the upper left corner of the window. You can relocate it by dragging to another place on the screen. If you click the 
Mini-console icon button in the Playback tab, the Mini-console will return its nesting place on the far right of the toolbar.

Mini-console functions

•	 Rewind, Play, Pause. These are the main transport buttons. 
Hitting Play will stop playback. Hitting Play again will resume 
playback from the same place in the score. Hitting Pause will  
stop playback. Hitting it again will restart playback from the 
beginning.

•	 Spring-loaded tempo scrubber. Dragging this slider to the  
right or to the left will increase or decrease playback speed  
depending on how far you drag the scrubber. Releasing your  
left mouse button will cause the spring-loaded scrubber to  
snap back to null position.

•	 Measure Finder.  Dragging the round Measure Finder slider  
will relocate playback to the position displayed in the small  
readout window. When Play is pushed, the ENF display will  
automatically relocate to the selected measure and resume  
following the music.

1

Playback / Mini-console

Controlling how the Mini-console behaves

•	 By default, the Mini-console will appear in the upper left  
corner. To change its position, drag the Mini-console  
anywhere to reposition it where you want.

•	 To return the Mini-console back to its nesting place on  
the toolbar, click the Mini-console icon button again.

•	 If you prefer that the Mini-console should remain nested in 
the Toolbar after Recognition or when you create a new file, 
you can change that default by checking: EDIT > Program 
Preferences > User Interface > Playback > “Do not open  
floating Mini Console after new file is created.”

2
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SmartScore’s Playback Console

The Playback Console acts a virtual mixer allowing you to assign instrument sounds to parts and voices of the recognized score.

Open the Playback Console from the icon button shown here. It is found on the toolbars of the Note Editor, Tools and Playback tabs. 
It can also be launched using Ctrl + 9 shortcut keys.

Tempo 
Default tempo for the entire score 
is set here. It can also be set from 
the EDIT > Tempo menu. NOTE: 
Keep in mind that any Tempo  
marking in the score will over-ride 
the default Tempo set here.

Transpose playback 
Select any number of steps, up 
or down to transpose playback. 
NOTE: This does NOT transpose 
the key signature in the notation.

Part Names List 
Each part (each staff line of the system) is assigned an 
Instrument (Part Name) automatically out of recognition. 
You can choose a new part name by clicking into the 
named field and even rename the part simply by typing in a 
new name.

Play 
Push to play. Push again to stop.

Measure Finder 
Use this slider to relocate playback to the 
Measure and Beat displayed in th readout.

MIDI Instrument 
You can change the default MIDI 
instrument assigned to the part 
by clicking into its name field 
and selecting one of a 128 MIDI 
instruments.

Transpose Part/Track playback 
Select any number of steps, up 
or down to transpose playback 
of the selected part. NOTE: This 
does NOT affect the notation or 
key signature. It simply changes 
the pitch of the MIDI instrument.

Mute / Solo 
You can mute or solo 
a single part (MIDI 
Track) with either of 
these buttons

Keyboard-Tip:

Ctrl 9

Playback Console
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Swing playback

•	 To apply swing effect to beamed notes, select Swing under the Playback menu. When Swing is activated,  beamed 
pairs will play the first beat as a dotted note. Uncheck Playback > Swing to deactivate swing effect.

1

More Playback Options

SmartScore provides many tools that control and enhance playback of your scanned music. Many are found under the  
Playback menu. Others may be found with the Properties tool or in preferences under FILE menu.

Random variations

•	 To apply subtle but random variations of tempo and loudness, select Randomize under the Playback menu. NOTE: 
You can adjust the amount of randomness applied to tempo and loudness from the EDIT > Document Preferences.

2

Define Playback Range and Loop

You may want to set a defined range of more than a few measures. Here’s how ...

•	 Select Playback > Set Playback Range sub-menu. In the dialog box, set the start an ending  
measures. Hit the spacebar key or push the Play button. You can close the dialog box at any  
time but the playback range will remain fixed to where you set it. Push Cancel to clear the  
range and return to normal full-score playback mode.

3

Activate this function to play the 
range of measures as a Loop.

Playback

Play back selected measures

You may want to hear only a few measures at time. Here’ how ...

•	 With your right mouse button down, draw a box around the  
measures you wish to isolate. They will turn BLUE. Only those  
measures will play back.

4 BLACK

BLUE

GREY

Only measures highlighted in 
blue will play back.
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Rubato Controller

Rubato is an expressive shaping of the tempo of the music. Its subtle shifts of time emulate human performance and is also known as phrasing.  
The Rubato Controller allows you to draw curves over the music to create small tempo shifts.

1.	 In the Playback menu, select Rubato (Shift + R ).  
Use your cursor and draw an up/down curve over  
a range of notes.

2.	 The range that tempo will change the default tempo  
-15% slower to + 15% faster depending on the  
amplitude of the curves.

3.	 To exit Rubato mode, select SHIFT + R again.

5

Velocity Controller 

While dynamic markings and symbols are recognized and  
applied to playback, sometimes more dynamic nuance is  
desirable. Here is a clever feature in SmartScore that allows  
you to make subtle changes to note velocities (loudness)  
while working on page in the ENF notation view.

1.	 In the Playback menu, select Velocity Controller  
(or use the shortcut, Shift + V ). You will notice notes  
on the page will display green, vertical lines. These  
represent the relative velocity of each note. 

2.	 With your cursor, drag the “pencil” glyph through the  
lines of the notes in such a way to make gentle  
(or abrupt) transitions in loudness.

3.	 To exit Velocity mode, select SHIFT + V again.

4.	 	NOTE: You will find a similar velocity controller in  
the Piano Roll window of the MIDI Editor (see Page 75).

6

Should you get carried away and find you made changes too extreme, you can reduce the  
overall effect by selecting Playback > Normalize Velocity and choosing the amount you want 
to reduce the effect (by percentage). If you wish to cancel all changes to Velocity Controller, 
select Playback > Normalize Velocity.

Playback

To zero-out all Rubato Controller changes, select 
Playback > Reset Rubato.
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The Playback Toolbar

The toolbar in the Playback contains the most important functions and dialogs for playback. They are accessible from these buttons:

Open Playback Console: Open and control MIDI instruments  
assigned to parts and to contrapuntal voices (see Page 62).

Toggle Mini-Console: On = Float the Mini-console inside the 
main window. Off = Put it back into the toolbar (see Page 61).

Insert Program Change: Insert a new MIDI instrument at any 
point in the measure for any part / staff line. 

Activate Drum Pattern:  Select one or more pre-set drum  
grooves to accompany your score. If you’re feeling creative, lay 
down your own drum track and add it to the Drum Track library 
(see Page 66).

Piano Roll View:  Click here to select a track (staff) and open  
it in the familiar “Piano Roll” environment where you can edit  
pitches, durations and even MIDI Velocity values graphically  
(see Page 75).

MIDI Overview: View all MIDI tracks simultaneously  
(see Page 80).

Event List: Display and edit MIDI events for the conductor’s  
track (0) or any selected track (staff line) in your score. Voice, 
Time, Duration, Pitch and Velocity values are all displayed and 
editable (see Page 82).

1

2

5

6

71 2 3 4 5 6

3

4

7

Playback
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Drums and Percussion

One very cool feature in SmartScore is the ability to add a rhythm accompaniment to your score during playback. This is done by assigning one or more 
pre-set “grooves” or patterns from the drum track library. You can also create your own rhythm loops and add them to the library as well.

Add an automatic drum track to playback

1.	 Click the Automatic Drum Track button in the 
toolbar of the Playback tab or choose EDIT > 
Automatic Drum Track sub-menu.

2.	 Select a drum pattern from the preset list of 
grooves then select a beginning measure for 
the loop and push Insert. NOTE: Pay attention 
to the beats per measure. They should match 
the numerator of the time signature.

3.	 To add another pattern, select the groove  
from the list, set the starting point in the from 
measure no. spin box then push Insert again.

4.	 Grooves will continue to cycle until another  
pattern is inserted or until the groove is  
silenced. To silence drum playback, select the 
starting measure and push Insert Silence. 

5.	 When your drum patterns are arranged to your 
satisfaction, push OK. A new MIDI track will 
automatically be created. 
 
 

NOTE: The Automatic Drum Track is a “virtual” tool. 
It does not affect the notation of your score. It is 
entirely separate from ENF percussion parts.

1

Sort and organize  
Reorganize grooves by swapping and 
resorting patterns as you go.

BLACK

BLUE

GREY

Applying selected patterns will 
create a new MIDI track auto-
matically assigned to Channel 
10, the channel exclusively used 
for drums sounds.

Drums & Percussion
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Creating your own custom drum track

Don’t care for any of our preset drum tracks? You can create your own drum patterns and save them to the master drum track library. Here’s how:

1.	 Select the Drum Track button in Playback toolbar. In the Automatic Drum Track dialog box, click the New Pattern button. 

2.	 Notate your pattern in the percussion staff template. Drum kit assignments are preset according to the Drum Map which can be opened and  
edited by pushing the Drum Map button above the template.

3.	 When finished, click on the Save Pattern button.

4.	 In the Generate Automatic Drumtrack Pattern dialog box, write in a name, assign a style from the pulldown menu. You can also adjust the  
beginning measure, MIDI track and total length for the pattern. Then click on Generate >>>. Your self-recorded drum rhythm will then be added  
to the drum library and can be accessed at any time from a SmartScore document via the Automatic Drum Track dialog box.

2

Import a drum pattern from a MIDI file
So many options ... If you have or can create a standard Type 1 MIDI file which contains a drum 
track on Channel 10, you will be able to extract that drum track and save to the drum track library: 
Select the menu item, Edit> Create Automatic Drum Rhythm. In the Generate Automatic Drumtrack 
Pattern window, make sure you select the track assigned to Channel 10 (Drums). You will see the 
Playback Console as a reference.

BLACK

BLUE

GREY

Select the MIDI track that contains the 
drum rhythm (MIDI channel 10).

Drums & Percussion
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Drums & Percussion

Changing note head shapes

While recognition of “non-standard” note heads is currently not possible, you are able to change the shape of note heads to one  
of several common “Shaped note” (Sacred harp) note heads.

1.	 Select the Properties tool (ESC key) and click on any given note head. 

or ... 

Activate the Selector tool (“O” key) and drag a box around the note whose note heads you  
wish to change to another shape. Then select the Properties tool (ESC), and click on any  
of the highlighted notes.

2.	 In the Note Properties dialog box, choose a note head shape from the Note head type  
pull-down menu.

3.	 Click OK. All highlighted notes will inherit the selected note head shape.

3

BLACK
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BLACK
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Apply to all similar notes 
You can also apply the new 
note head shape to all other 
notes in the score having the 
same note value. Check the 
box here before applying OK.

Select the desired note head shape from this pull-down menu.
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When you hear your music playing back after recognition, you are hearing MIDI “events” firing off one at a time. Each MIDI event represents a note  
(or and inserted effect)  and contains digital values for things like pitch, duration, volume (velocity), channel number, voice number, etc. MIDI is the 
playback engine that runs “under the hood” in SmartScore’s ENF notation view.

SmartScore’s MIDI Editor contains three windows each displaying a different level of detail from the “big picture” (Overview) to the level of a given part  
(or MIDI track) as seen in the Piano Roll down to the level of individual note events displaying each note’s various parameters numerically (Event List).

The MIDI Editor

BLACK

BLUE

GREY Overview window containing each part as a MIDI track

Piano Roll view  
of a selected part (track)

The Event List view of  a selected part (track).

BLACK

BLUE

GREY

What is the MIDI Editor good for? 
SmartScore’s MIDI Editor allows 
you to visualize every detail of 
your music. In the Piano Roll view, 
each note is displayed graphically. 
You can adjust note pitches, note 
widths (velocity) and note lengths 
(duration) as well as make smooth 
volume swells easily with your 
mouse in the velocity graph.

The Event List displays fully-edit-
able parameters such as Duration, 
Pitch and Voice Number for each 
note event. Changes made in the 
MIDI Editor are directly applied to 
playback. 

Furthermore,  if your changes 
affect how the notation ought to 
appear, those changes will au-
tomatically be applied when you 
return to the ENF editor window.

MIDI Editor
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Viewing an active ENF document in the MIDI Editor

You can view underlying MIDI data at any time by clicking on the Playback tab and selecting one of three MIDI view  
buttons found inside the active toolbar ...

BLACK

BLUE

GREY

•	 Choose either the Piano-Roll      view button, the Overview      button or the Event List     . button.  
If you select either Piano Roll or Event List, a dialog will appear asking you to choose which part  
(staff line) you wish to view as a MIDI track.

•	 You may also call up any of these MIDI environments from the View menu. 

1 2 3

1 2 3

Tip: To view ENF and MIDI view windows side-by-side, choose Window > Split Screen > Vertical menu selection.

MIDI Editor
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Using the MIDI Editor

ENF-MIDI-ENF: Two-way Transparency ... 

Following Recognition, the ENF notation pane is loaded FULL of MIDI data. Changes you make to notes, articulations and dynamics automatically 
update the underlying  MIDI data. All that goes on under-the-hood ...

Changes made in a MIDI View window, (to velocity, note pitch, durations, etc.) directly affects playback. That’s true.  At the same time, changes 
made in a MIDI View window will ALSO update the ENF graphical display. When you return to ENF view, changes you made will be apparent in  
the notation.

Manipulating the MIDI View (several options)

•	 Zoom: Select the Zoom tool from MIDI toolbar.. Click the  
left mouse button to zoom in. Click the right mouse button  
to zoom out.

•	 Hold down the Ctrl button and spin the mouse wheel (if  
available) to zoom in (forward) or to zoom out (backward).

•	 Drag the boundary lines between tracks to narrow or widen  
the zoom level.  You can also drag the measure boundary  
lines along the horizontal time line. Wider to zoom in. More  
narrow to zoom out.

1

Wider, Thinner 
Drag the edges between piano keys to 
resize the width of events. NOTE: Only 
the RELATIVE widths of events  properly 
reflect their relative velocities.

Piano Roll

Overview

BLACK

BLUE

GREY

+

-

MIDI Editor
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MIDI Options menu

Whenever you select one of the MIDI views, an additional menu selection,  
Options, will automatically appear. MIDI Options menu includes a number of 
MIDI-specific functions.

2

Music playback in MIDI views

Playback in the MIDI environment is similar to the ENF editor. You can use the 
Playback Console, Mini-console and spacebar controls as usual. But you also 
have a “scrubber” feature  that lets you shuttle your mouse back and forth at 
any speed, playing back slowly or quickly, even backwards allowing you to easily 
pinpoint trouble spots.

•	 To activate the scrubber, go to the Options menu and click the Shuttle on 
sub-menu.

•	 Position your cursor inside the piano roll event area where you wish to  
scrub the music.

•	 Left-click and drag to the right to advance playback. Drag to the left to  
hear notes played backwards.

3

Navigating from one MIDI track to another

The MIDI Overview window displays all MIDI tracks at once. But the Piano Roll and Event List views show only one MIDI track at a time. Here’s how to 
navigate from one track to the other...

•	 Click the  Back or Next buttons in the toolbar.

•	 Alternately, select the Left or Right carets inside the  Piano Roll or Event List window.

4
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MIDI Editor
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MIDI File Settings

Each MIDI file has the central information in its file header, such  
as playback tempo, time base (ticks per quarter note), information  
on the time signature and key and finally the sound table used  
(e.g. General MIDI). 

This information can be found in the File Settings dialog box and  
can be changed and applied to the current file. Changes will not  
be applied globally to other MIDI files. Basically, the default settings  
in this window are fixed but can be altered on a file-by-file basis.

5

Importing and Converting MIDI Files

You can import any standard MIDI file (Type 1 or Type 0) into SmartScore and it will appear in the Overview window where it can be played back.  
If you wish to  convert the MIDI file to standard musical notation

Importing a MIDI file

1.	 Select FILE > Open.

2.	 The keyboard Ctrl + O will also open a file browser.

3.	 Browse to a MIDI file on your computer then double-click to select it.

1

BLACK

BLUE
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Import MIDI file: Task Window icon 
Look for this icon if you want to  
import a MIDI file from there.

MIDI Editor
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Converting MIDI files into notation

1.	 With a MIDI file open in Overview or another MIDI view, select   
Edit  > Convert MIDI to ENF (ENF being SmartScore’s file format). 
Or simply close the Playback Console by pushing this button here

2.	 The MIDI to ENF dialog will open. Here you can apply options prior 
to conversion. SmartScore converts MIDI tracks to individual parts  
which will appear as staff lines connected by a bracket to a system.

3.	 By default, contrapuntal voices are not differentiated. If desired, set 
the maximum number of contrapuntal voices you wish to differenti-
ate using the Maximum voices pull-down menu. Each voice will be 
assigned a unique MIDI Channel and given an unique color. 

NOTE: Calculating polyphonic voices from a MIDI file is a tricky deal 
since MIDI has no contrapuntal intelligence. Trying to extract more 
than 2 voices per track will most likely result in something less than 
desirable ... but you can always try. If necessary, you can go back  
and try again with a lesser number of voices.

4.	 Select the Measures per System you wish to have in each system.

5.	 In the Quantization section of the dialog, set the NoteOn and NoteOff 
value to the smallest note value present in the file. If you set the note 
value higher, you may wind up with more notes than you bargained 
for. 

6.	 Click OK and the MIDI file will convert to a SmartScore .ENF file and 
appear as notation in the Note Editor window  

2

Is your MIDI file “quantized” ? It should be if you want it to look right... 
MIDI files can be created “freely” with no attention paid to the internal MIDI time clock or time signature. Such  “free-form” files may sound OK 
when played, but they lack internal timing constraints. Quantized MIDI files conform to strict rhythmic structures necessary to convert to music 
notation such as time signature and “number of ticks per note event”. Smartscore will properly convert only quantized MIDI files. 

MIDI Editor
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The Piano Roll View

The Piano Roll view is a familiar display in most MIDI sequencers. Colored “events” populate the grid wherever a note occurs; its length being equal to its 
duration in time. Pitch is represented along the vertical axis matching the white or black keys on the keyboard to the left. Horizontally, measures (red verti-
cal lines) are demarcated by beats (black vertical lines). Playback is marked by a green line that moves from left to right as the music plays.

MIDI Note Event 
The properties of a MIDI note 
(start time, duration, voice mem-
bership, pitch, velocity) can be ed-
ited individually by double-clicking 
on the event You can also move, 
lengthen or shorten the MIDI note 
event with the mouse.

Pitch 
The keyboard shows
the pitch of the event.

Measure 
The horizontal timeline is divided into bars 
and beats (here a 4/4 bar).

Quarter note on D and in 
Voice #2 (red color). 
This event spans a full beat 
(quarter note) at D-6 and 
belongs to the secondary 
voice since it is red in color.

Velocity Controller 
In the lower half of the Piano Roll display, you can access a number of 
MIDI controllers including Velocity Controller.

Smoothing velocity transitions with your mouse 
Transitioning from loud to soft or soft to loud can be smoothed out in 
the Velocity Controller by clicking and dragging with your mouse along 
the green markers that represent the volume for each note event.

MIDI Track Selector 
Use these buttons to switch between 
tracks in Piano and Event List views.

MIDI Editor: Piano Roll View
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Working in the Piano Roll environment

Editing, inserting and deleting MIDI note events

•	 To change pitch of a note event, click and drag up or down. When pitch shifted, the note 
will sound the new pitch.

•	 To change the duration of a note event, position your cursor over its left or right edge. 
When a double arrow appears, drag horizontally to extend or decrease the event accord-
ing to how much you want its duration value to increase or decrease.  
 
 

•	 To increase the velocity (volume) of a note event, click the top or bottom edge of the 
event and drag the edge to increase or decrease its velocity (volume). 
 
 

•	 To insert a new note event, position your cursor over the data point you want the new 
note to appear and right-click.

•	 To delete an note event, click on a note so it highlights then hit the Delete key or select 
EDIT > Delete.

•	 To examine the properties of any MIDI note event, double-click on the event. This will 
open the Note On dialog revealing the internal data assigned to the event.  You may edit 
the various data fields if necessary.     

1

Pitch and position

Note-on / Note-off (duration)

Velocity (loudness)

Insert MIDI Note Event

Note On dialog

Limiting the duration of note events to a precise value 
In order for MIDI note events to properly translate to standard notation values in the ENF view, 
you should set the “Snap to” note no lower than the smallest note value you want to appear. 
This value is set under the sub-menu selection, Option > Snap to.

MIDI Editor: Piano Roll View
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Selecting MIDI note events

•	 To select a single note event, simply click on it.

•	 Several note events can be “gang” selected by holding down the left mouse button and dragging a box 
around those you wish to select. 
 
 

•	 To select all note events in the track, hold down Ctrl + A or choose EDIT > Select All sub-menu.

•	 To select a specific region or to select one or more contrapuntal voice, choose EDIT > Select  
sub-menu. There you can define a range by measure and beat and/or identify exactly which  
voice or voices you wish to select.

2

Cut, Copy and Paste selected MIDI note events

•	 To “cut” and remove selected events from the track, hold down Ctrl + X or select EDIT > Cut  
sub-menu. Event data will be held in the clipboard for pasting.

•	 To “copy” selected events without removing them from the track, hold down Ctrl + C or  
select EDIT > Copy sub-menu. Event data will be held in the clipboard for pasting.

•	 To “paste” cut or copied events, hold down Ctrl + V or select EDIT > Paste sub-menu. Events  
will insert exactly where they originated.

•	 To paste cut or copied events to a location, select EDIT > Paste Special. You will be able choose  
exactly which measure, beat and tick you wish to drop the events as well as whether to replace,  
add or push out of the way any overlapping events.

3

MIDI Editor: Piano Roll View
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Graphical MIDI Controllers

In the Piano Roll view, below the event grid is the  Controller Window. It serves to directly draw controller values ​​and trends (e.g. velocity, modulation, 
volume, panorama, etc.) for the displayed track. 

1.	 Select the desired controller type from the pop-up list on the left edge of the controller window.

2.	 Move the mouse pointer into the controller window. Select the type of controller you wish to apply. Use your mouse to draw graphical changes 
along the horizontal axis  Changes you make will be heard the next time playback starts.

4

Adjust Velocity and Duration of selected notes inside one window

1.	 With one or more events selected, choose EDIT > Velocity / Duration to edit the velocity  
and / or the duration and all at the same time.

2.	 Use the sliders or the entry fields Velocity and Duration to enter a percentage value for  
the velocity or length change. If you change the duration of the selected note events e.g.  
For example, if you want to double, set the duration to 200%.

5

Controller Graphs
Vertical green lines in the controller window  
represent the velocity level of each event. Click, 
hold the mouse button down and drag above or in 
the line to change their  lengths and thereby, their 
velocity values.

Other types of controllers appear orange in color 
as a horizontal line and can also be edited with  
the mouse.

Controller Effect Selection
Select the effect controller you wish to  
apply For example, Velocity (0 - 127).

MIDI note events and velocity value
The greater the velocity value of a MIDI note 
event, the stronger its bar is shown in the 
piano roll view.

MIDI Editor: Piano Roll View
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MIDI File Settings and Measure Settings

•	 Select Options > File Settings. In this dialog box, 
you check that global settings of the file are correct. 
Of course, you can change them, but be careful ... 
you probably do not want to override ENF notation 
settings. 

•	 To open Measure Settings, double-click on any 
measure number along the horizontal timeline.

7

Inserting Instrument Changes (MIDI Program Change)

You are able to insert a change of instrument sounds in the Piano Roll using the same tool available in the 
Playback tab of the ENF notation view. (In MIDI-talk, it’s called Program Change)  
 
NOTE: Double-check that Options > Shuttle on is activated. Playback will follow wherever you click.

1.	 Locate where you wish to insert a change of MIDI instrument, then double-click at that point to mark  
the spot.

2.	 Push the Program Change button in the toolbar or select EDIT > Program Change sub-menu.

3.	 In the Program Change dialog box select the Channel you wish to apply the change to.  
 
NOTE: Double-check your colors ... if you select a voice that is not present in that track, you will hear no 
change in the instrument sound.  Check that the measure and beat are correctly set in the Time call-out 
and then select your new sound from the MIDI instrument pull-down menu.

4.	 After inserting the program change, you will notice an arrowhead or caret indicating where the change of 
instrument was inserted. The color of the caret indicates which voice will be affected. Double-clicking the 
caret will reopen the Program Change dialog box again.

5.	 If you need to, you can click and drag the caret left or right to reposition the start of the program change.

6

BLACK

BLUE

GREY

MIDI Editor: Piano Roll View
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MIDI Overview

The track overview of the MIDI editor is comparable to the piano roll view. The difference is, here you have an overview of all MIDI tracks instead of just 
one. As in the Piano Roll view, you can select any MIDI note event, edit its properties, move, lengthen or shorten it and also delete it.

The track overview is particularly suitable for editing entire tracks at a time. So for example, select an entire track and transpose the playback copy or 
delete the content of the track, or remove entire MIDI tracks from the file and/or add new MIDI tracks.

BLACK

BLUE

GREY

Track numbers 
Left-click on one of the track  
numbers to select the entire MIDI 
track for further processing.
Double click the number to access 
this track in the Piano Roll view.

Timeline 
The horizontal timeline is divided into 
bars and beats (here a 4/4 bar).

Select regions 
By simply clicking 
and dragging, you can 
simultaneously select 
MIDI note events in one 
or more tracks for further 
processing.

MIDI Editor: Overview

Track numbers 
Right-click to opem the Track Properties dialog.



QRG E2021-1.2

81SmartScore 64 MIDI Windows

Major features of the MIDI Overview

Most of the information about editing, selecting, copying, pasting and deleting MIDI note events can be found in the previous section, Piano Roll except 
for track-specific editing functions such as working with controllers and inserting a program change. Here are the unique features of the MIDI Overview 
environment: 

Select one or more complete tracks

•	 Left-click on a track number (left) to select the entire track. You can now remove the entire content of the track, delete the entire track or copy the 
contained MIDI note events (see Edit menu).

1

The Track Properties dialog box

You can use the Track Properties dialog box to edit the properties 
of each track. This includes, for example, the name of the track 
and its transposition interval. The dialog box can also be used to 
create new tracks or to open the currently selected track in the 
piano roll or event list view using the corresponding buttons.

•	 Right-click a track number to display the Track Properties 
dialog box.

2

Left-click here selects 
the complete track. 
Right-clicking opens 
the Track Properties 
dialog box.

Transpose function 
Choose an interval to transpose 
the playback pitch of the track. 
NOTE: This action does NOT 
transpose the notation in the 
ENF view. It merely transposes 
the playback pitch by the 
selected number of half-steps.

MIDI Editor: Overview
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The MIDI Event List

The Event List in SmartScore’s MIDI editor shows all the MIDI control data contained in the file in a simple event-by-event list in chronological order. This 
includes Note On and Note Off commands with the corresponding properties (voice, start time, duration, pitch, velocity), MIDI controller data as well as 
meta events and sysex commands. MIDI information on program changes, voice names and key and time signatures can also be found in the event list 
and can be edited individually. To edit a parameter, simply click on a line to select an event,  then make the desired data change in one of the columns.

Display Filter 
Use these check- 
boxes to control 
which MIDI data  
is displayed.

Scroll during playback 
Activate this check-box so 
that the event list scrolls 
vertically during playback.

MIDI events and control commands 
Click on a line in the event list. Parameters for this event open up and 
become active for editing. Double-click in the Type column to open a 
dialog box listing all the parameters for he given event, within which you 
are able to make the edits.

Jump to Previous or Next MIDI Track 
Use these buttons to move from one 
track to another.

Function keys 
You can use these buttons to cre-
ate new MIDI events or to delete 
selected events from the list.

MIDI Editor: Event List
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Major features of the Event List

Control and presentation

•	 In order to switch between the tracks of the file in the event list, click on either of the small arrow buttons in the header area or use buttons within 
the playback toolbar that are used to turn the pages in the ENF view.

•	 Use the check-boxes to specify which types of events appear in the list and which do not.

•	 If you want the event list to run during playback, select the Scrolling during playback check-box.

•	 The other buttons in the header of the event list are used to insert new MIDI events, delete selected events. Confirm or reject changes that you 
make directly in the list.

1

Edit Events

•	 Click in any field of an event line to edit the parameters of the MIDI event directly in the list. click on the Apply to button to confirm the change 
made, or ... 

•	 double-click in the field of a MIDI event to open an event-specific dialog box for editing the event parameters.

2

Insert new events

•	 In the list, click on an event below where you want to insert a new  
MIDI event.

•	 Click the New Event button in the header of the event list. This opens  
the Create New Event dialog box Create new event.

•	 Select the type of the event from the Event type pull-down menu.

•	 Click on OK. The MIDI event is inserted at the selected position in the  
event list.

•	 Click on the inserted event or double-click in its Type field to edit the  
parameters of the event.

3

Event extensions 
For controller and meta-event types, 
you can also choose from the event 
sub-type list. Tempo, key or time 
signature change are included in the 
group of meta events.

MIDI Editor: Event List
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SmartScore is an intermediary file handler converting different input file formats to different output file formats. You can save your 
SmartScore documents to a number of universal file formats. File formats supported by SmartScore are found under the FILE menu 
and in button form inside the toolbar found in the Import / Export tab.

Supported File Formats
BLACK

BLUE

GREY

ENF file format (*.enf)

ENF is SmartScore’s own proprietary notation format. It is the file type created after recognition and is what is editable in SmartScore. Although the 
original scanned image appears in yellow along with the ENF view in white, it is not part of the ENF format. It is a separate file linked to ENF after rec-
ognition. 

TIP: If linkage between the original .TIF image and .ENF file is lost, it can be restored from the VIEW > Associate Image Files menu.

TIFF (*.tif, *.tiff) and PDF  (*.pdf) file formats

TIFF is an image file format. If you scan your music using SmartScore’s scanning interface, a multi-page .TIF file (known as CCITT Group 4 Fax  
format) is automatically created and processed. PDF is also a multi-page image file format. When you import a PDF file into SmartScore, it is  
automatically converted to .TIF format since SmartScore can only processes .TIF files for recognition. 

TIP: If you scan your music outside of SmartScore, you should always scan and save score pages as a PDF file since most scanners do not support 
multi-page TIF format.  

•	 If you are scanning with your scanner’s software, scan at 300 - 400 dpi in Grayscale (not color or black&white) and save to a PDF file in a folder 
you use exclusively for scanning music. SmartScore remembers the location where you last opened and saved your files to. So keeping everything 
in one place makes sense.

BLACK

BLUE

GREY

BLACK

BLUE

GREY

1

2

Supported File Formats
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MIDI file format (*.mid)

To create files simply for playback or to edit your SmartScore projects with MIDI sequencing software, save to the MIDI file format (.mid). Choose  
between two MIDI format types: MIDI Type 0 (One track / many channels) or MIDI Type 1 (many tracks / many channels). We generally recommend 
using MIDI Type 1, since parts are preserved as tracks and voices are preserved as channels. Nonetheless, many MIDI keyboards only support the 
Type 0 MIDI format.

SmartScore not only saves your scores to MIDI files, it also imports and plays MIDI files in SmartScore’s MIDI sequencing environment and also  
converts quantized (time-stamped) MIDI files into standard notation.

•	 Select  FILE > Save as MIDI or click the Save button in the toolbar from the Import/Export tab.

•	 Choose a MIDI File Type (MIDI Type 1 or MIDI Type 0).

•	 Browse to your music folder and click Save.

•	 You will be asked if you wish to remove or leave articulations.  
Articulations affect the duration (on-off data) of notes. In  
SmartScore,  you may have notes that are being offset or  
truncated by articulations. This may affect how the MIDI file  
is interpreted by notation programs which rely on strictly  
quantized events to properly convert to notation.

3
BLACK

BLUE

GREY

Supported File Formats

MP3 file format (*.mp3)

You can save playback of any SmartScore ENF document as an .MP3 digital audio 
file in format. Make sure that Fluid Synth sound font is selected in Playback > MIDI 
devices menu. 

4
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Try to learn these keyboard shortcuts. It will make your work easier.

Viewing and Navigating

•	 Go To... navigate the score 	 Ctrl + G

•	 Scroll down	 Ctrl + Down arrow

•	 Scroll up	 Ctrl + Up arrow

•	 Roll scroll	 Up / Down keys

•	 Zoom	 Ctrl + Q

•	 Zoom in / Zoom out 	 Ctrl + Mouse wheel

General functions

•	 Show Task Window	 Ctrl + Shift + T

•	 New SmartScore ENF document	 Ctrl + N

•	 Open file 	 Ctrl + O

•	 Save file 	 Ctrl + S

•	 Close files	 Ctrl + F4

•	 Undo action	 Ctrl + Z

•	 Redo action	 Ctrl+ Y

Editing

•	 Quick-Select any symbol	 Ctrl + Click

•	 Properties tool 	 ESC  key

•	 Nudge mode (Pitch shift / Drag handles)	 Shift

•	 Selector tool	 O key

•	 Insert mode	 C key

•	 Delete mode	 X key

•	 Cluster mode (chord building tool)	 Z key

•	 Insert Triplet 	 T key

•	 Join selected notes to same event /  Disconnect voices 	 Y key

•	 Split selected 2-note clusters into 2 voices 	 H key

•	 Beam selected notes	 B key

•	 Toggle stem direction 	 S key

•	 Swap selected note heads 	 L key

•	 Unify Key & Time signatures	 U key

•	 Delete selected articulations	 G key

•	 Part Linking tool	 Ctrl + L

•	 Bracketing tool	 Ctrl + B

•	 Apply Auto-Spacing (on selected measures)	 Shift + A

Keyboard Shortcuts

Keep your left index finger positioned on the C key (Insert mode).  
Your fingers will naturally fall on the X, Z and Ctrl keys.
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Tools Notation symbols

•	 Quick-Select Symbol tool	 Ctrl + Click 

•	 Selector Tool	 O key

•	 Insert mode 	 C key

•	 Delete mode 	 X key

•	 Properties Tool	 ESC key

•	 Zoom	 Ctrl + Q

Copy, Paste, Cut symbols

•	 Selector tool	 O key

•	 Select all	 Ctrl + A

•	 Copy	 Ctrl + C

•	 Cut	 Ctrl + X

•	 Paste	 Ctrl + V

•	 Replace 	 Ctrl + R

•	 Delete	 DEL

•	 Note value (Whole note thru 128 note)	 Number keys 1 - 8

•	 Rest value (Whole thru 128)	 Shift + Number keys 1 - 6

•	 Quarter rest 	 R key

•	 Accidentals (Sharp, Flat, Natural) 	 Ctrl + 1, 2, 3

•	 Triplet	 T key

•	 Chord Cluster tool	 Z key

•	 Barline tool	 I key

•	 Crescendo / Decrescendo  	 Caret (< and >) keys

•	 Flip stem direction	 S key

•	 Swap position (joined voices)	 F key

•	 Dynamic mark (Piano) 	 P key

•	 Prolongation dot 	 D key

•	 Tie 	 V key

•	 Beaming tool	 B key

•	 Beaming tool (Left beam, middle and right beam) 	 A key

Playback

•	 Open Playback Console 	 Ctrl + 9

•	 Play / Pause 	 Spacebar

•	 Rewind	 Comma ( , )

•	 Velocity (Volume) Controller	 Shift + V

•	 Rubato Controller	 Shift + R

Keyboard Shortcuts
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Keyboard Shortcuts

Symbol Selector / Symbol sections

•	 Symbol Selector: Notes	  	 F1

•	 Symbol Selector: Accidentals	  	 F2

•	 Symbol Selector: Rests	  	 F3

•	 Symbol Selector: Dynamics	  	 F4

•	 Symbol Selector: Articulations	  	 F5

•	 Symbol Selector: Tempo	  	 F6

•	 Symbol Selector: Tuplets	  	 F7

•	 Symbol Selector: Text & Tools	  	 F8

•	 Symbol Selector: Key Signatures	  	 F9

•	 Symbol Selector: Time Signatures	 	 F10

•	 Symbol Selector: Clefs	  	 F11

•	 Symbol Selector: Barlines & Repeats	  	 F12

Playback

•	 Open Playback Console 	 Ctrl + 9

•	 Play / Pause 	 Spacebar

•	 Rewind	 Comma ( , )

•	 Velocity (Volume) Controller	 Shift + V

•	 Rubato Controller	 Shift + R
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Tips and Troubleshooting

Alternative Scanning Methods

It’s always advisable to scan using SmartScore’s scanning interface (located inside the Input/Output tab). Besides simple  
convenience, other advantages include automatic resolution detection,  automatic grayscale and multi-page .TIF creation / saving.  
However, it may not always be possible to scan from inside SmartScore, perhaps your scanner’s driver is not available or incompatible  
with your computer. Perhaps you need to scan with a computer that does not have SmartScore installed. In those cases, you can still  
create usable scan files for processing with SmartScore ...

Scan to PDF files

1.	 Open the scanning software that came with your scanner. Find Detailed Settings dialog.

2.	 In the “image type” or “bit type” settings, select grayscale or 8-bit grayscale.  
NOTE: Do not scan in color (24-bit) or in Black and white (1-bit).

3.	 Set the scanning resolution to 300 DPI (for music with “normal-sized” print). For  
miniature or orchestral scores with many  parts per system, increase resolution to  
no more than 500 DPI.

4.	 Find the “Save” or “Output setting” and set the file format to PDF.

5.	 Scan pages one by one. You should be prompted for each page.

6.	 Save the PDF file to your desktop or to your designated music folder. 

1

Scan to TIFF files

Most scanners will not create (CCITT G4) multi-page .TIF files. For those that do support ...

1.	 Proceed steps 1 through 3 indicated above. 

2.	 Select Multi-page or CCITT TIFF file format. NOTE: Make sure the scan is “Uncompressed”.

3.	 Save the .TIF file to your desktop or to your designated music folder. 

2

Tips & Troubleshooting
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Troubleshooting

The following pages provide an overview of possible problems when working with SmartScore and offer suitable solutions. Should you still have  
problems under control, please contact our support team by email (tech@musitek.com). Be sure to include your scanned .TIF or .PDF files when you do.

We’re here to help.

Scanning

When attempting to scan, you get the  
message: Scanner not ready.

Your scanner’s WIA driver was not installed or 
needs to be updated.

Visit your scanner manufacturer’s website and 
locate “Download drivers”. Download and install 
the most current scan drivers for your computer.

The WIA driver was not selected in SmartScore. Go to: FILE > Scan music > Select scanner.  
Find the WIA driver installed for you scanner 
model and select it. Push OK and close.

Your scanner is not connected to your computer 
or is not on.

Check that your scanner is on and properly  
connected to your computer.

While scanning with “Auto-resolution” on, you 
encounter the message, You should scan this 
page at xxx DPI. Change or Ignore.

The scanned image contains staff lines with 
varying staff widths. Auto-resolution measures 
staff widths to determine optimum resolution 
and assumes all staves have roughly the same 
width.

1. Select Ignore 
2. Scan again. In the scanning options dialog,  
uncheck Auto-resolution. Set resolution of  
300 dpi. Push Final scan.

Auto-resolution may select a non-rounded value 
such as “320” or “375”. Many scanners respond 
only to preset values (e.g. 300 / 600 dpi) so the 
resolution sent to the scanner is not recognized.

Scan again. In the scanning options dialog,  
uncheck Auto-resolution. Set resolution of  
300 dpi. Push Final scan.

Tips & Troubleshooting
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PDF to TIFF Conversion

PDF to TIFF conversion fails when opening  
a PDF file.

The PDF document is password-protected. Open the PDF file in Adobe Acrobat or some 
other PDF reader / editor. Resave the  file as  
.TIF (be sure to turn of RGB and CMYK color  
management). Otherwise, print out the score 
and then scan the printed material into  
SmartScore.

SmartScore reports that the PDF to TIFF  
conversion is a color PDF.

The PDF document was created as an RGB color 
file which cannot be processed by SmartScore. 

Even if the document looks to be black&white, it 
can still be saved as a color file.

Open the PDF file in Adobe Acrobat or some 
other PDF reader / editor and print out the score 
if possible. Then scan the printed material into 
SmartScore. 

Recognition

An error message appears indicating that  
the image is in color.

Recognition failed message.

The music was scanned as RGB color. Rescan using SmartScore’s scanning inter-
face or with your scanner’s software making 
sure your settings are Grayscale (sometimes 
called “Document” or “Text”) and not color or 
black&white (1-bit).

Open the .TIF file in Photoshop or some other 
image editing program, change “mode” or “bit 
depth” from color to Grayscale then resave the 
file as “Uncompressed .TIF

The music was scanned at screen resolution (70 
to 90 dpi) or too high (600+ dpi).

 
The scan was upside-down or sideways.

The music contained front matter (cover, table  
of contents, etc.)

Open the .TIF file in SmartScore (it will auto-
matically open in the Image Editor).  Check the 
resolution (View > Image Information). Rescan 
if necessary.

Use the tools in SmartScore’s Image Editor to 
rotate each page to the correct orientation and/
or delete cover, front matter, table of contents 
and any other non-music material

Tips & Troubleshooting
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Recognition Results

Poor Recognition quality. The scan was too light or the original score was 
faded, with broken or missing note stems an 
staff lines or was poorly scanned. 

Open the .TIF file in SmartScore (it will automat-
ically open in the Image Editor).  Examine the 
image carefully. If you see note stems and staff 
lines broken and poorly defined, check if the 
original is poorly printed. Scanning at a darker 
setting may improve your results. Otherwise, 
recall  the old saying:: “Garbage in. Garbage out.”

The music was scanned as a half-tone (dithered)  
image. 

Zoom in closely into the .TIF pane (in yellow). 
Look for the tell-tale signs of half-tone / dith-
ering: what should be solid areas of black are 
made up of many tiny black dots.

Delete the file. It is unusable. Rescan using 
SmartScore’s scanning interface or your  
scanner’s software making sure you select 
“Grayscale” (or “Document” or “Text”). Dithered 
images are always black&white (1-bit).

Staves (parts) that ought to belong together 
become detached and appear as separate 
systems.

If binder hole punches penetrated system 
brackets or if the original music had faded 
lines and brackets were broken, staff lines will 
become unlinked. 

Either draw lines to restore brackets in the 
Image Editor and recognize again. Or, if already 
recognized, rejoin broken systems using the  
Part Linking  tool  (Ctrl + L) in the note editor.

The sheet music is handwritten, containing 
handwriting-like musical character sets (“jazz 
fonts” or, is not standard notation (e.g. shaped 
notes / sacred harp).

If the manuscript resembles printed notation, 
then you may have reasonably good recognition 
results and you won’t have to enter notes in one-
by-one.

Problems occurred during scanning. If pages were skewed or crooked, use the 
Deskew tool in SmartSocre’s Image Editor to 
straighten it.

Tips & Troubleshooting
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Recognition Results

Page xx failed to recognize. message  
during recognition, but successfully created  
an .ENF file.

SmartScore may ignore a page that it can’t  
recognized. It’s best to make a note of the  
offending page, locate the problem and then 
correct it.

If you locate the offending page, you need only 
scan that page again and save it as a .TIF file. 
Select Begin Recognition in SmartScore. In the 
List of Files window, REMOVE the bad page. 
Then push Add files to list button, locate your 
rescanned page and select to add it to the list. 
Use either the Move up or Move down button to 
shuffle it into its rightful place. Then push Begin 
Recognition. SmartScore will ask if you want to 
overwrite the existing .TIF file. Push Yes.

Barlines were not recognized and dropped  
or else appeared where they should be.

Page was skewed (twisted) when scanned. Use the Deskew tool in SmartScore’s Image 
Editor to straighten the image.

Light leaked onto one of the edges of the page 
during scanning creating a long black mass 
along the edge of the image.

Rescan the page making sure there is sufficient 
pressure on spine of the book or original score 
that light from the scan bar does not leak onto 
the image.  
You will not have to rescan all the pages, just 
the one offending page. Save it as a .TIF file and 
in the Begin Recognition window, push Add to 
List then Move up or Move down to slide it into 
place.

Part of the scanned music was cut off. 

Size of the original music exceeded the size  
of the scanner.

Scan again making sure the music (not the page 
itself) is fully inside the glass scanning area.

Consider using a scanner with a large scan area 
(e.g. Legal size scanner - 11” x 14”).

Or use a copy machine to reduce the size of the 
image onto paper that will allow the full image of 
the music to be scanned on an 8” x 11” scanner.

Tips & Troubleshooting
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Playback

Playback pauses at the end of a measure. Pickup and Closeout measures are common at 
the beginning and sometimes at the end of every 
system.

For a single measure, use the Properties Tool 
(Esc key) and click on the beginning barline. In 
Barline Properties, select Play as written.

Playback appears to go faster or slower than the 
default Tempo set in the Playback Console.

Look for a Tempo marking (e.g. Allegro,  
Moderato or Andante ) in the body of the  
music. If recognized, Tempo markings will  
apply a new tempo value to playback.

If necessary, you can alter the tempo value of 
any Tempo marking. Use the Selector Tool (ESC 
key) and click on any Tempo marking. In Tempo 
Properties dialog, change the tempo value.

Playback pauses at the end of ALL measures. The time signature is probably incorrect. Check time signatures. Change time signature  
to the correct value as necessary.

Tips & Troubleshooting
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